Subject: Why MSDP?

From: "Nagesh Chintada" <[email-masked]>
Date: Thu, 22 Mar 2001 16:29:19 -0500

Greetings,

I have a very basic question:

First, the context:
For inter-domain Multicasting, one would typically deploy
PIM-SM/MBGP/MSDP protocols.....
MBGP for announcing  routes that include subnets containing multicast
sources, and MSDP
to announce sources.

Since MBGP already has the capability to announce multicast routes, why
not announce host routes of multicast sources as well, using MBGP? If
necessary, one can think of a simple extension to MBGP to mark the host
route as a "source route". IMHO, this will make it much easier to deploy
Multicast without having to worry about delpoying MSDP.

Any comments?

Best Regards,
Nagesh

---

From: "John M. Zwiebel" <[email-masked]>
Date: Thu, 22 Mar 2001 13:54:26 -0800

MSDP is required for ISM - or "internet standard multicast".
ISM is not SSM in that it allows building of shared-trees within
an AS which SSM does not.  The receiver does not need to know
who the senders to a given group are.

SSM builds only shortest-path trees because the host can signal
to the last hop router the specific hosts (senders) it wants to 
listen to.  This rendezvous mechanism is outside of the PIM 
protocol and can be discovered any way the application writer
wants it to be.

MSDP is not required (and not used) to support SSM groups.

Host routes are not needed in MBGP to be able to join toward the
shortest-path across the internet.  

 ^ Greetings,
 ^ 
 ^ I have a very basic question:
 ^ 
 ^ First, the context:
 ^ For inter-domain Multicasting, one would typically deploy
 ^ PIM-SM/MBGP/MSDP protocols.....
 ^ MBGP for announcing  routes that include subnets containing multicast
 ^ sources, and MSDP
 ^ to announce sources.
 ^ 
 ^ Since MBGP already has the capability to announce multicast routes, why
 ^ not announce host routes of multicast sources as well, using MBGP? If
 ^ necessary, one can think of a simple extension to MBGP to mark the host
 ^ route as a "source route". IMHO, this will make it much easier to deploy
 ^ Multicast without having to worry about delpoying MSDP.
 ^ 
 ^ Any comments?
 ^ 
 ^ Best Regards,
 ^ Nagesh
 ^ 

------------------------------------------------------------------------------
	John Zwiebel                       Phone: 408-526-5303
	Cisco Systems Inc.                 
	IP Multicast Group

---

From: "Mike Luby" <[email-masked]>
Date: Thu, 22 Mar 2001 14:21:10 -0800

John,
One of the things that I think we might have come to consensus on at the
IETF on Tuesday is to start calling the multicast service model defined in
RFC 1112 as "Any-Source Multicas" (ASM) hereafter (instead of ISM or
anything else).  This was raised by Dave Meyer in the SSM working group
meeting, and after a short discussion the consensus seemed to be that nobody
liked the term Internet Standard Multicast (ISM) because of its connotations
towards other models of multicast (as not being Internet Standards), that
there was a strong need for a common name for this service model, and that
although ASM was not the first choice of all people, ASM is the first choice
of quite a number of people and nobody had strong objections to ASM.

Michael Luby
Chief Technical Officer
Digital Fountain, Inc.
600 Alabama Street
San Francisco, CA  94110

www.digitalfountain.com
[email-masked]
(415) 401-2100 (main)
(415) 401-2120 (direct)
(415) 401-2199 (fax)

-----Original Message-----
From: John M. Zwiebel [mailto:[email-masked]]
Sent: Thursday, March 22, 2001 1:54 PM
To: Nagesh Chintada
Cc: SSM; [email-masked]; [email-masked]
Subject: Re: Why MSDP?

 ^ Greetings,
 ^

----------------------------------------------------------------------------
--
	John Zwiebel                       Phone: 408-526-5303
	Cisco Systems Inc.
	IP Multicast Group

---

From: "Nagesh Chintada" <[email-masked]>
Date: Thu, 22 Mar 2001 17:31:00 -0500

John,
See below.

> who the senders to a given group are.

Agreed.

> protocol and can be discovered any way the application writer

Agreed.

> MSDP is not required (and not used) to support SSM groups.

Agreed.

> shortest-path across the internet.

Agreed. for SSM.

My question is perhaps not clear, and is nothing to do with SSM.

To rephrase, if all that MSDP is doing is to advertize sources, why not let MBGP
to do the same?

Note that once an RP detects a new source ( via MBGP advt rather than MSDP in this
case), it can send a Join to the source in the neighboring domain and setup the
tree as it currently does.

I agree that the implementations will have to rely on policy for MBGP route
insertion in the originating domain and redistribution ( perhaps?) to PIM in the
destination domain.

I hope that is clear.

-
Nagesh

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 22 Mar 2001 17:04:56 -0800

>> RFC 1112 as "Any-Source Multicas" (ASM) hereafter (instead of ISM or

    Now that we're talking about names, Any-Source-Multicast presumes that
    SSM can't have multiple sources. You can certainly have a small conference
    with 3 participants which are each sourcing data, each using their own
    source-tree.

    But I'm in favor of keeping acroynms as simple as possible, so I would
    suggest:

	SSM - single source multicast (because changing this will really
                                       confuse people - again)
        OM  - original multicast

Dino

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 22 Mar 2001 17:59:20 -0800

> 	SSM - single source multicast (because changing this will really

Well, i thought we'd already called this "Source Specific Multicast" for quite
a while. At least in all the specs in the SSM working group.

And if you have that meaning of SSM, then ASM makes a very good distinction:
In SSM you the receiver must be SPECIFIC about which source you want traffic
from (and right, it can be more than one), and in ASM you take traffic from
ANY source.

>         OM  - original multicast

Oh no, yet another abbreviation ;-))

Cheers
	Toerless

---

From: John Meylor <[email-masked]>
Date: Thu, 22 Mar 2001 21:02:50 -0800

> a while. At least in all the specs in the SSM working group.

right, it treats sources specifically, rather than all sources
generally, but can  address several sources specifically
so it isn't really limited to a "single source".
Dino, I think this would resolve your point, correct?

And based on this conclusion from last year,
all the SSM related drafts use Source Specific in
the expansion, so
SSM = Source Specific Multicast would require the
least (zero) change.

> from (and right, it can be more than one), and in ASM you take traffic from

agree, ASM seems fine to me.

 John

 John

---

From: "John M. Zwiebel" <[email-masked]>
Date: Thu, 22 Mar 2001 21:23:55 -0800

How about  <dah, dah>  MMP -- (M)SDP/(M)BPG/(P)IM.

 ^ On Thu, Mar 22, 2001 at 05:04:56PM -0800, Dino Farinacci wrote:
 ^ >     But I'm in favor of keeping acroynms as simple as possible, so I would
 ^ >     suggest:
 ^ > 
 ^ > 	SSM - single source multicast (because changing this will really
 ^ >                                        confuse people - again)
 ^ 
 ^ Well, i thought we'd already called this "Source Specific Multicast" for qui
    te
 ^ a while. At least in all the specs in the SSM working group.
 ^ 
 ^ And if you have that meaning of SSM, then ASM makes a very good distinction:
 ^ In SSM you the receiver must be SPECIFIC about which source you want traffic
 ^ from (and right, it can be more than one), and in ASM you take traffic from
 ^ ANY source.
 ^ 
 ^ >         OM  - original multicast
 ^ 
 ^ Oh no, yet another abbreviation ;-))
 ^ 
 ^ Cheers
 ^ 	Toerless

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 22 Mar 2001 22:51:46 -0800

>> Dino, I think this would resolve your point, correct?

    Right. I did't mean to imply single source. I really thought that was
    the acronym expansion. I wanted to propose what was already decided on
    and just consider an alternative name for ASM or ISM.

Dino