Subject: Re: Why MSDP?

From: Bill Fenner <[email-masked]>
Date: Thu, 22 Mar 2001 17:25:48 -0600

One reason: the timescales for change of active source indications are
much different than BGP was designed to carry.  BGP wants to carry
data that doesn't change very often, e.g. see route dampening.  Sources
can come and go at an arbitrary rate, so the rate of change of the
information is potentially much higher.

  Bill

---

From: Vijay Gill <[email-masked]>
Date: Thu, 22 Mar 2001 19:41:35 -0500

> information is potentially much higher.

So churn wasn't ok for BGP, but its ok in MSDP? Just wondering.

/vijay

---

From: John Meylor <[email-masked]>
Date: Thu, 22 Mar 2001 21:01:48 -0800

> So churn wasn't ok for BGP, but its ok in MSDP? Just wondering.

Vijay, yes,
sa turnover and cache size variability in MSDP is 
perfectly normal and expected behavior in 
the interdomain msdp topology, (reflecting sources
becoming active or non-active which is cool)
and with basic filtering in place (for bogus/unwanted
registers, sa-messages, etc) this "churn" is ok.  
 (Of course in BGP you don't expect lots and lots
of prefixes to be coming and going regularly, so
thats not ok.)
 However, just as with unicast reachability in BGP, 
if you don't control what information you are receiving
or announcing (eg in bgp from redistributing igp, or not filtering 
on peering), then msdp churn can quickly become "not ok".
 I think one of the conclusions drawn at MBONED WG
this week was to define some standard policy practices
for PIM/MSDP which could help make sure we can avoid
unwanted contributions to churn in msdp topology, see
Marshall Eubanks talk.

 John

---

From: Vijay Gill <[email-masked]>
Date: Fri, 23 Mar 2001 00:19:55 -0500

> > So churn wasn't ok for BGP, but its ok in MSDP? Just wondering.

 [snip]

> unwanted contributions to churn in msdp topology, see

John, thanks for the very useful explanation. The question was asked half
in jest, without expecting any serious answers, but the answer is
appreciated nevertheless.

Anyway, jhall and I still owe you a pizza, let us know when and where.

/vijay

---

From: "Nagesh Chintada" <[email-masked]>
Date: Fri, 23 Mar 2001 10:13:36 -0500

Bill,
Isn't it true that MBGP alread is used to announce multicast routes to
these sources? They may not
be host routes but still MBGP is carrying routes for these sources!

Agreed that distributing source routes is a little more work for MBGP, but
IMHO it is far less work
that deploying MSDP protocol. And BGP does indeed handle a large amount of
route changes.....

Besides, relying on an MBGP solution will
1. Make it much easier to deploy PIM-SM interdomain. It becomes as easy (
or so they say)
    as deploying SSM interdomain.
2. Eliminate the extra traffic that is carried by MSDP msgs.
3. Make it that much easier to manage
4. Probably speed up adoption of multicast by ISPs.

I think there are lots of advantages to using MBGP...  can someone explain
what I may be missing here?

Cheers,
Nagesh

---

From: Bill Fenner <[email-masked]>
Date: Sun, 25 Mar 2001 13:23:02 -0600

>these sources?

Yes, but these announcements don't change when the sources start or
stop sending traffic.

>what I may be missing here?

You are missing the timescale argument that I wrote in my first reply.

  Bill

---

From: Ali Boudani <[email-masked]>
Date: Tue, 27 Mar 2001 20:38:32 +0200

Hello,

> information is potentially much higher.

I think that the main problem is that we are using multiple RPs instead of
one RP (RP for each domain) and that is why we are needing the MSDP. Isnt
true ??
PS : we are using multiple RPs to avoid administrative dependencies between
domains.

Ali