Subject: Re: SSm, simple multicast and Express

From: [email-masked] (Kevin C. Almeroth)
Date: Wed, 21 Mar 2001 06:45:53 -0800 (PST)

Well, Express was never a draft...  it was a research paper.

Simple was a draft but would have required a wholesale change in the infrastructure.

SSM is based on PIM and so is less dramatic a change to the existing infrastructure.

<humor on>

Maybe SSM stands for SUPER Simple Multicast!!! :-)

What is wrong with ISM?  Does it stand for Independent Source Multicast?!?  :-)

<humor off>

-Kevin

>>Ali Boudani wrote:
>>
>>> If I understood well (maybe), SSM has replaced Simple Multicast and
>>> EXPRESS
>>> But what was the problem in those 2 protocoles??
>>>
>>> thanx
>>
>>The only problem is, they weren't adopted.
>>
>>(i.e., there is nothing fundamentaly wrong with them that I know of, things just
>>evolved differently.)
>>
>>                                 Regards
>>                                 Marshall Eubanks

---

From: Lloyd Wood <[email-masked]>
Date: Wed, 21 Mar 2001 16:03:38 +0000 (GMT)

> Maybe SSM stands for SUPER Simple Multicast!!! :-)

well, simplifying the number of senders to one, at a fixed location,
means that the protocol's got a slightly better chance of deployment.

And once you also simplify the number of receivers to one, at a fixed
location, chances of deployment will increase dramatically, not least
because it will be a far less dramatic change to the existing
infrastructure.

(Call it SSS - Super Simple Stream.)

L.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>