Subject: SSM Implementation

From: Ali Boudani <[email-masked]>
Date: Fri, 16 Mar 2001 19:26:37 +0100

Is there any implementation for SSM??
Is there any code written, or it is just in the stage of developpement??

thanx

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 16 Mar 2001 11:29:27 -0800

> Is there any code written, or it is just in the stage of developpement??

SSM is in Cisco IOS starting with 12.0(15)S, 12.1(5)E, 12.2(1).
See the pointer to SSM on

   ftp://ftpeng.cisco.com/ipmulticast.html

Also note that to enable SSM you only need to have SSM software on the
routers besides receivers. In the rest of the nework you can have
standard PIM-SM routers.

Cheers
	Toerless

P.S.: Sorry if this was unppropriate for this mailing list. I hope it was not.

---

From: John Meylor <[email-masked]>
Date: Fri, 16 Mar 2001 11:43:55 -0800

> Is there any code written, or it is just in the stage of developpement??

A cisco implementation has been tested and is
deployed by customers in production images. 

Includes:
 SSM and IGMPv3

[email-masked] or
ftp://ftpeng.cisco.com/ipmulticast.html
for expansion on vendor details.

 john

---

From: "Timothy Hoff" <[email-masked]>
Date: Fri, 16 Mar 2001 14:44:55 -0600

SSM is supported in Cisco IOS beginning with release 12.1(3)T.  However,
12.1(5)T or later is recommended.

There is also support for URD and IGMPv3 lite as transition tools until
IGMPv3 is widely available in host operating systems.

--teh

-----Original Message-----
From: Ali Boudani [mailto:[email-masked]]
Sent: Friday, March 16, 2001 12:27 PM
To: [email-masked]
Subject: SSM Implementation

thanx

---

From: Tom Pusateri <[email-masked]>
Date: Fri, 16 Mar 2001 14:54:21 -0800

>Is there any code written, or it is just in the stage of developpement??

Well, the cool thing about SSM is that it uses protocols that
were either already done (PIM sparse mode) or were already in the works
(IGMP v3).

This means that in most cases, you can run SSM over existing PIM
implementations and just need IGMPv3 at the edge of your network
directly connected to your hosts.

In particular, all JUNOS versions from the beginning support PIM SSM.
JUNOS 4.4 adds IGMP v3 SSM-only support.

Thanks,
Tom