Subject: Address allocation

From: Ali Boudani <[email-masked]>
Date: Thu, 19 Apr 2001 13:57:37 +0200

I didnt understand the issue aof address allocation in ssm.?
we have a source S and a receiver say R want to recieve informations
from S.
So in that case R should inform its DR by using IGMPv3.
How R knows that he is a member of a group G and how is G is allocated?
is the address g is allocated by the application ??

I just want to know the complete process because it is not clear in the
drafts.
thanx

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 19 Apr 2001 09:10:40 -0400

Hello Ali;

> How R knows that he is a member of a group G and how is G is allocated?

R knows he is a member of the group because he joined it ? If you
are asking "how does R know that a group exists to be joined ?",
this is done "out of band" - that is, you will know about SSM groups
because you have been informed about them in some other fashion, such
as by clicking on a button on a web page, or in an e-mail, etc., etc.

The address G is allocated by the source. There are basically no
restrictions on G, except that it has to be kept in the 232/8 
address range (for multicasts to the general Internet) and,
if you are sourcing more than one group from the same IP address, S,
you have to give them unique group  addresses, G.

Also, from
http://www.ietf.org/internet-drafts/draft-holbrook-ssm-arch-02.txt

The network service
identified by (S,G), for SSM address G and source host address S, is
referred to as a "channel."  

So the use of "Group" is considered obsolete !

Again, from the above draft :

The following table summarizes the terminology:

  Service Model:        Any-Source          Source-Specific
  Network Abstraction:  group               channel
  Identifier:           G                   S,G
  Receiver Operations:  join, leave         subscribe, unsubscribe

(Personally, I regard unnecessary changes in widely used terminology to be
unwise, but the rough consensus seems to have gone otherwise.)

> I just want to know the complete process because it is not clear in the

                                   Regards
                                   Marshall Eubanks

   Multicast Technologies, Inc.
   10301 Democracy Lane, Suite 410
   Fairfax, Virginia 22030
   Phone : 703-293-9624          Fax     : 703-293-9609     
   e-mail : [email-masked]     http://www.on-the-i.com         

 Test your network for multicast : http://www.multicasttech.com/mt/

---

From: Ali Boudani <[email-masked]>
Date: Thu, 19 Apr 2001 15:41:48 +0200

Hello,
If all sources use the same G , there is no meaning of multicast group.
because S1 ....Sn can use the same address G and in that case all the
multicast world is using the same address G. So we can maybe just assign or
allocate a single multicast address to all the multicast recievers in the
internet and use the S just to differciate between them.
Isnt true??
Ali

---

From: Ali Boudani <[email-masked]>
Date: Thu, 19 Apr 2001 15:37:24 +0200

Ok,
then what is the meaning of S,G ??
the S, G is not useful also and we should use only S.
I should be interrested just about S and I dont care about G ..
The channel cant mean S,G because S cant generate more than one G , isnt
right??
Thanx

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 19 Apr 2001 10:15:05 -0400

> internet and use the S just to differciate between them.

What you say is true in principle.

This would cause problems in practice on Ethernet links, because of the mapping between
group addresses and MAC addresses is not unique -
see the discussion at the end of
http://www.multicasttech.com/faq/multicast_faq.html

Also, remember, for any given S, the sources must be unique. We
(for example) source 3 to 6 G for each S.

But SSM basically does remove any need to assign or allocate group addresses.

Note that not all multicast applications will migrate to SSM.

--
                                 Regards
                                 Marshall Eubanks

T.M. Eubanks
Multicast Technologies, Inc
10301 Democracy Lane, Suite 410
Fairfax, Virginia 22030
Phone : 703-293-9624
Fax     : 703-293-9609
e-mail : [email-masked]
http://www.on-the-i.com

---

From: Gregory Shepherd <[email-masked]>
Date: Thu, 19 Apr 2001 08:15:19 -0700 (PDT)

Ali,

Yes, S CAN generate more than one G and does. Content houses would hit a
scaling limit if each stream required a unique S.

Greg

---

From: "Mladen Sablic" <[email-masked]>
Date: Thu, 19 Apr 2001 17:13:05 +0100

Ali,

If you used only S to differentiate between SSM sources
then ALL multicast packets from that source would go to
ALL the receivers interested in S.

By having channels (S,G) one can have (in SSM range)
2^24 independent multicast packet streams from one
source each going to a independent set of receivers.

Hence you can have receiver interested in (S,G1) &
not in (S,G2) and each (S,G) is likely to have a
chunk of bandwidth associated with it and bandwidth
is likely to be a limited resource at the receiver
end.

By having (S,G) you control bandwidth at the expense
of router memory which has to store state for each
(S,G) passing through it.
 
Mladen

<[email-masked]>

---

From: Steve Simlo <[email-masked]>
Date: Thu, 19 Apr 2001 17:34:20 +0100

A Source can generate many IPmc discrete groups Gi and each will be a 
separate SSM Channel:

(S,G1), (S,G2)....etc etc

>The channel cant mean S,G because S cant generate more than one G , isnt

Steve Simlo
Consulting Engineer
Cisco Systems Ltd
3 The Square
Stockley Park
Uxbridge
Middlesex UB11 1BN
United Kingdom

Direct Line: 		+44 20-8756 8435
Fax:			+44-20-8756 8099
GSM:    		+44 7802-608 318
Home Office Tel: 	+44 20-8767 5886

Email: 	[email-masked]
Internal 
URL: 	http://wwwin-emea/FieldInfo/Consult/General/team/PersInfo/ssimlo.htm