Subject: RE: 232-Addresses not only for current SSM model

From: "Doron Rajwan" <[email-masked]>
Date: Wed, 2 May 2001 17:50:05 +0200

I guess you mean 232/8 (the range 232/24 is 232.0.0.xxx).

I tend to agree that 16M addresses seems a lot. However, keep in mind
that:

1. Reverse-IGMP, or On-Demand Multicast, will cause a server to use a
lot of addresses, about one address per URL per rate. This can be a lot.

2. In order not to have too many Ethernet MAC layer collisions, we
should have some bits in the address field, selected randomly by the
server.

Doron.

____________________________________________________
Doron Rajwan, Chief Technology Officer, Bandwiz Inc.
11 Bareket St. Herzlia 46511 Israel
mailto:[email-masked]
Office: +972-(9)-9515116, ext. 122
Fax:    +972-(9)-9515117
Cell:   +972-(56)-507799
Home:   +972-(3)-6736614

-----Original Message-----
From: Hummel Heinrich [mailto:[email-masked]]
Sent: Wednesday, May 02, 2001 2:46 PM
To: [email-masked]
Subject: 232-Addresses not only for current SSM model 

	Hello,

	The 232/24-address space is reserved for source-specific
multicast. An address G from this address space only uniquly identifies
a multicast channel
	together with a particular source's unicast address S.  

	Application: multicast model according to the SSM WG.

	1) 
	This is really great for many very good reasons.

	2)
	A particular source of unicast address S does not head  2**24
SSM-multicast channels. Therefore, a subrange would do as well.

	3)
	I can imagine further multicast models in the future, which
would be happy to use a 232/24-address, but which
	would use different protocol procedures, protocol messages,
protocol TLVs. 
	Just one example:
	A completely different mulitcast delivery channel could be a
ring. As a matter of fact, a ring needs only about 20 % more hops than a
Dijkstra-tree.
	The information can be sent out in two directions so that in
case of a link failure, each receiver node would get the information at
least once.
	Furthermore, in case of optical networks, the power of light is
preserved in a better way.
	Of course, a ring could be extended to a "tree of rings" or a
"ring of rings".
	 
	 I am quite sure that other folks have further ideas. People do
not stop thinking about multicast just because the SSM work is done.

	For all such reasons: Isn't it  appropriate to reserve a
subrange of the 232/24- address space for SSM?

	Regards,
	Heinrich Hummel
	Siemens AG

---

From: "Nagesh Chintada" <[email-masked]>
Date: Wed, 02 May 2001 13:01:05 -0400

Doron,
Can you point out the draft(s) that discuss the Reverse-IGMP?

Thanks,
Nagesh

---

From: Hugh Holbrook <[email-masked]>
Date: Wed, 2 May 2001 11:43:29 -0700 (PDT)

> Can you point out the draft(s) that discuss the Reverse-IGMP?

Here you go.

-Hugh

----------------------------------------------------------------
Message-Id: <[email-masked]>
To: IETF-Announce: ;
Cc: [email-masked]
From: [email-masked]
Reply-To: [email-masked]
Subject: I-D ACTION:draft-ietf-idmr-msnip-00.txt,.ps
Date: Wed, 28 Feb 2001 06:58:48 -0500

--NextPart

A New Internet-Draft is available from the on-line Internet-Drafts
directories.  This draft is a work item of the Inter-Domain Multicast
Routing Working Group of the IETF.

	Title		: Multicast Source Notification of Interest Protocol 
                          (MSNIP)
	Author(s)	: B. Fenner ET AL.
	Filename	: draft-ietf-idmr-msnip-00.txt,.ps
	Pages		: 18
	Date		: 27-Feb-01
	
This document discusses the Multicast Source Interest Notification
Protocol (MSNIP).  MSNIP is an extension to IGMPv3 [1] that provides
membership notification services for sources of multicast traffic.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-idmr-msnip-00.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-idmr-msnip-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-idmr-msnip-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.