Subject: AW: 232-Addresses not only for current SSM model

From: Hummel Heinrich <[email-masked]>
Date: Wed, 2 May 2001 17:23:37 +0200

Doron answered:

> I guess you mean 232/8 (the range 232/24 is 232.0.0.xxx).
	 Thanks. you are right. 
> I tend to agree that 16M addresses seems a lot. However, keep in mind
> that:
> 
> 1. Reverse-IGMP, or On-Demand Multicast, will cause a server to use a
> lot of addresses, about one address per URL per rate. This can be a lot.
	 Sure. But 1 million or  500 000 is still sufficient, isn't it ?

> 2. In order not to have too many Ethernet MAC layer collisions, we
> should have some bits in the address field, selected randomly by the
> server.
	 
	My point is another one or maybe I should ask this question:
	When a node in the middle of the network receives a particular "multicast" message, how can he
	recognize which  evtly. present  (S,G) -multicast channel is meant in case there are multiples of  (S,G)-models, and not just SSM ?

	Heinrich

> Subject: 232-Addresses not only for current SSM model 
> 
> 
> 	Hello,
> 
> 	The 232/24-address space is reserved for source-specific
> multicast. An address G from this address space only uniquly identifies
> a multicast channel
> 	together with a particular source's unicast address S.  
> 
> 	Application: multicast model according to the SSM WG.
> 
> 	1) 
> 	This is really great for many very good reasons.
> 
> 	2)
> 	A particular source of unicast address S does not head  2**24
> SSM-multicast channels. Therefore, a subrange would do as well.
> 
> 	3)
> 	I can imagine further multicast models in the future, which
> would be happy to use a 232/24-address, but which
> 	would use different protocol procedures, protocol messages,
> protocol TLVs. 
> 	Just one example:
> 	A completely different mulitcast delivery channel could be a
> ring. As a matter of fact, a ring needs only about 20 % more hops than a
> Dijkstra-tree.
> 	The information can be sent out in two directions so that in
> case of a link failure, each receiver node would get the information at
> least once.
> 	Furthermore, in case of optical networks, the power of light is
> preserved in a better way.
> 	Of course, a ring could be extended to a "tree of rings" or a
> "ring of rings".
> 	 
> 	 I am quite sure that other folks have further ideas. People do
> not stop thinking about multicast just because the SSM work is done.
> 
> 	For all such reasons: Isn't it  appropriate to reserve a
> subrange of the 232/24- address space for SSM?
> 
> 	Regards,
> 	Heinrich Hummel
> 	Siemens AG

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 02 May 2001 15:07:56 -0400

>         recognize which  evtly. present  (S,G) -multicast channel is meant in case there are multiples of  (S,G)-models, and not just SSM ?

Dear Heinrich;

    This should not happen. (Another way of putting it is that there should not need to be
any protocol dicovery.) 232/8 is reserved for SSM. The ONLY other address ranges that should
be used for SSM are the administratatively scoped ones, where it is up to the domain
administrator to keep SSM and ASM traffic separated.

See draft-albanna-iana-ipv4-mcast-guidelines-01.txt
and RFC 2365.
--
                                 Regards
                                 Marshall Eubanks

> > subrange of the 232/24- address space for SSM?

T.M. Eubanks
Multicast Technologies, Inc
10301 Democracy Lane, Suite 410
Fairfax, Virginia 22030
Phone : 703-293-9624
Fax     : 703-293-9609
e-mail : [email-masked]
http://www.on-the-i.com

Test your network for multicast : http://www.multicasttech.com/mt/

---

From: "Stephen Sprunk" <[email-masked]>
Date: Wed, 2 May 2001 15:18:47 -0500

Thus spake "Hummel Heinrich" <[email-masked]>
> When a node in the middle of the network receives a particular
> "multicast" message, how can he recognize which  evtly. present
> (S,G) -multicast channel is meant in case there are multiples of
> (S,G)-models, and not just SSM ?

A node in the middle of the network forwards a packet based on the (S,G)
state already stored in that node; this behavior is independent of how
exactly that (S,G) state is created (eg. DVMRP, MOSPF, PIM).

Using 232/8 addresses declares that the sender(s) and recipient(s) want
the SSM delivery model (versus the default ISM).  It does not mandate
the use of PIM; PIM just happens to be the only protocol (AFAIK) that
offers SSM delivery so far.

I can't tell from your first message if you're looking to develop a
different delivery model than either ISM or SSM, or if you're looking to
develop a different protocol to provide ISM and/or SSM delivery.

> Heinrich

S

     |          |         Stephen Sprunk, K5SSS, CCIE #3723
    :|:        :|:        Network Design Consultant, ANS
   :|||:      :|||:       RCDN2 in Richardson, TX
.:|||||||:..:|||||||:.    Email: [email-masked]