Subject: SSM, IGMPv3 on Linux

From: Aaron J Fabbri <[email-masked]>
Date: Tue, 18 Sep 2001 12:16:34 -0700 (PDT)

>
>Has anybody tried to get SSM working with on Linux ?
>

By "working", you may mean one of two things:

1. SSM support for end-hosts
  
  Sprint labs has a IGMPv3 patch available for kernel 2.4.0, and 2.2.18 at:
  
  http://www.sprintlabs.com/Department/IP-Interworking/multicast/linux-igmpv3/
  
  I had to make some minor modifications to the patch for my 2.4.2 kernel.  
  When you have your kernel patched, you simply use the new API discussed in
  
  draft-ietf-idmr-msf-api-01.txt  (try google)
  
2. Using Linux as a SSM router

 I've been using PIM-SM with application-layer source filters to do testing.  
 I am not aware of a SSM-specific mrouted for linux yet, but the changes 
 which need to be made to PIM-SM to realize the SSM model are fairly simple.  
 For specifics, see:
  
  http://www.dante.net/mbone/refs/draft-bhattach-diot-pimso-00.txt
  
  Basically the PIM-SM router needs to be able to skip the shared tree 
  and RP and go straight to source-specific trees, depending on which 
  type of IGMPv3 join was received.
  
>I am assuming that since the latest Linux distributions (Kernel 2.4+) have
>IGMP v3 and PIM-SM support, SSM should already be in place, or am I
>seriously missing something ?

I don't believe IGMPv3 is a standard part of linux yet, unfortunately.  Does 
anyone know what version this is going to be officially included in?

Thanks,

Aaron

   -------------------==============================------------------
Aaron Fabbri   http://www.cs.uoregon.edu/~fabbri    [email-masked]
   -------------------==============================------------------

------------- End Forwarded Message -------------

   -------------------==============================------------------
Aaron Fabbri   http://www.cs.uoregon.edu/~fabbri    [email-masked]
   -------------------==============================------------------

---

From: "fleischhauer" <[email-masked]>
Date: Wed, 19 Sep 2001 10:28:01 +0200

Hello,

I tried to install the Sprintlabs Kernel patches in both versions.
After this I had not an IGMP function on these hosts.
But the FreeBSD implementations from Wilbert de Graaf works very well.

KARSTEN

Karsten Fleischhauer

T-NOVA Berkom
EB 11.15
IP-Technologien

Goslarer Ufer 35
D-10589 Berlin

Mail:    [email-masked]
Telefon: +49-(0)30-3497-2854
Fax:     +49-(0)30-3497-3199

-----Ursprüngliche Nachricht-----
Von: Aaron J Fabbri [mailto:[email-masked]]
Gesendet: Dienstag, 18. September 2001 21:17
An: [email-masked]
Betreff: SSM, IGMPv3 on Linux

Thanks,

Aaron