Subject: [Stackevo] Workshop planning

From: Brian Trammell <[email-masked]>
Date: Thu, 28 Aug 2014 15:00:56 +0200

Greetings, all,

Ted, Eliot, Mirja and I had a meeting yesterday to finalize the scope for the workshop; a draft CFP resulting from this discussion is attached. I've also talked to Mat Ford about possible ISOC sponsorship of a social dinner / travel grants, if necessary, and expect to hear back soon.

Since the most important question is "who" at the moment, the list of attendees (beyond those in the IAB and the program) we know we'd like to invite to submit something are the following:

- Michio Honda, NEC Europe (TCP extensibility and user-space protocol stacks)
- Benoit Donnet, University of Liege (Tracebox, for measuring path impairment)
- Ryan Craven, Naval Postgraduate School (a middlebox-cooperative TCP)
- Vimalkumar Jayakumar, Stanford; or
- Mohammad Alizadeh, Cisco/Stanford (small languages for path signaling)
- Mark Nottingham, Akamai
- David Black, EMC
- Dave Clark, MIT (Mirja spoke with him at SIGCOMM last week; he's interested but probably won't be able to show up)

There are other communities of interest from which we'd like to have people in the room.

- Economists with some technical background; Eliot has some contacts here.

- We need application developers who are faced with these problems. Dave, would you know anybody in the XBox community we should talk to, perhaps? Joe, for WebEx? 

- The end to end principle is threatened enough in the "traditional Internet"; where the Internet meets mobile (cellular) communications, things are much, much works. So we probably need some cellular geeks in the room. Eliot and Ted mentioned they might be able to find someone. It might make sense to talk to Pete Resnick, as well.

If others have ideas about who should be in the room, please let us know...

We'd like to the the CFP up on the IAB website soon, so please have a look at it as well.

Thanks, cheers,

Brian

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 28 Aug 2014 21:38:58 +0800

> There are other communities of interest from which we'd like to have people in the room.

I can see good contribution from Stuart Cheshire.

> - The end to end principle is threatened enough in the "traditional Internet"; where the Internet meets mobile (cellular) communications, things are much, much works.

did you mean "worst"?

> So we probably need some cellular geeks in the room. Eliot and Ted mentioned they might be able to find someone. It might make sense to talk to Pete Resnick, as well.
> 

I'm sorry to put this back again, but we (IAB and specially this program) need to have operational people to provide a reality check on what can be deployed.   

> We'd like to the the CFP up on the IAB website soon, so please have a look at it as well.

will review.

Marc.

> 
> Thanks, cheers,
> 
> Brian
> 
> <stackevo-draft-cfp.pdf>
> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo

---

From: Brian Trammell <[email-masked]>
Date: Thu, 28 Aug 2014 16:13:24 +0200

> I can see good contribution from Stuart Cheshire.

Yep. He's already on the program, though.

>> - The end to end principle is threatened enough in the "traditional Internet"; where the Internet meets mobile (cellular) communications, things are much, much works.

yep... more coffee, please. :)

> I'm sorry to put this back again, but we (IAB and specially this program) need to have operational people to provide a reality check on what can be deployed.   

Agreed... Not really sure which bits of the network operations community would be interested, though. Any ideas who we should talk to?

>> We'd like to the the CFP up on the IAB website soon, so please have a look at it as well.

Thanks!

Cheers,

Brian

---

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Thu, 28 Aug 2014 15:58:11 +0000

On 8/28/14, 1:00 PM, "Brian Trammell" <[email-masked]> wrote:

>- We need application developers who are faced with these problems. Dave, 
>would you know anybody in the XBox community we should talk to, perhaps? 
>Joe, for WebEx?

I was thinking that Patrick McManus might be a really good choice here.  
He owns the network stack for Mozilla and was interested in helping when I 
talked to him in Toronto.

-- 
Joe Hildebrand

---

From: Mary Barnes <[email-masked]>
Date: Thu, 28 Aug 2014 11:13:30 -0500

I'll send comments separately on the cfp, but I think Nandita Dukkipati
would be a good choice.  You can see her research here and some of it seems
quite relevant: http://research.google.com/pubs/author39115.html

Mary.

On Thu, Aug 28, 2014 at 8:00 AM, Brian Trammell <[email-masked]> wrote:

> Greetings, all,
>
> Ted, Eliot, Mirja and I had a meeting yesterday to finalize the scope for
> the workshop; a draft CFP resulting from this discussion is attached. I've
> also talked to Mat Ford about possible ISOC sponsorship of a social dinner
> / travel grants, if necessary, and expect to hear back soon.
>
> Since the most important question is "who" at the moment, the list of
> attendees (beyond those in the IAB and the program) we know we'd like to
> invite to submit something are the following:
>
> - Dave Clark, MIT (Mirja spoke with him at SIGCOMM last week; he's
> interested but probably won't be able to show up)
>
> - The end to end principle is threatened enough in the "traditional
> Internet"; where the Internet meets mobile (cellular) communications,
> things are much, much works. So we probably need some cellular geeks in the
> room. Eliot and Ted mentioned they might be able to find someone. It might
> make sense to talk to Pete Resnick, as well.
>

---

From: Brian Trammell <[email-masked]>
Date: Thu, 28 Aug 2014 22:15:05 +0200

hi Joe,

> talked to him in Toronto.

Yep, sounds good... I don't know him very well; could you approach him once we have a final CFP?

Thanks, cheers,

Brian

---

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Thu, 28 Aug 2014 20:45:24 +0000

>once we have a final CFP?

Absolutely.

-- 
Joe Hildebrand

---

From: Brian Trammell <[email-masked]>
Date: Fri, 29 Aug 2014 00:18:16 +0200

hi Mary,

On 28 Aug 2014, at 18:13, Mary Barnes <[email-masked]> wrote:

> I'll send comments separately on the cfp, but I think Nandita Dukkipati would be a good choice.  You can see her research here and some of it seems quite relevant: http://research.google.com/pubs/author39115.html

Yep, absolutely. As with Patrick, I also don't know her very well (just as co-chair of conex)... could you approach her with the final CFP?

Thanks, cheers,

Brian

---

From: Brian Trammell <[email-masked]>
Date: Fri, 29 Aug 2014 10:23:00 +0200

A couple of updates; first, to the who:

> - Dave Clark, MIT (Mirja spoke with him at SIGCOMM last week; he's interested but probably won't be able to show up)

- Nandita Dukkipati
- Patrick McManus

(and hi, Stuart, we very much hope you'll be able to attend, too. :) )

> - The end to end principle is threatened enough in the "traditional Internet"; where the Internet meets mobile (cellular) communications, things are much, much worse. So we probably need some cellular geeks in the room. Eliot and Ted mentioned they might be able to find someone. It might make sense to talk to Pete Resnick, as well.
> 

Second, on the date: would anyone on the program have an issue with Monday-Tuesday 26 and 27 January 2015?

Cheers,

Brian