Subject: [Stackevo] Workshop on Stack Evolution in a Middlebox Internet

From: Brian Trammell <[email-masked]>
Date: Tue, 19 Aug 2014 16:10:40 +0200

Greetings, all,

After a few rounds of edits, and a little discussion on the IAB list and with the TSV ADs, the proposed CfP for our workshop now looks like the following:

IAB Workshop on Stack Evolution in a Middlebox Internet
=======================================================
Winter 2015 - location and exact date TBD

The Internet's transport layer has ossified, squeezed between narrow interfaces (from BSD sockets to pseudo-transport over HTTPS) and increasing in-network modification of traffic by middleboxes that make assumptions about the protocols running through them. This ossification makes it difficult to innovate in the transport layer, through the deployment of new protocols or the extension of existing ones. At the same time, emerging applications demand new functionality that existing protocols can provide only inefficiently, if at all.

To begin to address this problem, the Internet Architecture Board, within the scope of its IP Stack Evolution Program, is organizing a workshop to discuss approaches to de-ossifying transport, especially with respect to interactions with middleboxes and new methods for implementing transport protocols. Recognizing that the end-to-end principle has long been compromised, we start with the fundamental question of which functions should be provided on-path in the network, and how these should be exposed to endpoints, in order to support cooperative approaches to meeting new requirements for transport.

Topics
------

For this workshop we would like to consider topics including (but not limited to) the following:

- Characterization of middlebox behavior
- Methods for middlebox detection, traversal, and avoidance
- Mechanisms for cooperative middlebox-to-endpoint and endpoint-to-middlebox signaling
- Development and deployment of transport-like features in application-layer protocols
- Lessons learned from existing path signaling approaches

We will explicitly focus on approaches that are incrementally deployable within the present Internet.

The desired outcome of the workshop, based on discussion of proposed approaches, would be guidance on future work in the area to pursue within the IAB Stack Evolution Program or within new IETF Working Groups. We will also explore possible areas for standardization, e.g. new protocols that separate signaling to and from on-path devices and common transport semantics from the rest of the transport protocol; and for general guidance, e.g. how transports as well as middleboxes can be designed and deployed to achieve these goals.

Call for Position Papers
------------------------

Attendance at the workshop is by invitation only. Prospective participants are invited to submit short *(two-page or less)* position papers outlining their views on one or more topics related to the scope of the workshop. *(submission instructions TBD)*

Important Dates 
---------------

*(proposed)*

- end October 2014: position papers due
- end November 2014: author notification
- mid/end January 2015: workshop

Committee
---------

*(TBD)*

Any further comments, especially on the scope, would be welcome. We've removed a couple of points further down the path of transport agility in the hopes of keeping the scope small enough to have a successful workshop that useful guidance comes out of.

Cindy: once we have a final CFP, we'd like to put it up online somewhere on iab.org; I presume this is possible and you'd be the one to talk to about that?

On timing and location: our initial proposal was to have the workshop between Honolulu and Dallas in Zürich, end of January 2015. Of course, we'd like to make sure that the people we think we'd like to attend would be able to travel to the workshop, so we're open to holding this in other places (i.e. stateside) if necessary (and possible to organize space). My list of desired participants (beyond those in the program) would also include:

(1) People who have thought about measuring middlebox brokenness: e.g. Michio Honda from NEC, Benoit Donnet from Liege.

(2) People who have thought about middlebox-aware transport: Ryan Craven or Robert Beverley from NPS; Mark Allman (authors of "A Middlebox-Cooperative TCP for a non End-to-End Internet", which will be presented at SIGCOMM in Chicago in a few hours).

(3) People who have already tried to unbreak path signaling. Don't really know anyone here.

We'd also appreciate any further suggestions of people to add to the list. The idea would be to explicitly ask those on the list to contribute a position and participate, in addition to having an open call for position papers; who can participate and where would feed into a location decision.

Thoughts?

Thanks, cheers,

Brian

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 19 Aug 2014 09:56:19 -0500

Hi, Brian,

> (1) People who have thought about measuring middlebox brokenness: e.g. Michio Honda from NEC, Benoit Donnet from Liege.

I'd think you'd want at least one or two of the long-time BEHAVE folks. 
Perhaps asking Dan Wing and Dave Thaler for suggestions would be good. 
(I see that Dave is a program member, so maybe he's already thought of 
people)

If Bruce Lowekamp is still at Skype (LinkedIn thinks he is), he was one 
of the authors on http://tools.ietf.org/html/rfc5780, and Skype 
certainly spent time trying to figure out what to do in our ossified 
world ...

> (3) People who have already tried to unbreak path signaling. Don't really know anyone here.

I'm not quite sure what you mean by this one (more like STUN/TURN/ICE, 
or more like NSIS, or more like something else)?

Spencer