Subject: [Stackevo] ETSI NGP ISG

From: Natasha Rooney <[email-masked]>
Date: Thu, 10 Mar 2016 15:12:55 +0000

Hi all!

I spoke with Andy Sutton the other day, he’s the chair of the new ETSI Next Generation Protocol ISG. We went through the motivation for the group and their upcoming work. Here are the notes:

Motivators and Prep Work
It seems to motivators for this work came from an original study on TCP Optimisers which Andy and some of his colleagues conducted. The study showed how some protocols aren’t suited to running over operator networks so expensive optimisers is needed to solve this (sound familiar?!). He mentioned that with the introduction of 4G, the addition of security to the network (resolving in a need for IPSec gateways), the new edge computing plans meant there was a large need for stack evolution.

This paper got the attention of IET, the 5G Innovation Centre in Surrey and BSI. IET encouraged the continuation of the work which caused Andy and his team to discuss the paper with Fujitsu, Huawei, Telefonica and BT. All recognised the problem statement.

BSI then sponsored a small event including the paper authors, the organisations mentioned above and ETSI and IETF. The attendees agreed the problem statement. ETSI approached the authors to continue the work within ETSI and the authors agreed with some of the attendee support.

Aims of the Group
The group does not aim to create the technologies itself. Instead it wishes to provide the "drivers" for new internet architectures across nine key areas (listed below). After it does this work it wants the correct SDOs to pull the architecture and standardise and develop the technologies needed to make it work (for example; IETF would create the necessary protocols). Andy estimates the group should exist for around 3 years to create these drivers, then shut down to allow the SDOs to continue the work.

The areas the group wants to address are:

  *   Addressing
  *   Security, Identity and Authentication
  *   Mobility
  *   IoT requirements
  *   Video and content distribution requirements
  *   Requirements from ultra‐low latency use cases from different sectors (i.e. automotive)
  *   Needs of network operators (e.g. challenges with E2E encrypted content)
  *   eCommerce requirements
  *   Increased energy efficiency requirements within the global ICT sector

Deliverables and Meetings
Andy appreciates that since the press release there hasn’t been a lot of communication about the group causing a lot of people to ask questions. So, the group plans to release a whitepaper detailing the aims, motivators and plans in 6 weeks time (sometime in late April). They will also create a use cases document so they can benchmark solutions against these at a later date.

The group is also planning face-to-face meeting on 30-31st March in Sofia Antipolis, I will try to go to this.

Interested operators include AT&T and Verizon.

Presentations
Overview presentation: https://portal.etsi.org/Portals/0/TBpages/NGP/Docs/ETSI%20NGP%20ISG%20overview.pdf
Andy’s IET presentation: https://tv.theiet.org/?videoid=7664
Telecom TV Article: http://www.telecomtv.com/articles/standards/etsi-looks-beyond-tcp-ip-with-next-generation-protocol-group-13223/

If you have any comments or questions about this please let me know! Otherwise I will keep tabs on it with Andy, and try to attend the March meeting.

Thanks!

Natasha

Natasha Rooney | Technologist, Web and Internet, W3C & IETF | GSMA | [email-masked]<mailto:[email-masked]> | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]<mailto:[email-masked]>

This email and its attachments are intended for the above named only and may be confidential. If they have come to you in error you must take no action based on them, nor must you copy or show them to anyone; please reply to this email or call +44 207 356 0600 and highlight the error.

---

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 14 Mar 2016 14:17:13 +0100

Hi Natasha,

thanks for the detailed infos! Very helpful!

Two comments/questions:

1) You say below that there was an initial meeting including people from the IETF. Do you know who was/is involved in this?

2) Regarding use cases: are they aware of the spud activity? We also have a use case doc (draft-kuehlewind-spud-use-cases; going to update this dos this week with some additional use cases). Maybe that’s useful input form them?

Unfortenately, I will not be able to go to the meeting Sofia Antipolis, as I’m already flying to BA on March 31. But I guess to talk to the people there and monitor what going on, one of us is enough. So thanks for going!

Mirja

> Am 10.03.2016 um 16:12 schrieb Natasha Rooney <[email-masked]>:
> 
> Hi all!
> 
> 	• Addressing
> 	• Security, Identity and Authentication
> 	• Mobility
> 	• IoT requirements
> 	• Video and content distribution requirements
> 	• Requirements from ultra‐low latency use cases from different sectors (i.e. automotive)
> 	• Needs of network operators (e.g. challenges with E2E encrypted content)
> 	• eCommerce requirements
> 	• Increased energy efficiency requirements within the global ICT sector
> 
> Natasha Rooney | Technologist, Web and Internet, W3C & IETF | GSMA | [email-masked] | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked] 
> 
> 
> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo

---

From: Natasha Rooney <[email-masked]>
Date: Tue, 15 Mar 2016 12:25:26 +0000

Hey Mirja!

I remember during the talk Andy referred to a bunch of possible standards a new technologies including QUIC but I don’t remember him referring directly to spud. I should imagine he’s aware of this - but not the use cases directly. Would you mind if I shared these with him? I could copy you guys if you wish?

Thanks!

Natasha

On Mar 14, 2016, at 1:17 PM, Mirja Kühlewind <[email-masked]<mailto:[email-masked]>> wrote:

Hi Natasha,

Two comments/questions:

Mirja

Am 10.03.2016 um 16:12 schrieb Natasha Rooney <[email-masked]<mailto:[email-masked]>>:

Hi all!

Motivators and Prep Work

Aims of the Group

Presentations

Thanks!

Natasha

_______________________________________________
Stackevo mailing list
[email-masked]<mailto:[email-masked]>
https://www.iab.org/mailman/listinfo/stackevo

---

From: Mirja Kühlewind <[email-masked]>
Date: Tue, 15 Mar 2016 14:38:23 +0100

Hi, 

see below.

> Am 15.03.2016 um 13:25 schrieb Natasha Rooney <[email-masked]>:
> 
> Hey Mirja!
> 
> I remember during the talk Andy referred to a bunch of possible standards a new technologies including QUIC but I don’t remember him referring directly to spud. I should imagine he’s aware of this - but not the use cases directly. Would you mind if I shared these with him?

I think that would be good. Thanks!

> I could copy you guys if you wish?

Sure, if you think that’s helpful.

Mirja

>> On Mar 14, 2016, at 1:17 PM, Mirja Kühlewind <[email-masked]> wrote:
>> 
>> Hi Natasha,
>>