Subject: Re: [Stackevo] IP Stack Evolution Program Review

From: Natasha Rooney <[email-masked]>
Date: Wed, 2 Mar 2016 15:50:40 +0000

Hey guys!

https://docs.google.com/spreadsheets/d/1pTlTQ2Po3ltiGhMI7pM-NRuTiUsNEPECPqeJl4H-e1o/edit?usp=sharing<https://docs.google.com/spreadsheets/d/1pTlTQ2Po3ltiGhMI7pM-NRuTiUsNEPECPqeJl4H-e1o/edit#gid=0>

Here is the table I promised which details the solutions / items we discussed at MaRNEW and their progress since then. I am not sure all of them are necessary / relevant, but I went for a complete list over anything else. I undoubtably got some things wrong, so please let me know if so. Alternatively let me know if you want access to edit (and the necessary credentials!). Comments are open also.

Thanks everyone!

Natasha

Natasha Rooney | Technologist, Web and Internet, W3C & IETF | GSMA | [email-masked]<mailto:[email-masked]> | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]<mailto:[email-masked]>

On Feb 16, 2016, at 12:40 PM, Brian Trammell <[email-masked]<mailto:[email-masked]>> wrote:

Hi, Natasha, all

On 16 Feb 2016, at 09:16, Natasha Rooney <[email-masked]<mailto:[email-masked]>> wrote:

Hey Brian!

I had an awesome chat with Spencer the other day about the outputs from MaRNEW and their status. We know of some things which are actively happening (LURK from the Keyless SSL idea, Zero bit / 1 bit for latency / bandwidth as an idea which came from MaRNEW and will be discussed at ACCORD, etc.) but there are a number of items which either aren’t going anywhere or are not being tracked.

As a result I’m going to make a super helpful (and hopefully not super complicated) table showing all the items suggested at MaRNEW, their status, where they belong (IETF / GSMA and which WG) and some notes. I’ll try to not to make it two colourful (maybe just half a my-little-pony).

I want to get this done in the week after next (more commonly known as the week after MWC), but this doesn’t work so well with your timeline, so I’ll try and get something to you quicker then, and you can choose whether to use it or not!

Ooh, this'd be great to have! I'm not sure how much detail we'll go into on MaRNEW during the review though, so don't go to heroic efforts to get it done before 2.3.

FYI: attached is the first draft of slides I'm planning to show. (The voiceover for the captionless Gemini launch is "I prefer to think of us as a highly efficient launchpad for new work, as opposed to a rusty pickup truck that bits of work fall off of", in reference to the fact that most of what we do is "oooh let's have a workshop!").

Feedback welcome -- let me know if there's anything I'm missing here (at this level of detail).

Cheers,

Brian

<program-review-mar16.pdf>

Thanks!

Natasha

Natasha Rooney | Technologist, Web and Internet, W3C & IETF | GSMA | [email-masked]<mailto:[email-masked]> | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]<mailto:[email-masked]>

On Feb 15, 2016, at 6:14 PM, Brian Trammell <[email-masked]<mailto:[email-masked]>> wrote:

Greetings, all,

The IAB is now reviewing all its programs once per meeting cycle, to allow the whole Board to have visibility into the working of the programs, to compare notes across programs, to review the membership of the Programs to see if the right people are involved, and to see what works (and what doesn't) in order to help things run more smoothly.

The IAB will review the IP Stack Evolution program at its telechat on Wednesday 2 March 2016, and I'm preparing my presentation for this review now. Here's what I think I'm going to say:

(1) We've done a lot since we were "rebooted" following the May 2014 IAB retreat in Cancun, but much of this happens through the initial coordination of smaller groups of individual Program members, as opposed to official actions of the Program. Much of this involves workshop / BarBoF / BOF organization:

- SEMI workshop in Zurich in January 2015, which led to:
- SPUD non-WG BoF in Dallas in March 2015
- HOPS BarBoF in Dallas in March 2015, and the HOPSRG/MAPRG proposed RG afterward
- MaRNEW workshop in Atlanta in September 2015

- IOTSI workshop in San Jose in March 2016

- SEMI workshop proposed to SIGCOMM 2016; proposal rejected.
- ACCORD non-WG BoF proposed for Buenos Aires in April 2016

Indeed, I'm not sure we've had a conversation on the list that didn't lead to some of us going off and proposing a workshop of BoF somewhere. IOTSI came out of discussions about polishing up Point 5 on our program description, which *still* reads, in part: "[Erik and Ralph to provide text to flesh this out]".

(2) We have sent no correspondence, and no statements up to the IAB for approval, though we've discussed the possibility of doing so. Discussion on proposed communication on traffic characterization, still pending, led to another BoF proposal (ACCORD).

(3) We have no official program documents, and no current plans for any. There is one document for consideration as a "program work item", draft-trammell-stackevo-explicit-coop, but it's not clear where the boundary between "architecture" and "engineering" is here.

(4) We have no regular program meetings outside IETF meetings. It's not clear whether we should.

(5) The membership is largely active in areas of interest to the program.

First, I'd like to ask the program whether there's anything I'm missing here that should be included in the review.

Second, I'd like to ask the membership if there's anything less (or more) we should be doing: what would you like to see out of the program as members?

Thanks, cheers,

Brian
_______________________________________________
Stackevo mailing list
[email-masked]<mailto:[email-masked]>
https://www.iab.org/mailman/listinfo/stackevo

This email and its attachments are intended for the above named only and may be confidential. If they have come to you in error you must take no action based on them, nor must you copy or show them to anyone; please reply to this email or call +44 207 356 0600 and highlight the error.

_______________________________________________
Stackevo mailing list
[email-masked]<mailto:[email-masked]>
https://www.iab.org/mailman/listinfo/stackevo

This email and its attachments are intended for the above named only and may be confidential. If they have come to you in error you must take no action based on them, nor must you copy or show them to anyone; please reply to this email or call +44 207 356 0600 and highlight the error.

---

From: "Black, David" <[email-masked]>
Date: Thu, 3 Mar 2016 01:48:43 +0000

Hi Natasha,

Two quick updates:

- Line 2: Mobile Throughput Guidance.  This was brought to TSVWG as individual drafts, in Dallas, and got a mixed reception.
                The end-to-end aspects (e.g., impact beyond the mobile radio network) were a weak area.   As a TSVWG WG
chair, I haven’t heard about this since Dallas.

- Line 5: The conex WG has been closed.   For now, I suggest taking general congestion control topics to tsvwg (wondering
                what I’m wishing for as a tsvwg chair ...)

Unfortunately, I will not be in Buenos Aires, and I have obligations that week which are likely to make remote
participation difficult.

Thanks, --David

From: Stackevo [mailto:[email-masked]] On Behalf Of Natasha Rooney
Sent: Wednesday, March 02, 2016 10:51 AM
To: Brian Trammell; [email-masked]; [email-masked]
Subject: Re: [Stackevo] IP Stack Evolution Program Review

Hey guys!

Thanks everyone!

Natasha

Hi, Natasha, all

Hey Brian!

Cheers,

Brian

Thanks!

Natasha

Greetings, all,

Thanks, cheers,

Brian

---

From: Natasha Rooney <[email-masked]>
Date: Thu, 3 Mar 2016 17:14:48 +0000

Hi David!

Thanks for this! I’m chatting with Kevin Smith about the next steps for the Mobile Throughput Guidance draft - and I think they will bring this back to IETF (somewhere!) at 95, but for now I will add "Initially went to TSVWG, no update since." to the update column!

I have heard some renewed interest in ConEx, but yeah I see too that the group is closed. I’m going to rename the status to "Unknown" till I find out whether this renewed interested came from (I thought someone said something about the IETF95 agenda… but I’ll check!).

Brining new items to TSVWG is noted, and a good thing for me to say to people with new ideas and suggestions! It’s a shame you won’t be at 95, I’ll ask Gorry if he’ll be coming to 95, as it’ll be great to have someone from TSVWG in the ACCORD BoF.

Thanks again!

On Mar 3, 2016, at 1:48 AM, Black, David <[email-masked]<mailto:[email-masked]>> wrote:

Hi Natasha,

Two quick updates:

Thanks, --David

From: Stackevo [mailto:[email-masked]] On Behalf Of Natasha Rooney
Sent: Wednesday, March 02, 2016 10:51 AM
To: Brian Trammell; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Stackevo] IP Stack Evolution Program Review

Hey guys!

Thanks everyone!

Natasha

Hi, Natasha, all

Hey Brian!

Cheers,

Brian

Thanks!

Natasha

Greetings, all,

Thanks, cheers,

Brian

---

From: "Black, David" <[email-masked]>
Date: Thu, 3 Mar 2016 17:23:02 +0000

Gorry expects to be at IETF 95, AFAIK.

Thanks, --David

From: Natasha Rooney [mailto:[email-masked]]
Sent: Thursday, March 03, 2016 12:15 PM
To: Black, David
Cc: Brian Trammell; Stackevo; [email-masked]
Subject: Re: [Stackevo] IP Stack Evolution Program Review

Hi David!

Thanks again!

Hi Natasha,

Two quick updates:

Thanks, --David

Hey guys!

Thanks everyone!

Natasha

Hi, Natasha, all

Hey Brian!

Cheers,

Brian

Thanks!

Natasha

Greetings, all,

Thanks, cheers,

Brian

---

From: Mirja Kühlewind <[email-masked]>
Date: Sat, 5 Mar 2016 10:55:04 +0100

Hi Natasha,

Just quickly on ConEx: the working group is closed (and there was only little energy at the end) but effectively that means that the protocol is now done and can be used for experimentation. 

Dirk, Brian and I submitted a position paper to Marnew on ConEx and spud as examples for signaling alternatives for DPI. Unfortunately, I was not able to come to the workshop. Was there any additional discussion/interest on ConEx (besides Dirk’s presentation)?

I not aware that anybody is currently experimenting with ConEx but it could fit in the scope of accord. However, as I was not at the workshop, I don’t have a clear view what the problem statement for accord is and if it would fit/help. That's for me the interesting part of accord - learning more about the problems the mobile operators have (and not so much about potentially solutions that might exists in the IETF space).

Mirja

> Am 03.03.2016 um 18:14 schrieb Natasha Rooney <[email-masked]>:
> 
> Hi David!
> 
>> On Mar 3, 2016, at 1:48 AM, Black, David <[email-masked]> wrote:
>> 
>> Hi Natasha,
>>  
>> Two quick updates:
>>  
>> https://docs.google.com/spreadsheets/d/1pTlTQ2Po3ltiGhMI7pM-NRuTiUsNEPECPqeJl4H-e1o/edit?usp=sharing
>>  
>> Natasha Rooney | Technologist, Web and Internet, W3C & IETF | GSMA | [email-masked] | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked] 
>> 
>>  
>> On Feb 16, 2016, at 12:40 PM, Brian Trammell <[email-masked]> wrote:
>>  
>> Hi, Natasha, all
>> 
>> 
>> On 16 Feb 2016, at 09:16, Natasha Rooney <[email-masked]> wrote:
>> 
>> Hey Brian!
>> 
>> Natasha Rooney | Technologist, Web and Internet, W3C & IETF | GSMA | [email-masked] | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]
>> 
>> 
>> 
>> On Feb 15, 2016, at 6:14 PM, Brian Trammell <[email-masked]> wrote:
>> 
>> Greetings, all,
>> 
>> [email-masked]
>> [email-masked]
> [email-masked]

---

From: Martin Stiemerling <[email-masked]>
Date: Tue, 8 Mar 2016 09:20:57 +0100

Hi Natasha,

Am 03.03.16 um 18:14 schrieb Natasha Rooney:
> Hi David!
>
> Thanks for this! I’m chatting with Kevin Smith about the next steps for
> the Mobile Throughput Guidance draft - and I /think/ they will bring
> this back to IETF (somewhere!) at 95, but for now I will add "Initially
> went to TSVWG, no update since." to the update column!
>
> I have heard some renewed interest in ConEx, but yeah I see too that the
> group is closed. I’m going to rename the status to "Unknown" till I find
> out whether this renewed interested came from (I thought someone said
> something about the IETF95 agenda… but I’ll check!).

Conex is closed, as the WG has finished its chartered work items. 
However, other SDOs can send liaison statements saying that they are 
interested in CONEX (or any other protocol).

There has been a related work to CONEX in 3GPP: User Plan Congestion 
Management (UPCON). I am not sure about the state of this.

Let me know if there is more and better insight in this wanted.

Thanks,

   Martin

---

From: Natasha Rooney <[email-masked]>
Date: Tue, 8 Mar 2016 18:52:01 +0000

Hey Mirja!

Thanks for this! Yeah it’s really odd - I saw the grow was closed but many people have been speaking to me about this (operator people). I’ll do some digging to see if people are experimenting with it - and find out who (perhaps they can give more input at ACCORD). I changed the sheet to reflect this for now! Oh, I’ll ask Dirk too! He emailed me a while ago and I haven’t had time to mail him back!

Thanks again!

Natasha

On Mar 5, 2016, at 9:55 AM, Mirja Kühlewind <[email-masked]<mailto:[email-masked]>> wrote:

Hi Natasha,

Mirja

Am 03.03.2016 um 18:14 schrieb Natasha Rooney <[email-masked]<mailto:[email-masked]>>:

Hi David!

Thanks again!

Hi Natasha,

Two quick updates:

Thanks, --David

Hey guys!

Thanks everyone!

Natasha

Hi, Natasha, all

Hey Brian!

Cheers,

Brian

Thanks!

Natasha

Greetings, all,

Thanks, cheers,

Brian