Subject: [Stackevo] Fwd: New Version Notification for draft-welzl-irtf-iccrg-tcp-in-udp-00.txt

From: Michael Welzl <[email-masked]>
Date: Wed, 23 Mar 2016 09:21:25 +0100

Hi all,

I'm sending this here as well because it relates to the idea of "running the Internet over UDP" (which, I noticed, is presentation that Brian will give in MAPRG: https://datatracker.ietf.org/meeting/95/agenda/maprg/ ).
This draft explains how we think it should be done with TCP; we believe that it can have quite significant positive side-effects, mainly because of the opportunity to combine the congestion controls of multiple connections.

The draft also briefly discusses the issue of inserting an extra header (such as SPUD) in between the UDP and encapsulated TCP header.
https://tools.ietf.org/html/draft-trammell-spud-req-02#section-8.3 raises some concerns about such in-band SPUD signalling. What we found here is that this is quite unproblematic in case of TCP when inserted by the sender (it reduces the MSS and must be taken into account when calculating space on the sender side, but this really isn't a big problem).

Further discussion related to this draft should happen on the ICCRG list, please.

Cheers,
Michael

> Begin forwarded message:
> 
> From: Michael Welzl <[email-masked]>
> Subject: Fwd: New Version Notification for draft-welzl-irtf-iccrg-tcp-in-udp-00.txt
> Date: 23 Mar 2016 09:04:48 CET
> To: tcpm IETF list <[email-masked]>, [email-masked]
> 
> Hi,
> 
> This could be of interest to folks here. We'd be glad to get your comments - please send them to the ICCRG list only, at [email-masked].
> 
> Cheers,
> Michael
> 
> 
>> Begin forwarded message:
>> 
>> From: Michael Welzl <[email-masked]>
>> Subject: Fwd: New Version Notification for draft-welzl-irtf-iccrg-tcp-in-udp-00.txt
>> Date: 23 Mar 2016 09:02:38 CET
>> To: [email-masked]
>> 
>> (..)
>> 
>> Chair hat off:
>> 
>> Dear all,
>> 
>> I'm submitting this to ICCRG as the primary (and possibly ultimate? We'll see) forum to discuss this draft. We'd be happy to get your comments - please keep them on the ICCRG list.
>> We have FreeBSD code, from which we can already confirm that the encapsulation is indeed relatively easy to do (as our draft states). However, it doesn't do the congestion control coupling yet; we're working on it. For that, so far, we have simulations - from these, we hope to be able to show some first results in BA.
>> 
>> Cheers,
>> Michael
>> 
>> 
>> 
>>> Begin forwarded message:
>>> 
>>> From: <[email-masked]>
>>> Subject: New Version Notification for draft-welzl-irtf-iccrg-tcp-in-udp-00.txt
>>> Date: 21 Mar 2016 18:45:57 CET
>>> To: Jianjie You <[email-masked]>, Michael Welzl <[email-masked]>, Safiqul Islam <[email-masked]>, Kristian Hiorth <[email-masked]>
>>> Resent-From: <[email-masked]>
>>> 
>>> 
>>> A new version of I-D, draft-welzl-irtf-iccrg-tcp-in-udp-00.txt
>>> has been successfully submitted by Michael Welzl and posted to the
>>> IETF repository.
>>> 
>>> Name:		draft-welzl-irtf-iccrg-tcp-in-udp
>>> Revision:	00
>>> Title:		TCP in UDP
>>> Document date:	2016-03-21
>>> Group:		Individual Submission
>>> Pages:		17
>>> URL:            https://www.ietf.org/internet-drafts/draft-welzl-irtf-iccrg-tcp-in-udp-00.txt
>>> Status:         https://datatracker.ietf.org/doc/draft-welzl-irtf-iccrg-tcp-in-udp/
>>> Htmlized:       https://tools.ietf.org/html/draft-welzl-irtf-iccrg-tcp-in-udp-00
>>> 
>>> 
>>> Abstract:
>>> This document specifies a method to encapsulate multiple TCP
>>> connections using only one UDP port number pair.  Doing so allows for
>>> a relatively easy implementation of coupled congestion control for
>>> the TCP connections.  This can have several performance benefits, and
>>> it makes it possible to precisely assign a share of the congestion
>>> window to the connections based on priorities.  It also enables use
>>> of UDP-based NAT traversal techniques, and it can act as a framework
>>> for experimentation with novel changes to the TCP standard.
>>> 
>>> 
>>> 
>>> 
>>> 
>>> Please note that it may take a couple of minutes from the time of submission
>>> until the htmlized version and diff are available at tools.ietf.org.
>>> 
>>> The IETF Secretariat
>>> 
>> 
>

---

From: Michael Welzl <[email-masked]>
Date: Wed, 23 Mar 2016 12:42:55 +0100

Sure; done

(and thanks for calling it cool  :)   )

> On 23 Mar 2016, at 11:55, Brian Trammell <[email-masked]> wrote:
> 
> hi Michael,
> 
> Thanks, very cool work! Could you post this to [email-masked] as well?
> 
> Cheers,
> 
> Brian
> 
>> On 23 Mar 2016, at 09:21, Michael Welzl <[email-masked]> wrote:
>> 
>> Hi all,
>> 
>> _______________________________________________
>> Stackevo mailing list
>> [email-masked]
>> https://www.iab.org/mailman/listinfo/stackevo
>

---

From: Brian Trammell <[email-masked]>
Date: Wed, 23 Mar 2016 11:55:45 +0100

hi Michael,

Cheers,

Brian