Subject: [Stackevo] IAB Statement on the activation of Explicit Congestion Notification and Active Queue Management

From: Brian Trammell <[email-masked]>
Date: Tue, 30 Aug 2016 12:25:10 +0200

Greetings, all,

One item that has popped up now and again in various discussions about the state of the transport stack is that Things Would Be Much Better If We Just Started Deploying AQM And Turned On ECN Marking. While there is some work to redefine ECN markings in some contexts (DCTCP, L4S) or to augment the information in these markings (Accurate ECN in TCPM, L4S), there does seem to be a growing consensus that we should just go ahead and do it already. Apple, for instance, has turned on ECN negotiation by default on the client side in the hopes that this will break the incentive logjam for activating marking on appropriate routers in the Internet.

My question to the board and the program: should the IAB make a statement here encouraging the deployment of ECN and AQM in-network?

Thanks, cheers,

Brian

---

From: Michael Welzl <[email-masked]>
Date: Tue, 30 Aug 2016 12:43:12 +0200

> On 30 Aug 2016, at 12:25, Brian Trammell <[email-masked]> wrote:
> 
> Greetings, all,
> 

Yes

Cheers,
Michael

---

From: Matthew Ford <[email-masked]>
Date: Tue, 30 Aug 2016 11:51:44 +0100

> On 30 Aug 2016, at 11:25, Brian Trammell <[email-masked]> wrote:
> 
> Apple, for instance, has turned on ECN negotiation by default on the client side

Have they actually done that? I know they talked about doing it, and enabled it in beta MacOS seeds, but wasn’t aware that any full release had ECN negotiation enabled out of the box.

Mat

---

From: Brian Trammell <[email-masked]>
Date: Tue, 30 Aug 2016 12:58:49 +0200

> On 30 Aug 2016, at 12:51, Matthew Ford <[email-masked]> wrote:
> 
> 

Stuart made the announcement here: https://developer.apple.com/videos/play/wwdc2016/714/

It's not every connection on every machine, 5% of TCP connections at random use ECN in production. 100% of Wifi connections and connections on certain (whitelisted) mobile carriers in in the current dev seeds.

Cheers,

Brian

---

From: "Howard, Lee L" <[email-masked]>
Date: Tue, 30 Aug 2016 14:38:06 +0000

I would like to hear from operators whether there's a reason not to turn on ECN and AQM. From networks with which I am intimately familiar, there wasn't a technical reason stalling ECN, it just wasn't enabled by default and it was never an important thing to work on. For AQM, we were waiting for standardization of PIE, then waiting for code to be delivered from each of several different vendors. I don't know whether such code has been delivered, tested, and/or deployed.

More effective than a statement from the IAB would be a presentation at NOGs. Operators don't read IAB statements, but they do look at slides from their local operators group, and if someone says, "We turned these things on and saw these good things happen," it has credibility. There was a thread on NANOG last year about Apple's announcement, and a couple of corner cases where it could cause problems, but Google doesn't tell me about any followup since then.

Lee

---

From: Brian Trammell <[email-masked]>
Date: Tue, 30 Aug 2016 17:30:26 +0200

Hi Lee,

Good point. 

Perhaps the program could put together a presentation for the NOGs and people who are heading there anyway could apply to present?

I'd take RIPE, but given the present emergency Madrid will be hard to make personally.

Cheers,

Brian

Sent from my iPhone

> On 30 Aug 2016, at 16:38, Howard, Lee L <[email-masked]> wrote:
> 
> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 30 Aug 2016 11:49:09 -0700

+1 to doing a NOG presentation.

That said, I've spoken with several operators, and my sense is that folks
actually holding the AQM switch seem to not have enough incentive to deploy
it yet. If we had an operator that turned on ECN/AQM and found benefits,
and that was part of a NOG presentation, that will be quite helpful to
other operators. Alternatively, a NOG presentation could also ask the
operator community to try out AQM and report to this program about any
findings.

On Tue, Aug 30, 2016 at 8:30 AM, Brian Trammell <[email-masked]> wrote:

> Hi Lee,
>
> Good point.
>
> Perhaps the program could put together a presentation for the NOGs and
> people who are heading there anyway could apply to present?
>
> > I would like to hear from operators whether there's a reason not to turn
> on ECN and AQM. From networks with which I am intimately familiar, there
> wasn't a technical reason stalling ECN, it just wasn't enabled by default
> and it was never an important thing to work on. For AQM, we were waiting
> for standardization of PIE, then waiting for code to be delivered from each
> of several different vendors. I don't know whether such code has been
> delivered, tested, and/or deployed.
> >
> > More effective than a statement from the IAB would be a presentation at
> NOGs. Operators don't read IAB statements, but they do look at slides from
> their local operators group, and if someone says, "We turned these things
> on and saw these good things happen," it has credibility. There was a
> thread on NANOG last year about Apple's announcement, and a couple of
> corner cases where it could cause problems, but Google doesn't tell me
> about any followup since then.
> >
> > Lee
> >
> >
> >
> >> On 8/30/16, 6:25 AM, "IAB on behalf of Brian Trammell" <
> [email-masked] on behalf of [email-masked]> wrote:
> >>
> >> Greetings, all,
> >>
> >> One item that has popped up now and again in various discussions about
> the state of the transport stack is that Things Would Be Much Better If We
> Just Started Deploying AQM And Turned On ECN Marking. While there is some
> work to redefine ECN markings in some contexts (DCTCP, L4S) or to augment
> the information in these markings (Accurate ECN in TCPM, L4S), there does
> seem to be a growing consensus that we should just go ahead and do it
> already. Apple, for instance, has turned on ECN negotiation by default on
> the client side in the hopes that this will break the incentive logjam for
> activating marking on appropriate routers in the Internet.
> >>
> >> My question to the board and the program: should the IAB make a
> statement here encouraging the deployment of ECN and AQM in-network?
> >>
> >> Thanks, cheers,
> >>
> >> Brian