Subject: [Stackevo] Still slouching, but not clear toward what....

From: Ted Hardie <[email-masked]>
Date: Fri, 10 Mar 2017 14:58:15 -0800

Howdy,

I'd like to follow up on the "Slouching toward Catenets" discussion.
Please see below.

On Thu, Feb 16, 2017 at 9:59 AM, Spencer Dawkins at IETF <
[email-masked]> wrote:

> Ted,
>
> On Fri, Feb 3, 2017 at 10:47 AM, Ted Hardie <[email-masked]> wrote:
>
>> Hi Brian,
>>
>> I promised many moons ago to take the "Slouching toward Catanets" slide
>> deck and move it toward a draft.  That got pushed down the stack by too
>> many things, but I'd like to move it back up and have the program take it
>> on.  As an architectural challenge, the drift toward networks that must
>> have translating gateways is one that we need to understand.  Some of that
>> relates to the constrained network topic you list below, and some of it is
>> more general.   The heartening news on the constrained network front is
>> that some of the links are getting a little less constrained, which may
>> move some of the complexity out of the gateways again.  The increased
>> packet size in Bluetooth 5, for example, simplifies the stitching needed to
>> create IP packets.
>>
>> If you don't see a draft from me on Slouching within two weeks, please
>> start nagging.
>>
>
> I will be pleased to see this happen.
>
>
After I started writing this draft, I got the niggling feeling that I was
committing a major error.  While I was looking at a particular effect (the
return of complex gateways), I was losing sight of the causes.  Brian and I
had a chat about this a while back, and we decided that it might be best to
drop some of the less compelling cases and focus on two:  the SDN case and
the IoT case, each of which should be in its own draft.

The first case is one where the syntax of a particular set of headers
continues to look like the standard Internet syntax but the semantics are
unknown for specific networks.  A particular network operator may choose to
use the syntax to optimize a network outside of the longest-match approach,
while a different network may use the common syntax to create ad hoc paths
through virtualized network elements.  The "catanet" behavior here is that
the network transitions now silently update the treatment which will be
received, based on a controller's view of the network, without revealing
that to the peer networks.  Though there appears to be a coherent
addressing namespace for the Internet, in other words, it is increasingly
shared only in syntax.  These are, if you like, "silent catanets".

The second case is one in which the highly variable capabilities of the
different devices in the Internet of Things is causing a lot of those
devices to fit into a sensor/hub/cloud model.  That means some devices must
have a hub present to interact with the Internet. While we are seeing a new
"waist" emerge for the Internet of the Internet of Things (in the form of
6lo and CoAP/MQTT), that waist really interconnects with the Internet in a
very new way from the old "waists" and, indeed, even differently from the
older view catanets, because they are not truly independent.  They are
not-so-personal PANs, not catanets or, possibly, "tiny catanets".

This looked like a useful and productive split for a while, but during the
focused time I had this week to work on the IoT draft, it has looked less
and less productive.  Seen in isolation, these look like adaptive
radiation--a perfectly normal part of evolution.  New niches breed new
adaptations, after all.  Seen together, though, they continue to seem like
they present the same challenge to the Internet:  if the behavior on the
other side of a network border is not knowable to a sender, is this an
Internet or only internetworking?

I'm currently recasting this yet again, around the question "Do we still
have a next-hop Internet"?  And, consonant with Betteridge's law, the
answer looks to be at this point that you can count on it only at network
borders.  That sounds scary, but the number of network borders is now so
large, given the newly attached tiny networks, that the impact is more
balanced than it might appear.

I have tried to put this into a draft in some coherent way, but failed so
far.  All of the backstory about now-rejected thinking gets in the way.
I'm still worrying at it, though, so I'm hopeful that I'll have something
more coherent by Chicago. That might mean slides at Monday's lunch; it will
certainly mean I'll bend the ears of folks in hallways.

My apologies for not getting the draft out,

Ted

---

From: Ralph Droms <[email-masked]>
Date: Fri, 10 Mar 2017 18:10:19 -0500

Feel free to bend my ear whenever you have a chance.  I think you've come to an observation that's similar or complementary to what I failed to articulate well in observing that we have an entirely separate/parallel protocol stack for IoT.

- Ralph

> On Mar 10, 2017, at 5:58 PM, Ted Hardie <[email-masked]> wrote:
> 
> Howdy,
> 
> I'd like to follow up on the "Slouching toward Catenets" discussion.  Please see below.
> 
>> On Thu, Feb 16, 2017 at 9:59 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
>> Ted,
>> 
>>> I promised many moons ago to take the "Slouching toward Catanets" slide deck and move it toward a draft.  That got pushed down the stack by too many things, but I'd like to move it back up and have the program take it on.  As an architectural challenge, the drift toward networks that must have translating gateways is one that we need to understand.  Some of that relates to the constrained network topic you list below, and some of it is more general.   The heartening news on the constrained network front is that some of the links are getting a little less constrained, which may move some of the complexity out of the gateways again.  The increased packet size in Bluetooth 5, for example, simplifies the stitching needed to create IP packets.  
>>> 
>>> If you don't see a draft from me on Slouching within two weeks, please start nagging.
>> 
> After I started writing this draft, I got the niggling feeling that I was committing a major error.  While I was looking at a particular effect (the return of complex gateways), I was losing sight of the causes.  Brian and I had a chat about this a while back, and we decided that it might be best to drop some of the less compelling cases and focus on two:  the SDN case and the IoT case, each of which should be in its own draft.  
> 
> The first case is one where the syntax of a particular set of headers continues to look like the standard Internet syntax but the semantics are unknown for specific networks.  A particular network operator may choose to use the syntax to optimize a network outside of the longest-match approach, while a different network may use the common syntax to create ad hoc paths through virtualized network elements.  The "catanet" behavior here is that the network transitions now silently update the treatment which will be received, based on a controller's view of the network, without revealing that to the peer networks.  Though there appears to be a coherent addressing namespace for the Internet, in other words, it is increasingly shared only in syntax.  These are, if you like, "silent catanets".
> 
> The second case is one in which the highly variable capabilities of the different devices in the Internet of Things is causing a lot of those devices to fit into a sensor/hub/cloud model.  That means some devices must have a hub present to interact with the Internet. While we are seeing a new "waist" emerge for the Internet of the Internet of Things (in the form of 6lo and CoAP/MQTT), that waist really interconnects with the Internet in a very new way from the old "waists" and, indeed, even differently from the older view catanets, because they are not truly independent.  They are not-so-personal PANs, not catanets or, possibly, "tiny catanets".
> 
> This looked like a useful and productive split for a while, but during the focused time I had this week to work on the IoT draft, it has looked less and less productive.  Seen in isolation, these look like adaptive radiation--a perfectly normal part of evolution.  New niches breed new adaptations, after all.  Seen together, though, they continue to seem like they present the same challenge to the Internet:  if the behavior on the other side of a network border is not knowable to a sender, is this an Internet or only internetworking?
> 
> I'm currently recasting this yet again, around the question "Do we still have a next-hop Internet"?  And, consonant with Betteridge's law, the answer looks to be at this point that you can count on it only at network borders.  That sounds scary, but the number of network borders is now so large, given the newly attached tiny networks, that the impact is more balanced than it might appear.
> 
> I have tried to put this into a draft in some coherent way, but failed so far.  All of the backstory about now-rejected thinking gets in the way.  I'm still worrying at it, though, so I'm hopeful that I'll have something more coherent by Chicago. That might mean slides at Monday's lunch; it will certainly mean I'll bend the ears of folks in hallways.
> 
> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo

---

From: Eliot Lear <[email-masked]>
Date: Tue, 14 Mar 2017 23:38:53 +0100

Hi Ted,

RE IoT, your points below resonate with another one I and others have
made elsewhere.  How do we identify endpoints in such a model?  What is
the different between a host and a component?  When an iPhone can
securely identify individual components, are they really components or
tiny little hosts?  Perhaps the key lies somewhere in interoperability
expectations.  It's an interesting problem because one gets to redraw
the boundaries of not only the Internet, but perhaps the IETF.  Take for
instance the TEEP folk.  They need to securely identify endpoints that
don't have any form of IP addresses.  But is there an interoperability
requirement?  I just pose this as food for thought.

Eliot

On 3/10/17 11:58 PM, Ted Hardie wrote:
> On Thu, Feb 16, 2017 at 9:59 AM, Spencer Dawkins at IETF
> <[email-masked] <mailto:[email-masked]>>
> wrote:
>
>     Ted,
>
>     On Fri, Feb 3, 2017 at 10:47 AM, Ted Hardie <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         Hi Brian,
>
>         I promised many moons ago to take the "Slouching toward
>         Catanets" slide deck and move it toward a draft.  That got
>         pushed down the stack by too many things, but I'd like to move
>         it back up and have the program take it on.  As an
>         architectural challenge, the drift toward networks that must
>         have translating gateways is one that we need to understand. 
>         Some of that relates to the constrained network topic you list
>         below, and some of it is more general.   The heartening news
>         on the constrained network front is that some of the links are
>         getting a little less constrained, which may move some of the
>         complexity out of the gateways again.  The increased packet
>         size in Bluetooth 5, for example, simplifies the stitching
>         needed to create IP packets. 
>
> After I started writing this draft, I got the niggling feeling that I
> was committing a major error.  While I was looking at a particular
> effect (the return of complex gateways), I was losing sight of the
> causes.  Brian and I had a chat about this a while back, and we
> decided that it might be best to drop some of the less compelling
> cases and focus on two:  the SDN case and the IoT case, each of which
> should be in its own draft. 
>
> continues to look like the standard Internet syntax but the semantics
> are unknown for specific networks.  A particular network operator may
> choose to use the syntax to optimize a network outside of the
> longest-match approach, while a different network may use the common
> syntax to create ad hoc paths through virtualized network elements. 
> The "catanet" behavior here is that the network transitions now
> silently update the treatment which will be received, based on a
> controller's view of the network, without revealing that to the peer
> networks.  Though there appears to be a coherent addressing namespace
> for the Internet, in other words, it is increasingly shared only in
> syntax.  These are, if you like, "silent catanets".
>
> The second case is one in which the highly variable capabilities of
> the different devices in the Internet of Things is causing a lot of
> those devices to fit into a sensor/hub/cloud model.  That means some
> devices must have a hub present to interact with the Internet. While
> we are seeing a new "waist" emerge for the Internet of the Internet of
> Things (in the form of 6lo and CoAP/MQTT), that waist really
> interconnects with the Internet in a very new way from the old
> "waists" and, indeed, even differently from the older view catanets,
> because they are not truly independent.  They are not-so-personal
> PANs, not catanets or, possibly, "tiny catanets".
>
> This looked like a useful and productive split for a while, but during
> the focused time I had this week to work on the IoT draft, it has
> looked less and less productive.  Seen in isolation, these look like
> adaptive radiation--a perfectly normal part of evolution.  New niches
> breed new adaptations, after all.  Seen together, though, they
> continue to seem like they present the same challenge to the
> Internet:  if the behavior on the other side of a network border is
> not knowable to a sender, is this an Internet or only internetworking?
>
> I'm currently recasting this yet again, around the question "Do we
> still have a next-hop Internet"?  And, consonant with Betteridge's
> law, the answer looks to be at this point that you can count on it
> only at network borders.  That sounds scary, but the number of network
> borders is now so large, given the newly attached tiny networks, that
> the impact is more balanced than it might appear.
>
> I have tried to put this into a draft in some coherent way, but failed
> so far.  All of the backstory about now-rejected thinking gets in the
> way.  I'm still worrying at it, though, so I'm hopeful that I'll have
> something more coherent by Chicago. That might mean slides at Monday's
> lunch; it will certainly mean I'll bend the ears of folks in hallways.
>