Subject: Re: [stir] comments on draft-ietf-stir-problem-statement-00

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 5 Nov 2013 02:20:28 +0000

Well. Maybe I understood Andrew's message a bit differently than you did. What he originally asked was that services like Blackberry Messenger (also an out-of-band service like iMessage) be included so we don't appear to be favoring the work of a single monolithic vendor. He then asked that we reference something like Whatsapp, a platform-neutral service along these lines. I haven't objected to either of those requests. But the suggestion that we restrict this section to some other vendor's solution while removing the one with which people trying to understand the problem are most familiar would, I think, be a different matter.

The objective of this document is not to promote any solution, it's a problem statement document. Whatever we reference here is entirely exemplary and explicitly not a component of the STIR solution. While we can all see the vehemence of your personal objection, I am not seeing any rational reason here to strike information from the document that actually helps people to understand what this work is about. Nor do I think your curious construal of Andrew's (actually quite reasonable) request, when combined with your own more obscure complaint, justifies issuing blanket commands as you do below. Why don't we leave it to the chairs to assess consensus.

Jon Peterson
Neustar, Inc.

Sent with Good (www.good.com)

-----Original Message-----
From: Richard Shockey [[email-masked]<mailto:[email-masked]>]
Sent: Monday, November 04, 2013 08:27 PM Eastern Standard Time
To: Peterson, Jon; 'Andrew Allen'; [email-masked]
Subject: RE: [stir] comments on draft-ietf-stir-problem-statement-00

Jon .. what about NO don’t you understand.

We object to the references. Remove them now.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Peterson, Jon
Sent: Monday, November 04, 2013 6:26 PM
To: Andrew Allen; [email-masked]
Subject: Re: [stir] comments on draft-ietf-stir-problem-statement-00

<AA>I don’t think just the fact that some people happen to be familiar with iMessage is sufficient justification to make it a good example to use in the draft – particularly since it has short comings such as being currently restricted to a single platform. I believe Whatsapp has the most user’s and also has multi vendor support. I suppose a list of e.g’s is OK but I don’t see why we need to describe in any detail a specific service – since most of them have similar characteristics.</AA>

I think the fact that people are familiar with iMessage is a very good reason to list it as one example. I'm happy to include other examples, including Whatsapp. I would also be happy to make the descriptive text there less specific to any particular vendor, but I do have a hard time seeing how listing iMessage here would make people misunderstand the problem statement.

[AA] My problem is with the statement “domains that have no relationship with the number assignee” Certainly they have a relationship – in fact a close and trusted one and the home domain provides the number to assert to the roamed to domain.  So I think it needs to be made clearer.

Okay, per the text I sent in my last mail, we can make this clearer. Again, what this means for STIR is that the the roaming carrier won't have the authority over the number.

Jon Peterson
Neustar, Inc.

---

From: Andrew Allen <[email-masked]>
Date: Tue, 5 Nov 2013 16:44:31 +0000

Jon

I have not used iMessage so using it as an example doesn’t help me or the large community of non iPhone users out there to understand. I have however used WhatsApp, BlackBerry Messenger and Viber – all of which are very popular messaging services. WeChat is another messaging services that is also extremely popular in China and many other Asian countries.

I don’t see anything special about iMessage – other services have more users, have multi-platform support or have been around long before iPhone was a gleam in the Steve Jobs’ eye and all provide an out of band connection.

My proposal is to rewrite the text as follows:

For example, the Apple iMessage service, which allows iPhone users to send SMS messages to one another over the Internet rather than over the PSTN.  Like VIPR, iMessage creates an out-of-band connection over the Internet between iPhones; unlike VIPR, the rendezvous service is provided by a trusted centralized database of iPhones rather than by a DHT.  While Apple's service is specific to customers of its smart phones, it seems clear that similar databases could be provided by neutral third parties in a position to coordinate between endpoints.

REWRITE AS:

Mobile messaging services, (e.g. Whatsapp, Viber, BlackBerry Messenger, Apple’s iMessage and WeChat), allow smart phone users to send text messages to one another over the Internet rather than over the PSTN.  Like VIPR, such services create an out-of-band connection over the Internet between smart phones; unlike VIPR, the rendezvous service is provided by a trusted centralized database rather than by a DHT.  While such messaging services are specific to the users of the specific service, it seems clear that similar databases could be provided by neutral third parties in a position to coordinate between endpoints.

Andrew

From: Peterson, Jon [mailto:[email-masked]]
Sent: Monday, November 04, 2013 9:20 PM
To: 'Richard Shockey'; Andrew Allen; [email-masked]'
Subject: RE: [stir] comments on draft-ietf-stir-problem-statement-00

Jon Peterson
Neustar, Inc.

Sent with Good (www.good.com<http://www.good.com>)

-----Original Message-----
From: Richard Shockey [[email-masked]<mailto:[email-masked]>]
Sent: Monday, November 04, 2013 08:27 PM Eastern Standard Time
To: Peterson, Jon; 'Andrew Allen'; [email-masked]<mailto:[email-masked]>
Subject: RE: [stir] comments on draft-ietf-stir-problem-statement-00

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Peterson, Jon
Sent: Monday, November 04, 2013 6:26 PM
To: Andrew Allen; [email-masked]<mailto:[email-masked]>
Subject: Re: [stir] comments on draft-ietf-stir-problem-statement-00

Jon Peterson
Neustar, Inc.

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: "Richard Shockey" <[email-masked]>
Date: Tue, 5 Nov 2013 11:48:54 -0500

Excellent +1 

From: Andrew Allen [mailto:[email-masked]] 
Sent: Tuesday, November 05, 2013 11:45 AM
To: Peterson, Jon; 'Richard Shockey'; [email-masked]'
Subject: RE: [stir] comments on draft-ietf-stir-problem-statement-00

Jon

 

REWRITE AS:

 

Andrew

Jon Peterson
Neustar, Inc.

Sent with Good (www.good.com <http://www.good.com> )

-----Original Message-----
From: Richard Shockey [[email-masked] <mailto:[email-masked]> ]
Sent: Monday, November 04, 2013 08:27 PM Eastern Standard Time
To: Peterson, Jon; 'Andrew Allen'; [email-masked] <mailto:[email-masked]> 
Subject: RE: [stir] comments on draft-ietf-stir-problem-statement-00

From: [email-masked] <mailto:[email-masked]>  [mailto:[email-masked]] On Behalf Of Peterson, Jon
Sent: Monday, November 04, 2013 6:26 PM
To: Andrew Allen; [email-masked] <mailto:[email-masked]> 
Subject: Re: [stir] comments on draft-ietf-stir-problem-statement-00

 

Jon Peterson

Neustar, Inc.

---

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 5 Nov 2013 16:49:24 +0000

Sure, something along these lines would be fine. I would want to restrict the list to services that operate on telephone numbers and have the property that they deliver the originating telephone number to the destination along with the message, and that this attestation has some basis in reality. Do all those services have that property?

Jon Peterson
Neustar, Inc.

From: Andrew Allen <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, November 5, 2013 8:44 AM
To: Jon Peterson <[email-masked]<mailto:[email-masked]>>, Richard Shockey <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>'" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [stir] comments on draft-ietf-stir-problem-statement-00

Jon

REWRITE AS:

Andrew

From: Peterson, Jon [mailto:[email-masked]]
Sent: Monday, November 04, 2013 9:20 PM
To: 'Richard Shockey'; Andrew Allen; [email-masked]<mailto:[email-masked]>'
Subject: RE: [stir] comments on draft-ietf-stir-problem-statement-00

Jon Peterson
Neustar, Inc.

-----Original Message-----
From: Richard Shockey [[email-masked]<mailto:[email-masked]>]
Sent: Monday, November 04, 2013 08:27 PM Eastern Standard Time
To: Peterson, Jon; 'Andrew Allen'; [email-masked]<mailto:[email-masked]>
Subject: RE: [stir] comments on draft-ietf-stir-problem-statement-00

[AA] My problem is with the statement “domains that have no relationship with the number assignee”Certainly they have a relationship – in fact a close and trusted one and the home domain provides the number to assert to the roamed to domain.  So I think it needs to be made clearer.

Jon Peterson
Neustar, Inc.

---

From: Brian Rosen <[email-masked]>
Date: Tue, 5 Nov 2013 10:03:06 -0800

I believe they all do.

FWIW, the most interesting aspect of what happened with iMessage is that the iOS Messages app that used to be a strictly SMS interface was upgraded, with roughly no change to the UI, to use IP rather than PSTN, seamlessly, by one vendor.  As Jon points out, the identity (the TN) did not change, but the protocol and the trust anchor changed.

The other examples Andrew cites were always OTT apps which piggy-back on the TN as a unique identifier.  Some of them just assume you own the TN, some of them use an SMS verification message to prove you do.

That said,I’m happy with Andrews proposed edits.

Brian

On Nov 5, 2013, at 8:49 AM, Peterson, Jon <[email-masked]> wrote:

> From: Andrew Allen <[email-masked]>
> To: Jon Peterson <[email-masked]>, Richard Shockey <[email-masked]>, "[email-masked]'" <[email-masked]>
> From: Richard Shockey [[email-masked]]
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir

---

From: Alex Bobotek <[email-masked]>
Date: Tue, 5 Nov 2013 17:07:57 -0800

The “rather than over the PSTN” and “out of band connection” parts could be improved.

1.        Mobile text messaging in many countries (e.g., North American) doesn’t touch the PSTN.  It goes over private signaling and IP networks, sometimes tunneled through the Internet.  Suggestion:  strike “ rather than over the PSTN”.

2.       Many of the listed IP text messaging services do not create end-to-end L4 connections or L5+ enduring sessions/dialogs (e.g., RFC 3428’s MESSAGE does not require a SIP dialog between messaging endpoints).  It’s not clear to me whether the term “connection” is imprecise, or there is another issue. Similarly, I don’t understand why iMessage and similar should be considered out of band.  To me, “out of band” means outside of an established primary communications channel.  Suggestion:  use the accepted industry term “over the top” instead of “out-of-band” and some properly ambiguous term such as “communications path” instead of “connection”.

Regards,

Alex
.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Andrew Allen
Sent: Tuesday, November 05, 2013 8:45 AM
To: Peterson, Jon; 'Richard Shockey'; [email-masked]'
Subject: Re: [stir] comments on draft-ietf-stir-problem-statement-00

Jon

REWRITE AS:

Andrew

Jon Peterson
Neustar, Inc.

-----Original Message-----
From: Richard Shockey [[email-masked]<mailto:[email-masked]>]
Sent: Monday, November 04, 2013 08:27 PM Eastern Standard Time
To: Peterson, Jon; 'Andrew Allen'; [email-masked]<mailto:[email-masked]>
Subject: RE: [stir] comments on draft-ietf-stir-problem-statement-00

Jon Peterson
Neustar, Inc.