Subject: [stir] Minutes: STIR Virtual Interim Oct 9

From: Robert Sparks <[email-masked]>
Date: Thu, 15 Oct 2015 14:52:14 -0500

Minutes: STIR Virtual Interim Meeting - Oct 9, 2015
Attendees:
   Mary Barnes
   John Barnhill
   Alissa Cooper
   Mark Desterdick
   Martin Dolly
   Tim Dwight
   Arleen Elliot
   David Frankel
   Andrew Gallant
   Russ Housley (co-chair)
   Paul Kyzivat
   Cullen Jennings
   Natalie McNamer
   Hala Mowafy
   Victor Pascual (note taker)
   Jon Peterson
   Brian Rosen
   Henning Schulzrinne
   Richard Shockey
   Robert Sparks (co-chair)
   Patrick Tarpy
   Sean Turner (note taker)
   Chris Wendt

Recording: https://ietf.webex.com/ietf/ldr.php?RCID=4b9bfc47f8a11216961782a2639d19cb

Summary:
   The meeting focused on signalling: in particular what a signature should
   cover. Discussions of credentials was deferred. Chris Wendt introduced
   the verified token being discussed in the IP-NNI task force. Jon Peterson
   talked through the updates to RFC4474bis. Conversation focused on the
   differences and similarities in what the signatures in the verified token and
   RFC4474bis Identity header protected, noting that the differences were
   primarily syntactic. An open design team was formed to discuss finding a
   common way to address the signalling.

---

From: Eric Burger <[email-masked]>
Date: Thu, 15 Oct 2015 21:54:08 -0400

Victor and Sean both missed me, even when I set up the design team call during the meeting? Ouch.

BTW, STIR vs. SHAKEN is a red herring and irrelevant. They both calculate the same thing (OK, SITR has some a= lines. BTW, I like that). I have a preference for where that thing should go (Identity-Info) and what it should be (a JWT). So I suppose that means both Jon and Chris hate me or love me.

We seem to agree on what should go into the calculation (From, To, Date, maybe a= lines). We can eventually work it out. Especially if we put it into Identity-Info. The real discussion is all about the certificate. That is where there is significant and potentially irreconcilable differences.

More news tomorrow on the call.

You know, the one I set up.

When I was on the Virtual Interim Meeting call.

Even if I was not recorded.

I suppose this means I can keep all of my double-super-secret IPR to myself.

Unlike Dan & Cullen’s US 8,533,462. I, of course, have no opinion as to whether that patent would cover STIR, SHAKEN, or Vodka or if it would survive a USPTO IPR or jury. Likewise, I have no opinion as to whether US 8,200,959 would be pushing the direction of the current thinking on STIR certificates.

Oh, hey - I didn’t see any disclosure on ‘959 against the certificates draft.

I do not have an opinion as to whether that does or does not mean Rambus kicks in on that.

Speak with most of you tomorrow.
- Eric

> On Oct 15, 2015, at 3:52 PM, Robert Sparks <[email-masked]> wrote:
> 
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir

---

From: Chris Wendt <[email-masked]>
Date: Thu, 15 Oct 2015 23:32:15 -0400

Hi Eric,

How can we NOT love you with messages like that?

Stay tuned for tomorrow.

-Chris

> On Oct 15, 2015, at 9:54 PM, Eric Burger <[email-masked]> wrote:
>

---

From: Robert Sparks <[email-masked]>
Date: Fri, 16 Oct 2015 08:52:36 -0500

Totally my fault - error in manual sorting of the names. I'll send a 
corrected version.

---

From: Robert Sparks <[email-masked]>
Date: Mon, 19 Oct 2015 13:35:56 -0500

The only change is to to the Attendee list (I had missed Eric and 
Sanjay, and had Patrick's name misspelled).
RjS

-------
   Eric Burger
   Sanjay Mishra
   Patrick Tarpey
   Sean Turner (note taker)
   Chris Wendt

Recording: 
https://ietf.webex.com/ietf/ldr.php?RCID=4b9bfc47f8a11216961782a2639d19cb

Summary:
   differences and similarities in what the signatures in the verified 
token and