Subject: [stir] Documenting algorithms

From: Dave Crocker <[email-masked]>
Date: Sat, 20 Aug 2016 11:35:57 -0700

While it is possible to write relatively clear descriptions of 
algorithms using prose, the STIR documents' version of algorithm 
specifications are quite confusing and, I suspect, sometimes wrong. But 
the fact that I can't be sure is a mark of the problem.

Rewrite them in a pseudo-code. This will tend to produce much clearer 
explication.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Sat, 20 Aug 2016 18:53:45 +0000

Dave

Please be specific on what is wrong sir?

Thank you

Martin C. Dolly
Lead Member of Technical Staff
Core & Government/Regulatory Standards
AT&T
Cell: +1.609.903.3360<tel:+1.609.903.3360>
Email: [email-masked]<mailto:[email-masked]>

On Aug 20, 2016, at 2:36 PM, Dave Crocker <[email-masked]<mailto:[email-masked]>> wrote:

While it is possible to write relatively clear descriptions of algorithms using prose, the STIR documents' version of algorithm specifications are quite confusing and, I suspect, sometimes wrong. But the fact that I can't be sure is a mark of the problem.

Rewrite them in a pseudo-code. This will tend to produce much clearer explication.

d/
--

 Dave Crocker
 Brandenburg InternetWorking
 bbiw.net<http://bbiw.net>

_______________________________________________
stir mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/stir

---

From: Dave Crocker <[email-masked]>
Date: Sat, 20 Aug 2016 12:00:36 -0700

> Please be specific on what is wrong sir?

Martin,

You think "confusing and probably error-prone" isn't specific enough?

In that case, ask someone who has technical skills, but no special 
background in STIR work, to read the texts specifying the algorithms and 
then ask them to produce some pesudo-code that instantiates it.

I think they won't be able to.  I know I gave up.

That's a basic fail, given the job of that text.

This exercise could have a very nice upside:  To the extent that I'm 
wrong, and they /are/ produce pseudo-code that the working group agrees 
is correct, then please include it in the documents...

d/
-- 

   Dave Crocker

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Sat, 20 Aug 2016 19:15:07 +0000

Dave

I am waiting to see an update version that:
1. Provides clear Examples of PAI and FROM
2. Extensibility examples, particularly a scenario of signing for the CgP by the originating carrier and signing of RPH by the NS/EP authentication carrier
3. Christer comments addressed

I believe this will occur

Then SHAKEN handles the rest

Martin C. Dolly

On Aug 20, 2016, at 3:00 PM, Dave Crocker <[email-masked]<mailto:[email-masked]>> wrote:

Martin,

In that case, ask someone who has technical skills, but no special background in STIR work, to read the texts specifying the algorithms and then ask them to produce some pesudo-code that instantiates it.

This exercise could have a very nice upside:  To the extent that I'm wrong, and they /are/ produce pseudo-code that the working group agrees is correct, then please include it in the documents...

d/
--

 Dave Crocker

---

From: Dave Crocker <[email-masked]>
Date: Sat, 20 Aug 2016 12:26:43 -0700

On 8/20/2016 12:15 PM, DOLLY, MARTIN C wrote:
> 2. Extensibility examples, particularly a scenario of signing for the
> CgP by the originating carrier and signing of RPH by the NS/EP
> authentication carrier

How do you think Shaken will?

Here's why it won't:

      Nothing in your list fixes the IETF documents.  The IETF documents 
are 'specifications' of technical details.

      My informed reading of the segments intended to specify algorithms 
is that I find them difficult at best or impossible or deficient at worst.

      Shaken is not going to fix IETF documents.

d/

-- 

   Dave Crocker

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Sat, 20 Aug 2016 19:32:55 +0000

I respectfully disagree sir and I am done

Martin C. Dolly

On Aug 20, 2016, at 3:27 PM, Dave Crocker <[email-masked]<mailto:[email-masked]>> wrote:

Here's why it won't:

    Nothing in your list fixes the IETF documents.  The IETF documents are 'specifications' of technical details.

    My informed reading of the segments intended to specify algorithms is that I find them difficult at best or impossible or deficient at worst.

d/

--

 Dave Crocker

---

From: Dave Crocker <[email-masked]>
Date: Sat, 20 Aug 2016 12:41:27 -0700

Martin,

In terms of engaging with the substance of what I said, you never started.

You asked questions and then you made a pronouncement that had literally 
nothing to do with my responses.

d/

-- 

   Dave Crocker