Subject: [stir] Optional to include JSON key "ppt"

From: Christer Holmberg <[email-masked]>
Date: Wed, 24 Aug 2016 17:59:04 +0000

Hi,

The text in section 4.1. says:

        "Fourth, the optional JSON key "ppt", if present, MUST have a value
        equivalent to the quoted value of the "ppt" parameter of the
        Identity header field.  If the "ppt" parameter is absent from the
        header field, the "ppt" key MUST NOT not appear in the JSON header
        object."

Is there a reason why we can't simply mandate to include the JSON key "ppt" if the "ppt" parameter is present?

Less options, less errors :)

Regards,

Christer

---

From: "Peterson, Jon" <[email-masked]>
Date: Wed, 24 Aug 2016 18:07:43 +0000

Well, we need to say more than simply that the JSON key is included, we need to say how its value relates to the SIP request. We can reword it, but the semantics need to say pretty much what it does now.

Jon Peterson
Neustar, Inc.

From: stir <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, August 24, 2016 at 10:59 AM
To: IETF STIR Mail List <[email-masked]<mailto:[email-masked]>>
Subject: [stir] Optional to include JSON key "ppt"

Hi,

        “Fourth, the optional JSON key "ppt", if present, MUST have a value
        equivalent to the quoted value of the "ppt" parameter of the
        Identity header field.  If the "ppt" parameter is absent from the
        header field, the "ppt" key MUST NOT not appear in the JSON header
        object.”

Is there a reason why we can’t simply mandate to include the JSON key “ppt” if the “ppt” parameter is present?

Regards,

Christer