Subject: [stir] Minor comments on draft-ietf-stir-rfc4474bis-12

From: Anders Kristensen <[email-masked]>
Date: Wed, 21 Sep 2016 20:48:50 -0700

4.1 says

      Third, the JSON key "x5u" MUST have a value equivalent to the
      quoted URI in the "info" parameter.

I'm not sure exactly what equivalent means here. Maybe worth elaborating or
adding a reference?

Anyway, I don't think the URIs in the example in sec 5.1 would be
considered equivalent:

   {"alg":"ES256","typ":"passport","x5u":"https://cert.example.org/
      passport.cer"}

...

   Identity: "rq3pjT1hoRwakEGjHCnWSwUnshd0-zJ6F1VOgFWSjHBr8Qjpj \
    lk-cpFYpFYsojNCpTzO3QfPOlckGaS6hEck7w"; \
    info=<https://biloxi.example.org/biloxi.c>

Sec 6.2: s/that the that the/that the/

---

From: "Peterson, Jon" <[email-masked]>
Date: Thu, 22 Sep 2016 19:53:20 +0000

You are correct that the example URIs are conspicuously not at all the same URI; we'll fix that. In this case the equivalence has to be strict,  so yes we should be careful to specify what we mean here by equivalence.

And we will zap that nit as well.

Thanks!

Jon Peterson
Neustar, Inc.

From: stir <[email-masked]<mailto:[email-masked]>> on behalf of Anders Kristensen <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, September 21, 2016 at 8:48 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [stir] Minor comments on draft-ietf-stir-rfc4474bis-12

4.1 says

I'm not sure exactly what equivalent means here. Maybe worth elaborating or adding a reference?

Anyway, I don't think the URIs in the example in sec 5.1 would be considered equivalent:

...