Subject: [stir] DRAFT STIR Agenda for London

From: Russ Housley <[email-masked]>
Date: Fri, 9 Mar 2018 16:25:08 -0500

We only have 1 hour.  We received more speaking slots than we expected.  I have ordered the speaking slots to put priority on the active WG documents.  Time will be VERY tight.

For the active WG documents, please focus on the changes since Singapore and open issues.

For the other documents, please introduce the high-level concept, and then as the WG for advice on the way forward.

Russ

= = = = = = = = =

STIR WG Agenda for IETF 101
Thursday, 22 March 2018 at 11:00 AM
Co-chairs: Robert Sparks and Russ Housley

0)  Minute Taker, Jabber Scribe, Bluesheets

1)  Agenda Bash

2)  Documents that have been sent to the IESG
    a) 5 min : draft-ietf-stir-rph-03 (Ray, Martin, Subir, and An)

3)  Active Working Group Documents
    a) 10 min : draft-ietf-stir-passport-shaken-01 (Chris and Mary)
    b) 10 min : draft-ietf-stir-passport-divert-02 (Jon)
    c) 10 min : draft-ietf-stir-oob-02 (EKR and Jon)

4)  Other Business (if time allows)
    a) 5 min : draft-burger-stir-iana-cert-00 (Eric)
    b) 5 min : draft-peterson-stir-rfc4916-update-00 (Jon and Chris)
    c) 5 min : draft-rosenberg-stir-callback-00 (Jonathan and Cullen)
    d) 5 min : draft-rosenberg-stir-sipcoin-00 (Jonathan and Cullen)

5)  Wrap Up

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 10 Mar 2018 17:33:06 +0000

Hi,

I think there are some generic things that we need to sort out.

For example, do we specify in which order Identity header fields are added to a SIP message. Or, do we assume they can be put in any order, possible re-ordered by intermediaries, and the entities consuming them will figure out how they are related?

I think that is an essential issue to solve, considering that there are a number of PASSporT extensions in the pipeline. And, we should make a decision that apply to all of them.

Regards,

Christer

-----Original Message-----
From: stir [mailto:[email-masked]] On Behalf Of Russ Housley
Sent: 09 March 2018 23:25
To: IETF STIR Mail List <[email-masked]>
Subject: [stir] DRAFT STIR Agenda for London

Russ

= = = = = = = = =

1)  Agenda Bash

5)  Wrap Up

_______________________________________________
stir mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/stir

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Mon, 12 Mar 2018 13:43:10 +0000

I agree that the question of order (or not) of Identity headers needs to be resolved.

I started to write assumptions and questions on this topic but decided it wouldn't add much to a discussion amongst development professionals who have encountered the issue before (which is my assumption about the authors and Christer).  I can re-create it if anyone wants it.

Pierce

-----Original Message-----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Saturday, March 10, 2018 11:33 AM
To: Russ Housley <[email-masked]>; IETF STIR Mail List <[email-masked]>
Subject: Re: [stir] DRAFT STIR Agenda for London

Hi,

Regards,

Christer

-----Original Message-----
From: stir [mailto:[email-masked]] On Behalf Of Russ Housley
Sent: 09 March 2018 23:25
To: IETF STIR Mail List <[email-masked]>
Subject: [stir] DRAFT STIR Agenda for London

Russ

= = = = = = = = =

1)  Agenda Bash

5)  Wrap Up

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 14 Mar 2018 08:39:14 +0000

Hi,

For the Feature-Caps header field, we have the following text in RFC 6809:

   "When a SIP entity adds a Feature-Caps header field to a SIP message,
    it MUST place the header field before any existing Feature-Caps
    header field in the message to be forwarded, so that the added header
    field becomes the top-most one.²

If we were to take the same approach for Identity, the text could look
something like:

   "When a SIP entity adds an Identity header field to a SIP request,
    it MUST place the header field before any existing Identity
    header field in the message to be forwarded, so that the added header
    field becomes the top-most one.²

Alternatively, we could say that a header field is places AFTER any
existing header field. As long as we say something :)

And, if we decide that the order of header fields has no relevance, we
should say that. However, I would at least not suggest such approach.

Regards,

Christer

On 12/03/18 15:43, "Gorman, Pierce A [CTO]" <[email-masked]>
wrote:

>I started to write assumptions and questions on this topic but decided it
>wouldn't add much to a discussion amongst development professionals who
>have encountered the issue before (which is my assumption about the
>authors and Christer).  I can re-create it if anyone wants it.
>
>Pierce
>
>
>For example, do we specify in which order Identity header fields are
>added to a SIP message. Or, do we assume they can be put in any order,
>possible re-ordered by intermediaries, and the entities consuming them
>will figure out how they are related?
>
>I think that is an essential issue to solve, considering that there are a
>number of PASSporT extensions in the pipeline. And, we should make a
>decision that apply to all of them.
>
>Regards,
>
>Christer
>
>
>
>
>We only have 1 hour.  We received more speaking slots than we expected.
>I have ordered the speaking slots to put priority on the active WG
>documents.  Time will be VERY tight.
>
>For the other documents, please introduce the high-level concept, and
>then as the WG for advice on the way forward.
>
>Russ
>
>= = = = = = = = =
>
>This e-mail may contain Sprint proprietary information intended for the
>sole use of the recipient(s). Any use by others is prohibited. If you are
>not the intended recipient, please contact the sender and delete all
>copies of the message.