Subject: [stir] Fwd: New Version Notification for draft-burger-stir-iana-cert-00.txt

From: Eric Burger <[email-masked]>
Date: Mon, 5 Mar 2018 19:56:07 -0500

I could not stay away either.

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-burger-stir-iana-cert-00.txt
> Date: March 5, 2018 at 3:50:09 PM EST
> To: "Eric W. Burger" <[email-masked]>, "Eric Burger" <[email-masked]>
> 
> 
> A new version of I-D, draft-burger-stir-iana-cert-00.txt
> has been successfully submitted by Eric W. Burger and posted to the
> IETF repository.
> 
> Name:		draft-burger-stir-iana-cert
> Revision:	00
> Title:		Registry for Country-Specific Secure Telephone Identity (STIR) Root Certificates
> Document date:	2018-03-05
> Group:		Individual Submission
> Pages:		13
> URL:            https://www.ietf.org/internet-drafts/draft-burger-stir-iana-cert-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-burger-stir-iana-cert/
> Htmlized:       https://tools.ietf.org/html/draft-burger-stir-iana-cert-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-burger-stir-iana-cert-00
> 
> 
> Abstract:
>   This document defines an IANA registry that maps country codes to
>   secure telephone identity (STIR) root certificates authorized to
>   create signing certificates for telephone numbers under the authority
>   of a given country.  Some countries allow carriers to block
>   unsolicited, automatically generated nuisance calls commonly known as
>   'robocalls.'  The use of signed STIR tokens in the Session Initiation
>   Protocol (SIP) may be useful in such scenarios to provide positive
>   attestations as to call origin.  Legacy telephone numbering resources
>   are administrated by national policy.  Unlike the market-driven use
>   case of Web commerce, some nations may restrict the list of STIR root
>   certificate authorities acceptable for issuing signing certificates
>   for STIR tokens that provide attestations for their local legacy
>   telephone numbering resources.  The registry described in this
>   document enables call recipients in a first country to validate that
>   signaling it receives from a caller with a telephone number claiming
>   to be in a second country conforms to the second country's policy of
>   (1) having a limited list of STIR root certificate authorities (or
>   not) and (2) the certificate that produced the signature over the
>   signaling is signed by one of those authorized STIR root certificate
>   authorities.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 6 Mar 2018 06:15:36 +0000

Hi Eric,

The IANA policy is Expert Review. What exactly is the ER supposed to do in this case?

Regards,

Christer

Sent from my iPhone

On 6 Mar 2018, at 2.56, Eric Burger <[email-masked]<mailto:[email-masked]>> wrote:

Begin forwarded message:

From: [email-masked]<mailto:[email-masked]>
Subject: New Version Notification for draft-burger-stir-iana-cert-00.txt
Date: March 5, 2018 at 3:50:09 PM EST
To: "Eric W. Burger" <[email-masked]<mailto:[email-masked]>>, "Eric Burger" <[email-masked]<mailto:[email-masked]>>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
stir mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/stir

---

From: Eric Burger <[email-masked]>
Date: Mon, 19 Mar 2018 19:02:15 -0400

This is covered in Section 5.1 and 5.2. It is the same model used for the time zone database. Registration will usually be obvious, like the FCC or NTIA registering for the U.S., OFCOM registering for the U.K., FICORA registering for Finland, etc. IANA can look up the national authorities via the ITU-T document normatively referenced in the text. If it is not obvious or cleared up by a phone call, e.g., asking the FCC if Neustar or iconectiv is OK for the U.S., that is why the document says to take it to the list.

One open question is that since this is something that would probably get zero traffic, I defaulted to saying “use the RAI list if there’s a dispute.” Do we need to setup a separate, “National Numbering Authorities Dispute List”? That would be easy enough if necessary.

> On Mar 6, 2018, at 1:15 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi Eric,
> 
> On 6 Mar 2018, at 2.56, Eric Burger <[email-masked] <mailto:[email-masked]>> wrote:
> 
>>> From: [email-masked] <mailto:[email-masked]>
>>> To: "Eric W. Burger" <[email-masked] <mailto:[email-masked]>>, "Eric Burger" <[email-masked] <mailto:[email-masked]>>
>>> 
>>> 
>>> URL:            https://www.ietf.org/internet-drafts/draft-burger-stir-iana-cert-00.txt <https://www.ietf.org/internet-drafts/draft-burger-stir-iana-cert-00.txt>
>>> Status:         https://datatracker.ietf.org/doc/draft-burger-stir-iana-cert/ <https://datatracker.ietf.org/doc/draft-burger-stir-iana-cert/>
>>> Htmlized:       https://tools.ietf.org/html/draft-burger-stir-iana-cert-00 <https://tools.ietf.org/html/draft-burger-stir-iana-cert-00>
>>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-burger-stir-iana-cert-00 <https://datatracker.ietf.org/doc/html/draft-burger-stir-iana-cert-00>
>>> 
>>> 
>>> Abstract:
>>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>>> 
>>> The IETF Secretariat
>>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/stir <https://www.ietf.org/mailman/listinfo/stir>