Subject: Re: [stir] draft-passport-divert: "opt" extension

From: "Peterson, Jon" <[email-masked]>
Date: Thu, 8 Mar 2018 15:23:02 +0000

There will be a slide about this in London - I'm a bit on the fence about it at the moment, as there has been some talk about splitting this out into a separate document so other extensions to STIR might leverage it. If there are concrete examples of that we can anticipate, of other extensions that might want nesting, then perhaps we should split it out. Otherwise, it should be fine to let this be the document that specifies it. I don't think it requires a ton of specification: it's just a full-form PASSporT in a claim value.

Jon Peterson
Neustar, Inc.

From: stir <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 8, 2018 at 12:05 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [stir] draft-passport-divert: "opt" extension

Hi,

draft-ietf-stir-passport-divert talks about usage of the “opt” extension for nesting.

Where is the “opt" extension defined?

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 8 Mar 2018 15:40:44 +0000

Hi,

>There will be a slide about this in London - I'm a bit on the fence about it at the moment, as >there has been some talk about splitting this out into a separate document so other extensions >to STIR might leverage it. If there are concrete examples of that we can anticipate, of other >extensions that might want nesting, then perhaps we should split it out. Otherwise, it should be >fine to let this be the document that specifies it. I don't think it requires a ton of specification: >it's just a full-form PASSporT in a claim value.

My first reaction would be to define it in a separate document.

Another question: is there a reason why we need to indicate the previous destination in the "div" claim? Isn't the previous destination seen in the "original" PASSporT?

Something like this:

So, for an original PASSporT of the form:

      { "orig":{"tn":"12155551212"},
        "dest":{"tn":"12155551213"},
        "iat":1443208345 }

   If the retargeting entity is changing the target from 12155551213 to
   12155551214, the new PASSporT would look as follows:

      { "orig":{"tn":"12155551212"},
        "dest":{"tn":"12155551214"},
        "iat":1443208345 }

"ppt:div" indicates that this is diversion.

Regards,

Christer

Jon Peterson
Neustar, Inc.

Hi,

draft-ietf-stir-passport-divert talks about usage of the "opt" extension for nesting.

Where is the "opt" extension defined?

Regards,

Christer