Subject: [stir] SIPCoin - a new cryptocurrency for stopping robocalls

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 2 Mar 2018 17:45:15 -0500

Cullen and I have just submitted this:
https://www.ietf.org/id/draft-rosenberg-stir-sipcoin-00.txt

which is a proposal for a new type of cyryptocurrency dedicated solely to
preventing spam on the SIP-based phone network. It is designed to be fast,
causing less than one second increases in call setup time.
NOn-transferrable to avoid being a tool for fraud and avoid being tied to
market whim; backed by public CAs with a new type of centralized ledger
validation; trivially verifiable by receivers of calls. Also we suggest a
technique for incremental deployment on the PSTN which has incremental
benefits and economic benefits for each deployment phase. We've done some
analysis on the economics to help motivate the solution.

WHen combined with our previous draft, and some nice whitelisting thrown in
as described in here, I think this is a very interested technique to put
this robocalling plague to rest.

I'm coming to London and looking forward to discussing.

Comments are, of course, welcome.

-- 
Jonathan Rosenberg, Ph.D.
[email-masked]
http://www.jdrosen.net

---

From: Adam Roach <[email-masked]>
Date: Sat, 3 Mar 2018 18:06:19 -0600

One of the issues that has arisen in parallel with cryptocurrencies is a 
recognition of the exorbitant energy (and therefore environmental) costs 
they entail. I think this document probably requires a section 
addressing this aspect of the system, including any ways that it varies 
significantly from traditional cryptocurrencies in this regard.

/a

On 3/2/18 4:45 PM, Jonathan Rosenberg wrote:
> which is a proposal for a new type of cyryptocurrency dedicated solely 
> to preventing spam on the SIP-based phone network. It is designed to 
> be fast, causing less than one second increases in call setup time. 
> NOn-transferrable to avoid being a tool for fraud and avoid being tied 
> to market whim; backed by public CAs with a new type of centralized 
> ledger validation; trivially verifiable by receivers of calls. Also we 
> suggest a technique for incremental deployment on the PSTN which has 
> incremental benefits and economic benefits for each deployment phase. 
> We've done some analysis on the economics to help motivate the solution.
>
> WHen combined with our previous draft, and some nice whitelisting 
> thrown in as described in here, I think this is a very interested 
> technique to put this robocalling plague to rest.
>
> [email-masked] <mailto:[email-masked]>
> http://www.jdrosen.net
>
>
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 8 Mar 2018 05:41:01 -0700

So as a super casual analysis of the current draft, 

Lets say we need order of magnitude 10 cents to stop spam, that equates to something like 1KW, which equates to something like 1Kg of CO2. Each of of those steps is only an order go magnitude estimate so this cab be way out but you get the idea. So we would have a one time, assuming major carriers shared validation data,  ( or small number of times ) validation of the self signed cert and each validation would take about 1 Kg CO2. That sounds really bad. But for comparisons sake, your flight to IETF is probably over 1000 Kg and it is not a one time event

But all that said, I don’t think we would actually go for with something as simple as pure proof of work based approach so I don’t think that is a realistic look at the power usage. There are a bunch of techniques that add to the complexity but greatly reduce the reliance on proof work and more move to things like proof of stake or more risk based approaches. Solutions like that could greatly reduce the power usage. Keep in mind reducing the amount of spam calls would reduce the power usage of the whole phone system. 

> On Mar 3, 2018, at 5:06 PM, Adam Roach <[email-masked]> wrote:
> 
> One of the issues that has arisen in parallel with cryptocurrencies is a recognition of the exorbitant energy (and therefore environmental) costs they entail. I think this document probably requires a section addressing this aspect of the system, including any ways that it varies significantly from traditional cryptocurrencies in this regard.
> 
> /a
> 
>> https://www.ietf.org/id/draft-rosenberg-stir-sipcoin-00.txt <https://www.ietf.org/id/draft-rosenberg-stir-sipcoin-00.txt>
>> 
>> which is a proposal for a new type of cyryptocurrency dedicated solely to preventing spam on the SIP-based phone network. It is designed to be fast, causing less than one second increases in call setup time. NOn-transferrable to avoid being a tool for fraud and avoid being tied to market whim; backed by public CAs with a new type of centralized ledger validation; trivially verifiable by receivers of calls. Also we suggest a technique for incremental deployment on the PSTN which has incremental benefits and economic benefits for each deployment phase. We've done some analysis on the economics to help motivate the solution.
>> 
>> WHen combined with our previous draft, and some nice whitelisting thrown in as described in here, I think this is a very interested technique to put this robocalling plague to rest.
>> 
>> http://www.jdrosen.net <http://www.jdrosen.net/>
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/stir <https://www.ietf.org/mailman/listinfo/stir>
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 8 Mar 2018 15:44:02 +0000

My gut reaction: please let’s not have the IETF doing crypto-currency.  Yes, this is based on absolutely no technical data whatsoever.

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 9 Mar 2018 08:04:22 +0000

Hi,

Is the idea that SIPCoin would be built using some existing blockchain platform, or would we define a whole new blockchain platform from scratch for SIPCoin?

Regards,

Christer

From: stir <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Saturday 3 March 2018 at 00:45
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [stir] SIPCoin - a new cryptocurrency for stopping robocalls

--
Jonathan Rosenberg, Ph.D.
[email-masked]<mailto:[email-masked]>
http://www.jdrosen.net

---

From: Tim Hollebeek <[email-masked]>
Date: Mon, 19 Mar 2018 10:49:07 +0000

So, that environmental computation assumes that the energy input comes from fossil fuel, and the heat output is a useless waste product that has no value.

This is in fact largely true for mining operations that are sited primarily based on access to the cheapest carbon electricity in order to maximize profits, and then cool them to keep them operating.  Which is likely to be true today in many cases.

However, there are other use cases where you put your crypto miners in a location where you would otherwise be using an electric heater, using responsibly sourced electricity.  Crypto miners can also be seen as very expensive electric heaters, that also produce a computational side benefit.

>From that point of view (setting aside the question of whether mining cryptocurrency is useful computational work and whether there is another kind of computation that is more valuable for the same energy cost), is there an economical way to upgrade all the world’s electric heaters to provide useful computation resources available on demand as part of some sort of network?

That would have a much larger ecological impact if someone figures it out.  Moving computation to where heating is required makes more sense than providing cooling where computation is required.  Unfortunately it’s also generally much harder, which is why we often don’t do it today.

But I just wanted to throw it out there in case it inspires someone else.

-Tim

From: stir [mailto:[email-masked]] On Behalf Of Cullen Jennings
Sent: Thursday, March 8, 2018 12:41 PM
To: Adam Roach <[email-masked]>
Cc: Jonathan Rosenberg <[email-masked]>; [email-masked]
Subject: Re: [stir] SIPCoin - a new cryptocurrency for stopping robocalls

On Mar 3, 2018, at 5:06 PM, Adam Roach <[email-masked] <mailto:[email-masked]> > wrote:

/a

--

---

From: Eric Burger <[email-masked]>
Date: Mon, 19 Mar 2018 09:04:56 -0400

See https://www.qarnot.com <https://www.qarnot.com/>. Been around for a few years.

> On Mar 19, 2018, at 6:49 AM, Tim Hollebeek <[email-masked]> wrote:
> 
> 
> On Mar 3, 2018, at 5:06 PM, Adam Roach <[email-masked] <mailto:[email-masked]>> wrote:
>