Subject: [stir] SIP URI in info parameter

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 29 Mar 2019 11:37:45 -0700

Hi,

I read most of the RFCs/I-Ds on STIR and SHAKEN, but I could not find information on how to process a SIP URI in the info parameter of an Identity header attribute.

RFC 8226 states that "three URI schemes are REQUIRED: the CID URI, the SIP URI, and the HTTP URI."  The CID URI is pretty much self-explanatory, HTTP URI is explained a bit more in ATIS-1000082, but I could not find a document that describes the mechanism when using SIP.  RFC 8226 also says that the SIP mechanism is via SUBSCRIBE/NOTIFY but I think that there is still a lot there that is missing if one hope to implement an interoperable verification service based on SIP SUBSCRIBE/NOTIFY.

Is there a document that I overlooked?

Thanks.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Fri, 29 Mar 2019 19:53:35 +0000

Correct

Martin C Dolly
AT&T
Lead Member of Technical Staff
Government & Services Standards
+1 609 903 3360

> On Mar 29, 2019, at 2:38 PM, Marc Petit-Huguenin <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 29 Mar 2019 13:09:45 -0700

Then may I inquire what is the document that I overlooked, and where can I find it?

Thanks.

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Fri, 29 Mar 2019 21:17:38 +0000

I agree additional documentation is needed 

Martin C Dolly
AT&T

> On Mar 29, 2019, at 4:10 PM, Marc Petit-Huguenin <[email-masked]> wrote:
>