Subject: [stir] I-D Action: draft-ietf-stir-rph-emergency-services-00.txt

From: [email-masked]
Date: Fri, 10 Jan 2020 08:40:27 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Secure Telephone Identity Revisited WG of the IETF.

        Title           : Assertion Values for a Resource Priority Header Claim in Support of Emergency Services Networks
        Authors         : Martin Dolly
                          Chris Wendt
	Filename        : draft-ietf-stir-rph-emergency-services-00.txt
	Pages           : 6
	Date            : 2020-01-10

Abstract:
   This document adds new assertion values for a Resource Priority
   Header ("rph") claim defined in RFC 8443, in support of Emergency
   Services Networks for emergency call origination and callback.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-stir-rph-emergency-services/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-stir-rph-emergency-services-00
https://datatracker.ietf.org/doc/html/draft-ietf-stir-rph-emergency-services-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 12 Jan 2020 14:48:43 -0500

I'm having a little difficulty understanding the details of what 
constitutes a valid assertion. In section 3 I see:

      {
        "orig":{"tn":"CgPN"},
        "dest":{["tn":"911 or URN-SOS"]},
        "iat":1443208345,
        "rph":{"ESorig":["esnet,x"]}
      }

This isn't ABNF so I don't know the rules for interpreting it. Some of 
the stuff enclosed in quotes is obviously intended to be literal. But 
other parts, also included in quotes, seem to placeholders.

For instance "911 or URN-SOS" - I presume the assertion isn't actually 
supposed to literally include this. Rather, I guess it should be either 
"911" or "urn:service:sos".  Similarly I *guess* "CgPN" is not intended 
to be literal.

Do I get that right?

If so, I think there needs to be some additional work to specify this 
clearly. You could specify the assertion format in ABNF, but maybe there 
is a better way.

	Thanks,
	Paul

On 1/10/20 11:40 AM, [email-masked] wrote:
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir
>

---

From: Chris Wendt <[email-masked]>
Date: Sun, 12 Jan 2020 19:26:03 -0500

Hi Paul,

I think we do intend to make that clearer and provide explicit rules.  We had a discussion at the meeting about what the URN should be, etc. So hoping we can make progress on that for next version.

-Chris

> On Jan 12, 2020, at 2:48 PM, Paul Kyzivat <[email-masked]> wrote:
> 
> I'm having a little difficulty understanding the details of what constitutes a valid assertion. In section 3 I see:
> 
>     {
>       "orig":{"tn":"CgPN"},
> This isn't ABNF so I don't know the rules for interpreting it. Some of the stuff enclosed in quotes is obviously intended to be literal. But other parts, also included in quotes, seem to placeholders.
> 
> For instance "911 or URN-SOS" - I presume the assertion isn't actually supposed to literally include this. Rather, I guess it should be either "911" or "urn:service:sos".  Similarly I *guess* "CgPN" is not intended to be literal.
> 
> Do I get that right?
> 
> If so, I think there needs to be some additional work to specify this clearly. You could specify the assertion format in ABNF, but maybe there is a better way.
> 
> 	Thanks,
> 	Paul
>