Subject: [stir] Review of draft-ietf-stir-rph-emergency-services

From: Jack Rickard <[email-masked]>
Date: Fri, 14 Aug 2020 17:21:39 +0000

I have reviewed draft-ietf-stir-rph-emergency-services-02 and have some concerns and questions. I don't believe this spec is implementable in its current form.

Thanks,
Jack

Why are "ESorig" and "EScallback" distinct?
They seem to serve a very similar purpose with the only difference being whether orig or dest should be the emergency services. I don't believe there's any check that can be done to validate:
   When using "ESorig" as the "rph" assertion value, the "orig" claim of
   the PASSporT MUST represent the calling party number that initiates
   the call to emergency services.
This (and the equivalent statement for EScallback) don't seem possible to me to check (barring the standard orig/dest checking).
This would make the check "at least one of the parties should be the emergency services" enough to validate that this was a reasonable call.

Why have them at all rather than just using auth?
This is very possibly an issue with my understanding, but I'm not clear on why "ESorig" and "EScallback" even need to exist. "esnet.0" etc. are SIP Resource Priority headers, so should be included in the "auth" field anyway by the RPH spec. This spec appears to apply extra constraints (that a one of the callers must be the emergency services) for the "esnet" namespace but it's not clear why entirely separate claims are needed.

In a similar vein, what should a verifier do if it receives a call containing an invalid "ESorig" or "EScallback" value or the passport is invalid/untrusted, I'm assuming the behaviour is the same as for auth but this isn't clear. Although stripping the fact that this is an emergency call is potentially dangerous.

Specify the type of the "ESorig" and "EScallback" claims.
This specification currently doesn't specify the type of the new fields, there are only examples and this isn't enough. It looks like they both follow the same scheme as the rph "auth" claim, however "esnet,x" doesn't quite fit into that due to the comma and that x isn't a valid priority value.

Why is sph limited to psap-callback? What should the verifier do if it isn't that? What should it do if it is?
I'm not entirely clear on the purpose of the sph claim, however, it seems odd that it doesn't cover the full range of possible values for the SIP Priority Header. Is there a reason that it doesn't cover the "non-urgent", "normal", "urgent", or "emergency" values?
There is also no verifier behaviour defined here, should the verifier remove the Priority header if it receives an invite with no passports signing for it? That seems dangerous to me but would be consistent with rph. Alternatively, what should the verifier do if it receives an invite with a valid passport claiming sph but with no Priority header should it add it in? I'm not sure the spec needs to be too prescriptive here, however some mention of verifier behaviour and the associated security considerations would be useful.

Should the spec be stronger about the compact form?
Section 3 currently states

   The use of the compact form of PASSporT is not specified in this

   document.
However, a compact-form passport following this spec would be hard to verify as it introduces multiple possible rph variants, I think this spec could go further and say you shouldn't/mustn't.

What is the requirement of these new parameters.
As I understand it, the passport spec allows you to create a passport containing whatever JWT fields you want and verifiers should just ignore any fields they don't understand. Unless the "ppt" claim is set, which indicates that verifiers should discard it if they don't recognise that passport type. As this spec adds additional fields to an existing passport type it isn't immediately clear what the behaviour should be. Specifically, is an rph passport containing only "rph.ESorig" valid now (where it wouldn't be before because auth isn't present), is an rph passport containing no rph and only sph valid, and what does a non-rph passport with sph or ESorig set mean?

---

From: Brian Rosen <[email-masked]>
Date: Tue, 18 Aug 2020 17:30:32 -0400

Let’s keep the two use cases separate:
ESorig is an emergency call (user to authority).
EScallback is a call from authority to user.

For ESorg, the call is marked with a Request-URI of urn:service:sos.  The “To” field is ignored in routing and handling the call.  That’s how you know this is an emergency call.   For stir purposes, the From is an ordinary identifier, and gets treated in the normal way.  However, the rph value can only be used by a valid emergency call, and a valid emergency call is a Request URI of urn:service:sos, and a valid From.  So you don’t have any knowledge of emergency services identifiers, only the Request URI of urn:service:sos.   

For EScallback, the marking is a distinguished value in SIP Priority.  If a call has that value, it’s a call back.  The originating service provider knows who are the authorities who are allowed to place call backs, so the check is what is in SIP Priority, and one of the allowed authorities in From.  As a practical matter, in most cases, the call will be signed by the emergency authorities themselves, who will be able to get appropriate credentials for this purpose.  In most cases I’m aware of, the To in an emergency call won’t match the From in a Callback, but it’s possible for that to happen, and we want to allow it.

Esnet is a Resource Priority Header namespace, not a SIP Priority value.  We’re allowing emergency calls and call backs to use rph, and we’re protecting against malicious use of it.  So unless the call has urn:service:sos in Request URI, or the right SIP Priority in a call back (and from an authorized authority) they can’t use rph with the esnet namespace.  Generally, unless under attack, emergency calls go through even if there isn’t a passport.  Many networks won’t offer actual priority to emergency calls, but the emergency services networks (ESInets) will.  

If a call arrives anywhere with an rph using esnet, and isn’t an emergency call, with the appropriate passport,  any intermediary can refuse to give it any priority,  The emergency authorities may accept a call without a valid passport, but they might treat it with much more suspicion than they would any other call.

For call backs, the network may have special behavior.  For example, it may send the call to the device that placed the emergency call, rather than, for example, voice mail.  The network has to be able to trust that SIP Priority is set appropriately.  It will also have rph using esnet, and the network can grant it appropriate priority if it has that capability, and would not allow esnet otherwise.

The only value in covering other uses of SIP Priority is to protect against middle boxes modifying it.  We don’t really have use cases for that.  It probably wouldn’t hurt to allow it though.

Does that help?

Brian

> On Aug 14, 2020, at 1:21 PM, Jack Rickard <Jack.Rickard=[email-masked]> wrote:
> 
> This (and the equivalent statement for EScallback) don't seem possible to me to check (barring the standard orig/dest checking)..
> In a similar vein, what should a verifier do if it receives a call containing an invalid "ESorig" or "EScallback" value or the passport is invalid/untrusted, I'm assuming the behaviour is the same as for auth but this isn't clear. Although stripping the fact that this is an emergency call is potentially dangerous..
>  
>  
> _______________________________________________
> stir mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/stir <https://www.ietf.org/mailman/listinfo/stir>

---

From: Jack Rickard <[email-masked]>
Date: Wed, 19 Aug 2020 11:19:18 +0000

Thanks, that's really useful, however, I'm not convinced.

For ESorig, as far as I know this isn't currently always the case, I am aware of situations where emergency calls just look like normal calls with a number of 911. I'm also still unclear about what affect this has, as you can currently already sign emergency calls using the standard mechanisms (barring the whole "urn:service:sos" tn which I don't believe is standardised for STIR yet?)  by putting "esnet.0" in the auth field of an rph passport.

For EScallback, if the sph and "rph.auth" claims cover theis entirely why is EScallback needed? I'm also still unclear what the verification service behaviour is here.

I'm still unclear as to how this spec helps with allowing and preventing malicious use of emergency calls. You can already put esnet resource priority pairs in the "rph.auth" claim and that seems to provide as much security as this does. I do agree the sph claim does provide value, however.

I did just realise that the esnet Resource Priority needs to be in the "rph.auth" claim or the logic from that rfc will kick in and remove it, as per:
RFC 8443, section 4.2
   In such scenarios, the SIP 'Resource-Priority' header field SHOULD be
   stripped from the SIP request, and the network entities should treat
   the call as an ordinary call.

I'll note that some of my questions and concerns haven't been addressed yet, I'm happy to resolve this first, just making a note so that they don't get lost/I don't forget about them.
Jack

From: Brian Rosen <[email-masked]>
Sent: 18 August 2020 22:31
To: Jack Rickard <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [stir] Review of draft-ietf-stir-rph-emergency-services

Does that help?

Brian

On Aug 14, 2020, at 1:21 PM, Jack Rickard <Jack.Rickard=[email-masked]<mailto:Jack.Rickard=[email-masked]>> wrote:

Thanks,
Jack

   document.

_______________________________________________
stir mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/stir<https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fstir&data=02%7C01%7CJack.Rickard%40metaswitch.com%7C1da6b58cfadb48a6cef308d843bdf44e%7C9d9e56ebf6134ddbb27bbfcdf14b2cdb%7C1%7C0%7C637333830454755078&sdata=pFRkcyo37w0eVGz86WYmhiijHPeRYMA570KExOU9uis%3D&reserved=0>

---

From: Brian Rosen <[email-masked]>
Date: Wed, 19 Aug 2020 09:40:27 -0400

About 20% of the US has now upgraded to NG9-1-1, although most service providers haven’t yet.  The wireless carriers are moving towards it; testing is underway.  
I will have a companion document in sipcore that handles the signaling aspects of this mechanism.  For the older E911 system, none of stir really helps because the existing system is built on the older Class 4 switches (“Selective Routers”).  All of this mechanism is for NG9-1-1 and the equivalent services in the rest of the world, based on IETF standards (RFC6881, RFC5222, and several others).  

> On Aug 19, 2020, at 7:19 AM, Jack Rickard <[email-masked]> wrote:
> 
> On Aug 14, 2020, at 1:21 PM, Jack Rickard <Jack.Rickard=[email-masked] <mailto:Jack.Rickard=[email-masked]>> wrote:
>  
> https://www.ietf.org/mailman/listinfo/stir <https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fstir&data=02%7C01%7CJack.Rickard%40metaswitch.com%7C1da6b58cfadb48a6cef308d843bdf44e%7C9d9e56ebf6134ddbb27bbfcdf14b2cdb%7C1%7C0%7C637333830454755078&sdata=pFRkcyo37w0eVGz86WYmhiijHPeRYMA570KExOU9uis%3D&reserved=0>

---

From: Jack Rickard <[email-masked]>
Date: Thu, 20 Aug 2020 17:30:21 +0000

It's not clear that this spec relies on that, and I'm not sure that it should? To me it seems like this could be more widely applicable.

Would you be able to address, from a verification service's point of view, what it should do? I think that will clear up why "Esorig" and "EScallback" are useful above plain "auth".
I think the spec would benefit from that section as well Section 4 of RFC 8443 and section 11 of draft-ietf-stir-passport-rcd-06 are both incredibly useful.

Thanks,
Jack

Sent: 19 August 2020 14:40

NOTE: Message is from an external sender
About 20% of the US has now upgraded to NG9-1-1, although most service providers haven’t yet.  The wireless carriers are moving towards it; testing is underway.
I will have a companion document in sipcore that handles the signaling aspects of this mechanism.  For the older E911 system, none of stir really helps because the existing system is built on the older Class 4 switches (“Selective Routers”).  All of this mechanism is for NG9-1-1 and the equivalent services in the rest of the world, based on IETF standards (RFC6881, RFC5222, and several others).

On Aug 19, 2020, at 7:19 AM, Jack Rickard <[email-masked]<mailto:[email-masked]>> wrote:

From: Brian Rosen <[email-masked]<mailto:[email-masked]>>
Sent: 18 August 2020 22:31
To: Jack Rickard <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [stir] Review of draft-ietf-stir-rph-emergency-services

Does that help?

Brian

Thanks,
Jack

   document.

_______________________________________________
stir mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/stir<https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fstir&data=02%7C01%7CJack.Rickard%40metaswitch.com%7C2bc3d7e4e6aa4f85ebeb08d844457330%7C9d9e56ebf6134ddbb27bbfcdf14b2cdb%7C1%7C0%7C637334412375899805&sdata=jkZlyWrqCNpbqPArsBZNryW%2BWjTylJY%2FH86b1bwMLDQ%3D&reserved=0>

---

From: Chris Wendt <[email-masked]>
Date: Tue, 25 Aug 2020 11:14:54 -0400

Hi Jack,

I think we still want to keep “auth” and “ESorig/ESCallback” as separate and distinct key/value objects, i see your comments as maybe disagreement stylistically but didn’t see anything to suggest that it wouldn’t work.  The reasoning though is that “auth” is intended to be specific to priority services only, not extensible for other applications.  And the fact of the matter is key/values are cheap, no reason we can’t have new values and be explicit about the intent.  This document is specific to 911 and emergency services and to extend the key/values defined for ‘rph’ claim and ‘rph’ PASSporT extension.

I will make this clearer in the document and explicitly say that “auth” should not be used for emergency services purposes of using resource priority header.

I think it would also make sense to make it clear that that this document extends 8443 and linking the documents.

For compact form, we think it would confuse folks to add provisions for compact form or allow it for little gain, and therefore prefer to leave it undefined.

Thanks.

-Chris

> On Aug 20, 2020, at 1:30 PM, Jack Rickard <[email-masked]> wrote:
> 
> From: Brian Rosen <[email-masked] <mailto:[email-masked]>> 
> To: Jack Rickard <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> On Aug 19, 2020, at 7:19 AM, Jack Rickard <[email-masked] <mailto:[email-masked]>> wrote:
>  
> From: Brian Rosen <[email-masked] <mailto:[email-masked]>> 
> To: Jack Rickard <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/stir <https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fstir&data=02%7C01%7CJack.Rickard%40metaswitch.com%7C2bc3d7e4e6aa4f85ebeb08d844457330%7C9d9e56ebf6134ddbb27bbfcdf14b2cdb%7C1%7C0%7C637334412375899805&sdata=jkZlyWrqCNpbqPArsBZNryW%2BWjTylJY%2FH86b1bwMLDQ%3D&reserved=0>