Subject: Re: [stir] [Technical Errata Reported] RFC8224 (6519): ident-info

From: Christer Holmberg <[email-masked]>
Date: Thu, 8 Apr 2021 16:30:15 +0000

Hi,

...

> I would also like to point out that the definition of info parameter
> is also problematic since it is not a valid generic-param:
> ident-info = "info" EQUAL ident-info-uri
> ident-info-uri = LAQUOT absoluteURI RAQUOT
>
> A quoted-string should have been used for the info, not the LAQUOT
> absoluteURI RAQUOT.

Why would ident-info have to be a valid generic-param?

Note that ident-info is a separate header field item, and NOT part of ident-info-params (which has to be a valid generic-param) , so it can have whatever syntax it wants (as long as it is aligned with the syntax of a SIP header field).

Identity = "Identity" HCOLON signed-identity-digest SEMI ident-info *( SEMI ident-info-params )
…
ident-info-params = ident-info-alg / ident-type /ident-info-extension
ident-info-extension = generic-param

Regards,

Christer

---

From: Roman Shpount <[email-masked]>
Date: Fri, 9 Apr 2021 00:42:06 -0400

On Thu, Apr 8, 2021 at 12:30 PM Christer Holmberg <
[email-masked]> wrote:

> Note that ident-info is a separate header field item, and NOT part of
> ident-info-params (which has to be a valid generic-param) , so it can have
> whatever syntax it wants (as long as it is aligned with the syntax of a SIP
> header field).
>
> Identity = "Identity" HCOLON signed-identity-digest SEMI *ident-info* *(
> SEMI ident-info-params )
> …
You are right. It still makes handwritten parsers more complicated.
_____________
Roman Shpount

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 9 Apr 2021 13:46:05 +0000

Hi,

>> Note that ident-info is a separate header field item, and NOT part of ident-info-params (which has to be a valid generic-param) , so it can have
>> whatever syntax it wants (as long as it is aligned with the syntax of a SIP header field).
>>

Perhaps (not sure I agree, but that is irrelevant), but I don't think simplifying a parser justifies as a bug fix.

Regards,

Christer