Subject: Re: [stir] [Technical Errata Reported] RFC8224 (6519): COMMA separated Identity header fields

From: Christer Holmberg <[email-masked]>
Date: Thu, 8 Apr 2021 16:48:34 +0000

Hi,

...

>There is also the issue that an Identity header should have supported the use of repetition using COMMA, now the we can have
>multiple Identity headers in a message.  Here we have to make it an exception, must like for the various authorization headers.

I raised this issue prior to publication:

https://mailarchive.ietf.org/arch/msg/stir/nrZT-kAGT2UkMy4Z-9LuEqyZcn8/

But, as you can see from Adam's reply (https://mailarchive.ietf.org/arch/browse/stir/?q=Identity%20header%20field%20comma), as the issue was raised during AUTH48 people did not want to do the change that late in the process. It was also pointed out (as you also did) that there are other headers (the various authorization headers) where comma separation is not allowed.

So, as we didn't make the change back then, I don't think we shall do it now. You can still use multiple header fields, so nothing is broken.

Regards,

Christer

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 8 Apr 2021 09:58:49 -0700

> So, as we didn't make the change back then, I don't think we shall do it now. You can still use multiple header fields, so nothing is broken.

Right.  Thanks for the context.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug