Subject: Re: [stir] Proposal for update of erratum #6519 - ppt syntax and normalization

From: Christer Holmberg <[email-masked]>
Date: Sat, 24 Apr 2021 12:42:05 +0000

Hi,

...

>You would also need to explain that, contrary to the rule for a quoted-string, the string is case-insensitive.  And you still have to explain that the string needs to be normalized before copy in the JSON document.

Doesn't the normalization also apply to non-quoted values? 

Because, even if token values are case-insensitive, if you receive a ppt value - quoted or non-quoted - you need to normalize it before adding it to the JSON document.

Regards,

Christer

> -----Original Message-----
> From: Marc Petit-Huguenin <[email-masked]>
> Sent: torstai 22. huhtikuuta 2021 21.07
> To: Christer Holmberg <[email-masked]>; Roman Shpount <[email-masked]>
> Cc: Russ Housley <[email-masked]>; IETF STIR Mail List <[email-masked]>
> Subject: Re: [stir] Proposal for update of erratum #6519 - ppt syntax
> 
> On 4/22/21 11:02 AM, Christer Holmberg wrote:
>> Hi,
>>
>> Another thing. Since we are now using DQUOTE, won't those become part of the ppt value? I guess we don't want that.
> 
> The text I proposed is taking care of that:
> 
> ...a quoted value whose unquoted part is equivalent to the token in the "ppt" parameter, normalized to contain only lowercase characters...
> 
> 
>>
>> Regards,
>>
>> Christer
>>
>> ________________________________
>> From: Roman Shpount <[email-masked]>
>> Sent: Thursday, April 22, 2021 9:00 PM
>> To: Christer Holmberg <[email-masked]>
>> Cc: Marc Petit-Huguenin <[email-masked]>; Russ Housley <[email-masked]>; IETF STIR Mail List <[email-masked]>
>> Subject: Re: [stir] Proposal for update of erratum #6519 - ppt syntax
>>
>> On Thu, Apr 22, 2021 at 1:54 PM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
>> Doesn't the SIP ABNF allow spaces (LWS) between the different "syntax parts", DQUOTE and token in this case?
>>
>> I do not think so. At least all other elements like LQUOT and DQUOT explicitly define where LWS is allowed.
>> _____________
>> Roman Shpount
>>
> 
> 

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://protect2.fireeye.com/v1/url?k=6e950d4e-310e344b-6e954dd5-86959e472243-c5caf7fcad882c4c&q=1&e=17c0f412-5029-44f1-b38a-e934422287da&u=https%3A%2F%2Fmarc.petit-huguenin.org%2F
Profile: https://www.linkedin.com/in/petithug

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sat, 24 Apr 2021 05:43:56 -0700

> Doesn't the normalization also apply to non-quoted values?

Yes.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug