Subject: [Supa] SUPA configuration

From: Kostas Pentikousis <[email-masked]>
Date: Tue, 23 Sep 2014 11:03:41 +0200

Dear All,

We have been working on two drafts on SUPA configuration. The first one (SUPA Configuration and Policy Mapping, http://datatracker.ietf.org/doc/draft-pentikousis-supa-mapping/) discusses mapping of an abstract view to device-level configuration. The second one (YANG Data Model for Configuration of Shared Unified Policy Automation (SUPA), https://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/) introduces our early stage work on a few YANG models for L3VPN, IP TE etc.

We're looking forward to your comments and suggestions. 

Best regards,

Kostas

---

From: Ying Cheng <[email-masked]>
Date: Tue, 30 Sep 2014 11:17:42 +0800

Hi Kostas et al,

I've read the draft (SUPA Configuration and Policy Mapping, http://datatracker.ietf.org/doc/draft-pentikousis-supa-mapping/) and consider that it tackles a real problem of SUPA. The example therein aligns with what we proposed in ddc use case. Below please kindly find my commens.

In section 3.3 SUPA mapping example, it illustrates how to map configuration YANG model into device-based CLI with the assistance of topology YANG model. However, as CLI is usually vendor-dependent, it's a little complicated to map into CLIs directly (Although the complexity is not showed up in this example --- All the CLIs seem to follow the specification of the same vendor). IMHO, mapping configuration YANG model into a vendor-neutral device-level configuration YANG model firstly is more appropriate. After that we can map the vendor-neutral device-level configuation YANG model into different vendor's configuration interfaces/methods, which is vendor-dependent and is not required to be standardized.

PS. It is also suggested to consider to provide a more general description of mapping mechanism, instead of only presenting a detailed example, which makes this draft limited to a specific scenario.

BR,
Ying

2014-09-30 

Ying CHENG  程莹
China Unicom Network Technology Research Institute 中国联通网络技术研究院
Tel: +86-10-68799999-7702
Mobile: +86-18601102971

发件人： Kostas Pentikousis 
发送时间： 2014-09-23  17:04:12 
收件人： [email-masked] 
抄送： 
主题： [Supa] SUPA configuration 
 
Dear All,
We have been working on two drafts on SUPA configuration. The first one (SUPA Configuration and Policy Mapping, http://datatracker.ietf.org/doc/draft-pentikousis-supa-mapping/) discusses mapping of an abstract view to device-level configuration. The second one (YANG Data Model for Configuration of Shared Unified Policy Automation (SUPA), https://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/) introduces our early stage work on a few YANG models for L3VPN, IP TE etc.
We're looking forward to your comments and suggestions. 
Best regards,
Kostas
_______________________________________________
Supa mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/supa
.

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。
If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.