Subject: [Supa] zaalouk VPN model discussion

From: Maxim Klyus <[email-masked]>
Date: Mon, 13 Apr 2015 08:45:06 +0000

Hello SUPA,

After reviewing zaalouk draft more closely.

I have the following suggestions:

1)      Add the Status parameter for VPN Service, VPN Service Components, VPN Service Parts (proposed in L3SM group earlier (http://www.ietf.org/mail-archive/web/l3sm/current/msg00019.html, http://www.ietf.org/mail-archive/web/l3sm/current/msg00023.html).

2)      Science zaalouk draft about generic VPN will be useful to add another abstraction layer in the model. Right now in zaalouk only L2VPN and L3VPN and its variations, but in fact as you know real VPN service can be really complicated even on MPLS cloud (see VPN Service.png example). We can say even the set of different VPNs still can be the one VPN service. It will be very useful to define some upper layer abstractions like Composite VPN Service and Parts.  Composite VPN Service may include - Core Service Part and Access Parts. I'm not sure how it should be in the document, section 3.1 could be expanded or it could be placed in separate section. Structure and naming can be debated.

Structure example:

  Composite VPN Service
  |
  +- Core Parts
 |     |
  |     +-L3VPN Service
 |
  +- Access Parts
       |
       +-L2VPN
       |    |
       |    +Type VLL P-t-P
       |
       +-L2VPN
       |    |
       |    +Type VLL P-t-P

  Any comments?

       Best Regards,
       Max Klyus

________________________________
The information transmitted herein is intended only for the person or entity to which it is addressed and may contain confidential, proprietary and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from any computer.

---

From: Ying Cheng <[email-masked]>
Date: Thu, 16 Apr 2015 15:54:38 +0800

Hi Maxim,

Thanks for your comments. Please kindly see my response in line in orange.

BR,
Ying

2015-04-16 

Ying CHENG  程莹
China Unicom Network Technology Research Institute 中国联通网络技术研究院
Tel: +86-10-68799999-7702
Mobile: +86-18601102971

发件人： Maxim Klyus 
发送时间： 2015-04-13  16:45:24 
收件人： [email-masked] 
抄送： 
主题： [Supa] zaalouk VPN model discussion 
 
Hello SUPA,

 

[Ying]I agree. This parameter will help in service management and monitoring.
 
2)      Science zaalouk draft about generic VPN will be useful to add another abstraction layer in the model. Right now in zaalouk only L2VPN and L3VPN and its variations, but in fact as you know real VPN service can be really complicated even on MPLS cloud (see VPN Service.png example). We can say even the set of different VPNs still can be the one VPN service. It will be very useful to define some upper layer abstractions like Composite VPN Service and Parts.  Composite VPN Service may include - Core Service Part and Access Parts. I’m not sure how it should be in the document, section 3.1 could be expanded or it could be placed in separate section. Structure and naming can be debated.    
[Ying] Actually your use case can be realized by stitching current proposed L3 & L2VPN yang model. Let’s say a user want to establish a VPN service via multiple AS’s say AS1 (MPLS domain) and AS2 (Access domain). In such case we can use L3VPN model for AS1 and L2VPN model for the AS2. But I agree if we can generalize this as per your suggestion. Moreover, if we are talking about inter-AS domain then how about optical network as the intermediate domain ? I am not sure whether this should be the scope of this draft or we write a separate document to address this scenario.
 
Structure example:
 
  Composite VPN Service 
  |
  +- Core Parts
 |     |
  |     +-L3VPN Service
 |
  +- Access Parts
       |
       +-L2VPN
       |    |
       |    +Type VLL P-t-P
       |
       +-L2VPN
       |    |
       |    +Type VLL P-t-P
 
  Any comments?
 
       Best Regards,
       Max Klyus

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。
If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.