Subject: [Supa] SUPA meeting minutes for 20150406

From: John Strassner <[email-masked]>
Date: Wed, 15 Apr 2015 10:21:38 -0700

Apologies for sending this so late; I thought I did, but my work mailer
corrupted the file. I'm resending it from my gmail.

-- 
regards,
John

---

From: Andy Bierman <[email-masked]>
Date: Wed, 15 Apr 2015 10:44:05 -0700

Hi,

When reviewing these YANG modules, I found it difficult to
envision the procedures required (from an operator or application POV)
for creating and debugging the configuration.  This is a common problem
with YANG models.  A static representation of a data structure may not
be the best place to describe the procedures.  Examples or intro text
may be a better place than the YANG module itself for this text.

This is even more important for layered policy abstractions where a
controller is interacting with several NEs, and/or different policy layers.
I am hoping YANG (with possible extensions) will be capable of
expressing interactions between the "intent layer" and the "ECA layer".

Andy

On Wed, Apr 15, 2015 at 10:21 AM, John Strassner <[email-masked]> wrote:
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
>

---

From: Dan Martin <[email-masked]>
Date: Wed, 15 Apr 2015 18:08:31 +0000

It's a big challenge.  I've started to watch the onos stuff and I see they try and notice that I may not be able to get what I ask for or that something may change and the Physical network controller may have to renegotiate.  

One of the ways to ask for something in a way that gives you the ability to satisfy the request at least partially may be to use something like a code book from a Bayesian belief system, I hope i'm getting the terminology right.  I can find the row with the columns that most closely match what attributes I want in my path and I can make rules around what I'm willing to settle for.  So now my customer network controller initiated path request comes with a set of endpoints and attributes and another set of attributes about the things i'm willing to settle for.  

-----Original Message-----
From: Supa [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Wednesday, April 15, 2015 1:44 PM
To: John Strassner
Cc: Romascanu, Dan (Dan); [email-masked]; Tina TSOU
Subject: Re: [Supa] SUPA meeting minutes for 20150406

Hi,

When reviewing these YANG modules, I found it difficult to envision the procedures required (from an operator or application POV) for creating and debugging the configuration.  This is a common problem with YANG models.  A static representation of a data structure may not be the best place to describe the procedures.  Examples or intro text may be a better place than the YANG module itself for this text.

This is even more important for layered policy abstractions where a controller is interacting with several NEs, and/or different policy layers.
I am hoping YANG (with possible extensions) will be capable of expressing interactions between the "intent layer" and the "ECA layer".

Andy

On Wed, Apr 15, 2015 at 10:21 AM, John Strassner <[email-masked]> wrote:
> Apologies for sending this so late; I thought I did, but my work 
> mailer corrupted the file. I'm resending it from my gmail.
>
> --
> regards,
> John
>