Subject: [Supa] About scope of SUPA work item #3

From: "Jun Bi" <[email-masked]>
Date: Mon, 8 Jun 2015 20:35:42 +0800

Dear Andy,

Thank you very much for your help on the work item #3 which are policy data
models !

What do you think about the scope of the I-D? 

Below is just some suggestions. 

The scope of work item #3:

1, a generic YANG data model comes from John's generic policy information
model (SGPIM).

2, an extensible ECA policy data model from the ECA policy information model
(EPRIM) 

3, an extensible intent/goal policy data model from logic statement
information model (SLSIM) 

4, application of the ECA data model

More specifically, the table of content of the I-D could be constructed as:

1. Introduction

2. Terminology

3. SUPA generic policy model

3.1. Information model overview

3.2 Architecture

3.3 Generic policy data model implementation

4. SUPA ECA policy rule model

4.1. Information model overview

4.2 Architecture

4.3 ECA policy data model implementation

5. SUPA intent policy model

5.1. Information model overview

5.2 Architecture

5.3 Intent policy data model implementation

6. Applications of ECA policy rule data model

Then what do you think of the scope and the table of content? 

Thank you very much!

Jun Bi

-----邮件原件-----

发件人: Supa [mailto:[email-masked]] 代表 Andy Bierman

发送时间: 2015年6月3日 8:49

收件人: Tina TSOU

抄送: Juergen Schoenwaelder; Bert Wijnen (IETF); [email-masked]
<mailto:[email-masked]> 

主题: Re: [Supa] supa charter 2015-05-29

On Tue, Jun 2, 2015 at 4:26 PM, Tina TSOU <[email-masked]
<mailto:[email-masked]> > wrote:

> Dear Andy,

> Awesome!

> Would you like to be the editor of document #3 at 

> http://trac.tools.ietf.org/bof/trac/ ?

I can probably help with that.

Andy

> #3 one I-D translate information model to generic YANG, a set of YANG 

> data models that express the concepts defined in the generic policy 

> information model in concrete data models. These models will be 

> designed to be generic and extensible.

> Converged from

> http://datatracker.ietf.org/doc/draft-wang-netmod-yang-policy-dm/

> Thank you,

> Tina

> On Jun 3, 2015, at 3:10 AM, Andy Bierman <[email-masked]
<mailto:[email-masked]> > wrote:

> On Tue, Jun 2, 2015 at 4:21 AM, Juergen Schoenwaelder 

> <[email-masked]
<mailto:[email-masked]> > wrote:

> On Tue, Jun 02, 2015 at 12:57:57PM +0200, Bert Wijnen (IETF) wrote:

> Juergen wrote:

>   I am sometimes getting lost at these questions. What the charter 

> tries

>   to say (and I apologize if this is still not clear enough) is that

>   SUPA intends to work on policies that control how things get 

> configured

>   on network elements, it is not aiming to replace or reformulate how

>   packet filters work etc.

> Maybe my misunderstanding. But I think you want to say that the 

> policies

> control how some

> of the things get configure on network elements, no? Or is the intend 

> that

> these policies

> control all of the configuration?

> Policies certainly won't control everything. How can the charter text 

> be

> improved to avoid this confusion? The above was just an email 

> explanation

> and hence it is not that important.

> Let's say I had a simple policy for configuration.

> Perhaps I want to the user to choose between speed and robustness, 

> i.e., edits are done as fast as possible vs. edits done as robustly as 

> possible.

> Is this a valid intent-based policy?  I know how to change the NETCONF 

> parameters to implement either for speed or for robustness.  I don't 

> understand how high-level policy gets translated into a low-level 

> implementation of the policy in an automated fashion.

> I am hoping SUPA can support this sort of usage instead of just the 

> narrow scope of the hard-wired items.  I should be able to write a 

> structured document (policy mapping?) that tells a SUPA system how to 

> glue the policy to the implementation.

> Andy

> I do see there is a newer version SUPA CHARTER PROPOSAL (2015-06-01) 

> of the

> proposed

> charter from yesterday. The only questions in my mind to that latest

> proposed charter are:

>   The working group will decide how the work items are best mapped 

> into

>   deliverables.

> Does the list of work items not already specify the deliverables? Or 

> at

> least the titles for the documents?

> There was a discussion whether the information model will be one

> document or perhaps be split into multiple documents. Dan suggested

> that it is OK for the WG to decide how to best split things into

> documents.

> DO we have no idea as to when we want to deliver these (i.e. a set

> of milestones)? I can understand and can accept if we say that such

> would be decided in/during a WG-chartering/formation BOF

> Yes, this was the idea. Milestones are usually easy to settle once

> there is a sign of green light on the horizon.

> The other question I have is: are the work items listed in sequence of

> delivery?

> I would think that one would do some use cases first before one starts

> mapping into YANG, no?

> I guess the framework indeed goes first. In some other WG, we did an

> information model and afterwards a data model but it was decided to

> not submit the information model until the data model is reasonably

> complete. The reason is that changes you discover while writing the

> data model may be carried back to the information model. Use cases may

> go earlier but then it might also be good to keep the document alive

> in the WG until we are pretty sure the other deliverables are

> consistent wrt the use cases. But perhaps it makes sense to move 4) to

> position 2).

> I have started charter version 2015-06-02.

> /js

> --

> Juergen Schoenwaelder           Jacobs University Bremen gGmbH

> Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany

> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

> _______________________________________________

> Supa mailing list

> [email-masked] <mailto:[email-masked]> 

> https://www.ietf.org/mailman/listinfo/supa

> _______________________________________________

> Supa mailing list

> [email-masked] <mailto:[email-masked]> 

> https://www.ietf.org/mailman/listinfo/supa

---

From: Andy Bierman <[email-masked]>
Date: Mon, 8 Jun 2015 10:24:11 -0700

Hi,

I need to catch up on the SUPA drafts and see an example
that shows how this mapping between policy and "plain config"
really works.

Andy

On Mon, Jun 8, 2015 at 5:35 AM, Jun Bi <[email-masked]> wrote:
> On Tue, Jun 2, 2015 at 4:26 PM, Tina TSOU <[email-masked]>
> wrote:
>
>> Dear Andy,
>
>>
>
>> Awesome!
>
>>
>
>> On Jun 3, 2015, at 3:10 AM, Andy Bierman <[email-masked]> wrote:
>
>>
>
>> <[email-masked]> wrote:
>
>>
>
>> [email-masked]
>> [email-masked]
> [email-masked]

---

From: "Jun Bi" <[email-masked]>
Date: Tue, 9 Jun 2015 01:37:07 +0800

Thanks！

Jun

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Tuesday, June 9, 2015 1:24 AM
To: Jun Bi
Cc: John Strassner; Juergen Schoenwaelder; [email-masked]
Subject: Re: [Supa] About scope of SUPA work item #3

Hi,

I need to catch up on the SUPA drafts and see an example that shows how this mapping between policy and "plain config"
really works.

Andy

On Mon, Jun 8, 2015 at 5:35 AM, Jun Bi <[email-masked]> wrote:
>
>
>
>
> Dear Andy,
>
>
>
> Thank you very much for your help on the work item #3 which are policy 
> data models !
>
> 1, a generic YANG data model comes from John's generic policy 
> information model (SGPIM).
>

---

From: "Jun Bi" <[email-masked]>
Date: Tue, 9 Jun 2015 17:39:41 +0800

Dear Andy,

For your reference, here are some write-ups from John to show how to incorporate YANG policy model into generic policy information model.
http://www.ietf.org/mail-archive/web/supa/current/msg00833.html

The mapping of the "action" of the ECA policy to the configuration can be found:
http://datatracker.ietf.org/doc/draft-pentikousis-supa-mapping/

Best Regards,
Jun Bi

-----Original Message-----
From: Jun Bi [mailto:[email-masked]] 
Sent: Tuesday, June 9, 2015 1:37 AM
To: 'Andy Bierman'
Cc: 'John Strassner'; 'Juergen Schoenwaelder'; [email-masked]'
Subject: RE: [Supa] About scope of SUPA work item #3

Thanks！

Jun

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Tuesday, June 9, 2015 1:24 AM
To: Jun Bi
Cc: John Strassner; Juergen Schoenwaelder; [email-masked]
Subject: Re: [Supa] About scope of SUPA work item #3

Hi,

Andy

---

From: Andy Bierman <[email-masked]>
Date: Tue, 9 Jun 2015 09:23:30 -0700

Hi,

thanks -- this is helping me understand SUPA a little more.
I am not convinced YANG would be a good choice for expressing
policy mappings.  It looks like a programming language deconstructed
into parts, each part with a YANG data structure to fill out.
Maybe a policy scripting language would be easier to use.
IMO it would be about the same complexity to implement
either way.

The Q&A on the Wiki does not really make things 100% clear.
I don't get how info models will help.  The claims of increased
understanding of the parts are hard to prove.

Andy