Subject: Re: [Supa] 06/22/15 SUPA Applicability

From: Ying Cheng <[email-masked]>
Date: Wed, 24 Jun 2015 17:23:56 +0800

Hi Narasimha,

Many thanks for your drafting the presentation on SUPA Applicability. After reading it, I have several questions/comments as follows. Could you please kindly let me know your positions?

In the latest charter, there are two types of information model:  ECA information model and intent-based information model, besides the generic information model. But in the slides, it seems that only ECA is covered, how about the intent-based information model?
Some use cases are given in the slides, it might be useful to further explain how ECA or intent-based information model can be used in these use case. E.g. what kind of event and condition will trigger what kind of action(s).
Regarding SUPA application scope, “Software management (patches, upgrade etc.)” is mentioned. Can you elaborate this? I am not quite sure how SUPA information / data models can be used for this purpose.

Thanks and best regards,
Ying

2015-06-24 

Ying CHENG  程莹
China Unicom Network Technology Research Institute 中国联通网络技术研究院
Tel: +86-10-68799999-7702
Mobile: +86-18601102971

发件人： Narasimha Rao Vadrevu 
发送时间： 2015-06-22  23:41:30 
收件人： [email-masked] 
抄送： 
主题： [Supa] 06/22/15 SUPA Applicability 
 
Hi All,
 
I was to do a 10 minute presentation of this time permitting, but we overran, so I am sending this scross.
This is live and will evolve with the charter.
 
Regards,
Narasimha Rao Vadrevu
 
Principal, VN Telecom Consultancy
www.von20.com
+14087810490

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。
If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

---

From: "Narasimha Rao Vadrevu" <[email-masked]>
Date: Wed, 24 Jun 2015 11:04:57 -0700

Hi Ying,

Thanks for the feedback. Some answers in line

Regards,

Narasimha

From: Ying Cheng [mailto:[email-masked]] 
Sent: Wednesday, June 24, 2015 2:24 AM
To: [email-masked]; [email-masked]
Subject: Re: [Supa] 06/22/15 SUPA Applicability

Hi Narasimha,

1.	In the latest charter, there are two types of information model:  ECA information model and intent-based information model, besides the generic information model. But in the slides, it seems that only ECA is covered, how about the intent-based information model?

[Narasimha Vadrevu] Draft charter relates to one ECA  model  ‘draft-bi-supa-policy-model-02’.  I will need some time for an intent based  information model, will try to come up with in a couple of days.

2.	Some use cases are given in the slides, it might be useful to further explain how ECA or intent-based information model can be used in these use case. E.g. what kind of event and condition will trigger what kind of action(s).
3.	Regarding SUPA application scope, “Software management (patches, upgrade etc.)” is mentioned. Can you elaborate this? I am not quite sure how SUPA information / data models can be used for this purpose.

[Narasimha Vadrevu] Please find attached an EMS PRD document I wrote some time back. The prototype was developed by http://www.elitect.com/default.aspx . I worked with them in driving this. Unfortunately the this was never productized as we ran out. Since SUPA can create an input to an EMS, bulk upgrades are possible in an ECA model. Compare the software string and if it is not matched with a new version, crate event for software upgrade and that should create an action.

I believe once you have a generic YANG model, above  IT apps will evolve. 

All, correct me if I am wrong.

Thanks and best regards,

Ying

2015-06-24 

  _____  

Ying CHENG  程莹

  _____  

收件人： [email-masked] <mailto:[email-masked]>  

抄送： 

Hi All,

Regards,

Narasimha Rao Vadrevu

 <http://www.von20.com> www.von20.com

+14087810490

如果您错误接收了该邮件，请通过电子邮件立即通知我们。请回复邮件到 <mailto:[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除> [email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] <mailto:[email-masked]>  if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.