Subject: [Supa] 06/22/15 SUPA Applicability

From: "Narasimha Rao Vadrevu" <[email-masked]>
Date: Mon, 22 Jun 2015 08:41:07 -0700

Hi All,

I was to do a 10 minute presentation of this time permitting, but we
overran, so I am sending this scross.

This is live and will evolve with the charter.

Regards,

Narasimha Rao Vadrevu

Principal, VN Telecom Consultancy

 <http://www.von20.com> www.von20.com

+14087810490

---

From: John Strassner <[email-masked]>
Date: Fri, 26 Jun 2015 18:43:21 -0700

Hi Narasimha,

In general, I don't understand how this is related to the proposition draft
or the charter. You need to tie one or both to your points, and make your
points clearer (at least for me, because I didn't understand what you are
trying to say, sorry!).

slide 2 (bullet by bullet)
SUPA is not a template language. Actually, SUPA is not strictly a language
at all - it is a set of models. While one could build a template language
to interact with SUPA, that is not in our scope.

SUPA does not define SLAs, SLOs, or SLSs. However, it is a model fragment,
and could be combined with other models or model fragments to do so. In
that case, one could write policies that test various SLA parameters and
take appropriate actions.

Sorry, I can't parse the third bullet.

What is "evolutionary network functionality"? Why couldn't you use SUPA
with legacy systems?

The fifth bullet is not quite correct. The GPIM is NOT a YANG model; either
is the EPRIM or SLSIM. The GPIM + EPRIM give you one YANG model, the GPIM +
SLSIM give you a different YANG model. I wouldn't say that YANG is
implemented using netconf.

In the sense that SUPA can create policy, and in the sense that an OSS,
EMS, NMS, or BSS needs policy, then sure, it is an input. It could also be
an output (direct, if the management entity understood SUPA; indirect, if a
SUPA policy server needed to translate OSS output to a form that SUPA could
build into a policy). But DIAMETER is **just** a protocol, and shouldn't be
in this list.

slide 3 (comment on the slide, not bullet-by-bullet)
SUPA could be used with NFV, SDN, or legacy. I personally cannot envision a
YANG model that instantiates a VNF. In an IT or cloud environment, people
seem to use anything but YANG to instantiate compute and storage resources.
NFV doesn't have a policy model or policy manager, and its APIs are not
ready for prime time, and these are far greater problems than SUPA can
solve.

slide 4 (comment on the slide, not bullet-by-bullet)
I see you are a fan of Light Reading :-)

Why couldn't SUPA instantiate a new vRouter?
SUPAPolicy Foo {
   event:  user login
   condition:  no user connectivity
   action: instantiate user-router
}
where the action is a script, as Andy suggested.

slide 5 (comment on the slide, not bullet-by-bullet)
Yes, this could be done, but I think that it is way out of scope. We're
still dealing with simple policies, not deploying clouds. :-)

slide 6 (comment on the slide, not bullet-by-bullet)
If you mean something like
SUPAPolicy Bar {
   event: monitoredTime
   condition:  numWebRequests BETWEEN webRequestThreshold1 AND
webRequestThreshold2
   action:  run app-scaling-policy Baz
}
sure, why not? In fact, this is where the majority of past deployments have
been: the event is receiving an alarm, or data from a cron job, or some
other temporal event; the condition is a variable-operator-value test; the
action is either change a command, or run a script.

slide 7 (comment on the slide, not bullet-by-bullet)
I don't understand what you are trying to say here.

regards,
John

On Mon, Jun 22, 2015 at 8:41 AM, Narasimha Rao Vadrevu <[email-masked]>
wrote:

> www.von20.com
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
>
>

-- 
regards,
John

---

From: "Narasimha Rao Vadrevu" <[email-masked]>
Date: Sat, 27 Jun 2015 10:15:30 -0700

Hi John,

Thanks for the detailed feedback (thrashing or bashing I need it).

*         Agree it is a quick and patchy job. Will try to rework

*         For this forum, I center my navigation through SUPA Wiki, as I was thinking that is where the current status of this group is. 

*         WiKI links to ‘Charter proposal’ but there is no link to ‘draft proposal’, is that how the WiKi supposed to be.   I was only referencing to charter and only saw the draft proposition after Andy’s email subsequent to this.

When I put together this, I was trying to address #4 in the charter proposal (An applicability document). My QUESTION is:

*         Is the Applicability document for an end user (Operator or Developer) delineating the high level possibilities for this charter and used for offline discussions in BOF? That’s what this doc was trying to address to, even though only 40% accurate

*         Or a low level document, in terms of protocol connectivity model?

I remember Dan mentioning we need people to write docs etc. Will try to re work based on the answer to the  above.

Regards,

Narasimha

From: John Strassner [mailto:[email-masked]] 
Sent: Friday, June 26, 2015 6:43 PM
To: [email-masked]; John Strassner
Cc: [email-masked]
Subject: Re: [Supa] 06/22/15 SUPA Applicability

Hi Narasimha,

In general, I don't understand how this is related to the proposition draft or the charter. You need to tie one or both to your points, and make your points clearer (at least for me, because I didn't understand what you are trying to say, sorry!).

SUPA is not a template language. Actually, SUPA is not strictly a language at all - it is a set of models. While one could build a template language to interact with SUPA, that is not in our scope.

SUPA does not define SLAs, SLOs, or SLSs. However, it is a model fragment, and could be combined with other models or model fragments to do so. In that case, one could write policies that test various SLA parameters and take appropriate actions.

What is "evolutionary network functionality"? Why couldn't you use SUPA with legacy systems?

The fifth bullet is not quite correct. The GPIM is NOT a YANG model; either is the EPRIM or SLSIM. The GPIM + EPRIM give you one YANG model, the GPIM + SLSIM give you a different YANG model. I wouldn't say that YANG is implemented using netconf.

In the sense that SUPA can create policy, and in the sense that an OSS, EMS, NMS, or BSS needs policy, then sure, it is an input. It could also be an output (direct, if the management entity understood SUPA; indirect, if a SUPA policy server needed to translate OSS output to a form that SUPA could build into a policy). But DIAMETER is **just** a protocol, and shouldn't be in this list.

SUPA could be used with NFV, SDN, or legacy. I personally cannot envision a YANG model that instantiates a VNF. In an IT or cloud environment, people seem to use anything but YANG to instantiate compute and storage resources. NFV doesn't have a policy model or policy manager, and its APIs are not ready for prime time, and these are far greater problems than SUPA can solve.

SUPAPolicy Foo {

   event:  user login

}

Yes, this could be done, but I think that it is way out of scope. We're still dealing with simple policies, not deploying clouds. :-)

SUPAPolicy Bar {

   event: monitoredTime

   condition:  numWebRequests BETWEEN webRequestThreshold1 AND webRequestThreshold2

}

sure, why not? In fact, this is where the majority of past deployments have been: the event is receiving an alarm, or data from a cron job, or some other temporal event; the condition is a variable-operator-value test; the action is either change a command, or run a script.

regards,

John

On Mon, Jun 22, 2015 at 8:41 AM, Narasimha Rao Vadrevu <[email-masked] <mailto:[email-masked]> > wrote:

Hi All,

I was to do a 10 minute presentation of this time permitting, but we overran, so I am sending this scross.

Regards,

Narasimha Rao Vadrevu

+14087810490 <tel:%2B14087810490> 

_______________________________________________
Supa mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/supa

-- 

regards,

John

---

From: John Strassner <[email-masked]>
Date: Sun, 28 Jun 2015 19:17:46 -0700

Hi Narasimha,

Thanks for the effort; my comments are meant to help explain.

The applicability statement is work item #4 on the 2015-06-09
version of the charter. It says":

4) An applicability document providing a number of examples that
   demonstrate how the generic policy models can be used to express
   policies that are relevant for network operators. The examples may
   tie into network service models developed by other working groups.

regards,
John

On Sat, Jun 27, 2015 at 10:15 AM, Narasimha Rao Vadrevu <[email-masked]>
wrote:

> ·         Agree it is a quick and patchy job. Will try to rework
>
> ·         For this forum, I center my navigation through SUPA Wiki, as I
> was thinking that is where the current status of this group is.
>
> ·         WiKI links to ‘Charter proposal’ but there is no link to ‘draft
> proposal’, is that how the WiKi supposed to be.   I was only referencing to
> charter and only saw the draft proposition after Andy’s email subsequent to
> this.
>
>
>
> When I put together this, I was trying to address #4 in the charter
> proposal (An applicability document). My QUESTION is:
>
> ·         Is the Applicability document for an end user (Operator or
> Developer) delineating the high level possibilities for this charter and
> used for offline discussions in BOF? That’s what this doc was trying to
> address to, even though only 40% accurate
>
> ·         Or a low level document, in terms of protocol connectivity
> model?
>
>
>
> *From:* John Strassner [mailto:[email-masked]]
> *Sent:* Friday, June 26, 2015 6:43 PM
> *To:* [email-masked]; John Strassner
> *Cc:* [email-masked]
> *Subject:* Re: [Supa] 06/22/15 SUPA Applicability
>
>
>
> Hi Narasimha,
>
>
>
> In general, I don't understand how this is related to the proposition
> draft or the charter. You need to tie one or both to your points, and make
> your points clearer (at least for me, because I didn't understand what you
> are trying to say, sorry!).
>
>
>
> The fifth bullet is not quite correct. The GPIM is NOT a YANG model;
> either is the EPRIM or SLSIM. The GPIM + EPRIM give you one YANG model, the
> GPIM + SLSIM give you a different YANG model. I wouldn't say that YANG is
> SUPA could be used with NFV, SDN, or legacy. I personally cannot envision
> a YANG model that instantiates a VNF. In an IT or cloud environment, people
> sure, why not? In fact, this is where the majority of past deployments
> have been: the event is receiving an alarm, or data from a cron job, or
> some other temporal event; the condition is a variable-operator-value test;
> the action is either change a command, or run a script.
>
>
>

-- 
regards,
John

---

From: "Narasimha Rao Vadrevu" <[email-masked]>
Date: Mon, 29 Jun 2015 07:10:29 -0700

Hi John,

Thanks for the comments, Now  I got clarified on a few things. Thinking of a high level generic user flow as follows:

*         Legacy Data center operator with legacy SNMP based NMS

*         Operations grow in complexity. Need to be more agile and scale

*         Creates YANG modules by reading the MIBs from NEs

*         Creates a SGPIM which can be translated into YANG models

*         These YANG models can act on NEs using NETCONF for better operations. It’s all run time since it’s an XML parsing than an MIB compilation

My disconnect , I was thinking SGPIM as an YANG model and you clarified that.

Thanks,

Narasimha

From: John Strassner [mailto:[email-masked]] 
Sent: Sunday, June 28, 2015 7:18 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Supa] 06/22/15 SUPA Applicability

Hi Narasimha,

regards,

John

On Sat, Jun 27, 2015 at 10:15 AM, Narasimha Rao Vadrevu <[email-masked] <mailto:[email-masked]> > wrote:

Hi John,

Regards,

Narasimha

From: John Strassner [mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Friday, June 26, 2015 6:43 PM
To: [email-masked] <mailto:[email-masked]> ; John Strassner
Cc: [email-masked] <mailto:[email-masked]> 
Subject: Re: [Supa] 06/22/15 SUPA Applicability

Hi Narasimha,

SUPAPolicy Foo {

   event:  user login

}

SUPAPolicy Bar {

   event: monitoredTime

}

regards,

John

Hi All,

Regards,

Narasimha Rao Vadrevu

 

-- 

regards,

John

-- 

regards,

John

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 29 Jun 2015 16:24:58 +0200

> *         Creates YANG modules by reading the MIBs from NEs

Really? Is there any large data center managed by SNMP MIBs out there?

And what does it mean to 'create YANG modules by reading the MIBs from
NEs'? This does not lead to anything useful. RFC 6643 for example is a
read-only (config false) translation for very specific reasons.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>