Subject: [Supa] Notes from weekly SUPA Weekly Conference Call - June 29, 2015 - 10:30

From: Jon Saperia <[email-masked]>
Date: Mon, 29 Jun 2015 12:44:34 -0400

Below are notes I took during the call this morning.  I just started looking at this work this morning, so If there is a format convention, I am happy to convert these notes into that form.

Please let me know about errors and omissions - I am sure there are; if you were on the call, please verify you are on the attendee list and that I have captured the discussions correctly.

Attendees (I know I did not get everyone)
Tina Tsou Zouting
Dan Romascanu
Georgios Karagiannis
Jon Saperia
Juergen Schöenwaelder (was there another?)

——

(1) Agenda/Logistic/Misc:
Jon Saperia agreed to take meeting notes.
Tina reminded everyone this was and IETF call.
Maxim Klyus will be on vacation the week of July 6
(2) Questions about the Draft Charter (Andy Bierman was not on the call)
Dan led this discussion and indicated that he was not aware of any actionable changes to the charter at this time.
He (Dan) does not think all questions are answered but has not seen anything to change the charter.
Dan will ask the list if issues have been clarified or if something needs to change in the charter.
It was noted that John Strassner had comments, but he was not on the call.

(3) Review of the value proposition ID
There was some discussion but not specific actions/objections were noted in this section.

(4) Wiki changes/Questions
(see: https://github.com/IETF-SUPA/SUPA/wiki/Q-&-A <https://github.com/IETF-SUPA/SUPA/wiki/Q-&-A>)
Dan noted that last time questions 1 and 2 were reviewed. There were no objections to these two items noted.
No objections were raised to question #3.
Dan recapped #4: Why is SUPA doing something divergent from IETF policy (i.e., information vs. data model). Dan noted that there were no policies about doing one or the other and reviewed the answers/justifications published on the Wiki.  
Jon S. noted that some of the newer models of networking embodied in various networking and cloud computing environments represented a new need for an information model-based approach.
Dan will revise question 4.
There was no objection to using the answers provided to question number 5 on the Wiki.
In answer to question #6, Dan added that we now have configuration data models that did not exist at the time of the previous RFCs.
Tina thought that John Strassner wrote #7.  Dan was not sure if it was fully expressive. He was happy with what is there if others are - there was not any additional comment. (Juergen thought we should point to section 3 of the proposition document).  
There was consensus to leave question #8 open so that we can create consensus on intent based policy. Additionally want to avoid duplication or conflict with other work. Juergen will work with John Strassner for clarification and will send an email.
The charter (#9) now seems OK - no further objections.
For question #10, there was consensus that we should use “Simplified Use of Policy Abstraction” vs. “Shared Unified Policy Automation”.

(5) The Poster
We discussed the poster that describes what the SUPA activity is about.  Its goal is to help people knows about the activities, provide pointers to information, and provide meeting logistics information.  Dan showed the previous version for the IETF in Dallas and noted that it is due by the end of the week to the secretariat (or you must bring it yourself). 
Dan will make revisions and bring it to Prague.
He felt the previous version was a bit to dense so he will simplify it.
The poster needs a new diagram - this would be the same that is the revised version to be placed into the ID.
Dan would like help over the next two days to revise the diagram, fix the Wiki and circulate three key questions to be incorporated into the poster by July 1 (Wednesday). People should provide feedback by July 3.

(6) ID Updates
The proposition ID needs the updated diagram. 
There is work to be done in the separation of subsections (John and/or Max) should look into this.
Georgios should send comments to the list.
We were reminded this is not a working group. We are doing BOF activities.
Andy should submit the new Data Model draft. Dan expressed some concern about the Data Model update and was not sure if John has started.  Dan will check with John.
The new applicability draft should be submitted by Nashima (SP?) working with Tina within the week.
Believe the information model draft is fine as is.  Don’t know if John Strassner will make changes. If so that is OK, but not required.

There was a discussion about reviewing BOF slides at the next Monday meeting.  Since Monday is the ID cutoff Dan suggested we focus on ID updates.

Georges will be on holiday next week.

Thanks
/jon

---

From: John Strassner <[email-masked]>
Date: Tue, 30 Jun 2015 01:27:54 +0000

Thanks Jon for taking notes. Sorry I couldn't attend.

My comments were not against the charter (I would vote to leave well enough alone! Juergen has done an excellent editing job, and we have more important topics to look at), but rather against the proposition draft. So far, I have only seen Juergen's opinion, my response, and his reply. I do sympathize with Juergen's desire to have a functional picture for Figure 1 in that draft. If no one else has comments, then I'll change that accordingly.

Thanks to Georgios for talking to me this morning; I will update both the value proposition draft as well as the policy model draft, hopefully by 7/3.

regards,
John

John Strassner, Ph.D.
CTO, Software Laboratory, CRD

Futurewei Technologies
US R&D Center
2330 Central Expressway
Building A, office A2-2143
Santa Clara, California   95050

  Office:  +1.408.330.4923
  Email:   [email-masked]<mailto:[email-masked]>

From: Supa [mailto:[email-masked]] On Behalf Of Jon Saperia
Sent: Monday, June 29, 2015 9:45 AM
To: [email-masked]
Subject: [Supa] Notes from weekly SUPA Weekly Conference Call - June 29, 2015 - 10:30

——

  *   Jon Saperia agreed to take meeting notes.
  *   Tina reminded everyone this was and IETF call.
  *   Maxim Klyus will be on vacation the week of July 6
(2) Questions about the Draft Charter (Andy Bierman was not on the call)

  *   Dan led this discussion and indicated that he was not aware of any actionable changes to the charter at this time.
  *   He (Dan) does not think all questions are answered but has not seen anything to change the charter.
  *   Dan will ask the list if issues have been clarified or if something needs to change in the charter.
  *   It was noted that John Strassner had comments, but he was not on the call.

  *   There was some discussion but not specific actions/objections were noted in this section.

  *   (see: https://github.com/IETF-SUPA/SUPA/wiki/Q-&-A)
  *   Dan noted that last time questions 1 and 2 were reviewed. There were no objections to these two items noted.
  *   No objections were raised to question #3.
  *   Dan recapped #4: Why is SUPA doing something divergent from IETF policy (i.e., information vs. data model). Dan noted that there were no policies about doing one or the other and reviewed the answers/justifications published on the Wiki.
  *   Jon S. noted that some of the newer models of networking embodied in various networking and cloud computing environments represented a new need for an information model-based approach.
  *   Dan will revise question 4.
  *   There was no objection to using the answers provided to question number 5 on the Wiki.
  *   In answer to question #6, Dan added that we now have configuration data models that did not exist at the time of the previous RFCs.
  *   Tina thought that John Strassner wrote #7.  Dan was not sure if it was fully expressive. He was happy with what is there if others are - there was not any additional comment. (Juergen thought we should point to section 3 of the proposition document).
  *   There was consensus to leave question #8 open so that we can create consensus on intent based policy. Additionally want to avoid duplication or conflict with other work. Juergen will work with John Strassner for clarification and will send an email.
  *   The charter (#9) now seems OK - no further objections.
  *   For question #10, there was consensus that we should use “Simplified Use of Policy Abstraction” vs. “Shared Unified Policy Automation”.

(5) The Poster

  *   Dan will make revisions and bring it to Prague.
  *   He felt the previous version was a bit to dense so he will simplify it.
  *   The poster needs a new diagram - this would be the same that is the revised version to be placed into the ID.
  *   Dan would like help over the next two days to revise the diagram, fix the Wiki and circulate three key questions to be incorporated into the poster by July 1 (Wednesday). People should provide feedback by July 3.

(6) ID Updates

  *   The proposition ID needs the updated diagram.
  *   There is work to be done in the separation of subsections (John and/or Max) should look into this.
  *   Georgios should send comments to the list.
  *   We were reminded this is not a working group. We are doing BOF activities.
  *   Andy should submit the new Data Model draft. Dan expressed some concern about the Data Model update and was not sure if John has started.  Dan will check with John.
  *   The new applicability draft should be submitted by Nashima (SP?) working with Tina within the week.
  *   Believe the information model draft is fine as is.  Don’t know if John Strassner will make changes. If so that is OK, but not required.

Thanks
/jon

---

From: John Strassner <[email-masked]>
Date: Tue, 30 Jun 2015 01:27:54 +0000

Sorry, hit the wrong button due to lack of caffeination...

> Andy should submit the new Data Model draft. Dan expressed some concern
> about the Data Model update and was not sure if John has started.
> Dan will check with John.

Sorry, are you asking if I have started a data model draft (i.e., work item #3)?
If so, then the answer is no. However, I'm happy to help Andy (or whoever)
that wants to start.

regards,
John

John Strassner, Ph.D.

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923

——

(5) The Poster

(6) ID Updates

Thanks
/jon

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 30 Jun 2015 09:11:43 +0000

Hi,

As discussed in the meeting – I need an updated Figure 1 by tomorrow the latest to include it in the poster!

Thanks and Regards,

Dan

From: John Strassner [mailto:[email-masked]]
Sent: Tuesday, June 30, 2015 4:28 AM
To: Jon Saperia; Georgios Karagiannis; [email-masked]
Cc: Romascanu, Dan (Dan); Tina TSOU
Subject: RE: [Supa] Notes from weekly SUPA Weekly Conference Call - June 29, 2015 - 10:30

regards,
John

John Strassner, Ph.D.

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923

From: Supa [mailto:[email-masked]] On Behalf Of Jon Saperia
Sent: Monday, June 29, 2015 9:45 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Supa] Notes from weekly SUPA Weekly Conference Call - June 29, 2015 - 10:30

——

  *   (see: https://github.com/IETF-SUPA/SUPA/wiki/Q-&-A<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_IETF-2DSUPA_SUPA_wiki_Q-2D-26-2DA&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=aJy70L2FU1GNVqrWVMBJW5TmGdfGIXfKEKlCPA4rJa0&s=_mxt1lV3ganCjn5_OvDAam-ufw8INzUDm3iQBEl9l5c&e=>)

(5) The Poster

(6) ID Updates

Thanks
/jon

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 30 Jun 2015 09:13:36 +0000

I meant Andy. Maybe I mis-spoke, although by 6PM I was supposed to be OK with the caffeine.

Thanks for the update.

Regards,

Dan

regards,
John

John Strassner, Ph.D.

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923

——

  *   (see: https://github.com/IETF-SUPA/SUPA/wiki/Q-&-A<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_IETF-2DSUPA_SUPA_wiki_Q-2D-26-2DA&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=vLMCv2-QhNBX3ohXnSJL8wal8RYjgaCqHJcOhxXXvkY&s=7KLqx-PptT8arrUG8TqdqnZ9FcAVrXm5q0-wYERz_Dw&e=>)

(5) The Poster

(6) ID Updates

Thanks
/jon

---

From: John Strassner <[email-masked]>
Date: Tue, 30 Jun 2015 15:17:48 +0000

I am assuming that this is Figure 1 of the Proposition draft. If so, I'll redo it (since I am editing the draft as well).
Do you want ASCII or something pretty?

regards,
John

From: Supa [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Tuesday, June 30, 2015 2:12 AM
To: John Strassner; Jon Saperia; Georgios Karagiannis; [email-masked]
Cc: Tina TSOU
Subject: Re: [Supa] Notes from weekly SUPA Weekly Conference Call - June 29, 2015 - 10:30

Hi,

Thanks and Regards,

Dan

regards,
John

John Strassner, Ph.D.

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923

——

(5) The Poster

(6) ID Updates

Thanks
/jon

---

From: Andy Bierman <[email-masked]>
Date: Tue, 30 Jun 2015 08:18:49 -0700

Hi,

I don't really understand the SUPA data model solution well enough
to have a draft by Monday.  I think I can help somebody else with
the YANG details, once the WG forms and there is some WG consensus
on the solution.

Andy

On Tue, Jun 30, 2015 at 2:13 AM, Romascanu, Dan (Dan) <[email-masked]>
wrote:

> *From:* John Strassner [mailto:[email-masked]]
> *Sent:* Tuesday, June 30, 2015 4:28 AM
> *To:* Jon Saperia; Georgios Karagiannis; [email-masked]
> *Cc:* Romascanu, Dan (Dan); Tina TSOU
> *Subject:* RE: [Supa] Notes from weekly SUPA Weekly Conference Call -
> June 29, 2015 - 10:30
>
>
>
> *Futurewei Technologies*
> *US R&D Center*
>   *Office:  +1.408.330.4923*
>
>   *Email:   [email-masked] <[email-masked]>*
>
>
>
>
>
>
>
>
>
> *From:* Supa [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Jon Saperia
> *Sent:* Monday, June 29, 2015 9:45 AM
> *To:* [email-masked]
> *Subject:* [Supa] Notes from weekly SUPA Weekly Conference Call - June
> 29, 2015 - 10:30
>
>
>
> Below are notes I took during the call this morning.  I just started
> looking at this work this morning, so If there is a format convention, I am
> happy to convert these notes into that form.
>
>
>
> Please let me know about errors and omissions - I am sure there are; if
> you were on the call, please verify you are on the attendee list and that I
> have captured the discussions correctly.
>
>
>
> Attendees *(I know I did not get everyone)*
>
> Tina Tsou Zouting
>
> Dan Romascanu
>
> Georgios Karagiannis
>
> Jon Saperia
>
>    - Jon Saperia agreed to take meeting notes.
>    - Tina reminded everyone this was and IETF call.
>    - Maxim Klyus will be on vacation the week of July 6
>
>    - Dan led this discussion and indicated that he was not aware of any
>    actionable changes to the charter at this time.
>    - He (Dan) does not think all questions are answered but has not seen
>    anything to change the charter.
>    - Dan will ask the list if issues have been clarified or if something
>    needs to change in the charter.
>    - It was noted that John Strassner had comments, but he was not on the
>    call.
>
>
>
>    - There was some discussion but not specific actions/objections were
>    noted in this section.
>
>
>
>    - (see: https://github.com/IETF-SUPA/SUPA/wiki/Q-&-A
>    <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_IETF-2DSUPA_SUPA_wiki_Q-2D-26-2DA&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=vLMCv2-QhNBX3ohXnSJL8wal8RYjgaCqHJcOhxXXvkY&s=7KLqx-PptT8arrUG8TqdqnZ9FcAVrXm5q0-wYERz_Dw&e=>)
>
>    - Dan noted that last time questions 1 and 2 were reviewed. There were
>    no objections to these two items noted.
>    - No objections were raised to question #3.
>    - Dan recapped #4: Why is SUPA doing something divergent from IETF
>    policy (i.e., information vs. data model). Dan noted that there were no
>    policies about doing one or the other and reviewed the
>    answers/justifications published on the Wiki.
>    - Jon S. noted that some of the newer models of networking embodied in
>    various networking and cloud computing environments represented a new need
>    for an information model-based approach.
>    - Dan will revise question 4.
>    - There was no objection to using the answers provided to question
>    number 5 on the Wiki.
>    - In answer to question #6, Dan added that we now have configuration
>    data models that did not exist at the time of the previous RFCs.
>    - Tina thought that John Strassner wrote #7.  Dan was not sure if it
>    was fully expressive. He was happy with what is there if others are - there
>    was not any additional comment. (Juergen thought we should point to section
>    3 of the proposition document).
>    - There was consensus to leave question #8 open so that we can create
>    consensus on intent based policy. Additionally want to avoid duplication or
>    conflict with other work. Juergen will work with John Strassner for
>    clarification and will send an email.
>    - The charter (#9) now seems OK - no further objections.
>    - For question #10, there was consensus that we should use “Simplified
>    Use of Policy Abstraction” vs. “Shared Unified Policy Automation”.
>
>
>
> (5) The Poster
>
> We discussed the poster that describes what the SUPA activity is about.
> Its goal is to help people knows about the activities, provide pointers to
> information, and provide meeting logistics information.  Dan showed the
> previous version for the IETF in Dallas and noted that it is due by the end
> of the week to the secretariat (or you must bring it yourself).
>
>    - Dan will make revisions and bring it to Prague.
>    - He felt the previous version was a bit to dense so he will simplify
>    it.
>    - The poster needs a new diagram - this would be the same that is the
>    revised version to be placed into the ID.
>    - Dan would like help over the next two days to revise the diagram,
>    fix the Wiki and circulate three key questions to be incorporated into the
>    poster by July 1 (Wednesday). People should provide feedback by July 3.
>
>
>
> (6) ID Updates
>
>    - The proposition ID needs the updated diagram.
>    - There is work to be done in the separation of subsections (John
>    and/or Max) should look into this.
>    - Georgios should send comments to the list.
>    - We were reminded this is not a working group. We are doing BOF
>    activities.
>    - Andy should submit the new Data Model draft. Dan expressed some
>    concern about the Data Model update and was not sure if John has started.
>    - The new applicability draft should be submitted by Nashima (SP?)
>    working with Tina within the week.
>    - Believe the information model draft is fine as is.  Don’t know if
>    John Strassner will make changes. If so that is OK, but not required.
>
>
>
> There was a discussion about reviewing BOF slides at the next Monday
> meeting.  Since Monday is the ID cutoff Dan suggested we focus on ID
> updates.
>
>
>
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
>
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 30 Jun 2015 15:25:20 +0000

ASCII is REQUIRED in the I-D. Something pretty for the poster would be appreciated.

Thanks and Regards,

Dan

From: John Strassner [mailto:[email-masked]]
Sent: Tuesday, June 30, 2015 6:18 PM
To: Romascanu, Dan (Dan); Jon Saperia; Georgios Karagiannis; [email-masked]
Cc: Tina TSOU
Subject: RE: [Supa] Notes from weekly SUPA Weekly Conference Call - June 29, 2015 - 10:30

regards,
John

From: Supa [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Tuesday, June 30, 2015 2:12 AM
To: John Strassner; Jon Saperia; Georgios Karagiannis; [email-masked]<mailto:[email-masked]>
Cc: Tina TSOU
Subject: Re: [Supa] Notes from weekly SUPA Weekly Conference Call - June 29, 2015 - 10:30

Hi,

Thanks and Regards,

Dan

To: Jon Saperia; Georgios Karagiannis; [email-masked]<mailto:[email-masked]>

regards,
John

John Strassner, Ph.D.

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923

——

(5) The Poster

(6) ID Updates

Thanks
/jon

---

From: Georgios Karagiannis <[email-masked]>
Date: Tue, 30 Jun 2015 16:49:41 +0000

Hi John,

Thank you  very much.
I have been asked to send my comments to the SUPA group.

Here there are:

Please note that I have looked into the 01 version of the SUPA proposition draft, see below:

https://www.ietf.org/id/draft-klyus-supa-proposition-01.txt

I think that it is good. However, I have some comments:

Comment_1: The problem statement needs some work.

o) currently the problem statement is only 3 line long. This is in my opinion not good.

Suggestion: please combine sections 1.1 and 1.2 and provide a good explanation on what section 1.2 describes and what you now have in the 3 lines problem statement.

o)  I have not looked in detail, but I think that this draft does not include all the questions, answers that one can find in the wiki.

Comment_2: ACTN is not an IETF working group In section 4.1.8 it is mentioned that ACTN is a working group. However, I could not find information at the IETF website that mentions that it ACTN is a working group. Please note that ACTN has been already presented in 2 BOFs previously. from what I understood, parts of ACTN will be done in TEAS WG. However, we need to confirm the above.

Comment_3: Difference between NEMO and SUPA.

Section 4.2.6 describes the differences between SUPA and NEMO. We probably need to extend this section. John, from what I know you have provided already a comparison. The main aspect that we need to emphasize is the differences in the NBI interfaces that SUPA and NEMO are referring to.

The type of the NBI interface that SUPA needs is different than the one that IBNEMO needs.

Best regards,

Georgios

From: John Strassner
Sent: 30 June 2015 03:28

regards,
John

John Strassner, Ph.D.

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923

——

(5) The Poster

(6) ID Updates

Thanks
/jon

---

From: Tina TSOU <[email-masked]>
Date: Wed, 1 Jul 2015 03:01:42 +0000

Dear Andy et al,

The closest to the data model so far is
3. Data model: TBD
Converged from ​http://datatracker.ietf.org/doc/draft-wang-netmod-yang-policy-dm/<http://datatracker.ietf.org/doc/draft-wang-netmod-yang-policy-dm/>

The design team can reuse draft-wang a lot.

I assume Jon will hold the pen.

Can you remind us what the latest ToC and scope discussed previously?

Thank you,
Tina

On Jul 1, 2015, at 1:19 AM, Andy Bierman <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Andy

On Tue, Jun 30, 2015 at 2:13 AM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:
I meant Andy. Maybe I mis-spoke, although by 6PM I was supposed to be OK with the caffeine.

Thanks for the update.

Regards,

Dan

From: John Strassner [mailto:[email-masked]<mailto:[email-masked]>]

regards,
John

John Strassner, Ph.D.

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923

——

(5) The Poster

(6) ID Updates

Thanks
/jon

_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa

---

From: John Strassner <[email-masked]>
Date: Tue, 30 Jun 2015 21:13:12 -0700

I don't see how a meaningful draft for this effort can be done by the 6th.
Jon and I will talk Thursday, and try and make a plan forward.
I think people should concentrate on deliverable #4; I am editing the
proposition and info model drafts now.

regards,
John

On Tue, Jun 30, 2015 at 8:01 PM, Tina TSOU <[email-masked]>
wrote:

> Converged from ​
> http://datatracker.ietf.org/doc/draft-wang-netmod-yang-policy-dm/
>
> On Jul 1, 2015, at 1:19 AM, Andy Bierman <[email-masked]> wrote:
>
>   Hi,
>
>>   *Office:  +1.408.330.4923 <%2B1.408.330.4923>*
>>
>>    - It was noted that John Strassner had comments, but he was not on
>>    the call.
>>
>>
>>
>>    - Dan noted that last time questions 1 and 2 were reviewed. There
>>    were no objections to these two items noted.
>>    - Jon S. noted that some of the newer models of networking embodied
>>    in various networking and cloud computing environments represented a new
>>    need for an information model-based approach.
>>    - For question #10, there was consensus that we should use
>>    “Simplified Use of Policy Abstraction” vs. “Shared Unified Policy
>>    Automation”.
>>
>>
>>
>> (5) The Poster
>>

-- 
regards,
John