Subject: Re: [T2TRG] New Version Notification for draft-bormann-t2trg-ble-uri-00.txt

From: Ari Keränen <[email-masked]>
Date: Mon, 5 Sep 2016 19:21:07 +0000

Hi Christian,

Thank you for the review comments! The model in the draft is indeed different than in the original BT SIG white papers. We are currently working together with Bluetooth folks to see how the model could be improved from the old approach.

We still need to work on the GAP/GATT split and related URIs. It would be good to be able to use same URI structure for both but if it doesn't work, perhaps the split makes sense as you suggested. We'll have a look at that for the next version.

Cheers,
Ari

> On 31 Aug 2016, at 04:44, Christian Groves <[email-masked]> wrote:
> 
> Hello Ari,
> 
> A general question on the approach. Is there a reason why you didn't align with the white papers and use the query part of the URI for things like enable, indicate, notify? Is the goal of the draft to define another scheme rather than formalising the one already in the whitepapers?
> 
> With respect to the first table in section 2 it has "ble:/gatt/nodes" the information in the text below indicates the table relates to GAP operations. The BLE GAP whitepaper has a /gapnodes/<node> operation that returns information about the node. In the 2nd table there is an entry for {node} (presumably matching the GAP functionality) but the text below indicates the operations are GATT operations.
> 
> There's a note about needing two types of node links, I would assume that both would be required if the white papers already have both possibilities. Otherwise the URI scheme would not match what has already been defined.
> 
> Would it be clearer to split 2 into subsections. One specifically for GAP and the other for GATT, in order to parallel the white papers?
> 
> Regards, Christian
> 
> 
> On 16/07/2016 1:55 AM, Ari Keränen wrote:
>> Hi all,
>> 
>> This draft is straw man proposal for a Bluetooth Low Energy URI scheme and media types. It enables using web technologies for interacting with locally connected BLE devices (as discussed e.g., in W3C WoT work).
>> 
>> Comments welcome!
>> 
>> 
>> Cheers,
>> Ari & Carsten
>> 
>>> Begin forwarded message:
>>> 
>>> From: <[email-masked]>
>>> Subject: New Version Notification for draft-bormann-t2trg-ble-uri-00.txt
>>> Date: 8 Jul 2016 23:27:43 CEST
>>> To: Carsten Bormann <[email-masked]>, "Dr. Carsten Bormann" <[email-masked]>, "Ari Keranen" <[email-masked]>
>>> 
>>> 
>>> A new version of I-D, draft-bormann-t2trg-ble-uri-00.txt
>>> has been successfully submitted by Ari Keranen and posted to the
>>> IETF repository.
>>> 
>>> Name:		draft-bormann-t2trg-ble-uri
>>> Revision:	00
>>> Title:		The BLE (Bluetooth Low Energy) URI Scheme and Media Types
>>> Document date:	2016-07-08
>>> Group:		Individual Submission
>>> Pages:		8
>>> URL:            https://www.ietf.org/internet-drafts/draft-bormann-t2trg-ble-uri-00.txt
>>> Status:         https://datatracker.ietf.org/doc/draft-bormann-t2trg-ble-uri/
>>> Htmlized:       https://tools.ietf.org/html/draft-bormann-t2trg-ble-uri-00
>>> 
>>> 
>>> Abstract:
>>>   In addition to its use as a subnetwork layer for IP (e.g., via
>>>   RFC 7668), in various IoT web applications Bluetooth Low Energy (BLE)
>>>   can serve as a "local interconnect", connecting devices locally
>>>   (i.e., not over IP) for use as a source of information and a target
>>>   for actuation.  In order to fully use these capabilities in
>>>   applications using web technologies, there is a need for a method for
>>>   addressing the resources, i.e., a URI scheme, and definition of the
>>>   representation of the data exchanged between the application and
>>>   devices, i.e., media types.  This document is a straw man proposal
>>>   for such a URI scheme and media types for interacting with the
>>>   Bluetooth GAP and GATT protocols.
>>> 
>>> 
>>> 
>>> 
>>> Please note that it may take a couple of minutes from the time of submission
>>> until the htmlized version and diff are available at tools.ietf.org.
>>> 
>>> The IETF Secretariat
>>> 
>> _______________________________________________
>> T2TRG mailing list
>> [email-masked]
>> https://www.irtf.org/mailman/listinfo/t2trg
>> 
> 
> _______________________________________________
> T2TRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/t2trg

---

From: Christian Groves <[email-masked]>
Date: Wed, 7 Sep 2016 09:36:43 +1000

Hello Ari,

Is there a reason why the draft moved away from using the query part of 
the existing BLE URIs?

Regards, Christian

---

From: Ari Keränen <[email-masked]>
Date: Wed, 7 Sep 2016 10:29:55 +0000

Hi Christian,

Some use of the query parameters and HTTP methods was not in line with best practices for RESTful API design. The RESTful design draft has some discussion around this.

Cheers,
Ari 

> On 07 Sep 2016, at 02:36, Christian Groves <[email-masked]> wrote:
> 
> Hello Ari,
> 
> Is there a reason why the draft moved away from using the query part of the existing BLE URIs?
> 
> Regards, Christian
> 
>