Subject: [T2TRG] Reminder: IRTF Thing-to-Thing Research Group meeting this weekend

From: "Kovatsch, Matthias" <[email-masked]>
Date: Wed, 21 Sep 2016 16:26:29 +0000

Dear all

A reminder for the adjacent T2TRG meeting on Saturday and Sunday:

We will meet on the Siemens Lisbon campus in "Forum 3": Rua Irmãos Siemens 1, 2720-093 Amadora, Portugal
https://www.google.de/maps/place/Siemens/@38.7172138,-9.2251032,13.82z/data=!4m5!3m4!1s0x0:0xab1302613365c828!8m2!3d38.7372641!4d-9.2291594
I would recommend to share cabs or Uber to get there.

The doors open at 9am on Saturday with coffee, first session starts at 10am. You can find the full agenda here:
https://github.com/t2trg/2016-09-w3c-wot

Please register ASAP with the T2TRG chairs: [email-masked]<mailto:[email-masked]>
We need your name for the visitor badges...

With best regards,
Dr. Matthias Kovatsch

Siemens AG
Corporate Technology
CT RDA NEC EMB-DE
Otto-Hahn-Ring 6
81739 Muenchen, Germany
Mobile: +49 173 5288856
mailto:[email-masked]

Siemens Aktiengesellschaft: Chairman of the Supervisory Board: Gerhard Cromme; Managing Board: Joe Kaeser, Chairman, President and Chief Executive Officer; Roland Busch, Lisa Davis, Klaus Helmrich, Janina Kugel, Siegfried Russwurm, Ralf P. Thomas; Registered offices: Berlin and Munich, Germany; Commercial registries: Berlin Charlottenburg, HRB 12300, Munich, HRB 6684; WEEE-Reg.-No. DE 23691322

---

From: Michael Koster <[email-masked]>
Date: Sat, 24 Sep 2016 11:23:38 -0700

Here are some slides to explain my views on the design of the type system for IoT/WoT. 

This is to follow up to today's type system discussion and lead into tomorrow's discussion on the same topic.

Best regards,

Michael

> On Sep 21, 2016, at 9:26 AM, Kovatsch, Matthias <[email-masked]> wrote:
> 
> Dear all
>  
> We will meet on the Siemens Lisbon campus in “Forum 3”: Rua Irmãos Siemens 1, 2720-093 Amadora, Portugal
> https://www.google.de/maps/place/Siemens/@38.7172138,-9.2251032,13.82z/data=!4m5!3m4!1s0x0:0xab1302613365c828!8m2!3d38.7372641!4d-9.2291594 <https://www.google.de/maps/place/Siemens/@38.7172138,-9.2251032,13.82z/data=!4m5!3m4!1s0x0:0xab1302613365c828!8m2!3d38.7372641!4d-9.2291594>
> https://github.com/t2trg/2016-09-w3c-wot <https://github.com/t2trg/2016-09-w3c-wot>
>  
> Please register ASAP with the T2TRG chairs: [email-masked] <mailto:[email-masked]>
> We need your name for the visitor badges…
>  
> With best regards,
> Dr. Matthias Kovatsch
> 
> Siemens AG
> Corporate Technology
> CT RDA NEC EMB-DE
> Otto-Hahn-Ring 6
> 81739 Muenchen, Germany 
> Mobile: +49 173 5288856
> mailto:[email-masked] <mailto:[email-masked]>
> 
> _______________________________________________
> T2TRG mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/t2trg <https://www.irtf.org/mailman/listinfo/t2trg>

---

From: Michael Koster <[email-masked]>
Date: Sat, 24 Sep 2016 11:59:25 -0700

To the last slide "Web of Things Framework MVP" I would add a block for high level program API, e.g. the W3C WoT Scripting API, as an important component.

Best regards,

MIchael

> On Sep 24, 2016, at 11:23 AM, Michael Koster <[email-masked]> wrote:
> 
> <Data Typing.pptx>
>> On Sep 21, 2016, at 9:26 AM, Kovatsch, Matthias <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dear all
>>  
> [email-masked]
> https://www.irtf.org/mailman/listinfo/t2trg

---

From: Dave Raggett <[email-masked]>
Date: Sun, 25 Sep 2016 12:06:42 +0100

> On 24 Sep 2016, at 19:23, Michael Koster <[email-masked]> wrote:
> 

Hi Michael,

Thanks for sending the slides.  I am intrigued by your positioning of the problem to be solved, but don’t fully understand everything you say. e.g. you say that the focus is on informing a client application about how to consume resources. That makes some assumptions that need to be made explicit if we’re to have a shared understanding.

Given that the web of things is intended to be an abstraction layer that scales across a very broad range of platforms and requirements, I believe we need to clearly distinguish requirements for application developers, and requirements for platform developers. The former are about how to describe the interfaces by which applications can interact with “things”.  The latter are about enabling platforms to interoperate even when they are using different standards.

More generally, we can exploit the huge success of software objects and event driven behaviour over more than three decades, and expose things to applications as software objects with properties, actions and events. These need to be independent of the underlying protocols and communication patterns. In Lisbon, we also talked about the need for application layer metadata for the communication characteristics, e.g. whether it is safe to drop some updates or whether a complete log of all changes is needed, e.g. for a black box recorder. The application needs to be able to check whether the requested characteristics can be met by the given platform.

I am not 100% sure of the meaning you intend when you say resources and would appreciate some clarification.  I am aware of the use of the term for hierarchies of resources exposed by RESTful services that are addressed using a URI path syntax, but that sense belongs to the metadata for platform developers, i.e. how other platforms can access a resource on a given server, and is distinct from the interaction model exposed to applications.

You say “should not use schemas to explain JSON structures as atomic resources, this may not scale well”.  This too makes some assumptions that need to be made explicit. I believe that we need to consider the formal model for the interfaces exposed to applications separately from the way that these models can be serialised. This will allow for different serialisation formats, and more importantly, for an evolution of these formats as the technologies and requirements change over time.

One requirement that is regularly stated is the need to simplify the processing and network requirements for processing thing descriptions on constrained devices. Another requirement is the ability to capture regularities across similar devices. One such case is where all the devices are the same kind, and the thing description varies in just a few details, e.g. IDs for each device, the location, IP address and so forth.

You say: "Explain structure through a combination of hypermedia controls and application semantics”. Hypermedia controls require explanation.  Are these at the application layer and exposed to application developers or are they a framework for use by platform developers? For application semantics, we need a scalable approach that is modular and extensible.  The joint white paper on semantic interoperability [1] provides some background on what is needed, but is only just a first step in the discussion around a shared vision and roadmap. In principle, semantic models can be defined as constraints on the properties, actions and events for things. Thing descriptions could then be stated  in terms where the details for the properties, actions and events are derived from these models. I see that as something for a service composition engine to deal with, and not for resource constrained devices, where it will be appropriate to precompile the thing description to minimise the processing requirements.

I am hoping that with clarifications and further explanations we can move to a shared understanding of the choices before us.

p.s. We missed you in Lisbon, and hope that you can make it to the next face to face.

[1] http://dx.doi.org/10.13140/RG.2.2.25758.13122

—
   Dave Raggett <[email-masked] <mailto:[email-masked]>>