Subject: [T2TRG] CoRE Applications side-meeting @IETF106

From: Klaus Hartke <[email-masked]>
Date: Thu, 7 Nov 2019 09:22:56 +0000

We're planning another side-meeting on Applications in
Constrained RESTful Environments at IETF106 in Singapore.

Proposed Topics

* Problem Details for CoRE Applications
   [1] [2]

   How to carry machine-readable details of errors in
   CoAP responses to avoid the need to define a new
   error response format for each CoRE application?

* Extensibility and Code Points in CoRE Applications
   [2] [3] [4]

   How to mint identifiers for semantic vocabulary
   (such as identifiers for error conditions in above
   problem details) that are efficient on the wire
   and have a low barrier to entry?

* Specification of CoRE Applications
   [5] [6] [7]

   How to specify the interfaces of CoRE applications
   in Internet Drafts?

When

Tuesday Afternoon session III (17:10-18:40)

Where

Room "Butterworth" [8]

Welcome!

[1] https://tools.ietf.org/html/rfc7807
[2] 
https://thomas-fossati.github.io/draft-coap-problem/draft-fossati-core-coap-problem.html
[3] https://tools.ietf.org/html/draft-ietf-core-sid-07
[4] https://tools.ietf.org/html/draft-ietf-core-coral-01
[5] https://tools.ietf.org/html/draft-hartke-t2trg-coral-pubsub-00
[6] https://tools.ietf.org/html/draft-hartke-t2trg-coral-reef-03
[7] https://tools.ietf.org/html/draft-hartke-t2trg-data-hub-05
[8] 
https://datatracker.ietf.org/meeting/106/floor-plan?room=butterworth#raffles-city-convention-center

---

From: Klaus Hartke <[email-masked]>
Date: Tue, 19 Nov 2019 04:19:27 +0000

We will try to set up a WebEx for remote participation (best effort, no 
promises):

https://ietf.webex.com/ietf/j.php?MTID=m1a205c2d62d19a9686dd35ab848c7052

Klaus

> -----Original Message-----
> From: T2TRG <[email-masked]> On Behalf Of Klaus Hartke
> Sent: Thursday, November 7, 2019 10:23 AM
> To: [email-masked]; [email-masked]
> Subject: [T2TRG] CoRE Applications side-meeting @IETF106
>
> We're planning another side-meeting on Applications in Constrained RESTful
> Environments at IETF106 in Singapore.
>
> Proposed Topics
>

---

From: Jaime Jiménez <[email-masked]>
Date: Tue, 19 Nov 2019 17:43:58 +0800

Minutes: https://etherpad.ietf.org/p/notes-ietf-106-applications

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core