Subject: [T2TRG] FW: New Version Notification for draft-hong-t2trg-iot-edge-computing-01.txt

From: Jungha Hong <[email-masked]>
Date: Fri, 8 Nov 2019 08:28:31 +0000

Dear all,

IoT Edge computing draft was updated and submitted as below. We also put it into a T2TRG repo on github.

Section 5 has been mainly updated and it is discussing IoT Edge computing model.

The figure of Gateway-based IoT Edge computing architecture was also replaced with IoT Edge computing model to focus on common functions of IoT Edge computing.

We would like to discuss adopting it as RG document in Singapore.

Please review the draft and give us comments (in advance if possible).

Thanks,

Jungha

________________________________
보낸 사람 : "[email-masked]" <[email-masked]>
보낸 날짜 : 2019-11-04 17:45:50 ( +09:00 )
받는 사람 : 홍용근 <[email-masked]>, 홍정하 <[email-masked]>, Dirk Kutscher <[email-masked]>, 홍용근 <[email-masked]>, Eve Schooler <[email-masked]>, Xavier de Foy <[email-masked]>, Matthias Kovatsch <[email-masked]>
참조 :
제목 : New Version Notification for draft-hong-t2trg-iot-edge-computing-01.txt

A new version of I-D, draft-hong-t2trg-iot-edge-computing-01.txt

has been successfully submitted by Yong-Geun Hong and posted to the

IETF repository.

Name: draft-hong-t2trg-iot-edge-computing

Revision: 01

Title: IoT Edge Computing Challenges and Functions

Document date: 2019-11-04

Group: Individual Submission

Pages: 25

URL: https://www.ietf.org/internet-drafts/draft-hong-t2trg-iot-edge-computing-01.txt

Status: https://datatracker.ietf.org/doc/draft-hong-t2trg-iot-edge-computing/

Htmlized: https://tools.ietf.org/html/draft-hong-t2trg-iot-edge-computing-01

Htmlized: https://datatracker.ietf.org/doc/html/draft-hong-t2trg-iot-edge-computing

Diff: https://www.ietf.org/rfcdiff?url2=draft-hong-t2trg-iot-edge-computing-01

Abstract:

This document describes new challenges such as strict latency, uplink

cost, uninterrupted services, privacy and security, for IoT services

originated from the IoT environmental changes. In order to address

those new challenges, the integration of Edge computing and IoT has

emerged as a promising solution. This document describes the concept

of IoT integrated with Edge computing as well as the state-of-the-art

of IoT Edge computing. It also proposes a general model for IoT Edge

computing. The direction of Edge computing for IoT should be

discussed in the IETF/IRTF.

Please note that it may take a couple of minutes from the time of submission

until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Rute Sofia <[email-masked]>
Date: Fri, 8 Nov 2019 08:48:18 +0000

Hello Jungha

I will not be in Singapore and given the time gap, remote participation is hard. Here are a few comments and if needed, I can assist in contributing:

-          3.3, Edge Computing, the title should go for Edge/Fog computing (which anyway is referenced in the text)

-          4. Additional challenges not mentioned:

o   Energy consumption

o   Handling both event-driven and time-driven traffic (you mention latency and jitter, but speak mostly about deterministic aspects)

-          5.

o   The definition of what the edge is/can be is missing. The edge can be a complex device co-located to a BS, on a shop-floor. But it can also be a smartphone. There is the need to define this in the context being provided.

-           The document provides (Figure 1) a centralized version of the edge computing manager.  It would be good to consider a second figure, with a de-centralized version.

-          5.3, the edge computing functions should also include the relevant abstraction functions, e.g., semantic interoperability; data aggregation, etc.

-          5.4, stating that the edge computing domain should directly or indirectly control the network functions (of the data exchange) is reducing the possibility of having an autonomous, self-organizing behaviour between edge computing nodes.

-          6.1, the computing aspects and protocols mentioned should consider or cite work that are relevant both from a consumer and an industrial perspective. OPC-UA must be mentioned; and other relevant protocols are DDS.

-          6.1, this section is not really also clear…this seems to describe a set of services which are today common to any edge platform, but seems to be quite incomplete…

-          6.2 Likewise for this section. Perhaps it should be split into consumer and Industrial IoT, and for each category, then address specific and relevant use-cases, as well as provide pointers to prior work on this

BR

Rute Sofia
From: T2TRG <[email-masked]> On Behalf Of Jungha Hong
Sent: 08 November 2019 09:29
To: [email-masked]
Subject: [T2TRG] FW: New Version Notification for draft-hong-t2trg-iot-edge-computing-01.txt

Dear all,

Thanks,

Jungha

________________________________
보낸 사람 : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
보낸 날짜 : 2019-11-04 17:45:50 ( +09:00 )
받는 사람 : 홍용근 <[email-masked]<mailto:[email-masked]>>, 홍정하 <[email-masked]<mailto:[email-masked]>>, Dirk Kutscher <[email-masked]<mailto:[email-masked]>>, 홍용근 <[email-masked]<mailto:[email-masked]>>, Eve Schooler <[email-masked]<mailto:[email-masked]>>, Xavier de Foy <[email-masked]<mailto:[email-masked]>>, Matthias Kovatsch <[email-masked]<mailto:[email-masked]>>
참조 :
제목 : New Version Notification for draft-hong-t2trg-iot-edge-computing-01.txt

IETF repository.

Revision: 01

Pages: 25

Abstract:

The IETF Secretariat

---

From: Matthias Kovatsch <[email-masked]>
Date: Tue, 26 Nov 2019 11:13:16 +0000

Dear Rute

Thank you for your interest and input. We (the authors) had a meeting at IETF 106 to discuss the way forward and also talked about your e-mail. Please find our comments inline:

We want to avoid such slashed terms in the document, especially in the title (and we have a todo to further fix the current document in this regard). Overall, Edge has many different meanings depending on the background and we agreed that it also includes multi-tiered approaches. We will include the term “Fog” in the background section on Edge Computing to clarify.

o   Energy consumption

Energy consumption is actually not that big a problem when going from IoT to IoT Edge Computing. The whole point is to have less constrained devices close to the physical objects.

For the traffic types, we maybe need a clarification what new challenge you have in mind.

-          5. The definition of what the edge is/can be is missing. The edge can be a complex device co-located to a BS, on a shop-floor. But it can also be a smartphone. There is the need to define this in the context being provided.

This is in line with the missing background on Edge Computing and the different models/patterns (slash here because we also have a todo on deciding on our own terminology) we want to document. It was more a time problem in particular on my side to work on the background section.

The figured was changed to logical functions, hence there were no assumptions about implementation (e.g., centralized vs distributed). We decided to replace the figure anyway and follow a step-by-step introduction of models/patterns from simple to more complex.

We do not see interoperability as a function; there can be translation functions to connect devices from different ecosystems (usually called gateway).

Data aggregation should indeed be mentioned in more detail under the storage and data functions.

We see this again more as an implementation aspect, centralized vs distributed. Overall, there needs to be function to provide control over the network.

Full completeness is hard to achieve and the current examples in the appendix are rather input for the writing phase – we probably remove it completely because of the issue of always missing something. If you have concrete functions or models in mind that OPC UA introduces, we are happy to include them at the abstract level.

The original idea was to have a structure for investigating the state of the art, which is listed in more detail in the (to be removed) appendix. We have a todo to better align sections 5 and 6.

Our hope is the talk about models and functions that can apply for both.

Ultimately, we would like to get an idea which models and functions are already well covered by the state of the art and where there are white spots that can be addressed by the IETF.

Thanks again for your input. It helped to define the direction and decide on the todos. As mentioned in the T2TRG summary meeting, we plan to have an improved version of the draft by Christmas and would be very happy to have another review from you some time before the next IETF meeting (with enough time to have another iteration ready at IETF 107).

Best wishes,
Jungha, Yong-Geun, Xavier, Matthias, Eve, and Dirk

---

From: Rute Sofia <[email-masked]>
Date: Tue, 26 Nov 2019 12:41:09 +0000

Dear Matthias,

thanks for the feedback.

inline, still a few comments…

From: Matthias Kovatsch <[email-masked]>
Sent: 26 November 2019 12:13
To: Rute Sofia <[email-masked]>; Jungha Hong <[email-masked]>; [email-masked]
Subject: RE: New Version Notification for draft-hong-t2trg-iot-edge-computing-01.txt

Dear Rute

o   Energy consumption

In IoT, we have also even-driven traffic, e.g., alarms. If we think about deterministic scheduling, then this type of traffic will be handled as BE (or, we need a mechanism before that can place it in a QoS class to handle more “urgent” traffic.

Ok, you are then assuming just translation from protocols? What about services and apps? Interoperability “management” could be a function…

Hum, perhaps I am not reading this right…imagine an “edge” based on a crowd-sensing infrastructure (in other words, an opportunistic wireless environment). The control has to be decentralised, or at least part of it, correct?

Hum, in section 6.1 you specifically mention CoAP and MQTT. Which are not the preferred protocols in Industrial IoT environments. From an abstraction perspective, the different is the broker-based pubsub model used by MQTT; the client/server architecture used by CoAP; and the PubSub approach of OPC-UA…or in other interesting (architectural) approaches, e.g., ICN…

Yes, and this is a great contribution. However, IMO the focus should not forget the largest market share of IoT, which is IIoT…so when considering the computational abstraction of edge computing, it is relevant to ensure that this is also being covered…

Sure,
Rute
Best wishes,