Subject: Re: [Taps] TAPS is what SDN is really about

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 14 Apr 2014 16:23:38 +0000

Hi Linda,

I agree and would like to add that TAPS and AEON (https://sites.google.com/site/aeonsignalling/) are aligning in terms of specification and usage of application metadata. Some of the “metadata” conveyed by applications when describing the transport services they need are applicable for network services as well, such as those envisioned by AEON. Ideally, mechanisms used to exchange this information between applications to the network could be used to aid with classification for SFC.

Cheers,
Charles

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 8, 2014 at 9:35 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Michael Welzl <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Martin Stiemerling <[email-masked]<mailto:[email-masked]>>, Spencer Dawkins <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Taps] TAPS is what SDN is really about

Thanks to Martin’s presentation on “Towards Transport – Agnostic Middleware”. I think what Martin’s presented is the key value of SDN, providing the hooks and ways for Applications to control the desired services from network (transport), more than what TCP/UDP can provide.

I’ve been closely following and contributing to SFC, SDNrg, and have been chairing ONF’s L4-L7 Service group. There has been a lot of talks on Metadata in SFC, but the metadata discussion has been mudded by information among various entities.

The  “messaging middleware Layer” is a really good way to show metadata among Middle ware boxes. There could be metadata among applications, metadata among transport layers or network layers. Then there could be metadata across layers: such as meta data from middle ware boxes to Transport layer, the meta data from applications to middleware layer, etc.

I think the work proposed by TAPS is a concrete step towards allowing applications to have better control of the network services.

Linda Dunbar

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 14 Apr 2014 18:45:25 +0200

Hi Linda, hi Charles,

for me Taps was mainly about the interface between the application and the 
transport layer (within one host without any signalling through the network). 
I believe this interface is also one aspect that could help to address your 
problem(s) but for my understanding what you propose it much more than Taps.

Mirja

On Monday 14 April 2014 18:23:38 Charles Eckel (eckelcu) wrote:
> Hi Linda,
>
> I agree and would like to add that TAPS and AEON
> (https://sites.google.com/site/aeonsignalling/) are aligning in terms of
> specification and usage of application metadata. Some of the “metadata”
> conveyed by applications when describing the transport services they need
> are applicable for network services as well, such as those envisioned by
> AEON. Ideally, mechanisms used to exchange this information between
> applications to the network could be used to aid with classification for
> SFC.
>
> Cheers,
> Charles
>
> From: Linda Dunbar
> <[email-masked]<mailto:[email-masked]>> Date: Tuesday,
> April 8, 2014 at 9:35 AM
> To: "[email-masked]<mailto:[email-masked]>"
> <[email-masked]<mailto:[email-masked]>>, Michael Welzl
> <[email-masked]<mailto:[email-masked]>>,
> "[email-masked]<mailto:[email-masked]>"
> <[email-masked]<mailto:[email-masked]>> Cc: Martin Stiemerling
> <[email-masked]<mailto:[email-masked]>>, Spencer Dawkins
> <[email-masked]<mailto:[email-masked]>>,
> "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
> Thanks to Martin’s presentation on “Towards Transport – Agnostic
> Middleware”. I think what Martin’s presented is the key value of SDN,
> providing the hooks and ways for Applications to control the desired
> services from network (transport), more than what TCP/UDP can provide.
>
> I’ve been closely following and contributing to SFC, SDNrg, and have been
> chairing ONF’s L4-L7 Service group. There has been a lot of talks on
> Metadata in SFC, but the metadata discussion has been mudded by information
> among various entities.
>
>
> The  “messaging middleware Layer” is a really good way to show metadata
> among Middle ware boxes. There could be metadata among applications,
> metadata among transport layers or network layers. Then there could be
> metadata across layers: such as meta data from middle ware boxes to
> Transport layer, the meta data from applications to middleware layer, etc.
>
> I think the work proposed by TAPS is a concrete step towards allowing
> applications to have better control of the network services.
>
> Linda Dunbar

-- 
-------------------------------------------------------------------
Dipl.-Ing. Mirja Kühlewind
Institute of Communication Networks and Computer Engineering (IKR)
University of Stuttgart, Germany
Pfaffenwaldring 47, D-70569 Stuttgart

tel: +49(0)711/685-67973
email: [email-masked]
web: www.ikr.uni-stuttgart.de
-------------------------------------------------------------------

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 14 Apr 2014 17:29:42 +0000

Hi Mirja,

As for the application is concerned, the transport services are local to
the host. However, several of the TAPS use cases involve communication
between the local transport services and the network, to determine
available interfaces, level of congestion, interaction with
NATs/firewalls, etc. At a minimum I would expect some of the information
conveyed by the application to the local transport services via TAPS APIs
to be communicated with the network.

Cheers,
Charles

On 4/14/14, 9:45 AM, "Mirja Kuehlewind"
<[email-masked]> wrote:

>> specification and usage of application metadata. Some of the ³metadata²
>> Thanks to Martin¹s presentation on ³Towards Transport  Agnostic
>> Middleware². I think what Martin¹s presented is the key value of SDN,
>> I¹ve been closely following and contributing to SFC, SDNrg, and have
>>been
>> chairing ONF¹s L4-L7 Service group. There has been a lot of talks on
>> The  ³messaging middleware Layer² is a really good way to show metadata

---

From: Michael Welzl <[email-masked]>
Date: Mon, 14 Apr 2014 20:46:12 +0200

Well - these use cases are possibilities.. I'd agree with Mirja about the scope of TAPS. Anyway there is no doubt that TAPS and AEON complement each other very well.

Cheers,
Michael

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 14 Apr 2014 20:11:35 +0000

At a minimum I would expect some of the information conveyed by the application to the local transport services via TAPS APIs to be communicated with the network.

[Linda] 100% agree. As more application developers start to use those transport (and network) services, more demand may come up. 

Linda