Subject: [Taps] Which APIs are used by Applications that need low Latency? draft-mcquistin-taps-low-latency-services?

From: Linda Dunbar <[email-masked]>
Date: Fri, 11 Nov 2016 10:01:19 +0000

Dear Authors,

Your draft listed down several APIs. But which one is used by Applications that need low latency?

Aren't the "Socket Setup & Tear down" described in Section 3.1 the original Berkley sockets APIs? If not, what are the differences?

How about the "getsocketopt" and "Setsockopt"?  and the APIs listed in Section 3.3.?

Which APIs are used by Applications that need low Latency?

Are there any Applications today using the APIs proposed in draft-mcquistin-taps-low-latency-services?

Thank you very much,

Linda Dunbar

---

From: Colin Perkins <[email-masked]>
Date: Fri, 11 Nov 2016 11:30:54 +0000

Hi Linda,

The key goal of the draft is to do a requirements analysis on the transport services needed for low-latency and real-time applications. The proposed abstract API is the minimal API to achieve this. The new API features, compared to the Sockets API, are those in Sections 3.4-3.6.

We have an experimental implementation of an API much like this, written as part of our TCP Hollywood work (https://csperkins.org/research/tcp-hollywood/). This is a research prototype, so there are no deployed applications using it. 

If you’re interested in the API work, the proposal in draft-trammell-post-sockets-00 is a more interesting, and radical, approach, and should also meet the requirements we outline.

Colin

> On 11 Nov 2016, at 10:01, Linda Dunbar <[email-masked]> wrote:
> 
> Dear Authors, 
>  
> Aren’t the “Socket Setup & Tear down” described in Section 3.1 the original Berkley sockets APIs? If not, what are the differences?
>  
> How about the “getsocketopt” and “Setsockopt”?  and the APIs listed in Section 3.3.?
>  

-- 
Colin Perkins
https://csperkins.org/