Subject: [tcmtf] TCM-TF and mobility

From: "Jose Saldana" <[email-masked]>
Date: Thu, 4 Jul 2013 17:49:27 +0200

Hi all.

We are discussing a lot about security and TCM-TF. Why not talking a bit
about TCM-TF and mobility?

A) First question: How can user mobility and TCM-TF affect each other?

1- Residential scenario: I am a network operator, and I am TCM-optimizing a
number of real-time (VoIP, online games) flows which are present in my
access network. What happens if one of the users moves to another location?
Is there any difference between the case in which the traffic is
TCM-optimized and the non-TCM case?

In a first approach, I don’t think so. TCM is applied in a network segment.
The end hosts may not even notice that TCM is being used. It would be seen
as an additional network delay and jitter. Thus, if the user moves and a
flow disappears, nothing happens to the rest of the flows. And regarding the
flow of the mobile user, it will be managed by the mobility protocol in the
same way.

2-Corporate environment: I am using two network appliances in order to
create a VPN between two offices of my company. There is a TCM session
between the two appliances, optimizing a number of VoIP calls. If a user
gets out of the office and his/her VoIP call moves to a 3G data connection,
what happens? Is there any difference with respect to the non-TCM case?

I think the answer is the same as in 1.

3- Machine to machine scenario (sensors, industrial control): Does mobility
exist here? Any ideas?

B) Second question: Can any mobility protocol take advantage of TCM-TF?

Just an idea (suggested by Jose Ruiz) regarding *PMIPv6* (RFC5213,
<http://tools.ietf.org/html/rfc5213> http://tools.ietf.org/html/rfc5213):

This network-based mobility protocol creates a tunnel between the LMA
(similar to the HA in MIPv6) and the MAG (typically runs on the access
router).

This *tunnel is shared by all the flows* between the LMA and the MAG: 

“the bidirectional tunnel between the LMA and MAG is typically a shared
tunnel, and can be employed for routing traffic streams for different MNs
attached to the same MAG. It extends the 1:1 relation between a tunnel and
an MN’s binding cache entry to a 1:m relation, reflecting the shared nature
of the tunnel” [1]. The tunnel between LMA and MAG can be based on GRE or
IP-in-IP.

So we have a tunnel shared by a number of flows. Why not optimizing that
traffic? Instead of a tunnel including lots of small packets, can we
multiplex them and compress headers? Are these bandwidth and pps reductions
interesting?

Thanks,

Jose 

[1]  Ki-Sik Kong; Wonjun Lee; Youn-Hee Han; Myung-Ki Shin; HeungRyeol You,
"Mobility management for all-IP mobile networks: mobile IPv6 vs. proxy
mobile IPv6," Wireless Communications, IEEE , vol.15, no.2, pp.36,45, April
2008

http://ieeexplore.ieee.org/stamp/stamp.jsp?tp=
<http://ieeexplore.ieee.org/stamp/stamp.jsp?tp=&arnumber=4492976&isnumber=44
92967> &arnumber=4492976&isnumber=4492967

 <http://voiplab.niu.edu.tw/ppt/ipv6/R9843011.pdf>
http://voiplab.niu.edu.tw/ppt/ipv6/R9843011.pdf

More info:

 <http://en.wikipedia.org/wiki/Proxy_Mobile_IPv6>
http://en.wikipedia.org/wiki/Proxy_Mobile_IPv6

http://www.cisco.com/en/US/docs/ios-xml/ios/mob_pmipv6/configuration/xe-3s/d
eployment/Proxy_Mobile_IPv6_Network-Based_Mobility.html

---

From: "Diego R. Lopez" <[email-masked]>
Date: Thu, 18 Jul 2013 09:36:11 +0000

Hi,

Getting to this after another discussion on LISP and TCM-TF, let me say that TCM can benefit mobility-enhancing protocols the same way it can benefit security protocols (as we have discussed with the IPsec case) and possibly any other tunneling-based techniques. Grouping flows and optimizing their transport translates into more efficient tunneling. It is true we are not talking here about fast hand-over mobility, but of the case of roaming users, but anyway it is a relevant portion of mobility use cases.

Be goode,

On 4 Jul 2013, at 17:49 , Jose Saldana wrote:

Hi all.

We are discussing a lot about security and TCM-TF. Why not talking a bit about TCM-TF and mobility?

1- Residential scenario: I am a network operator, and I am TCM-optimizing a number of real-time (VoIP, online games) flows which are present in my access network. What happens if one of the users moves to another location? Is there any difference between the case in which the traffic is TCM-optimized and the non-TCM case?

In a first approach, I don’t think so. TCM is applied in a network segment. The end hosts may not even notice that TCM is being used. It would be seen as an additional network delay and jitter. Thus, if the user moves and a flow disappears, nothing happens to the rest of the flows. And regarding the flow of the mobile user, it will be managed by the mobility protocol in the same way.

2-Corporate environment: I am using two network appliances in order to create a VPN between two offices of my company. There is a TCM session between the two appliances, optimizing a number of VoIP calls. If a user gets out of the office and his/her VoIP call moves to a 3G data connection, what happens? Is there any difference with respect to the non-TCM case?

3- Machine to machine scenario (sensors, industrial control): Does mobility exist here? Any ideas?

Just an idea (suggested by Jose Ruiz) regarding *PMIPv6* (RFC5213, http://tools.ietf.org/html/rfc5213):

This network-based mobility protocol creates a tunnel between the LMA (similar to the HA in MIPv6) and the MAG (typically runs on the access router).

This *tunnel is shared by all the flows* between the LMA and the MAG:
“the bidirectional tunnel between the LMA and MAG is typically a shared tunnel, and can be employed for routing traffic streams for different MNs attached to the same MAG. It extends the 1:1 relation between a tunnel and an MN’s binding cache entry to a 1:m relation, reflecting the shared nature of the tunnel” [1]. The tunnel between LMA and MAG can be based on GRE or IP-in-IP.

So we have a tunnel shared by a number of flows. Why not optimizing that traffic? Instead of a tunnel including lots of small packets, can we multiplex them and compress headers? Are these bandwidth and pps reductions interesting?

Thanks,

Jose

[1]  Ki-Sik Kong; Wonjun Lee; Youn-Hee Han; Myung-Ki Shin; HeungRyeol You, "Mobility management for all-IP mobile networks: mobile IPv6 vs. proxy mobile IPv6," Wireless Communications, IEEE , vol.15, no.2, pp.36,45, April 2008
http://ieeexplore.ieee.org/stamp/stamp.jsp?tp=&arnumber=4492976&isnumber=4492967
http://voiplab.niu.edu.tw/ppt/ipv6/R9843011.pdf

More info:
http://en.wikipedia.org/wiki/Proxy_Mobile_IPv6
http://www.cisco.com/en/US/docs/ios-xml/ios/mob_pmipv6/configuration/xe-3s/deployment/Proxy_Mobile_IPv6_Network-Based_Mobility.html
_______________________________________________
tcmtf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tcmtf

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx