Subject: [tcpinc] Call for adoption of draft-rescorla-tcpinc-tls-option-05

From: Mirja Kühlewind <[email-masked]>
Date: Tue, 20 Oct 2015 18:49:27 +0200

Hi all,

please indicate if you support adoption of
draft-rescorla-tcpinc-tls-option-05 as a tcpinc working group item, or not, by

	Monday, Nov 2, 2015.

draft-rescorla-tcpinc-tls-option is one candidate for tcpinc where the first 
version of this draft was proposed more than a year ago. Verison -04 was 
release about three weeks ago and specifies the TLS 1.3 profile as well as 
the use of draft-rescorla-tcpinc-tls-option with tcp-eno. Since then this 
draft received a lot of discussion. The lasted update was provided yesterday, 
but only changes a few minor fixes.

Similar as before, if you do not support adoption of this document because 
you think it is not in scope for the wg or has fundamental technicals flaws 
and would therefore harm the goals of the wg, it would be great if you could 
given some reasoning/explanation with your response.

This is solely an adoption call for draft-rescorla-tcpinc-tls-option 
independent of any other documents. If you have a personal preference for a 
different approach that should not be a reason to reject this adoption. 
Forcing the wg to make a decision has not worked previously, and even though 
both proposed approaches have evolved, I do not see any indication that the 
wg is now ready to make a decision. The goal of this adoption call is to 
figure out if there is enough interest and energy to further follow the 
approach as outlined in draft-rescorla-tcpinc-tls-option-05.

This process may lead to the situation where the wg will adopt and work on 
two solution approaches. This does not mean that the wg will publish two 
(incompatible) approaches, as this would not fulfill our charter. If we end 
up adopting more than one approach, I currently see three way to proceed:

1) Both approaches (naturally) converge into one approach.

2) We work on both approaches to get them into a (similar) state where the wg 
is able to make a decision (and withdraw the other doc).

3) We publish both approaches as different 'versions' of tcpinc that can be 
negotiated in the tcp-eno handshake, where at least one of them is mandatory 
to support/implement.

Thanks!
Mirja

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 20 Oct 2015 23:51:38 +0100

Given the choices presented, I do not support adoption of this draft.

That's not because of a technical flaw in the proposal, but mostly
because I think that the future where this wg works on two proposals
will end badly, despite everyone's good intentions (and I do think
everyone here has good intentions).

I regret that the folks who are participating in this wg have not
managed to bite the bullet and make the hard decision.

S.

PS: The technical pros and cons for this vs tcpcrypt have all been
sufficiently well rehearsed so I won't repeat those.

On 20/10/15 17:49, Mirja Kühlewind wrote:u
> draft-rescorla-tcpinc-tls-option is one candidate for tcpinc where the
> first version of this draft was proposed more than a year ago. Verison
> -04 was release about three weeks ago and specifies the TLS 1.3 profile
> as well as the use of draft-rescorla-tcpinc-tls-option with tcp-eno.
> Since then this draft received a lot of discussion. The lasted update
> was provided yesterday, but only changes a few minor fixes.
> 
> Similar as before, if you do not support adoption of this document
> because you think it is not in scope for the wg or has fundamental
> technicals flaws and would therefore harm the goals of the wg, it would
> be great if you could given some reasoning/explanation with your response.
> 
> independent of any other documents. If you have a personal preference
> for a different approach that should not be a reason to reject this
> adoption. Forcing the wg to make a decision has not worked previously,
> and even though both proposed approaches have evolved, I do not see any
> indication that the wg is now ready to make a decision. The goal of this
> adoption call is to figure out if there is enough interest and energy to
> further follow the approach as outlined in
> draft-rescorla-tcpinc-tls-option-05.
> 
> This process may lead to the situation where the wg will adopt and work
> on two solution approaches. This does not mean that the wg will publish
> two (incompatible) approaches, as this would not fulfill our charter. If
> we end up adopting more than one approach, I currently see three way to
> proceed:
> 
> 2) We work on both approaches to get them into a (similar) state where
> the wg is able to make a decision (and withdraw the other doc).
> 
> 3) We publish both approaches as different 'versions' of tcpinc that can
> be negotiated in the tcp-eno handshake, where at least one of them is
> mandatory to support/implement.
> 
> Thanks!
> Mirja
> 
> _______________________________________________
> Tcpinc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpinc
>

---

From: Ted Hardie <[email-masked]>
Date: Tue, 20 Oct 2015 16:45:42 -0700

On Tue, Oct 20, 2015 at 9:49 AM, Mirja Kühlewind <
[email-masked]> wrote:

> first version of this draft was proposed more than a year ago. Verison -04
> was release about three weeks ago and specifies the TLS 1.3 profile as well
> as the use of draft-rescorla-tcpinc-tls-option with tcp-eno. Since then
> this draft received a lot of discussion. The lasted update was provided
> yesterday, but only changes a few minor fixes.
>
> and would therefore harm the goals of the wg, it would be great if you
> could given some reasoning/explanation with your response.
>
> Forcing the wg to make a decision has not worked previously, and even
> though both proposed approaches have evolved, I do not see any indication
> that the wg is now ready to make a decision. The goal of this adoption call
> is to figure out if there is enough interest and energy to further follow
> the approach as outlined in draft-rescorla-tcpinc-tls-option-05.
>
>
​I support adoption of this draft on this basis.

Ted​

> 2) We work on both approaches to get them into a (similar) state where the
> wg is able to make a decision (and withdraw the other doc).
>

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Wed, 21 Oct 2015 04:47:47 +0000

I support adoption as well

--
Likely to be brief and not very
elaborate as sent from my mobile
Diego R. Lopez
Telefonica I+D

On 21 Oct 2015, at 01:45, Ted Hardie <[email-masked]<mailto:[email-masked]>> wrote:

Ted​

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 21 Oct 2015 07:45:57 +0000

Agreed; no support

---

From: <[email-masked]>
Date: Wed, 21 Oct 2015 14:00:04 +0000

Hi

I support the adoption of draft-rescorla-tcpinc-tls-option because it is consistent with the works of the HTTPbis WG on opportunistic encryption.

Regards
Emile

De : Tcpinc [mailto:[email-masked]] De la part de Ted Hardie
Envoyé : mercredi 21 octobre 2015 01:46
À : Mirja Kühlewind
Cc : tcpinc
Objet : Re: [tcpinc] Call for adoption of draft-rescorla-tcpinc-tls-option-05

On Tue, Oct 20, 2015 at 9:49 AM, Mirja Kühlewind <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

        Monday, Nov 2, 2015.

draft-rescorla-tcpinc-tls-option is one candidate for tcpinc where the first version of this draft was proposed more than a year ago. Verison -04 was release about three weeks ago and specifies the TLS 1.3 profile as well as the use of draft-rescorla-tcpinc-tls-option with tcp-eno. Since then this draft received a lot of discussion. The lasted update was provided yesterday, but only changes a few minor fixes.

Similar as before, if you do not support adoption of this document because you think it is not in scope for the wg or has fundamental technicals flaws and would therefore harm the goals of the wg, it would be great if you could given some reasoning/explanation with your response.

This is solely an adoption call for draft-rescorla-tcpinc-tls-option independent of any other documents. If you have a personal preference for a different approach that should not be a reason to reject this adoption. Forcing the wg to make a decision has not worked previously, and even though both proposed approaches have evolved, I do not see any indication that the wg is now ready to make a decision. The goal of this adoption call is to figure out if there is enough interest and energy to further follow the approach as outlined in draft-rescorla-tcpinc-tls-option-05.

This process may lead to the situation where the wg will adopt and work on two solution approaches. This does not mean that the wg will publish two (incompatible) approaches, as this would not fulfill our charter. If we end up adopting more than one approach, I currently see three way to proceed:

2) We work on both approaches to get them into a (similar) state where the wg is able to make a decision (and withdraw the other doc).

3) We publish both approaches as different 'versions' of tcpinc that can be negotiated in the tcp-eno handshake, where at least one of them is mandatory to support/implement.

Thanks!
Mirja

_______________________________________________
Tcpinc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tcpinc

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorization.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange shall not be liable if this message was modified, changed or falsified.
Thank you.

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 21 Oct 2015 08:02:36 -0700

Obviously, I support adoption of this draft for the reasons I've stated
before.

Also, Mirja pointed out that I accidentally submitted the -05 draft off the
wrong
branch so it is just a rebuild of the -04 draft. The to-be-06 draft is on
github
at:

http://ekr.github.io/tcpinc-tls/

This contains a number of changes to address people's reviews. If you
think some of those make it worse, please let me know on a separate
thread. :)

-Ekr

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 21 Oct 2015 09:08:55 -0700

Diff at:
https://raw.githubusercontent.com/ekr/tcpinc-tls/gh-pages/draft-rescorla-tcpinc-tls-option-from--05.diff.html

On Wed, Oct 21, 2015 at 8:02 AM, Eric Rescorla <[email-masked]> wrote:

> Also, Mirja pointed out that I accidentally submitted the -05 draft off
> the wrong
>> technicals flaws and would therefore harm the goals of the wg, it would be
>> great if you could given some reasoning/explanation with your response.
>>
>> on two solution approaches. This does not mean that the wg will publish two

---

From: Yuchung Cheng <[email-masked]>
Date: Wed, 21 Oct 2015 13:34:10 -0700

I support the adoption of tcpinc-tls.

On Tue, Oct 20, 2015 at 9:49 AM, Mirja Kühlewind
<[email-masked]> wrote:
> draft received a lot of discussion. The lasted update was provided

---

From: ianG <[email-masked]>
Date: Thu, 22 Oct 2015 10:43:04 +0100

I do not support putting TLS into TCP.

It is a heavyweight, one size fits all, baggage laden protocol.  Putting 
something complicated and baggage-laden into TCP is going to harm the 
overall goal of TCPINC - get some lightweight opportunistic encryption 
out there where we can, because the alternate is no security.

 From an engineering perspective, putting TLS into TCP increases the 
chances of no security, IMHO.

iang

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 22 Oct 2015 06:12:44 -0700

Have you actually read the TLS 1.3 profile in my draft?

-Ekr

On Thu, Oct 22, 2015 at 2:43 AM, ianG <[email-masked]> wrote:

> overall goal of TCPINC - get some lightweight opportunistic encryption out
> there where we can, because the alternate is no security.
>

---

From: "Border, John" <[email-masked]>
Date: Thu, 22 Oct 2015 22:27:39 +0000

I support adoption of this document...

John

-----Original Message-----
From: Tcpinc [mailto:[email-masked]] On Behalf Of Mirja Kühlewind
Sent: Tuesday, October 20, 2015 12:49 PM
To: tcpinc
Subject: [tcpinc] Call for adoption of draft-rescorla-tcpinc-tls-option-05

Hi all,

	Monday, Nov 2, 2015.

This is solely an adoption call for draft-rescorla-tcpinc-tls-option independent of any other documents. If you have a personal preference for a different approach that should not be a reason to reject this adoption. 
Forcing the wg to make a decision has not worked previously, and even though both proposed approaches have evolved, I do not see any indication that the wg is now ready to make a decision. The goal of this adoption call is to figure out if there is enough interest and energy to further follow the approach as outlined in draft-rescorla-tcpinc-tls-option-05.

This process may lead to the situation where the wg will adopt and work on two solution approaches. This does not mean that the wg will publish two
(incompatible) approaches, as this would not fulfill our charter. If we end up adopting more than one approach, I currently see three way to proceed:

Thanks!
Mirja

---

From: Derek Fawcus <[email-masked]>
Date: Thu, 22 Oct 2015 23:49:17 +0100

> Given the choices presented, I do not support adoption of this draft.

Likewise,  I'm against adopting this, for similar reasons

---

From: Stephen Kent <[email-masked]>
Date: Tue, 27 Oct 2015 10:37:07 -0400

I support adoption of this I-D.

Sorry to be late on this; I was on vacation (again).

Steve

---

From: Mirja Kühlewind <[email-masked]>
Date: Sat, 31 Oct 2015 11:49:33 +0900

Hi all,

just a reminder that there are two days left to provide feedback on the adoption of 

	draft-rescorla-tcpinc-tls-option-05

David & Mirja

> Am 21.10.2015 um 01:49 schrieb Mirja Kühlewind <[email-masked]>:
> 
> Hi all,
>