Subject: [tcpinc] New Draft versions

From: "Black, David" <[email-masked]>
Date: Thu, 18 Feb 2016 19:57:25 +0000

Reminder: The expert reviews should be starting soon.

Would the draft authors please reply to the list on when the next version
of each draft will be posted, or in the alternative to say that the current
version of the draft is stable and suitable for external expert review?

Thanks, --David

> -----Original Message-----
> From: Tcpinc [mailto:[email-masked]] On Behalf Of Black, David
> Sent: Wednesday, January 27, 2016 8:24 PM
> To: tcpinc
> Subject: Re: [tcpinc] Reminder: Expert reviews awaited
> 
> Review timing update: The WG chairs want to see versions of both of the
> protocol
> drafts plus the TCP option draft (draft-ietf-tcpinc-tcpeno) that will be ready for
> both
> security and transport expert review by Friday, February 19.  If this will be a
> problem,
> please let us know, *now*.
> 
> We are starting to identify expert reviewers and plan to run the reviews for
> about a month from late February to late March so that review comments are
> ready for WG discussion during the tcpinc WG meeting in Buenos Aires (first
> week of April).
> 
> Thanks, --David & Kyle & Mirja
> 
> > -----Original Message-----
> > From: Tcpinc [mailto:[email-masked]] On Behalf Of Mirja Kühlewind
> > Sent: Tuesday, January 12, 2016 1:28 PM
> > To: tcpinc
> > Subject: [tcpinc] Reminder: Expert reviews awaited
> >
> > Hi all, hi draft authors,
> >
> > this is a reminder that we would like to run expert reviews on both proposed
> > protocol specs, namely draft-ietf-tcpinc-tcpcrypt and draft-ietf-tcpinc-use-tls,
> > latest by the end of February.
> >
> > As there have been a couple of comments and quite a bit discussion at the last
> > meeting as well as on the list, we expect to see updates on both drafts by mid
> of
> > February.
> >
> > This means also, that if you are not an authors (who is busy updating the spec),
> > it’s now time to have another look at these docs and make sure that your
> > comments/concerns will be addressed in the next version (by sending more
> > review comments on the mailing list).
> >
> > Thanks to all in advance for the hard work!
> >
> > We will come back to you with more information on this process as soon as we
> > have seen new revision for both docs.
> >
> > Best,
> > Mirja & David & Kyle
> > _______________________________________________
> > Tcpinc mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/tcpinc
> _______________________________________________
> Tcpinc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpinc

---

From: David Mazieres <[email-masked]>
Date: Thu, 18 Feb 2016 13:37:28 -0800

> version of the draft is stable and suitable for external expert review?

The tcpcrypt folds are working on new drafts, and should upload them up
within about 48 hours or so...

David

---

From: David Mazieres <[email-masked]>
Date: Sun, 21 Feb 2016 17:21:14 -0800

Hi, everyone.  We have just uploaded a new draft of TCP-ENO.  Sorry for
the delay.  The new draft incorporates the feedback from the last IETF
meeting and the mailing list.  Here is a summary of the changes:

  * A SYN segment can now contain at most one TCP-ENO option, because
    order matters and people were worried about middleboxes rearranging
    TCP options, and adding logic to sort different options seemed like
    it would add complexity.

  * There's now a concept of a marker byte that specifies non-zero data
    length for the following TCP-ENO suboption.  Hence, more than one
    suboption can contain data.  However, the optimization remains that
    the last suboption to contain data does not require a marker byte.
    
  * The definition of role priority has been changed so that the 'b' bit
    is now more significant than the 'p' bit.  This is in response to a
    point made by Bryan Ford that because of dropped SYN segments,
    potentially only one side of a TCP connection knows it is
    participating in a simultaneous open.  We also added language
    discussing this case.

  * As requested at the last meeting, the new draft clarifies that it is
    the responsibility of encryption specs to authenticate any data in
    non-SYN ENO options.  (Such data is optional and ignored by ENO.)

  * The subsection of section 6 pertaining to simultaneous open has been
    removed, since despite a small number of objections, the working
    group seems to have settled on TCP-ENO's design point (i.e., TCP
    never fails, but encryption requires application help for
    simultaneous open).

  * The subsection of section 6 dealing with optimizing suboption data
    has been removed, now that there is a marker byte mechanism that
    essentially offers the best of both worlds.

The new version is available here:

        https://datatracker.ietf.org/doc/draft-ietf-tcpinc-tcpeno/

We believe this does not change very much for the encryption spec
drafts, other than the citation.  We plan to submit an updated version
of tcpcrypt very soon, but with possibly only one word change and a
citation update.

We will also update the informational API draft within the next few
days.

David