Subject: [tcpinc] tcpcrypt v0.5 release

From: Andrea Bittau <[email-masked]>
Date: Thu, 14 Jul 2016 23:05:38 -0700

We released a new version of tcpcrypt based on the updated specs.  We're
now using the experimental TCP option exid that has been allocated to us.

You can download the Windows, Mac and Linux versions here:

http://tcpcrypt.org/download.php

thanks!

---

From: Joe Touch <[email-masked]>
Date: Fri, 15 Jul 2016 10:29:06 -0700

On 7/14/2016 11:05 PM, Andrea Bittau wrote:
> We released a new version of tcpcrypt based on the updated specs. 
> We're now using the experimental TCP option exid that has been
> allocated to us.

This issue was raised at IETF 80 in Prague in 2011, and resulted in the
development and completion of RFC 6994 in 2013.

Yet it has taken another 3 *years* to get it fixed in the reference code.

Although I'm glad to see this happen, it's frankly very long overdue and
the damage created by squatting on unassigned TCP codepoints is
something we really need to take seriously in how codepoints are
assigned to this (or other squatters) in the future.

Joe

---

From: Kyle Rose <[email-masked]>
Date: Fri, 15 Jul 2016 13:34:01 -0400

> assigned to this (or other squatters) in the future.

Perhaps so, but I'm pretty sure the proposed discussion isn't business for
the tcpinc mailing list.

Kyle

---

From: Joe Touch <[email-masked]>
Date: Fri, 15 Jul 2016 10:37:06 -0700

On 7/15/2016 10:34 AM, Kyle Rose wrote:
> Perhaps so, but I'm pretty sure the proposed discussion isn't business
> for the tcpinc mailing list.
>

It is if/when tcpcrypt applies for an assigned TCP codepoint. If
tcpcrypt never does this, it'll merely be used as a example of behavior
to avoid in d iscussions on other lists.

Joe

---

From: Watson Ladd <[email-masked]>
Date: Sat, 16 Jul 2016 08:58:44 -0700

> to avoid in d iscussions on other lists.

We might have to break the existing users of tcpcrypt. All 10 of them.

The horror, the horror. (Yes, squatting is a problem. But I think we
can live with a tcpcrypt flag day or two before it becomes an RFC)
>
> Joe
>
> _______________________________________________
> Tcpinc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpinc

-- 
"Man is born free, but everywhere he is in chains".
--Rousseau.