Subject: [tcpinc] Why retain negotatiation

From: Watson Ladd <[email-masked]>
Date: Sat, 16 Jul 2016 08:58:16 -0700

Dear all,
Originally negotiation was proposed because EKR wanted to use TLS.
That has now ended, but we are retaining the negotiation layer with
far more generality then required. I'm not sure why that is.
Sincerely,
Watson

---

From: Yoav Nir <[email-masked]>
Date: Sat, 16 Jul 2016 20:31:44 +0300

IIUC the idea is that the TLS work is not ended, merely suspended, and will resume once TLS 1.3 is out the door. Whether that will actually happen is of course not known.

Yoav

> On 16 Jul 2016, at 6:58 PM, Watson Ladd <[email-masked]> wrote:
> 
> Dear all,
> _______________________________________________
> Tcpinc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpinc

---

From: Kyle Rose <[email-masked]>
Date: Sun, 17 Jul 2016 13:18:51 +0200

+1.

Additionally, there has been interest expressed by others in using the ENO
mechanism for negotiating privacy extensions to TLS, such as disabling SNI
and having the server issue a cert without direct identifying information
(e.g., delivering a nonce instead of a hostname in the CN). Dave Plonka is
scheduled to talk about this briefly at the meeting on Tuesday.

Kyle

On Sat, Jul 16, 2016 at 7:31 PM, Yoav Nir <[email-masked]> wrote:

> IIUC the idea is that the TLS work is not ended, merely suspended, and
> will resume once TLS 1.3 is out the door. Whether that will actually happen
> is of course not known.
>
> Yoav
>

---

From: David Mazieres <[email-masked]>
Date: Sun, 17 Jul 2016 13:52:59 -0700

> far more generality then required. I'm not sure why that is.

As already noted by Yoav, TLS is just suspended, not ended.

More importantly, even though TCP-ENO was initial born out of
frustration at the working group's indecision over tcpcrypt
vs. TCP-use-TLS, after doing the work we realized that even just for
tcpcrypt, TCP-ENO was a better approach.  It saves us from making
tcpcrypt maximally general (we were able to cut the draft size in half)
and ensures we can take advantage of any future developments such as
large options without predicting them today.

David