Subject: RE: [tcpm] ICMP and TCP

From: "Bora Akyol" <[email-masked]>
Date: Fri, 19 May 2006 11:08:04 -0700

Joe

Please see my other email, I think it was wrong for TCP to rely on these

in the first place.

The logic was that all L4 protocols can share the same control protocol
in ICMP,
but how does this help when L4 protocols are so divergent in their
nature?
How does this help, when the security of one protocol is so tightly
coupled with another.
How does it help, when responses to hard errors now become dependent on
the state we're in ;-)

I think lack of all the *+unreachable messages can be handled within
TCP.

Thanks

Bora

> -----Original Message-----
> From: Joe Touch [mailto:[email-masked]] 
> Sent: Friday, May 19, 2006 10:55 AM
> To: Bora Akyol
> Cc: [email-masked]
> Subject: Re: [tcpm] ICMP and TCP
> 
> 
> 
> Bora Akyol wrote:
> > Should we stop beating around the bush and cut the cord 
> between these 
> > two altogether? Even PMTU discovery is really an L3 function.
> >  
> > What the icmp/tcp draft proposes turns all hard errors to 
> soft anyway, 
> > why not just cut the cord and let TCP react to only the other peer 
> > TCP.
> 
> That won't help find out when the other peer isn't there 
> (host unreachable), TCP isn't there (protocol unreachable), 
> or network isn't there (net unreachable).
> 
> Those turn out to be useful; if we care about 
> short-circuiting IPv6 attempts to fall-back on IPv4 attempts, 
> then we ought to care as much about these errors, which are 
> equivalently important.
> 
> (and when a host or net decides they're a security risk, the 
> host or net can disable them)
> 
> Joe
> 
> 

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: Joe Touch <[email-masked]>
Date: Mon, 22 May 2006 09:32:44 -0700

> but how does this help when L4 protocols are so divergent in their

They're not all that divergent - SCTP, DCCP, all share state and have 
TCP-like congestion control. Where they do diverge (state vs. 
stateless), that difference is already described (RFC1122).

> How does this help, when the security of one protocol is so tightly

Therein lies the rub.

> How does it help, when responses to hard errors now become dependent on

You're arguing for the deprecation of ICMP. That's independent from 
redefining it just within TCP.

> I think lack of all the *+unreachable messages can be handled within

It's entirely consistent to handle those both within TCP and within 
other L4's, e.g., to allow a bunch of different protocols to react to 
the disappearance of a host.

It's also consistent to allow the host to do other things - e.g., affect 
its forwarding table (L3) based on some of these messages.

Joe