Subject: Re: [tcpm] TCPx2

From: Mark Allman <[email-masked]>
Date: Mon, 08 May 2006 14:51:54 -0400

> Agreed, but as I read the proposal it has the same impediments
> to deployment as SCTP without any of the additional features.
> 
> Is there any reason why the network elements that do not 
> support SCTP will support TCPx2?

People use TCP?

allman

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: "Caitlin Bestler" <[email-masked]>
Date: Mon, 8 May 2006 11:43:39 -0700

[email-masked] wrote:
> Christian:
>> Increase size fields is definitely a good reason for looking at
>> TCPx2. [...] But there are other reasons as well, e.g.:
> 
> Caitlyn:
>> In any sort of "let's really fix TCP" discussion I think the starting
>> point should be SCTP.
> 
> Allow me to call attention to this bit from the draft:
> 
>     This document is not about specifying a "TCPng".  The
>     functionality (or lack thereof) of TCP is not changed.  The
> intention 
> is to simply
>     give TCP some possibly breathing room.  The proposal is for
>     pragmatic evolution, rather than principled engineering.
> 
> This draft is not about adding functionality.  I believe
> everyone in the transport community has their own vision of
> what a TCPng looks like.  If you do, please write it down and
> take it from there.  This proposal is a (probably cracked
> out) wondering about whether simply bumping the size and
> leaving the functionality is a reasonable path.
> 
> (And, pragmatically, this leaves more option space and more
> reserved bits in the header for people to tinker with.)
> 
> allman