Subject: RE: [tcpm] tcpsecure & IPR

From: "Mitesh Dalal \(mdalal\)" <[email-masked]>
Date: Tue, 28 Nov 2006 10:57:22 -0800

Scott did a presentation on this topic. The slides are
at: 
http://www3.ietf.org/proceedings/04aug/slides/tcpm-11.pdf

Hope this should demystify some of your Qs.

Mitesh

> -----Original Message-----
> From: Fernando Gont [mailto:[email-masked]] 
> Sent: Monday, November 27, 2006 4:53 AM
> To: [email-masked]
> Subject: [tcpm] tcpsecure & IPR
> 
> Folks,
> 
> I was having a look at the tcpsecure doc, and at some point I 
> recalled the issue of the pending patent, etc.
> 
> A few questions with respect to this issue:
> 
> * Is the pending patent on all the mitigations, or just on 
> some of them? If so, which ones?
> * Do vendors have to do paperwork with Cisco (or whoever) 
> before being able to implement this? No matter what the 
> answer to this one
> is: Is there any online documentation of this that one could 
> show to vendors willing to implement this (but afraid of the 
> patent thing)?
> * Any data regarding implementation of these counter-measures 
> by vendors other than Cisco & Juniper? Open source OSes?
> 
> Thanks!
> 
> Kindest regards,
> 
> --
> Fernando Gont
> e-mail: [email-masked] || [email-masked] PGP 
> Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1
> 
> 
> 
> 
> 
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tcpm
> 

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: Fernando Gont <[email-masked]>
Date: Wed, 29 Nov 2006 04:23:35 -0300

Mitesh,

Thanks for your answer. However, I don't think that presentation 
addresses my concerns.

There's one basic concern that I have:
Let's say I want to encourage vendors to implement tcpsecure. Vendors 
will want to be assured that they want have to pay anything, or be 
sued, or whatever. However, I have not been able to find an 
"official" statement by Cisco regarding this whole issue.

Scott may be extremely accurate and right in what he says. But, as he 
acknowledges in his presentation, he is not speaking for Cisco.

A vendor willing to implement tcpsecure will want to read a statement 
from Cisco claiming whether vendors implementing tcpsecure will have 
to pay a royalty, or whatever.

In the event that somebody implemented tcpsecure, and then Cisco sued 
them for that, I don't think vendors will be able to defend 
themselves by claiming "Scott said that we wouldn't have to pay anything".

The presentation does not say whether the pending patent is on all 
the countermeasures, or only on some of them, either.

Kindest regards,
Fernando Gont

--
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1