Subject: [tcpm] tcpsecure & IPR

From: Fernando Gont <[email-masked]>
Date: Mon, 27 Nov 2006 09:53:28 -0300

Folks,

I was having a look at the tcpsecure doc, and at some point I 
recalled the issue of the pending patent, etc.

A few questions with respect to this issue:

* Is the pending patent on all the mitigations, or just on some of 
them? If so, which ones?
* Do vendors have to do paperwork with Cisco (or whoever) before 
being able to implement this? No matter what the answer to this one 
is: Is there any online documentation of this that one could show to 
vendors willing to implement this (but afraid of the patent thing)?
* Any data regarding implementation of these counter-measures by 
vendors other than Cisco & Juniper? Open source OSes?

Thanks!

Kindest regards,

--
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: "Anantha Ramaiah \(ananth\)" <[email-masked]>
Date: Wed, 29 Nov 2006 19:13:09 -0800

Fernando, 
    I thought the IPR disclosure from Cisco and also Scott's
presentation put together, this IPR issue was beaten to death. Cisco's
is a defensive patent and if you read it carefully, it tells : [ among
other things ]

<snip>
......
......
If this standard is adopted, Cisco will not assert any patents owned or
controlled by Cisco against any party for making, using, selling,
importing
or offering for sale a product that implements the standard, provided,
however that Cisco retains the right to assert its patents (including
the
right to claim past royalties) against any party that asserts a patent
it
owns or controls (either directly or indirectly) against Cisco or any of
Cisco's affiliates or successors in title for an implementation of any
IETF
standard;

Pl read
http://www.ietf.org/ietf/IPR/cisco-ipr-draft-ietf-tcpm-tcpsecure.txt for
more details. I think this should answer all your questions below.

-Anantha

> -----Original Message-----
> From: Fernando Gont [mailto:[email-masked]] 
> Sent: Tuesday, November 28, 2006 11:24 PM
> To: Mitesh Dalal (mdalal); [email-masked]
> Subject: RE: [tcpm] tcpsecure & IPR
> 
> Mitesh,
> 
> Thanks for your answer. However, I don't think that 
> presentation addresses my concerns.
> 
> There's one basic concern that I have:
> Let's say I want to encourage vendors to implement tcpsecure. 
> Vendors will want to be assured that they want have to pay 
> anything, or be sued, or whatever. However, I have not been 
> able to find an "official" statement by Cisco regarding this 
> whole issue.

AFAIK, Cisco's patent is very defensive. I cannot recall the exact
wordings, but I says
> 
> Scott may be extremely accurate and right in what he says. 
> But, as he acknowledges in his presentation, he is not 
> speaking for Cisco.
> 
> A vendor willing to implement tcpsecure will want to read a 
> statement from Cisco claiming whether vendors implementing 
> tcpsecure will have to pay a royalty, or whatever.
> 
> In the event that somebody implemented tcpsecure, and then 
> Cisco sued them for that, I don't think vendors will be able 
> to defend themselves by claiming "Scott said that we wouldn't 
> have to pay anything".
> 
> The presentation does not say whether the pending patent is 
> on all the countermeasures, or only on some of them, either.
> 
> Kindest regards,
> Fernando Gont
> 
> 
> 
> 
> >Scott did a presentation on this topic. The slides are
> >at:
> >http://www3.ietf.org/proceedings/04aug/slides/tcpm-11.pdf
> >
> >Hope this should demystify some of your Qs.
> >
> >Mitesh
> >
> >
> > > -----Original Message-----
> > > From: Fernando Gont [mailto:[email-masked]]
> > > Sent: Monday, November 27, 2006 4:53 AM
> > > To: [email-masked]
> > > Subject: [tcpm] tcpsecure & IPR
> > >
> > > Folks,
> > >
> > > e-mail: [email-masked] || [email-masked] PGP
> > > Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1
> > >
> > >
> > >
> > >
> > >
> > >
> e-mail: [email-masked] || [email-masked] PGP 
> Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1
> 
> 
> 
> 
> 
>