Subject: [tcpm] Probing the viability of TCP extensions

From: "Adam Langley" <[email-masked]>
Date: Tue, 16 Sep 2008 11:38:09 -0700

For my own gratification, if nothing else, I ran an experiment probing
for a few TCP behaviours on common webservers. Greg Chesson encouraged
me to write it up:

Abstract:

TCP was designed with extendibility in mind, chiefly re-
flected in the options mechanism. However, there have been
repeated observations of misbehaving middleware that have
hampered the deployment of beneficial TCP extensions.

This paper reports on an experiment to determine how preva-
lent three types of behaviour are. We find that 9.08% of
hosts don't respond to SYN frames with payloads, 0.17% of
hosts don't respond to SYN frames with non-standard op-
tions and 0.56% of hosts don't respond to SYN frames which
attempt to negotiate ECN.

http://www.imperialviolet.org/binary/ecntest.pdf

Comments welcome. If anyone thinks it worthwhile, I may submit it somewhere.

Cheers

AGL

-- 
Adam Langley [email-masked] http://www.imperialviolet.org
_______________________________________________
tcpm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tcpm

---

From: Sally Floyd <[email-masked]>
Date: Tue, 16 Sep 2008 16:19:52 -0700

Adam -

 >for a few TCP behaviours on common webservers. Greg Chesson encouraged
...
> http://www.imperialviolet.org/binary/ecntest.pdf
...

Thanks.
I added a pointer to the paper on the TBIT web page
(TCP Behavior Inference) at
   "http://www.icir.org/tbit/".

- Sally
http://www.icir.org/floyd/