Subject: [tcpm] Fwd: Re: Data on 'Nonce' and 'Broken' responses to AccECN SYN?

From: Bob Briscoe <[email-masked]>
Date: Wed, 18 Jul 2018 07:40:59 -0400

Michael,

Below is data from 410,803 of the Alexa top 500k web server that 
confirms what I said in the presentation about space for future 
evolution of AccECN:

  * the nonce pattern on the SYN-ACK could be reused now (0.0007%)
  * the broken reflection pattern is still far too prevalent to re-use
    it (0.35%).

If anyone wants the list of broken servers that Anna attached for me, 
pls ask.
The whole dataset is also available via: 
http://www.it.uc3m.es/amandala/ecn++/

@Anna, thanks v much for responding so quickly - it was me that hadn't 
read your email in time for the talk.

Bob

-------- Forwarded Message --------
Subject: 	Re: Data on 'Nonce' and 'Broken' responses to AccECN SYN?
Date: 	Tue, 17 Jul 2018 15:42:10 +0200
From: 	ANNA MARIA MANDALARI <[email-masked]>
To: 	Bob Briscoe <[email-masked]>

Hi Bob,

I had a look at the data and I found *1,438 servers *over the top 
410,803 Alexa (0.35%) that reply SYN/ACK+111 to a SYN+111 (attached the 
list).

Only *3 servers *(0.0007%) reply SYN/ACK+101 to a SYN+111:

test_synack;200.12.171.53;80;ect;0;flags;338
test_synack;60.28.220.134;80;ect;0;flags;338
test_synack;200.12.171.52;80;ect;0;flags;338

Let me know if I can help you with something else!

2018-07-17 13:26 GMT+02:00 Bob Briscoe <[email-masked] 
<mailto:[email-masked]>>:

    Anna,

    Could you do me a favour and look up how many servers responded to
    an AccECN (111) SYN with a SYN/ACK carrying respectively 'Nonce'
    (101) or 'Broken' (111)?

    And also the total number of tests sent with an AccECN SYN, so I can
    give proportions in the AccECN draft.

    Cheers

    Bob (too lazy to look at the data myself)

    -- 
    ________________________________________________________________
    Bob Briscoe http://bobbriscoe.net/

-- 
ANNA MARIA MANDALARI
Universidad Carlos III de Madrid

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Wed, 18 Jul 2018 13:24:47 +0000

Interesting. So what prevents us from reserving the nonce pattern for future use?

Michael

From: tcpm [mailto:[email-masked]] On Behalf Of Bob Briscoe
Sent: Wednesday, July 18, 2018 1:41 PM
To: Michael Scharf <[email-masked]>
Cc: ANNA MARIA MANDALARI <[email-masked]>; tcpm IETF list <[email-masked]>
Subject: [tcpm] Fwd: Re: Data on 'Nonce' and 'Broken' responses to AccECN SYN?

Michael,

Below is data from 410,803 of the Alexa top 500k web server that confirms what I said in the presentation about space for future evolution of AccECN:

  *   the nonce pattern on the SYN-ACK could be reused now (0.0007%)
  *   the broken reflection pattern is still far too prevalent to re-use it (0.35%).
If anyone wants the list of broken servers that Anna attached for me, pls ask.
The whole dataset is also available via: http://www.it.uc3m.es/amandala/ecn++/

@Anna, thanks v much for responding so quickly - it was me that hadn't read your email in time for the talk.

Bob

-------- Forwarded Message --------
Subject:

Re: Data on 'Nonce' and 'Broken' responses to AccECN SYN?

Date:

Tue, 17 Jul 2018 15:42:10 +0200

From:

ANNA MARIA MANDALARI <[email-masked]><mailto:[email-masked]>

To:

Bob Briscoe <[email-masked]><mailto:[email-masked]>

Hi Bob,

I had a look at the data and I found 1,438 servers over the top 410,803 Alexa (0.35%) that reply SYN/ACK+111 to a SYN+111 (attached the list).

Only 3 servers (0.0007%) reply SYN/ACK+101 to a SYN+111:

2018-07-17 13:26 GMT+02:00 Bob Briscoe <[email-masked]<mailto:[email-masked]>>:
Anna,

Could you do me a favour and look up how many servers responded to an AccECN (111) SYN with a SYN/ACK carrying respectively 'Nonce' (101) or 'Broken' (111)?

And also the total number of tests sent with an AccECN SYN, so I can give proportions in the AccECN draft.

Cheers

---

From: Bob Briscoe <[email-masked]>
Date: Wed, 18 Jul 2018 13:50:18 -0400

Michael,

I agree. Also, even tho 'broken' is not currently any use, it might be 
one day.

So we should reserve both the nonce and broken patterns on the SYN-ACK 
(in response to 111 on the SYN) for future AccECN use. They have to be 
solely for AccECN use, cos the SYN is still saying "I support AccECN".

We can add a RESVD tag in table 2, and explain in the notes underneath.

Bob

On 18/07/18 09:24, Scharf, Michael (Nokia - DE/Stuttgart) wrote:
> *From:*tcpm [mailto:[email-masked]] *On Behalf Of *Bob Briscoe
> *Sent:* Wednesday, July 18, 2018 1:41 PM
> *To:* Michael Scharf <[email-masked]>
> *Cc:* ANNA MARIA MANDALARI <[email-masked]>; tcpm IETF list 
> <[email-masked]>
> *Subject:* [tcpm] Fwd: Re: Data on 'Nonce' and 'Broken' responses to 
> AccECN SYN?
>
> Michael,
>
>
> <http://www.it.uc3m.es/amandala/ecn++/>
>
> *Subject: *
> *Date: *
> *From: *
> ANNA MARIA MANDALARI <[email-masked]> <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> Bob Briscoe <[email-masked]> <mailto:[email-masked]>
>
> Hi Bob,
>
> 410,803 Alexa (0.35%) that reply SYN/ACK+111 to a SYN+111 (attached 
> the list).
>
>     And also the total number of tests sent with an AccECN SYN, so I
>     can give proportions in the AccECN draft.
>
>     Cheers
>
>
>