Subject: [tcpm] RFC 6298

From: Jonathan Walter <[email-masked]>
Date: Sat, 9 Mar 2019 20:35:03 +0000

Dear IETF,

I am studying computer science at Frostburg State University and doing a mini research project on calculating RTO timer.
I am interested in background discussions around changes that were made when the latest RFC was revised in 2011, especially around how the 1 second minimum was determined and why it was reduced to that from 3 seconds.  Please could you let me know if there is a public discussion board that would have background discussions posted I could read to gets some background history?

Thank you.

Sincerely,

Jon Walter

---

From: "Scharf, Michael" <[email-masked]>
Date: Sun, 10 Mar 2019 15:31:53 +0000

Hi Jon,

You can parse the list archive of the TCPM working group, most notably for the term "rfc2988bis":

https://mailarchive.ietf.org/arch/browse/tcpm/?q=rfc2988bis

That, as well as the appendix of RFC 6298, is probably a good starting point.

Best regards

Michael

From: tcpm [mailto:[email-masked]] On Behalf Of Jonathan Walter
Sent: Saturday, March 9, 2019 9:35 PM
To: [email-masked]
Subject: [tcpm] RFC 6298

Dear IETF,

Thank you.

Sincerely,

Jon Walter

---

From: Neal Cardwell <[email-masked]>
Date: Sun, 10 Mar 2019 11:36:35 -0400

These slide decks also have some motivating context for the 1 second value:

https://www.ietf.org/proceedings/75/slides/tcpm-1.pdf
  (" ~2.5% connections with RTT > 1sec")

https://www.ietf.org/proceedings/77/slides/iccrg-1.pdf
  ("~97.5% of connections have RTT < 1 second")

neal

On Sun, Mar 10, 2019 at 11:32 AM Scharf, Michael <
[email-masked]> wrote:

> Hi Jon,
>
>
>
> You can parse the list archive of the TCPM working group, most notably for
> the term “rfc2988bis”:
>
>
>
> *From:* tcpm [mailto:[email-masked]] *On Behalf Of *Jonathan Walter
> *Sent:* Saturday, March 9, 2019 9:35 PM
> *To:* [email-masked]
> *Subject:* [tcpm] RFC 6298
>
>
>
> Dear IETF,
>
>
>
> I am studying computer science at Frostburg State University and doing a
> mini research project on calculating RTO timer..
>
> I am interested in background discussions around changes that were made
> when the latest RFC was revised in 2011, especially around how the 1 second
> minimum was determined and why it was reduced to that from 3 seconds.
> Please could you let me know if there is a public discussion board that
> would have background discussions posted I could read to gets some
> background history?
>
>
>
> Thank you.
>
>
>
> Sincerely,
>
>
>
> Jon Walter
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>