Subject: [tcpm] Lars Eggert's No Objection on draft-ietf-tcpm-ao-test-vectors-06: (with COMMENT)

From: Lars Eggert via Datatracker <[email-masked]>
Date: Tue, 01 Mar 2022 07:42:39 -0800

Lars Eggert has entered the following ballot position for
draft-ietf-tcpm-ao-test-vectors-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ 
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-tcpm-ao-test-vectors/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

The datatracker state does not indicate whether to include the
consensus boilerplate for this document.

Found terminology that should be reviewed for inclusivity; see
https://www.rfc-editor.org/part2/#inclusive_language for background and more
guidance:

 * Terms "master" and "master_key"; alternatives might be "active",
   "central", "initiator", "leader", "main", "orchestrator", "parent",
   "primary", "server".

Thanks to Peter E. Yee for their General Area Review Team (Gen-ART) review
(https://mailarchive.ietf.org/arch/msg/gen-art/CHS1WZam2FsNmxLR2z9sutDZzj0).

-------------------------------------------------------------------------------
All comments below are about very minor potential issues that you may choose to
address in some way - or ignore - as you see fit. Some were flagged by
automated tools (via https://github.com/larseggert/ietf-reviewtool), so there
will likely be some false positives. There is no need to let me know what you
did with these suggestions.

Document still refers to the "Simplified BSD License", which was corrected in
the TLP on September 21, 2021. It should instead refer to the "Revised BSD
License". The document boilerplate overall seems to be 10+ years out of date.

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 1 Mar 2022 09:57:45 -0800

Hi, Lars,

Thanks for the corrections. I should note to others that I was his PhD advisor; in other circles, we would never review each others work (as a COI).

We are using the “master key” terminology established by RFC 5925. Its use there appears to be permitted as per the guidance. Even if we were writing 5925 anew, we probably would need to stay with the term due to its prominence in the crypto community. 
(FWIW, I found it amusing that the advice was prepared by groups including “Toastmasters”, a name that itself uses “master”).

As to boilerplate, it would be easier to keep current if it were kept *stable*. I’ll see what I can do to sync it, but I will leave verification of that to the RFC Editor.

Joe

—
Dr. Joe Touch, temporal epistemologist
www.strayalpha.com

> On Mar 1, 2022, at 7:42 AM, Lars Eggert via Datatracker <[email-masked]> wrote:
>

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 1 Mar 2022 12:45:06 -0800

FWIW - I tried to update the boilerplate beyond the “Revised” issue and ID-NITS complained.

Joe
—

> On Mar 1, 2022, at 9:57 AM, [email-masked] wrote:
> 
> Hi, Lars,
> ...
> 
> www.strayalpha.com <http://www.strayalpha.com/>
> 
>> On Mar 1, 2022, at 7:42 AM, Lars Eggert via Datatracker <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ <https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/> 
>> https://datatracker.ietf.org/doc/draft-ietf-tcpm-ao-test-vectors/ <https://datatracker.ietf.org/doc/draft-ietf-tcpm-ao-test-vectors/>
>> 
>> 
>> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm