Subject: [tcpm] Erik Kline's No Objection on draft-ietf-tcpm-ao-test-vectors-08: (with COMMENT)

From: Erik Kline via Datatracker <[email-masked]>
Date: Wed, 02 Mar 2022 14:26:53 -0800

Erik Kline has entered the following ballot position for
draft-ietf-tcpm-ao-test-vectors-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ 
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-tcpm-ao-test-vectors/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

[S3.1, etc.; nit]

* I'm somewhat surprised that IETF standard documentation prefixes aren't
  being used (192.0.2.0/24, 2001:db8::/32).

  I do not feel strongly enough, however, to suggest that the examples need
  to be rewritten and the values recomputed.

[S3.1.4; nit]

* If these examples are typical of BGP sessions and GSTM (RFC 5082) is
  a typical BGP deployment practice I would have expected to see the IPv6
  hop limit in use also be 255, rather than 64.

  Again: no need to redo all the examples.

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 2 Mar 2022 14:58:43 -0800

Hi, Erik,

Thanks for your review. Comments below; please let me know if you concur or have a better suggestion forward.

Thanks,

Joe

> On Mar 2, 2022, at 2:26 PM, Erik Kline via Datatracker <[email-masked]> wrote:
> 

We considered this, but test vectors are an odd case. Although they are for “documentation” purposes, the IP addresses given need to be those that can be used in an actual test environment. That’s why we used private addresses rather than documentation addresses.

>  Again: no need to redo all the examples.

Hopcount is not included in the calculation so would not affect the overall results. We can change them if needed, but it would affect only parts of the examples that are not being tested or validated.

--

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 3 Mar 2022 19:11:49 -0800

Hi, Erik,

Regarding the TTL, we used the default for IPv6 based on the implementation tested.  GSTM is an additional configuration to BGP that was not used for this test.

Note, however, that a test vector need not reflect actual content per se; it is sufficient that it be usable as input/output tests. 

Given the vectors have already been verified by multiple parties, we are hesitant to change them.

Joe

—
Dr. Joe Touch, temporal epistemologist
www.strayalpha.com

> On Mar 2, 2022, at 2:58 PM, [email-masked] wrote:
> 
> Hi, Erik,
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Erik Kline <[email-masked]>
Date: Sat, 12 Mar 2022 14:39:08 -0800

Ack; understood.  Thanks.