Subject: Re: TCP over IP over PPP (over Satellite)

From: Marian Stagarescu <[email-masked]>
Date: Fri, 18 Dec 1998 17:30:24 -0500 (EST)

I was conducting SkyX (Mentat) tests at NASA Goddard.
Our test configuration is over emulated "GEO-satellite" links 
and the results are showing a throughput gain ratio of 10
to 100 in favor of Skyx when compared with a "vanilla" TCP
(no large windows).

The TCP throughput w/ large windows and SACK over long-fat pipes (RTT=540 msec, 
OC-3 links) is good (72% of theoretical rate) at low BER (none or 1E-10) 
but it degrades heavily when BER is bellow
1E-7 (only 4% of theoretical rate for BER=1E-7). 

SkyX throughput doesn't degrades (only small variations) at low BER 
(1E-6, 1E-5).

We plan to cooperate with another group here at NASA Goddard
for tests over real satellite.

Our tests involved the following configuration:

+----------+ TCP  +---------+ SkyX  +--------+ 
| end-host |______|         |_______|unix gw |
|(receiver)| IP/  | SkyX gw | IP/   |________|        
+----------+ Eth  +---------+ Eth    
                                        | SkyX/IP/ATM        
                                        |
                                    +--------+
                                    | ADTECH | - data link emulator
                                    +--------+
                                        | SkyX/IP/ATM 
                                        |
+----------+ TCP +---------+  SkyX  +---------+
| end host | IP  |         |   IP   |         |
|(sender)  |-----|         |--------|unix gw  |
|          | Eth | Skyx gw |   Eth  |         |
+----------+     +---------+        +---------+

The links are 100 Mbps.

The end-host machines and SkyX gateways are Linux boxes;
The 2 UNIX gateways are mapping the IP traffic to ATM;
The data link emulator (ADTECH AX/4000 ATM test system)
is used for tests of IP over ATM traffic; it is emulating
delays, BER, cell drops, burst error rates, etc.

If you are interested in more information regarding specific performance
metrics and test conditions (window size, RTTs, BERs, ttcp parameters used)
please contact me @ 301-286-2188 
or Pat Gary @ 301-286-9539 ([email-masked])

Marian Stagarescu - NASA GSFC/Raytheon ITSS
		    HPCC/HECN group

---

From: William D Ivancic <[email-masked]>
Date: Mon, 21 Dec 1998 07:18:38 -0500

At 05:30 PM 12/18/98 -0500, Marian Stagarescu wrote:
>...The TCP throughput w/ large windows and SACK over long-fat pipes
(RTT=540 msec, 
>1E-7 (only 4% of theoretical rate for BER=1E-7). 

Why do you only get 72% of theoretical results for error-free links?  Are
you considering SONET and ATM overhead?  Theory should be approximately
134-134.5 Mbps depending on the amount of extensions used.  Do you have the
advertised window set to theory or are you letting the data overrun the
available link?  At LeRC over ACTS and using the Adtech for delay/error we
can get near theory minus a few percent due to the inability of the CPU and
drivers to match theory.  This is when the system is perfectly tuned. 

*********************************************
William D. Ivancic
NASA Lewis Research Center
21000 Brookpark Rd.   MS 54-8
Cleveland, Ohio  44135
USA
Phone:   1 216 433 3494
FAX:     1 216 433 8705
Email:   [email-masked]
         [email-masked]		
*********************************************