Subject: [Teas] TE Topology YANG Model Design Team

From: Lou Berger <[email-masked]>
Date: Thu, 11 Dec 2014 08:07:23 -0500

All,
    We have formed a WG Design Team whose objective is to deliver a TE
Topology YANG Model  draft in
time for discussion in Dallas.  It is our intent that the document will
become a TEAS WG draft post Dallas.  The scope of the design team is
intentionally narrow and the work of the DT will need to be coordinated
with other related YANG work -- and such coordination is the focus of
next week's interim meeting*.  The DT will be closed once we have a WG
document adopted on this topic.

While the DT has limited membership (and a limited lifespan), how the DT
works to produce it's individual draft(s) is up to the DT. For example
they may choose to publicize their calls/progress or not. We do
appreciate that not all who volunteered are include.  Those who are
willing to provide input to the DT should contact them directly.  Keep
in mind that there will be plenty of opportunity for input, per normal
WG process, once the DT's individual draft(s) are adopted as WG
documents. Again, thank you to all who volunteered.

* - Next week's interim is of course open to all -- and we have an open
call for those who wish a discussion slot.  The focus of the interim is
on the scope of the TE Topology YANG model  and how it relates/ties-in
to other work.

The members of the DT are:
    Vishnu Pavan Beeram <[email-masked]>
    Igor Bryskin <[email-masked]>
    Oscar Gonzalez De Dios <[email-masked]>
    Xufeng Liu <[email-masked]>
    Tarek Saad <[email-masked]>
    Himanshu Shah <[email-masked]>

Deborah and Lou

---

From: Leeyoung <[email-masked]>
Date: Tue, 16 Dec 2014 16:24:24 +0000

Hi Lou,

Just wondering if you consider other individual contributions on TE Topology YANG model other than DT's contribution? Another question is what is the scope of this DT's YANG model effort? There can be many aspects of TE YANG model (e.g., integrated multi-layer vs. multiple individual single-layer, etc.)

If you can define the clear work scope of the DT, that will be great. If the WG would not allow other individual contributions, I have some concerns on the issue of fairness. 

Best regards,
Young

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Thursday, December 11, 2014 7:07 AM
To: TEAS WG
Subject: [Teas] TE Topology YANG Model Design Team

All,
    We have formed a WG Design Team whose objective is to deliver a TE Topology YANG Model  draft in time for discussion in Dallas.  It is our intent that the document will become a TEAS WG draft post Dallas.  The scope of the design team is intentionally narrow and the work of the DT will need to be coordinated with other related YANG work -- and such coordination is the focus of next week's interim meeting*.  The DT will be closed once we have a WG document adopted on this topic.

While the DT has limited membership (and a limited lifespan), how the DT works to produce it's individual draft(s) is up to the DT. For example they may choose to publicize their calls/progress or not. We do appreciate that not all who volunteered are include.  Those who are willing to provide input to the DT should contact them directly.  Keep in mind that there will be plenty of opportunity for input, per normal WG process, once the DT's individual draft(s) are adopted as WG documents. Again, thank you to all who volunteered.

* - Next week's interim is of course open to all -- and we have an open call for those who wish a discussion slot.  The focus of the interim is on the scope of the TE Topology YANG model  and how it relates/ties-in to other work.

Deborah and Lou

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Lou Berger <[email-masked]>
Date: Tue, 16 Dec 2014 12:50:08 -0500

Young,

> Just wondering if you consider other individual contributions on TE Topology YANG model other than DT's contribution? Another question is what is the scope of this DT's YANG model effort? There can…

There is no restriction on individual work just because there is a
design team.  In fact, you can even author individual documents when
there is a WG topic on a subject. It is for the WG to judge if it is
work to be supported.

It would be most helpful though to try to work with the DT.  Their
mission is to develop a draft in time for discussion in Dallas, and they
are free to work as they see fit, much like any other individual draft. 
Once we  have a WG draft on the topic, the WG as a whole has control on
the content of the draft.

The details of their work is a largely up to them.  They will be basing
their work on published individual work, so I expect it to be aligned
with what we can see in those documents.

You are welcome to comment on those to the DT and on the list.  You (and
anyone else) can attend Thursday's virtual Interim as well as request a
discussion slot, if you have something to add -- we are particularly
interested to hear about what may be missing from the scope perspective.

> If you can define the clear work scope of the DT, that will be great. 
I'm not sure what additional clarity you are looking for.  If it's for
more details on the content of the TE Topology YANG models, I think we
will wait to see what the DT produces and chooses to include/exclude. 
There's a complexity/progress tradeoff to be made at this point and the
choice is theirs.

This will be reviewed at the interim, and you should feel free to raise
any questions you have during the meeting.

> If the WG would not allow other individual contributions, I have some concerns on the issue of fairness. 

Sure, anyone can submit anything they choose at any point.  Such input,
as is the output of the DT, always subject to approval, rejection or 
modification by the WG as a whole.

Lou

---

From: Leeyoung <[email-masked]>
Date: Tue, 16 Dec 2014 19:40:15 +0000

Lou,

Thanks, this helps. 

Young

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Tuesday, December 16, 2014 11:50 AM
To: Leeyoung
Cc: TEAS WG
Subject: Re: [Teas] TE Topology YANG Model Design Team

Young,

On 12/16/2014 11:24 AM, Leeyoung wrote:
> Hi Lou,
>
> Just wondering if you consider other individual contributions on TE 
> Topology YANG model other than DT's contribution? Another question is 
> what is the scope of this DT's YANG model effort? There can be many 
> aspects of TE YANG model (e.g., integrated multi-layer vs. multiple 
> individual single-layer, etc.)

There is no restriction on individual work just because there is a design team.  In fact, you can even author individual documents when there is a WG topic on a subject. It is for the WG to judge if it is work to be supported.

It would be most helpful though to try to work with the DT.  Their mission is to develop a draft in time for discussion in Dallas, and they are free to work as they see fit, much like any other individual draft. 
Once we  have a WG draft on the topic, the WG as a whole has control on the content of the draft.

The details of their work is a largely up to them.  They will be basing their work on published individual work, so I expect it to be aligned with what we can see in those documents.

You are welcome to comment on those to the DT and on the list.  You (and anyone else) can attend Thursday's virtual Interim as well as request a discussion slot, if you have something to add -- we are particularly interested to hear about what may be missing from the scope perspective.

> If you can define the clear work scope of the DT, that will be great. 
I'm not sure what additional clarity you are looking for.  If it's for more details on the content of the TE Topology YANG models, I think we will wait to see what the DT produces and chooses to include/exclude. 
There's a complexity/progress tradeoff to be made at this point and the choice is theirs.

This will be reviewed at the interim, and you should feel free to raise any questions you have during the meeting.

> If the WG would not allow other individual contributions, I have some concerns on the issue of fairness. 

Sure, anyone can submit anything they choose at any point.  Such input, as is the output of the DT, always subject to approval, rejection or modification by the WG as a whole.

Lou

---

From: Fatai Zhang <[email-masked]>
Date: Wed, 17 Dec 2014 01:10:23 +0000

Hi Lou,

Thanks. Just one more comment for clarification.

You said:
>It would be most helpful though to try to work with the DT.  Their mission is to develop a draft in time for discussion in Dallas, and they are free to work as they see fit, much 
>like any other individual draft. Once we have a WG draft on the topic, the WG as a whole has control on the content of the draft.

[Fatai] Did you mean the DT's mission is to produce a WG draft directly? I assume that any (normal) drafts should be passed by IETF process, e.g., WG poll is necessary before an individual draft becomes a WG draft, am I right?

Best Regards

Fatai

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, December 17, 2014 1:50 AM
To: Leeyoung
Cc: TEAS WG
Subject: Re: [Teas] TE Topology YANG Model Design Team

Young,

Lou

---

From: "Matt Hartley (mhartley)" <[email-masked]>
Date: Wed, 17 Dec 2014 02:09:18 +0000

Fatai,

My understanding is that the DT will come out with an individual draft to be presented in Dallas, but the expectation is that this will probably become a WG draft fairly soon afterwards through the normal process... but the normal process will not be bypassed, so I'd expect the usual IPR and adoption polls.

Cheers

Matt

> [Fatai] Did you mean the DT's mission is to produce a WG draft directly? I
> assume that any (normal) drafts should be passed by IETF process, e.g., WG
> poll is necessary before an individual draft becomes a WG draft, am I
> right?
> 
> 
> 
> Best Regards
> 
> Fatai
> 
> 
> There is no restriction on individual work just because there is a design
> team.  In fact, you can even author individual documents when there is a
> WG topic on a subject. It is for the WG to judge if it is work to be
> supported.
> 
> It would be most helpful though to try to work with the DT.  Their mission
> is to develop a draft in time for discussion in Dallas, and they are free
> to work as they see fit, much like any other individual draft.
> their work on published individual work, so I expect it to be aligned with
> what we can see in those documents.
> 
> Sure, anyone can submit anything they choose at any point.  Such input, as
> is the output of the DT, always subject to approval, rejection or
> Topology YANG Model  draft in time for discussion in Dallas.  It is our
> intent that the document will become a TEAS WG draft post Dallas.  The
> scope of the design team is intentionally narrow and the work of the DT
> will need to be coordinated with other related YANG work -- and such
> coordination is the focus of next week's interim meeting*.  The DT will be
> closed once we have a WG document adopted on this topic.
> >
> they may choose to publicize their calls/progress or not. We do appreciate
> that not all who volunteered are include.  Those who are willing to
> provide input to the DT should contact them directly.  Keep in mind that
> there will be plenty of opportunity for input, per normal WG process, once
> the DT's individual draft(s) are adopted as WG documents. Again, thank you
> to all who volunteered.
> >
> call for those who wish a discussion slot.  The focus of the interim is on
> the scope of the TE Topology YANG model  and how it relates/ties-in to
> other work.
> >

---

From: Fatai Zhang <[email-masked]>
Date: Wed, 17 Dec 2014 02:29:36 +0000

Hi Matt,

What you said is my understanding, and I think that is fair.

Best Regards

Fatai

-----Original Message-----
From: Matt Hartley (mhartley) [mailto:[email-masked]] 
Sent: Wednesday, December 17, 2014 10:09 AM
To: Fatai Zhang; Lou Berger; Leeyoung
Cc: TEAS WG; Matt Hartley (mhartley)
Subject: RE: [Teas] TE Topology YANG Model Design Team

Fatai,

Cheers

Matt

---

From: Lou Berger <[email-masked]>
Date: Wed, 17 Dec 2014 07:42:11 -0500

Fatai,

Matt did a reasonable job reiterating what we said before. Adopting working 
group drafts based on working group feedback, and after the important step 
of the ipr poll, is both typical and good practice. And this is the plan 
for any DT produced drafts.

> WG poll is necessary before an individual draft becomes a WG draft, am I right?

Actually, while this statement does reflect common practice, it does not 
reflect a required step from IETF process perspective. From a formal 
process perspective, all that is required for a document to be a working 
document is for a chair to approve it as such. There are RFCs on this.

Lou

On December 16, 2014 9:31:46 PM Fatai Zhang <[email-masked]> wrote:

> My understanding is that the DT will come out with an individual draft to 
> be presented in Dallas, but the expectation is that this will probably 
> become a WG draft fairly soon afterwards through the normal process... but 
> the normal process will not be bypassed, so I'd expect the usual IPR and 
> adoption polls.
>
> Cheers
>
> Matt
>
> > Hi Lou,
> >