Subject: [Teas] Updating draft-ietf-teas-yang-te-topo-00

From: Xufeng Liu <[email-masked]>
Date: Mon, 22 Jun 2015 20:22:36 +0000

Hi Folks,

The next version of the TE-Topology model draft will be submitted next week. In the meantime, please review the latest version of the model uploaded on github and let us know if there are any questions/comments. We expect to make one more update before submitting the draft.

https://github.com/ietf-mpls-yang/te/blob/master/ietf-te-topology.yang
https://github.com/ietf-mpls-yang/te/blob/master/ietf-te-topology_tree.txt

Regards,
- Xufeng (on behalf of the authors)

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Fri, 26 Jun 2015 09:31:31 +0000

Hi, Xufeng and the authors,

Thank you for getting us updated.

I haven’t got time to read in details; just by skimming through the tree,  I have the following questions:

1)      During last IETF presentation, Pavan mentioned the model will try to use the generic topology model. Is this going to happen in this version?  If not, what is your plan?

2)      A topology is now identified via a triplet ( provider-id, client-id, te-topology-id). I fail to see client-id as an universal attribute. For example, if I am the provider and I have one or topology, so how do I fill in the client-id field?

3)      I thought schedule will go away in a newer version, but instead it is made as a feature. I can live with this option, but why does a topology has a detailed timing information, while in the meantime its links and nodes have the same amount of information? Isn’t the existence of a topology depends on that of the nodes and links?

4)      underlay-path and underlay-backup-path both have a list of path elements. I think the first is working, is it? if so, could you rename the first as underlay-working-path? Alternatively, it would be better to put the two together and add a working/backup flag?

Will get a more detailed review once the text is updated together with the code.

Cheers,
Xian

From: Teas [mailto:[email-masked]] On Behalf Of Xufeng Liu
Sent: 2015年6月23日 4:23
To: [email-masked]
Subject: [Teas] Updating draft-ietf-teas-yang-te-topo-00

Hi Folks,

Regards,

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 1 Jul 2015 03:36:07 +0000

Hi Xian,

Thanks for the comments. Please check the replies below in-line.

Best,

- Xufeng

From: Zhangxian (Xian) [mailto:[email-masked]]
Sent: Friday, June 26, 2015 5:32 AM
To: Xufeng Liu
Cc: [email-masked]
Subject: RE: Updating draft-ietf-teas-yang-te-topo-00

1)      During last IETF presentation, Pavan mentioned the model will try to use the generic topology model. Is this going to happen in this version?  If not, what is your plan?
[Xufeng] The integration with the i2rs generic topology model is currently working in progress. We will report the status during IETF93.

2)      A topology is now identified via a triplet ( provider-id, client-id, te-topology-id). I fail to see client-id as an universal attribute. For example, if I am the provider and I have one or topology, so how do I fill in the client-id field?
[Xufeng] In that case, the client-id will be 0. Similar to  the Global_ID described in RFC6370, 0 means that the client-id is not specified.

3)      I thought schedule will go away in a newer version, but instead it is made as a feature. I can live with this option, but why does a topology has a detailed timing information, while in the meantime its links and nodes have the same amount of information? Isn’t the existence of a topology depends on that of the nodes and links?
[Xufeng] The schedule is still here because there has been no proper home for it. Topology, node, and link all have such a scheduling option so that each entity can be scheduled independently. There could be such a case when some links are removed but the topology remains.

4)      underlay-path and underlay-backup-path both have a list of path elements. I think the first is working, is it? if so, could you rename the first as underlay-working-path? Alternatively, it would be better to put the two together and add a working/backup flag?
[Xufeng] We have renamed them to underlay-primary-path and underlay-backup-path.

Cheers,
Xian

From: Teas [mailto:[email-masked]] On Behalf Of Xufeng Liu
Sent: 2015年6月23日 4:23
To: [email-masked]<mailto:[email-masked]>
Subject: [Teas] Updating draft-ietf-teas-yang-te-topo-00

Hi Folks,

Regards,