Subject: Re: [Teas] FW: New Version Notification for draft-lee-teas-actn-requirements-01.txt

From: Lou Berger <[email-masked]>
Date: Mon, 03 Aug 2015 07:53:46 -0400

ACTN Requirements Authors,
	It looks like a related draft,
draft-zhao-pce-central-controller-user-cases, will be coming over to
teas.  How do you think the use cases covered in that draft will impact
the your draft?

Thanks,
Lou

On 07/27/2015 03:19 PM, Leeyoung wrote:
> Hi TEAS WG,
> 
> This updated version incorporated all comments received during the WG session and off-line discussions. 
> 
> Major changes are:
> - add contributors and two new use-cases
> - incorporated all comments received in the mailing list (Kwangkook, Takuya, Yunbin)
> - Section 4 deleted
> - Section 3 updated: the scope of work in terms of Network Functions/YANG Models. 
> 
> The authors believe the draft is ready to be adopted as WG document. 
> 
> Thanks.
> Young (on behalf of authors/contributors).
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Monday, July 27, 2015 2:11 PM
> To: Daniele Ceccarelli; Dhruv Dhody; Leeyoung; Khuzema Pithewan; Daniele Ceccarelli; Dhruv Dhody; Leeyoung; Sergio Belotti; Khuzema Pithewan; Sergio Belotti
> Subject: New Version Notification for draft-lee-teas-actn-requirements-01.txt
> 
> 
> A new version of I-D, draft-lee-teas-actn-requirements-01.txt
> has been successfully submitted by Young Lee and posted to the
> IETF repository.
> 
> Name:		draft-lee-teas-actn-requirements
> Revision:	01
> Title:		Requirements for Abstraction and Control of Transport Networks
> Document date:	2015-07-27
> Group:		Individual Submission
> Pages:		22
> URL:            https://www.ietf.org/internet-drafts/draft-lee-teas-actn-requirements-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-lee-teas-actn-requirements/
> Htmlized:       https://tools.ietf.org/html/draft-lee-teas-actn-requirements-01
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-lee-teas-actn-requirements-01
> 
> Abstract:
>    This draft provides a set of requirements for abstraction and
>    control of transport networks.
> 
> 
> 
>                                                                                   
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 3 Aug 2015 20:15:32 +0530

Hi Lou,

Speaking only for myself and being involved in both efforts, I see PCECC as
a "PNC" in ACTN terms. The PCECC Extns, dealing with the southbound
interface between PCECC (PNC) and the NE (device). In its current state
PCECC and ACTN do not have any overlap and in fact they complement each
other.

Regards,
Dhruv

On Mon, Aug 3, 2015 at 5:23 PM, Lou Berger <[email-masked]> wrote:

> > To: Daniele Ceccarelli; Dhruv Dhody; Leeyoung; Khuzema Pithewan; Daniele
> Ceccarelli; Dhruv Dhody; Leeyoung; Sergio Belotti; Khuzema Pithewan; Sergio
> Belotti
> > URL:
> https://www.ietf.org/internet-drafts/draft-lee-teas-actn-requirements-01.txt
> > Status:
> https://datatracker.ietf.org/doc/draft-lee-teas-actn-requirements/
> > Htmlized:
> https://tools.ietf.org/html/draft-lee-teas-actn-requirements-01
> > Diff:
> https://www.ietf.org/rfcdiff?url2=draft-lee-teas-actn-requirements-01
> >
> > Abstract:

---

From: Leeyoung <[email-masked]>
Date: Mon, 3 Aug 2015 18:15:21 +0000

Hi Lou,

I think the draft you referred to generally covered by other use-cases especially on the multi-domain service controller (MDSC) functions such as DB/state sync. Between two controllers, etc. I don't think the current requirement draft will be affected too much. Label DB sync is a part of DB/State sync. 

Thanks.
Young

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Monday, August 03, 2015 6:54 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Teas] FW: New Version Notification for draft-lee-teas-actn-requirements-01.txt

Thanks,
Lou

---

From: Quintin zhao <[email-masked]>
Date: Mon, 3 Aug 2015 19:29:16 +0000

Hello Lou,

I agree what Dhruv summarized here and PCECC and ACTN complement each other.

The PCECC focuses on moving the existing MPLS control plan functionalities from the NE (devices) into the LSP central controller (PCECC) and simplifying them.  The use cases  for PCECC also mainly  focuses on the label resources (for the LSP and also MPLS services such as L3VPN and PWE3) and  LSP forwarding info management/allocation/distribution for all kind of LSPs including P2P,P2MP, MP2MP and SR based LSP.  The PCECC Extns leverages the existing PCEP for the southbound interface between LSP central controller and the NE.

Regards,
Quintin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: 2015年8月3日 10:46
To: Lou Berger
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Teas] FW: New Version Notification for draft-lee-teas-actn-requirements-01.txt

Hi Lou,

Speaking only for myself and being involved in both efforts, I see PCECC as a "PNC" in ACTN terms. The PCECC Extns, dealing with the southbound interface between PCECC (PNC) and the NE (device). In its current state PCECC and ACTN do not have any overlap and in fact they complement each other.

Regards,
Dhruv

On Mon, Aug 3, 2015 at 5:23 PM, Lou Berger <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Lou

On 07/27/2015 03:19 PM, Leeyoung wrote:
> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>
> The IETF Secretariat
>
> [email-masked]<mailto:[email-masked]>

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Tue, 4 Aug 2015 13:00:18 +0000

Hi Lou, Druhv,

speaking as co-author, I would tend to share Druhv’s view: I see the option proposed by draft-zhao-pce-central-controller-user-cases as special case of “PNC” and then the related interface is not part of ACTN context. Moreover use-cases is already part of a multi-domain use case related to MSDC controller so I do not see any further update needed .

On the other hand, as also said personally to authors of draft-zhang after presentation I consider the proposal of the draft as an extension of functionality of “PCE” as depicted in RFC 4655 Architecture, and a little not aligned with what instead proposed by RFC 7491 on ABNO architecture that I’m personally consider more close to an SDN architecture view . But this sorry falls a little outside of your question ..

From: [email-masked] [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: lunedì 3 agosto 2015 16:46
To: Lou Berger
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Teas] FW: New Version Notification for draft-lee-teas-actn-requirements-01.txt

Hi Lou,

Regards,
Dhruv

Thanks,
Lou