Subject: [Teas] Initial version for liaison text //答复: CALL FOR VOLUNTEER - New Liaison Statement, "Achieving Packet Network Optimization using DWDM Interfaces"

From: Zhenghaomian <[email-masked]>
Date: Tue, 27 Oct 2015 09:16:52 +0000

Hi, All,

After reviewing the liaison and document from BBF, we would like to provide the following text as an initial version for response. Please help review, your comments are highly welcomed. 

=====================================for discussion================================================
The working groups in IETF routing area would like to thank you for sending this liaison. We much appreciate BBF on the effort of packet over optical, and sending the document to IETF CCAMP, TEAS and PCE WGs for review. This project defines a set of control plane requirements that the Physically Separated Model should be satisfied. We are generally fine about the content, with some minor suggestions listed as follow for your reference: 

• When referring to PCE and related issues, e.g., in [R-26] and [R-27], it seems only stateless PCE (RFC4655) and corresponding PCEP (RFC5520) are included in the current version. As IETF PCE working group is investigating on stateful PCE, PCE Initiation and PCE as a Central Controller, which are planned to be published in the future, it is better to specify which kind of PCE is now referred by this documents. Moreover, RFC 5623, PCE-based inter-layer MPLS and GMPLS Traffic Engineering, may be a good reference for this document. 
• In section 4.4 when talking about SDN, Openflow is mentioned as a standard protocol to interact between packet nodes and DWDM nodes. We would like to suggest add PCE Protocol (PCEP) as another example, as it is currently used in IETF. Besides, it is suggest to reference to RFC 3413 about SNMP, and RFC 4208 about GMPLS UNI. 
• In section 4.5, [R-36] is not clear whether to be applied to the north-bound of SDN controller, or between the packet NE and SDN controller. We prefer the latter one. 

It seems to us the requirements proposed in the current document could be addressed by the referenced RFCs defined for GMPLS, so we would like to make sure if you have identified any gaps, which need an update on GMPLS to satisfy these requirements. IETF CCAMP is discussing to define a framework for Management and Control of DWDM optical interface parameters and GMPLS protocols that need to be updated, which might be relevant to your project, but this work in CCAMP is still in individual drafts stage. We would like to receive your input. 
==================================================================================================================

Thanks.

Best wishes,
Haomian

-----邮件原件-----
发件人: Zhenghaomian 
发送时间: 2015年10月21日 11:11
收件人: Daniele Ceccarelli; Fatai Zhang
抄送: [email-masked]
主题: 答复: CALL FOR VOLUNTEER - New Liaison Statement, "Achieving Packet Network Optimization using DWDM Interfaces"

Daniele, Fatai and All,

I would like to volunteer for generating the response liaison, as the topic is highly related to my research work. I will review the document and share my comments early next week. Please also feel free to share your opinion, thanks. 

Best wishes,
Haomian

-----邮件原件-----
发件人: CCAMP [mailto:[email-masked]] 代表 Daniele Ceccarelli
发送时间: 2015年10月20日 23:46
收件人: CCAMP ([email-masked])
主题: [CCAMP] CALL FOR VOLUNTEER - New Liaison Statement, "Achieving Packet Network Optimization using DWDM Interfaces"

WG,

We received this liaison from BBF on Packet-Optical integration. 
I'm copying the links to liaison and attachment here for your convenience
Liaison:  https://datatracker.ietf.org/liaison/1432/
Attachment: https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2015-10-16-broadband-forum-rtg-ccamp-teas-achieving-packet-network-optimization-using-dwdm-interfaces-attachment-1.pdf

We'd really like 1 or 2 volunteers interested in the topic to draft an answer to the liaison before the meeting in Yokohama so to be able to discuss it on the list and reply during or immediately after the meeting.

Please consider volunteering.
Thanks
Fatai & Daniele

> -----Original Message-----
> From: Liaison Statement Management Tool [mailto:[email-masked]]
> Sent: venerdì 16 ottobre 2015 22:05
> To: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; Daniele 
> Ceccarelli
> Cc: Alvaro Retana; Deborah Brungard; David Sinicrope; Fatai Zhang; 
> Alia Atlas; Vishnu Pavan Beeram; The IETF Chair; Daniele Ceccarelli; 
> Lou Berger; Common Control and Measurement Plane Discussion List; 
> [email-masked]; Traffic Engineering Architecture and 
> Signaling Discussion List
> Subject: New Liaison Statement, "Achieving Packet Network Optimization 
> using DWDM Interfaces"
> 
> Title: Achieving Packet Network Optimization using DWDM Interfaces 
> Submission Date: 2015-10-16 URL of the IETF Web page:
> https://datatracker.ietf.org/liaison/1432/
> Please reply by 2015-11-08
> From:  (David Sinicrope <[email-masked]>)
> To:  ([email-masked], [email-masked], [email-masked], 
> [email-masked], [email-masked], [email-masked],
> [email-masked])
> Cc:
> Response Contacts: [email-masked] Technical Contacts:
> Purpose: For comment
> 
> Body: Dear IETF Routing Area and Working Group Leaders:
> 
> As previously communicated, we have been working on a project entitled 
> “Achieving Packet Network Optimization using DWDM Interfaces” and are 
> referencing work being done by IETF CCAMP and TEAS in this area. We 
> are pleased to report that we have made significant progress towards 
> completion of our specifications. Specifically,
> 
> o TR-319 Base, “Achieving Packet Network Optimization using DWDM 
> Interfaces”, was published June 2015 o TR-319 Part A, “Achieving 
> Packet Network Optimization using DWDM Interfaces – Physically 
> Integrated Model”, was published June 2015
> 
> WT-319 Part B, Achieving Packet Network Optimization using DWDM 
> Interfaces – Physically Separated, Logically Separated, is undergoing 
> Straw Ballot (similar to IETF WG Last Call), and we are attaching it for your review and comment.
> 
> Our ballot period closes on November 8, 2015. If it is at all 
> possible, we would appreciate and look forward to any input in time 
> for our ballot close. The next meeting of BBF occurs November 16, 
> 2015. A schedule of our future meetings appears below.
> 
> We want to express our appreciation for your continued consideration 
> of this important topic.
> 
> Sincerely,
> Michael Fargano,
> Broadband Forum Technical Committee Chair
> 
> Date of Upcoming Broadband Forum Meetings DATES LOCATION November 16 – 
> 20, 2015 Puerto Vallarta, Mexico February 1 – 5, 2016 Asia Pac 
> (precise location TBD)
> 
> Note: A list of upcoming meetings can also be found at 
> http://www.broadbandforum.
> org/meetings/upcomingmeetingsataglance.php
> 
> Attachments:
> § WT-319 Part B Straw Ballot Text (bbf2015.071.07)
> Attachments:
> 
>     Attachment
>     https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2015-10-16-
> broadband-forum-rtg-ccamp-teas-achieving-packet-network-optimization-
> using-dwdm-interfaces-attachment-1.pdf
> 
>     Statement
>     https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2015-10-16-
> broadband-forum-rtg-ccamp-teas-achieving-packet-network-optimization-
> using-dwdm-interfaces-attachment-2.pdf

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Daniele Ceccarelli <[email-masked]>
Date: Sun, 1 Nov 2015 03:27:05 +0000

Hi Haomian, all,

Thanks for starting putting together the reply. Please find some updated proposals from my side.

===========================

The working groups in IETF routing area would like to thank you for sending this liaison. We much appreciate BBF on the effort of packet over optical, and sending the document to IETF CCAMP, TEAS and PCE WGs for review. This project defines a set of control plane requirements that the Physically Separated Model should be satisfied. We have some questions and comments:

Questions:

·         It is not clear to us how the communication between the packet layer and the optical layer occurs. E.g. control channels, signaling and so on.

·         We would like to see some more details on the management aspects between the packet domain and the optical domain.

Comments:

·         When referring to PCE and related issues, e.g., in [R-26] and [R-27], it seems only stateless PCE (RFC4655) and corresponding PCEP (RFC5520) are included in the current version. As IETF PCE working group is investigating on stateful PCE, PCE Initiation and PCE as a Central Controller, which are planned to be published in the future, it is better to specify which kind of PCE is now referred by this documents. Moreover, RFC 5623, PCE-based inter-layer MPLS and GMPLS Traffic Engineering, may be a good reference for this document.

·         In section 4.4 when talking about SDN, Openflow is mentioned as a standard protocol to interact between packet nodes and DWDM nodes. We would like to suggest add PCE Protocol (PCEP) as another example, as it is currently used in IETF. Besides, it is suggest to reference to RFC 3413 about SNMP, and RFC 4208 about GMPLS UNI.

·         In section 4.5, [R-36] is not clear whether to be applied to the north-bound of SDN controller, or between the packet NE and SDN controller. We prefer the latter one.

It seems to us the requirements proposed in the current document could be addressed by the referenced RFCs defined for GMPLS, so we would like to make sure if you have identified any gaps, which need an update on GMPLS/PCEP to satisfy these requirements. IETF CCAMP is discussing to define a framework for Management and Control of DWDM optical interface parameters and GMPLS protocols that need to be updated, which might be relevant to your project, but this work in CCAMP is still in individual drafts stage. We would like to receive your input.

============================

Thanks

Daniele

> From: CCAMP [mailto:[email-masked]] On Behalf Of Zhenghaomian

> Sent: martedì 27 ottobre 2015 18:17

> To: [email-masked]'; [email-masked]; TEAS WG

> Subject: [CCAMP] Initial version for liaison text //答复: CALL FOR

> VOLUNTEER - New Liaison Statement, "Achieving Packet Network

> Optimization using DWDM Interfaces"

> After reviewing the liaison and document from BBF, we would like to provide

> the following text as an initial version for response. Please help review, your

> comments are highly welcomed.

> =====================================for

> discussion================================================

> The working groups in IETF routing area would like to thank you for sending

> this liaison. We much appreciate BBF on the effort of packet over optical, and

> sending the document to IETF CCAMP, TEAS and PCE WGs for review. This

> project defines a set of control plane requirements that the Physically

> Separated Model should be satisfied. We are generally fine about the

> content, with some minor suggestions listed as follow for your reference:

> • When referring to PCE and related issues, e.g., in [R-26] and [R-27], it

> seems only stateless PCE (RFC4655) and corresponding PCEP (RFC5520) are

> included in the current version. As IETF PCE working group is investigating on

> stateful PCE, PCE Initiation and PCE as a Central Controller, which are planned

> to be published in the future, it is better to specify which kind of PCE is now

> referred by this documents. Moreover, RFC 5623, PCE-based inter-layer

> MPLS and GMPLS Traffic Engineering, may be a good reference for this

> document.

> • In section 4.4 when talking about SDN, Openflow is mentioned as a

> standard protocol to interact between packet nodes and DWDM nodes. We

> would like to suggest add PCE Protocol (PCEP) as another example, as it is

> currently used in IETF. Besides, it is suggest to reference to RFC 3413 about

> SNMP, and RFC 4208 about GMPLS UNI.

> • In section 4.5, [R-36] is not clear whether to be applied to the north-bound

> of SDN controller, or between the packet NE and SDN controller. We prefer

> the latter one.

> It seems to us the requirements proposed in the current document could be

> addressed by the referenced RFCs defined for GMPLS, so we would like to

> make sure if you have identified any gaps, which need an update on GMPLS

> to satisfy these requirements. IETF CCAMP is discussing to define a

> framework for Management and Control of DWDM optical interface

> parameters and GMPLS protocols that need to be updated, which might be

> relevant to your project, but this work in CCAMP is still in individual drafts

> stage. We would like to receive your input.

> ==========================================================

> ========================================================

> 抄送: [email-masked]<mailto:[email-masked]>

> 主题: 答复: CALL FOR VOLUNTEER - New Liaison Statement, "Achieving

> Packet Network Optimization using DWDM Interfaces"

> I would like to volunteer for generating the response liaison, as the topic is

> highly related to my research work. I will review the document and share my

> comments early next week. Please also feel free to share your opinion,

> thanks.

> 收件人: CCAMP ([email-masked]<mailto:[email-masked]>)

> 主题: [CCAMP] CALL FOR VOLUNTEER - New Liaison Statement, "Achieving

> Packet Network Optimization using DWDM Interfaces"

> Attachment: https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2015-<https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2015-10-16-broadband-forum-rtg-ccamp-teas-achieving-packet-network-optimization-using-dwdm-interfaces-attachment-1.pdf>

> 10-16-broadband-forum-rtg-ccamp-teas-achieving-packet-network-<https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2015-10-16-broadband-forum-rtg-ccamp-teas-achieving-packet-network-optimization-using-dwdm-interfaces-attachment-1.pdf>

> optimization-using-dwdm-interfaces-attachment-1.pdf<https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2015-10-16-broadband-forum-rtg-ccamp-teas-achieving-packet-network-optimization-using-dwdm-interfaces-attachment-1.pdf>

> We'd really like 1 or 2 volunteers interested in the topic to draft an answer to

> the liaison before the meeting in Yokohama so to be able to discuss it on the

> list and reply during or immediately after the meeting.

> > To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>;

> > [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Daniele

> > [email-masked]<mailto:[email-masked]>; Traffic Engineering Architecture and

> > From:  (David Sinicrope <[email-masked]<mailto:[email-masked]>>)

> > To:  ([email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>,

> > [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>,

> > [email-masked]<mailto:[email-masked]>)

> > Response Contacts: [email-masked]<mailto:[email-masked]> Technical Contacts:

> > Straw Ballot (similar to IETF WG Last Call), and we are attaching it for your

> review and comment.

> > Date of Upcoming Broadband Forum Meetings DATES LOCATION

> November 16 –

> [email-masked]<mailto:[email-masked]>

> [email-masked]<mailto:[email-masked]>

---

From: Zhenghaomian <[email-masked]>
Date: Sun, 1 Nov 2015 04:42:34 +0000

Thanks Daniele,

Incorporate Dhruv’s nit, the PCEP RFC no. is corrected to RFC 5440.  Further comments welcomed☺

Questions:

Comments:

·         When referring to PCE and related issues, e.g., in [R-26] and [R-27], it seems only stateless PCE (RFC4655) and corresponding PCEP (RFC5440) are included in the current version. As IETF PCE working group is investigating on stateful PCE, PCE Initiation and PCE as a Central Controller, which are planned to be published in the future, it is better to specify which kind of PCE is now referred by this documents. Moreover, RFC 5623, PCE-based inter-layer MPLS and GMPLS Traffic Engineering, may be a good reference for this document.

Thanks.

Best wishes,
Haomian

发件人: Daniele Ceccarelli [mailto:[email-masked]]
发送时间: 2015年11月1日 11:27
收件人: Zhenghaomian; [email-masked]'; [email-masked]; TEAS WG
主题: RE: Initial version for liaison text //答复: CALL FOR VOLUNTEER - New Liaison Statement, "Achieving Packet Network Optimization using DWDM Interfaces"

Hi Haomian, all,

Questions:

Comments:

Thanks

Daniele

> To: [email-masked]'; [email-masked]<mailto:[email-masked]>; TEAS WG