Subject: [Teas] Fwd: [i2rs] WG LC for Topology (10/1 to 10/14)

From: Lou Berger <[email-masked]>
Date: Thu, 8 Oct 2015 14:01:47 -0400

WG, Authors,

    Note that the base I2RS topology models are in LC in I2RS.  I know
that there's been some discussion on expected / desired changes to those
models to support TE Topology.  Now is the time to make your
comments/desired changes known.

Please send comments [email-masked].  cc this list (teas) if you think
draft-ietf-teas-yang-te-topo will be directly impacted.

Thank you!

Lou
-------- Forwarded Message --------
Subject: 	[i2rs] WG LC for Topology (10/1 to 10/14)
Date: 	Thu, 1 Oct 2015 18:41:34 -0400
From: 	Susan Hares <[email-masked]>
To: 	[email-masked]
CC: 	'Jeffrey Haas' <[email-masked]>, 'Alia Atlas' <[email-masked]>

This begins a 2 week WG Last call (10/1 to 10/14)

draft-ietf-yang-network-topo – modeling draft

http://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/

draft-ietf-i2rs-yang-l3-topology – L3 topology

http://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/

draft-ietf-i2rs-yang-l2-topology – L2 topology

http://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/

Implementation status:

This an OpenDaylight (ODL) implementation of the L3 topology and general
model.  It is likely the L2 topology model will be supported in future
ODL implementations.   Jeff and I would appreciate anyone who has
implementations of these topology models to provide details on list or
offlist to the chairs.

Sue Hares

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Fri, 9 Oct 2015 02:20:19 +0000

Hi, Xufeng, Alex,

Thank you for taking the effort to work toward getting aligned as discussed in last meeting.   I have some comments on some of the conclusions.

Could you share a bit more on reasons behind Point 3 conclusion?

For points 4 and 5, I think they are related. My understanding is that for ietf-network, it does not follow the method taken by YANG modules such as ietf-interface and ietf-te-topology, in which each –rw leaf will have a corresponding –ro leaf. Instead, it choose to use the “server-provided” attribute to say whether all the leafs in the module is configurable or state. I am not sure I understand the conclusion of these two points. Do you agree that both methods are acceptable?

One last comment on point 6: is this for future-proofness or you have already have some attributes in mind that can apply to all networks?

Thank you,
Xian

From: i2rs [mailto:[email-masked]] On Behalf Of Xufeng Liu
Sent: 2015年10月9日 4:15
To: Susan Hares; [email-masked]
Cc: 'Jeffrey Haas'; 'Alia Atlas'
Subject: Re: [i2rs] WG LC for Topology (10/1 to 10/14)

Hi Folks,

The following is an update on the ongoing I2RS<=>TE Topology alignment discussion (between the authors of the TE Topology model and Alex).

The issues / solutions that are currently being discussed are:

I2RS Generic Network Topology Model (draft-ietf-yang-network-topo):

1.      Some groupings in ietf-network.yang and ietf-network-topology.yang cannot be used in augmenting module because of missing name spaces, such as “path "/network/network-id" at line 42 of ietf-network.yang.
Solution: Proposed fixes have been sent to Alex to verify.

2.      “leaf network-ref” in ietf-network-topology.yang:169, 220, is causing pyang validation errors.
Solution: Alex will check the errors.

3.      Can the group of schedule attributes be moved from ietf-te-topology.yang to ietf-network-topology.yang?
Solution: We agreed to keep them in ietf-te-topology.yang.

4.      How to support state branch in augmenting module?
Solution: Keep base model ietf-network-topology.yang as is. In the augmenting module, for each entity like topology, node and link, create a config container for configuration attributes and a state container for operational state attributes.

5.      Should “server-provided” flag be used to block user operation on read-only entities?
Solution: Keep base model ietf-network-topology.yang as is. TE topology will use other means to achieve such a purpose.

6.      Should I2RS Generic Network Topology model have a top-level container? The benefit of doing so is to provide an augmentation target node to define attributes global to all networks.
Solution: I2RS Generic Network Topology module authors will consider making “/networks” as the top level container.

L3 Topology Model (draft-ietf-i2rs-yang-l3-topology)

1.      L3 Topology Model should have references to TE Topology model, so that the related TE information can be properly retrieved, when L3 topology and TE topology are congruent.
Solution: L3 Topology Model authors will need to update the model and draft to include these.

L2 Topology Model (draft-ietf-i2rs-yang-l2-topology)

1.      L2 Topology Model should have references to TE Topology model, so that the related TE information can be properly retrieved, when L2 topology and TE topology are congruent.
Solution: This needs to be discussed with L2 Topology Model authors.

Regards,
- Xufeng (on behalf of the authors of the TE Topology Model)

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, October 01, 2015 6:42 PM
To: [email-masked]
Cc: 'Jeffrey Haas'; 'Alia Atlas'
Subject: [i2rs] WG LC for Topology (10/1 to 10/14)

Implementation status:

This an OpenDaylight (ODL) implementation of the L3 topology and general model.  It is likely the L2 topology model will be supported in future ODL implementations.   Jeff and I would appreciate anyone who has implementations of these topology models to provide details on list or offlist to the chairs.

Sue Hares

---

From: Xufeng Liu <[email-masked]>
Date: Tue, 13 Oct 2015 03:15:24 +0000

Hi Xian,

Responding on item 6 inline below.
Thanks,

- Xufeng

From: Alexander Clemm (alex) [mailto:[email-masked]]
Sent: Friday, October 09, 2015 8:21 PM
To: Zhangxian (Xian); Xufeng Liu; Susan Hares; [email-masked]
Cc: 'Jeffrey Haas'; TEAS WG; 'Alia Atlas'
Subject: RE: [i2rs] WG LC for Topology (10/1 to 10/14)

Hi Xian,

responses inline, <ALEX>

Thanks
--- Alex

From: i2rs [mailto:[email-masked]] On Behalf Of Zhangxian (Xian)
Sent: Thursday, October 08, 2015 7:20 PM
To: Xufeng Liu <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: 'Jeffrey Haas' <[email-masked]<mailto:[email-masked]>>; TEAS WG <[email-masked]<mailto:[email-masked]>>; 'Alia Atlas' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [i2rs] WG LC for Topology (10/1 to 10/14)

Hi, Xufeng, Alex,

<ALEX> The reason is that the schedule stuff, while generic / non-specific to any specific topology, is not “common”, i.e. does not apply to all topologies/ every instantiation of the model.  The goal is to have ietf-network-topology refer to the stuff that is truly common.
</ALEX>

<ALEX> There is no operational data defined.  The server-provided attributed guides whether network topology information is populated by the server or by the client application, but the information is the same – this not the config vs oper data (read: stats) separation.  To add stats, you should provide an additional subtree/branch as applicable when you are augmenting.
</ALEX>

<ALEX>
I’ll let Xufeng respond to that one.  We did not have a top-level container because it keeps paths shorter (one less level in the hierarchy) and because if you wanted to insert something at the “top level”, you could always do it in parallel.  I still think this is the design that’s preferable.
That said, having a top-level container may not really hurt.  There were concerns regarding the ramification to existing implementations of the model (notably, Open Daylight) if we were to add it but it seems the fallout would be manageable.

Thanks, Alex (end of my comments)
</ALEX>
[Xufeng] This is for both future-proofness and current requirement. To allow operator easily configure TE topology attributes, we are defining templates that can be applied to all networks.

Thank you,
Xian

From: i2rs [mailto:[email-masked]] On Behalf Of Xufeng Liu
Sent: 2015年10月9日 4:15
To: Susan Hares; [email-masked]<mailto:[email-masked]>
Cc: 'Jeffrey Haas'; 'Alia Atlas'
Subject: Re: [i2rs] WG LC for Topology (10/1 to 10/14)

Hi Folks,

Regards,

To: [email-masked]<mailto:[email-masked]>

Implementation status:

Sue Hares