Subject: [Teas] FW: New Version Notification for draft-ietf-mpls-residence-time-05.txt

From: Gregory Mirsky <[email-masked]>
Date: Tue, 15 Mar 2016 21:13:49 +0000

Hi,
this version primarily addresses comments related to the proposed extensions to RSVP-TE and operation of the control plane in support of Residence Time Measurement. Would appreciate the confirmation from Lou.

Authors always welcome comments and questions about RTM.

	Regards,
		Greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, March 15, 2016 2:08 PM
To: Alexander Vainshtein; Gregory Mirsky; Stefano Ruffini; John Drake; Sasha Vainshtein; Eric Gray; Stewart Bryant; Eric Gray
Subject: New Version Notification for draft-ietf-mpls-residence-time-05.txt

A new version of I-D, draft-ietf-mpls-residence-time-05.txt
has been successfully submitted by Greg Mirsky and posted to the IETF repository.

Name:		draft-ietf-mpls-residence-time
Revision:	05
Title:		Residence Time Measurement in MPLS network
Document date:	2016-03-15
Group:		mpls
Pages:		26
URL:            https://www.ietf.org/internet-drafts/draft-ietf-mpls-residence-time-05.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-mpls-residence-time/
Htmlized:       https://tools.ietf.org/html/draft-ietf-mpls-residence-time-05
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-mpls-residence-time-05

Abstract:
   This document specifies G-ACh based Residence Time Measurement and
   how it can be used by time synchronization protocols being
   transported over MPLS domain.

   Residence time is the variable part of propagation delay of timing
   and synchronization messages and knowing what this delay is for each
   message allows for a more accurate determination of the delay to be
   taken into account in applying the value included in a PTP event
   message.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Lou Berger <[email-masked]>
Date: Tue, 15 Mar 2016 18:40:43 -0400

Greg,

I don't think I saw a response to:
> I think this doesn't always work, e.g., when RRO is modified due to
> policy or limited due to size constraints.  This has to be addressed.  I
> can see how to easily detect this situation, but not how to get the
> number of non-supporting hops.  I guess it's always possible to play ttl
> comparison games, but that's pretty ugly too.  Any thoughts?

Parts of Sections 4.6 and 4.7 are a bit rough and could stand a reread
and editorial pass.

Section 4.7 says PathErr messages are sent in response to Resv
processing error.  This is clearly wrong.

Lou

> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 15 Mar 2016 22:55:39 +0000

Hi Lou,

thank you for the most detailed comments. Please find my notes in-line tagged GIM>>.

                Regards,

                                Greg

-----Original Message-----
From: Lou Berger [mailto:[email-masked]]
Sent: Tuesday, March 15, 2016 3:41 PM
To: Gregory Mirsky; Loa Andersson; [email-masked]
Cc: [email-masked]; TEAS WG
Subject: Re: [Teas] FW: New Version Notification for draft-ietf-mpls-residence-time-05.txt

Greg,

> policy or limited due to size constraints.  This has to be addressed.

> I can see how to easily detect this situation, but not how to get the

> number of non-supporting hops.  I guess it's always possible to play

> ttl comparison games, but that's pretty ugly too.  Any thoughts?

GIM>> The following text in Section 4.7 intended to handle the situation you've described:

   If the node cannot find matching ID in RRO,

   then it MUST try to use ID of the next node in the RTM_SET until it

   finds the match or reaches the end of RTM_SET TLV.  If match have

   been found, then the calculated value is used by the node as TTL

   value in outgoing label to reach the next RTM capable node on the

   LSP.  Otherwise, the TTL value MUST be set to 255.

In essence, the node tries to locate the closest to it downstream RTM-capable node. Otherwise, it sets TTL to 255 so that the RTM packets arrive at egress LER.

Parts of Sections 4.6 and 4.7 are a bit rough and could stand a reread and editorial pass.

GIM>> I'm trying.

Section 4.7 says PathErr messages are sent in response to Resv processing error.  This is clearly wrong.

GIM>> Great catch! I'm ready to update to ResvErr in -06.

Lou

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]

> To: Alexander Vainshtein; Gregory Mirsky; Stefano Ruffini; John Drake;

> Sasha Vainshtein; Eric Gray; Stewart Bryant; Eric Gray

> Subject: New Version Notification for

> draft-ietf-mpls-residence-time-05.txt

> [email-masked]<mailto:[email-masked]>

---

From: Lou Berger <[email-masked]>
Date: Wed, 16 Mar 2016 08:29:41 -0400

Greg,

Thanks for the response.  See below.

On March 15, 2016 6:56:34 PM Gregory Mirsky
<[email-masked]> wrote:

> > this version primarily addresses comments related to the proposed
> extensions to RSVP-TE and operation of the control plane in support of
> Residence Time Measurement. Would appreciate the confirmation from Lou.
>
>  
>
> GIM>> The following text in Section 4.7 intended to handle the
> situation you’ve described:
>
> In essence, the node tries to locate the closest to it downstream
> RTM-capable node. Otherwise, it sets TTL to 255 so that the RTM
> packets arrive at egress LER.
>

So this doesn't cover the case where there are holes in the RRO -- which
I think then translates to RTM black holes.  Also not covered is what
happens during Resv processing if there is no room (or a policy) against
adding local information.

Perhaps it would just be better to add a section that explicitly states
that the defined mechanism only works  in cases where full RRO is
supported (i.e., where RRO is not limited due to size constraints or
otherwise impacted due to policy)? -- not saying I like this, I just
think it fills the open gaps in the spec - but at the price of limiting
applicability.  I haven't spent too much time thinking about this so
there may be a better solution out there.

Lou

> GIM>> I’m trying.
> GIM>> Great catch! I’m ready to update to ResvErr in -06.
>
>  
>
> Lou
>
>  
>
> > From: [email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]]
>
> > URL:           
> https://www.ietf.org/internet-drafts/draft-ietf-mpls-residence-time-05.txt
>
> > Status:        
> https://datatracker.ietf.org/doc/draft-ietf-mpls-residence-time/
>
> > Htmlized:      
> https://tools.ietf.org/html/draft-ietf-mpls-residence-time-05
>
> > Diff:          
> https://www.ietf.org/rfcdiff?url2=draft-ietf-mpls-residence-time-05
>
> > 
>
> > Abstract:
>
> > Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> > 
>
> > The IETF Secretariat
>
> > 
>
> > [email-masked] <mailto:[email-masked]>
>
> [email-masked] <mailto:Teas%40ietf.org>

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 16 Mar 2016 14:15:24 +0000

Hi Lou,
thank you for the detailed explanation of the case. I agree that there could be other ways to handle it from what been described in the document. If a node ID of the first node in the RTM_SET TLV is not found in the RRO list, then the TTL will be set to 255 and packet will not be processed by intermediate RTM-capable nodes but arrive at LSP egress LSR. Thus not all RTM capable nodes will be accounted for in the Scratch Pad but still some nodes may. I'll add some text to highlight this case.

	Regards,
		Greg

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Wednesday, March 16, 2016 5:30 AM
To: Gregory Mirsky; Loa Andersson; [email-masked]
Cc: [email-masked]; TEAS WG
Subject: Re: [Teas] FW: New Version Notification for draft-ietf-mpls-residence-time-05.txt

Greg,

On March 15, 2016 6:56:34 PM Gregory Mirsky <[email-masked]> wrote:

> situation you've described:
>

So this doesn't cover the case where there are holes in the RRO -- which I think then translates to RTM black holes.  Also not covered is what happens during Resv processing if there is no room (or a policy) against adding local information.

Perhaps it would just be better to add a section that explicitly states that the defined mechanism only works  in cases where full RRO is supported (i.e., where RRO is not limited due to size constraints or otherwise impacted due to policy)? -- not saying I like this, I just think it fills the open gaps in the spec - but at the price of limiting applicability.  I haven't spent too much time thinking about this so there may be a better solution out there.

Lou

---

From: Lou Berger <[email-masked]>
Date: Wed, 16 Mar 2016 10:18:46 -0400

Greg,
    What happens when some information is removed from an RRO due to
policy processing (e.g., as may happen between providers).  Couldn't the
TTL calculation some up too small if the wrong SOs are removed, and
wouldn't this result in a black hole of actual RTM messages?  How do you
cover this case?

Thanks,
Lou

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 16 Mar 2016 14:23:40 +0000

Hi Lou,
if node A is on RTM_SET TLV but not in RRO, then its first upstream RTM-capable node, e.g. node B, would set TTL to 255 according to the text. Thus there will be no RTM processing downstream of node B and all packets will be arriving at the egress LER in RTM encapsulation.

	Regards,
		Greg

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Wednesday, March 16, 2016 7:19 AM
To: Gregory Mirsky; Loa Andersson; [email-masked]
Cc: [email-masked]; TEAS WG
Subject: Re: [Teas] FW: New Version Notification for draft-ietf-mpls-residence-time-05.txt

Greg,
    What happens when some information is removed from an RRO due to policy processing (e.g., as may happen between providers).  Couldn't the TTL calculation some up too small if the wrong SOs are removed, and wouldn't this result in a black hole of actual RTM messages?  How do you cover this case?

Thanks,
Lou

On 3/16/2016 10:15 AM, Gregory Mirsky wrote:
>> extensions to RSVP-TE and operation of the control plane in support 
>> of Residence Time Measurement. Would appreciate the confirmation from Lou.
>>
>>  
>>
>>> I can see how to easily detect this situation, but not how to get 
>>> the number of non-supporting hops.  I guess it's always possible to 
>>> play ttl comparison games, but that's pretty ugly too.  Any 
>>> thoughts?
>>> To: Alexander Vainshtein; Gregory Mirsky; Stefano Ruffini; John 
>>> Drake; Sasha Vainshtein; Eric Gray; Stewart Bryant; Eric Gray

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 16 Mar 2016 19:11:46 +0000

Hi Lou,
following the discussion we propose the following new paragraph before Section 4.7.1:
   There are scenarios when some information is removed from an RRO due
   to policy processing (e.g., as may happen between providers) or RRO
   is limited due to size constraints .  Such changes affect the core
   assumption of the method to control processing of RTM packets.  RTM
   SHOULD NOT be used if it is not guaranteed that RRO contains complete
   information.

Hope that would address your concern with potential blackholed RTM packets.

	Regards,
		Greg

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Wednesday, March 16, 2016 7:19 AM
To: Gregory Mirsky; Loa Andersson; [email-masked]
Cc: [email-masked]; TEAS WG
Subject: Re: [Teas] FW: New Version Notification for draft-ietf-mpls-residence-time-05.txt

Greg,

Thanks,
Lou

---

From: Lou Berger <[email-masked]>
Date: Fri, 25 Mar 2016 08:50:55 -0400

Greg,
    Sorry for not responding before the ID cutoff. 

I think this is fine, but why not go a step further and have the nodes
that have the limitation indicate that RTM can't be used, e.g., clear
the RTM_SET  Attribute Flag and/or remove the RTM_SET TLV to notify the
ingress of the issue.  This would allow the automatic detection of the
(corner) cases were there are actual issues and let RTM operate properly
in the common case.

Lou

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 25 Mar 2016 16:52:07 +0000

Hi Lou,
Greatly appreciate you've found time during these extremely busy days before the IETF meeting.

I agree, that there could be different ways a node can handle the RRO limitation. I addition to those you've suggested node may change RTM Capability state advertised in IGP-TE. I think that the choice can be left to a developer.

I've published the -06 version with all updates noted in my mail before the cut-off and if you agree with the changes perhaps Loa can start the WGLC at the most suitable time.

	Regards,
		Greg

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Friday, March 25, 2016 5:51 AM
To: Gregory Mirsky; Loa Andersson; [email-masked]
Cc: [email-masked]; TEAS WG
Subject: Re: [Teas] FW: New Version Notification for draft-ietf-mpls-residence-time-05.txt

Greg,

I think this is fine, but why not go a step further and have the nodes that have the limitation indicate that RTM can't be used, e.g., clear the RTM_SET  Attribute Flag and/or remove the RTM_SET TLV to notify the ingress of the issue.  This would allow the automatic detection of the
(corner) cases were there are actual issues and let RTM operate properly in the common case.

Lou

On 3/16/2016 3:11 PM, Gregory Mirsky wrote:
>>> https://www.ietf.org/internet-drafts/draft-ietf-mpls-residence-time-
>>> 05
>>> .txt
>>>
>>>> Status:

---

From: Lou Berger <[email-masked]>
Date: Fri, 25 Mar 2016 12:58:10 -0400

Greg,

> I agree, that there could be different ways a node can handle the RRO limitation. I addition to those you've suggested node may change RTM Capability state advertised in IGP-TE. I think that the ch…

I think the RSVP change should be in the draft as it impacts
interoperability and expected behavior.

Once this change is made I think the draft will be ready to progress.

Lou

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 25 Mar 2016 20:51:41 +0000

Hi Lou,
I'll work on the update and will post after the meeting.

	Regards,
		Greg

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Friday, March 25, 2016 9:58 AM
To: Gregory Mirsky; Loa Andersson; [email-masked]
Cc: [email-masked]; TEAS WG
Subject: Re: [Teas] FW: New Version Notification for draft-ietf-mpls-residence-time-05.txt

Greg,

> I agree, that there could be different ways a node can handle the RRO limitation. I addition to those you've suggested node may change RTM Capability state advertised in IGP-TE. I think that the ch…

I think the RSVP change should be in the draft as it impacts interoperability and expected behavior.

Lou

> the RTM_SET  Attribute Flag and/or remove the RTM_SET TLV to notify 
> the ingress of the issue.  This would allow the automatic detection of 
> the
>>>>> I think this doesn't always work, e.g., when RRO is modified due 
>>>>> to policy or limited due to size constraints.  This has to be addressed.
>>>>> the number of non-supporting hops.  I guess it's always possible 
>>>>> to play ttl comparison games, but that's pretty ugly too.  Any 
>>>>> thoughts?

---

From: Lou Berger <[email-masked]>
Date: Fri, 25 Mar 2016 16:58:48 -0400

Great, thank you.  Feel free to unicast me a diff if you'd like.

Lou