Subject: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

From: Dieter Beller <[email-masked]>
Date: Tue, 1 Mar 2016 14:45:14 +0100

Hi TEAS WG,

as suggested by Lou, I am sharing with you some slides describing single 
layer and multi layer use cases, which were discussed during
the IETF TE Topology YANG Model Design Meeting yesterday.

The first 2 slides address (sub-)network abstraction and propose to use 
the connectivity matrix in case the resulting abstract node is
not blocking free.

The remaining slides are describing multi-layer network scenarios where 
a server layer trail is established in order to carry client layer
connections. In order to support multi-layer path computation, 
transitional links are proposed, which allow the construction of a
multi-layer network topology graph. Transitional links connect the 
topology graphs of two adjacent network layers. They are created
based on the capability of a node to encapsulate a client layer signal 
into a server layer signal. Exampleas are: IP in MPLS, OTN ODUk
into an OCh signal. While the transitional link concept is explained in 
the context of the OTN, it is generally applicable to all mult-layer
networks.

According to my perception, there was rough consensus that transitional 
links are useful  and should be included in the TE topology
YANG models.

Comments are welcome.

Thanks,
Dieter

---

From: Gert Grammel <[email-masked]>
Date: Tue, 1 Mar 2016 15:32:20 +0000

Hi Dieter,

Thanks for sharing the slides. When it comes to Multilayer use cases,
RFC5212 appears to be a good starting point. So looking at the slides, it
seems that the term "transitional link² is the same construct as ³internal
Link² in RFC6001:
<snip> The logical composition of a hybrid node contains at least two
distinct switching elements that are interconnected by "internal links" to
provide adjustment between the supported
   switching capabilities.  These internal links have finite capacities
that MUST be taken into account when computing the path of a multi- region
TE-LSP. <snip> 

While I see value in modelling those constructs in YANG, it might not
require new terminology.

Thoughts?

Gert

---

From: Dieter Beller <[email-masked]>
Date: Tue, 1 Mar 2016 18:14:21 +0100

Hi Gert,

thanks for your comment!

If I understand your comment correctly, you are basically in agreement  
with the concept of modelling layer transitions between
adjacent layers in a multi-layer network.

When we introduced the term "transitional link, we were well aware of 
RFC5212 which is also addressing multi-layer aspects.
The term "internal link" may make sense in the context of a network 
element (--> Figure 1). The TE topology YANG model,
however, shall model the TE topology graph of a network that is composed 
of nodes and links and in this context the qualifier
"internal" seems not very useful. Therefore, we introduced the qualifier 
"transitional" to indicate the difference between a
"transitional link" and a "normal" link. We do belive that a 
"transitional link" can be modeled very similar to a "normal" link.
The major differences are that it has TPs of a different type on the 
link ends (for normal links, they are the same) and the
YANG model shall unambiguously describe the adaptation and termination 
functions which a re logically located on the link.
This can probably be inferred from the properties of the "transitional 
link" and does not need to be describes explicitly.

I hope that this clarifies why we are preferring a different term. In 
the draft, when the term "transitional link" is defined we can
mention that the term "internal link" is used in RFC5212.

Thanks,
Dieter

---

From: Gert Grammel <[email-masked]>
Date: Tue, 1 Mar 2016 17:45:36 +0000

Hi Dieter,

See below ...

>adjacent layers in a multi-layer network.
Since RFC5212 defined that relation (among others) it appears to me the
natural way to do so in a multi-layer context.

>"internal" seems not very useful.
When looking at your slides e.g. P.5  it seems the transitional link is
internal to N2 and N5. Looks pretty much like an internal link.

>Therefore, we introduced the qualifier
Isn’t that what RFC5212 defined as “internal link”?

>mention that the term "internal link" is used in RFC5212.
If so, why bothering with "yet another term”, instead of referencing
RFC5212 an move on?

---

From: "Belotti, Sergio (Nokia - IT)" <[email-masked]>
Date: Tue, 1 Mar 2016 19:31:35 +0000

Hi Gert
See in line with SB before 

Cheers
sergio

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of EXT Gert Grammel
Sent: martedì 1 marzo 2016 18:46
To: Beller, Dieter (Nokia - DE)
Cc: TEAS WG
Subject: Re: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

Hi Dieter,

See below ...

On 2016-01-03 18:14, "Dieter Beller" <[email-masked]> wrote:

>with the concept of modelling layer transitions between adjacent layers 
>in a multi-layer network.
Since RFC5212 defined that relation (among others) it appears to me the natural way to do so in a multi-layer context.

>element (--> Figure 1). The TE topology YANG model, however, shall 
>model the TE topology graph of a network that is composed of nodes and 
>links and in this context the qualifier "internal" seems not very 
>useful.
When looking at your slides e.g. P.5  it seems the transitional link is internal to N2 and N5. Looks pretty much like an internal link.

>"transitional" to indicate the difference between a "transitional link" 
>and a "normal" link. We do belive that a "transitional link" can be 
>modeled very similar to a "normal" link.
>link ends (for normal links, they are the same) and the YANG model 
>shall unambiguously describe the adaptation and termination functions 
>which a re logically located on the link.
Isn't that what RFC5212 defined as "internal link"?

>the draft, when the term "transitional link" is defined we can mention 
>that the term "internal link" is used in RFC5212.
If so, why bothering with "yet another term", instead of referencing
RFC5212 an move on?

SB> Gert, when RFC5212 is talking about "internal link" is in the view to make understandable that in the "hybrid" node configuration there could be "finite" capacity for adaptation/termination in multi layer context, that edge nodes need to take into account during path computation.
The intention was to "hide" the internal link (as normal in IETF) and introducing IACD , that is provided in addition to ISCD , but always related to interfaces.

Here the intention is to introduce  a new topological entity concept, we can have a "link" ( forget about is internal or external) that represent a "layer" transition between two layer topology. Since TE topo has to describe TE topology graph , this special "link" needs to be part of this description. As reminded by Dieter, it is probably no need to introduce specifically a new link entity, but the layer transition can be inferred by the different layer on which the TP of this link belongs to. So specific attributes added to TP could be enough. But we can think about how to model this once we agreed the concept.

>> RFC5212 appears to be a good starting point. So looking at the 
>>slides, it  seems that the term "transitional link² is the same 
>>construct as ³internal  Link² in RFC6001:
>>     switching capabilities.  These internal links have finite 
>>capacities  that MUST be taken into account when computing the path of 
>>a multi- region  TE-LSP. <snip>
>>
>>> as suggested by Lou, I am sharing with you some slides describing 
>>>single  layer and multi layer use cases, which were discussed during  
>>> The first 2 slides address (sub-)network abstraction and propose to 
>>> use the connectivity matrix in case the resulting abstract node is 
>>> not blocking free.
>>>
>>> The remaining slides are describing multi-layer network scenarios 
>>> where a server layer trail is established in order to carry client 
>>> layer connections. In order to support multi-layer path computation, 
>>> based on the capability of a node to encapsulate a client layer 
>>> signal into a server layer signal. Exampleas are: IP in MPLS, OTN 
>>> ODUk into an OCh signal. While the transitional link concept is 
>>> explained in the context of the OTN, it is generally applicable to 
>>> all mult-layer networks.
>>>
>>> According to my perception, there was rough consensus that 
>>> transitional links are useful  and should be included in the TE 
>>> topology YANG models.
>>>
>>> Comments are welcome.
>>>
>>>
>>> Thanks,
>>> Dieter
>>>
>

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: "Doolan, Paul (Coriant - US/Irving)" <[email-masked]>
Date: Tue, 1 Mar 2016 19:34:37 +0000

Hi Gert (and Dieter), 

> Isn’t that what RFC5212 defined as “internal link”?

I don't think that, if you look carefully, you will find that RFC5212 defines 'internal link'.  It uses it, and you may be tempted to infer a definition from that usage, but it doesn't IMO define it.

In any case you earlier quote RFC6001 thus:

The logical composition of a hybrid node contains at least two distinct switching elements that are interconnected by "internal links" to provide adjustment between the supported  switching capabilities. 

Again as a definition this text leaves something to be desired; I don't think it's good practice that reader is supposed to infer from the quotation marks that this is a (complete) definition. In addition there is no requirement imposed by this text that the switching capabilities on each end of the internal link be different.

Using transitional link allows us to provide a definition that improves on these shortcomings. A definition of transitional link should explicitly state whether the TPs at the link ends MUST be different or if they MAY be the same.

best,
pd

On Mar 1, 2016, at 12:45 PM, Gert Grammel wrote:

>>>> single

---

From: Gert Grammel <[email-masked]>
Date: Tue, 1 Mar 2016 21:08:31 +0000

Paul,

The subject line refers to a YANG data model definition. How does a new term facilitate that definition?

Gert

Sent from my Apple ][

> On 01 Mar 2016, at 20:34, Doolan, Paul (Coriant - US/Irving) <[email-masked]> wrote:
> 
> Hi Gert (and Dieter), 
> 
> if I may interject here:
>

---

From: Gert Grammel <[email-masked]>
Date: Tue, 1 Mar 2016 22:04:48 +0000

Sergio,

I would also prefer not to coin new terminology unless it is truly required. How an internal link shall be put in a data model can be debated on technical grounds. Coming up with new terminology  at this stage doesn't look particularly helpful though.

Gert

Sent from my Apple ][

> On 01 Mar 2016, at 20:31, Belotti, Sergio (Nokia - IT) <[email-masked]> wrote:
> 
> Hi Gert

---

From: "Doolan, Paul (Coriant - US/Irving)" <[email-masked]>
Date: Wed, 2 Mar 2016 03:01:24 +0000

On Mar 1, 2016, at 4:08 PM, Gert Grammel wrote:

Paul,

Gert

Well Gert , at the start of this thread Dieter observed that :-

According to my perception, there was rough consensus that transition links are useful  and should be included in the TE topology YANG models.

Nothing that you have cited so far provides an accurate definition of transition links as explained by Dieter. In fact I think they point to deficiencies in the definition(s), such as they are, of something different, namely 'internal links'.

Why does this matter in the context of YANG model definition? It matters only insofar as a model is useful if, and only if, there is no ambiguity as to the meaning of the terms that it, the model, employs. A consequence of this is that if one finds while developing a model  that the existing vocabulary is inadequate to unambiguously describe the situation being modeled then new terms need to be defined. In an ideal world one would go back to the relevant Information Model  and fix the problem - if it exists - there or use an applicable definition from that model.

So to answer your question, a new term facilitates the definition of YANG model (for topology) if the existing terminology  is inadequate to describe something necessary, or at least 'useful' ,to  allow that model to describe the reality it is intended to describe.

I see no reason that a draft describing a model cannot define terms specific to the domain it is attempting to model.

best,
pd

Sent from my Apple ][

On 01 Mar 2016, at 20:34, Doolan, Paul (Coriant - US/Irving) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Gert (and Dieter),

if I may interject here:

best,
pd

Hi Dieter,

See below ...

On 2016-01-03 18:14, "Dieter Beller" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Gert,

thanks for your comment!

I hope that this clarifies why we are preferring a different term.
In
the draft, when the term "transitional link" is defined we can
mention that the term "internal link" is used in RFC5212.
If so, why bothering with "yet another term”, instead of referencing
RFC5212 an move on?

Thanks,
Dieter

Thanks for sharing the slides. When it comes to Multilayer use cases,
RFC5212 appears to be a good starting point. So looking at the slides,
it
seems that the term "transitional link² is the same construct as
³internal
Link² in RFC6001:
<snip> The logical composition of a hybrid node contains at least two
distinct switching elements that are interconnected by "internal links"
to
provide adjustment between the supported
 switching capabilities.  These internal links have finite capacities
that MUST be taken into account when computing the path of a multi-
region
TE-LSP. <snip>

Thoughts?

Gert

On 2016-01-03 14:45, "Teas on behalf of Dieter Beller"
<[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi TEAS WG,

Comments are welcome.

Thanks,
Dieter

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: Gert Grammel <[email-masked]>
Date: Wed, 2 Mar 2016 10:02:58 +0000

Paul,

New terms & definitions are welcome if they are necessary. In the case under discussion, we have a few slides that apparently describe the model used by RFC5212 - albeit with different terms.  In the following thread it was clarified that the author knew about RFC5212 and intentionally decided to use alternative terms, which is his choice.

So apparently there are now two distinct concepts of an internal/transitional link. Without a definition of “transitional link”, it is premature to conclude that there is a consensus for one of those incarnations. I am wary about the fact that the term “transitional link” comes already with a baggage of connotation that may spoil the technical discussion about what problem we need to address: a YANG data model.

In that sense, I’d like to come back to your statement:
<snip>  So to answer your question, a new term facilitates the definition of YANG model (for topology) if the existing terminology  is inadequate to describe something necessary, or at least 'useful' ,to  allow that model to describe the reality it is intended to describe. <snip>

If you feel that existing terminology would be inadequate to describe something necessary, some due diligence should be spent to define “something” and then have a look if existing terms can be extended or new terms need to be coined.

- Gert

From: Paul Doolan <[email-masked]<mailto:[email-masked]>>
Date: Wednesday 2 March 2016 04:01
To: Gert Grammel <[email-masked]<mailto:[email-masked]>>
Cc: Dieter Beller <[email-masked]<mailto:[email-masked]>>, TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

Paul,

Gert

best,
pd

Sent from my Apple ][

Hi Gert (and Dieter),

if I may interject here:

best,
pd

Hi Dieter,

See below ...

Hi Gert,

thanks for your comment!

Thanks,
Dieter

Thoughts?

Gert

Hi TEAS WG,

Comments are welcome.

Thanks,
Dieter

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Thu, 3 Mar 2016 07:56:21 +0000

Hi, Gert, Paul, Dieter,

      I wonder if we are only debating whether there is need of new terminology,  or whether TE TOPOLOGY YANG model have already captured the attributes needed for such an entity (be it transitional link or internal link)?

   None of this two terms are listed in this YANG model and what we have now is only the IACD and it has  the following information/attributes under the TE link:

      +--ro interface-adjustment-capability* [upper-sc]
            |  |     +--ro upper-sc             identityref
            |  |     +--ro upper-encoding?      identityref
            |  |     +--ro max-lsp-bandwidth* [priority]
            |  |        +--ro priority     uint8
            |  |        +--ro bandwidth?   decimal64

Regards,
Xian

From: Teas [mailto:[email-masked]] On Behalf Of Gert Grammel
Sent: 2016年3月2日 18:03
To: Doolan, Paul (Coriant - US/Irving)
Cc: Dieter Beller; TEAS WG
Subject: Re: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

Paul,

- Gert

Paul,

Gert

best,
pd

Sent from my Apple ][

Hi Gert (and Dieter),

if I may interject here:

best,
pd

Hi Dieter,

See below ...

Hi Gert,

thanks for your comment!

Thanks,
Dieter

Thoughts?

Gert

Hi TEAS WG,

Comments are welcome.

Thanks,
Dieter

---

From: Gert Grammel <[email-masked]>
Date: Thu, 3 Mar 2016 10:57:24 +0000

Hi Zhangxian,

You got my point

Gert

From: Teas <[email-masked]<mailto:[email-masked]>> on behalf of Zhangxian <[email-masked]<mailto:[email-masked]>>
Date: Thursday 3 March 2016 08:56
To: Gert Grammel <[email-masked]<mailto:[email-masked]>>, Paul Doolan <[email-masked]<mailto:[email-masked]>>, Dieter Beller <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

Hi, Gert, Paul, Dieter,

Regards,
Xian

Paul,

- Gert

Paul,

Gert

best,
pd

Sent from my Apple ][

Hi Gert (and Dieter),

if I may interject here:

best,
pd

Hi Dieter,

See below ...

Hi Gert,

thanks for your comment!

Thanks,
Dieter

Thoughts?

Gert

Hi TEAS WG,

Comments are welcome.

Thanks,
Dieter

---

From: Dieter Beller <[email-masked]>
Date: Thu, 3 Mar 2016 15:30:58 +0100

Hi Gert, Xiang, all,

during the TE Topology YANG Model Design Meetings, we discussed how
the TE topology of a multi-layer network should be modeled.

This is different from the GMPLS MRN extensions defined in RFC6001!
RFC6001 defines the IACD sub-TLV fro OSPF-TE as an extension

for the network element extenal LSAs to describe network element
internal capabilities. It shall be noted that OSPF-TE is only
advertising

TE information only for the links interconnecting the network
element with its neighbors ("normal" links). Based on the MRN
information

disseminated via OSPF into the network, each network element has to
determine whether layer transitions are possible inside all the
other

network elements in the domain and has to create a topology graph
(TED) including transitional links.

Now, we are defining a TE topology YANG model for that topology
including the transitional links. Therefore, it does not make sense
to

add the IACD information to the normal links. Instead, the TE
topology model should explicitly include the transitional links
already as

they belong to the multi-layer topology. IMO, it does not make sense
to still use the IACD approach.

I hope that this clarifies why we are proposing to model
transitional links in the TE topology.

Thanks,

Dieter

P.S.: I am preparing a figure showing the decomposition of a
multi-layer node into external links, sub-nodes, and transitional
links.

On 03.03.2016 11:57, EXT Gert Grammel
wrote:

Hi Zhangxian,

You got my point

Gert

From: Teas <[email-masked]>
on behalf of Zhangxian <[email-masked]>

Date: Thursday 3 March
2016 08:56

To: Gert Grammel <[email-masked]>,
Paul Doolan <[email-masked]>,
Dieter Beller <[email-masked]>

Cc: TEAS WG <[email-masked]>

Subject: Re: [Teas] Use
cases discussed during the IETF TE Topology YANG Model Design
Meeting

Hi, Gert, Paul, Dieter,

I wonder if we are only
debating whether there is need of new terminology,  or
whether TE TOPOLOGY YANG model have already captured
the attributes needed for such an entity (be it
transitional link or internal link)?

None of this two terms are listed in this YANG model
and what we have now is only the IACD and it has  the
following information/attributes under the TE link:

|  |        +--ro priority     uint8

Regards,

Xian

From: Teas [mailto:[email-masked]]
On Behalf Of Gert Grammel

Sent: 2016年3月2日 18:03

Subject: Re: [Teas] Use cases discussed
during the IETF TE Topology YANG Model Design
Meeting

Paul,

New terms & definitions are welcome
if they are necessary. In the case under discussion,
we have a few slides that apparently describe the
model used by RFC5212 - albeit with different terms.
In the following thread it was clarified that the
author knew about RFC5212 and intentionally decided
to use alternative terms, which is his choice.

So apparently there are now two
distinct concepts of an internal/transitional link.
Without a definition of “transitional link”, it is
premature to conclude that there is a consensus for
one of those incarnations. I am wary about the fact
that the term “transitional link” comes already with
a baggage of connotation that may spoil the
technical discussion about what problem we need to
address: a YANG data model.

In that sense, I’d like to come back to
your statement:

<snip>  So to answer your
question, a new term facilitates the definition of
YANG model (for topology) if the existing
terminology  is inadequate to describe something
necessary, or at least 'useful' ,to  allow that
model to describe the reality it is intended to
describe. <snip>

If you feel that existing terminology
would be inadequate to describe something necessary,
some due diligence should be spent to define
“something” and then have a look if existing terms
can be extended or new terms need to be coined.

- Gert

From:
Paul Doolan <[email-masked]>

To: Gert Grammel <[email-masked]>

Cc: Dieter Beller <[email-masked]>,
TEAS WG <[email-masked]>

Subject: Re: [Teas] Use cases discussed
during the IETF TE Topology YANG Model Design
Meeting

On Mar 1, 2016, at
4:08 PM, Gert Grammel wrote:

Paul,

The subject line refers to a YANG data model
definition. How does a new term facilitate
that definition?

Gert

Well Gert , at the
start of this thread Dieter observed that :-

According to my perception,
there was rough consensus that
transition links are useful  and should be
included in the TE topology YANG models.

Nothing that you
have cited so far provides an accurate
definition of transition links as explained by
Dieter. In fact I think they point to
deficiencies in the definition(s), such as
they are, of something different, namely
'internal links'.

Why does this
matter in the context of YANG model
definition? It matters only insofar as a model
is useful if, and only if, there is no
ambiguity as to the meaning of the terms that
it, the model, employs. A consequence of this
is that if one finds while developing a model
that the existing vocabulary is inadequate to
unambiguously describe the situation being
modeled then new terms need to be defined. In
an ideal world one would go back to the
relevant Information Model  and fix the
problem - if it exists - there or use an
applicable definition from that model.

So to answer your
question, a new term facilitates the
definition of YANG model (for topology) if the
existing terminology  is inadequate to
describe something necessary, or at least
'useful' ,to  allow that model to describe the
reality it is intended to describe.

I see no reason
that a draft describing a model cannot define
terms specific to the domain it is attempting
to model.

best,

pd

Sent from my Apple ][

On 01 Mar 2016, at
20:34, Doolan, Paul (Coriant - US/Irving) <[email-masked]>
wrote:

Hi Gert (and
Dieter),

if I may
interject here:

Isn’t that
what RFC5212 defined as “internal link”?

I don't think
that, if you look carefully, you will find
that RFC5212 defines 'internal link'.  It
uses it, and you may be tempted to infer a
definition from that usage, but it doesn't
IMO define it.

In any case you
earlier quote RFC6001 thus:

The logical
composition of a hybrid node contains at
least two distinct switching elements that
are interconnected by "internal links" to
provide adjustment between the supported
switching capabilities.

Again as a
definition this text leaves something to be
desired; I don't think it's good practice
that reader is supposed to infer from the
quotation marks that this is a (complete)
definition. In addition there is no
requirement imposed by this text that the
switching capabilities on each end of the
internal link be different.

Using
transitional link allows us to provide a
definition that improves on these
shortcomings. A definition of transitional
link should explicitly state whether the TPs
at the link ends MUST be different or if
they MAY be the same.

best,

pd

On Mar 1,
2016, at 12:45 PM, Gert Grammel wrote:

Hi Dieter,

See below ...

On
2016-01-03 18:14, "Dieter Beller" <[email-masked]>
wrote:

Hi Gert,

thanks for
your comment!

If I
understand your comment correctly, you
are basically in agreement

with the
concept of modelling layer transitions
between

adjacent
layers in a multi-layer network.

Since RFC5212
defined that relation (among others) it
appears to me the

natural way to
do so in a multi-layer context.

When we
introduced the term "transitional link,
we were well aware of

RFC5212
which is also addressing multi-layer
aspects.

The term
"internal link" may make sense in the
context of a network

element
(--> Figure 1). The TE topology YANG
model,

however,
shall model the TE topology graph of a
network that is composed

of nodes and
links and in this context the qualifier

"internal"
seems not very useful.

When looking
at your slides e.g. P.5  it seems the
transitional link is

internal to N2
and N5. Looks pretty much like an internal
link.

Therefore,
we introduced the qualifier

"transitional"
to indicate the difference between a

"transitional
link" and a "normal" link. We do belive
that a

"transitional
link" can be modeled very similar to a
"normal" link.

The major
differences are that it has TPs of a
different type on the

link ends
(for normal links, they are the same)
and the

YANG model
shall unambiguously describe the
adaptation and termination

functions
which a re logically located on the
link.

Isn’t that
what RFC5212 defined as “internal link”?

This can
probably be inferred from the properties
of the "transitional

link" and
does not need to be describes
explicitly.

I hope that
this clarifies why we are preferring a
different term.

In

the draft,
when the term "transitional link" is
defined we can

mention that
the term "internal link" is used in
RFC5212.

If so, why
bothering with "yet another term”, instead
of referencing

RFC5212 an
move on?

Thanks,

Dieter

On 01.03.2016 16:32, EXT
Gert Grammel wrote:

Hi Dieter,

Thanks for sharing the
slides. When it comes to Multilayer
use cases,

RFC5212 appears to be a
good starting point. So looking at the
slides,

it

seems that the term
"transitional link² is the same
construct as

³internal

Link² in RFC6001:

<snip> The logical
composition of a hybrid node contains
at least two

distinct switching
elements that are interconnected by
"internal links"

to

provide adjustment
between the supported

switching capabilities.
These internal links have finite
capacities

that MUST be taken into
account when computing the path of a
multi-

region

TE-LSP. <snip>

While I see value in
modelling those constructs in YANG, it
might not

require new terminology.

Thoughts?

Gert

On 2016-01-03 14:45,
"Teas on behalf of Dieter Beller"

<[email-masked]
on behalf of
[email-masked]>
wrote:

Hi TEAS
WG,

as
suggested by Lou, I am sharing with
you some slides describing

single

layer
and multi layer use cases, which
were discussed during

the IETF
TE Topology YANG Model Design
Meeting yesterday.

The
first 2 slides address (sub-)network
abstraction and propose to use

the
connectivity matrix in case the
resulting abstract node is

not
blocking free.

The
remaining slides are describing
multi-layer network scenarios where

a server
layer trail is established in order
to carry client layer

connections.
In order to support multi-layer path
computation,

transitional
links are proposed, which allow the
construction of a

multi-layer
network topology graph. Transitional
links connect the

topology
graphs of two adjacent network
layers. They are created

based on
the capability of a node to
encapsulate a client layer signal

into a
server layer signal. Exampleas are:
IP in MPLS, OTN ODUk

into an
OCh signal. While the transitional
link concept is explained in

the
context of the OTN, it is generally
applicable to all mult-layer

networks.

According
to my perception, there was rough
consensus that transitional

links
are useful  and should be included
in the TE topology

YANG
models.

Comments
are welcome.

Thanks,

Dieter

Teas mailing
list

[email-masked]

---

From: Igor Bryskin <[email-masked]>
Date: Thu, 3 Mar 2016 16:15:07 +0000

Hi guys,

First, I welcome new folks – Gert, Paul and the WG to the discussion.

I do agree with Dieter that having IACD associated with “regular” TE links is very ambiguous, does not help much for multi-layer  TE and, therefore, totally unnecessary.

But I do have some concerns WRT transitional link method, which I summarized below. I am also suggesting an alternative solution based on the concept of “inter-layer locks”.

Today, our “regular” TE link looks like this:

It interconnects two distinct TE nodes with the topology unique IDs, N1 and N2. The link is connected to both nodes via link termination points (LTPs) identified by topology (numbered) or respective node scope unique IDs, L1 and L2, so that node ID/link ID combination is always topology unique. Rare exceptions aside, the TE link is symmetrical, i.e. except for mirrored local/remote node/link IDs, both nodes normally advertise the same set of attributes.

The introduction of transitional TE link has IMO the following issues:

1.      Multi-layer nodes have to be split into as many TE nodes (each with the topology unique ID) as the number of layers they are part of: TE link ends cannot belong to the same TE node or  to TE nodes with identical Node IDs. Furthermore, because multiple client links can be adopted on the same server tunnel termination point (TTP), and the same client link can be adopted on several server TTPs (see more below), this many-to-many inter-layer cardinality will likely to take significant amount of p2p transitional links to model. For example, WDM ROADM may have 80 transponders capable of terminating 80 OCh trails. This means 80 Och layer TTPs and at least 80 transitional links to terminate. In fact the number could be much greater because each TTP can adopt multiple clients, each connected via separate transitional link. The point is that a TE topology with transitional TE links can potentially explode size-wise (or, at least, become significantly larger) as compared to the TE topology without transitional links.

2.      Transitional TE link is heavily asymmetrical:

Not only it goes across the layer boundary and interconnects termination points in different layers (which we allow today for legacy reasons, although discourage), transitional link interconnects TPs of completely different types – link termination point – LTP - on the client side and tunnel termination point  - TTP - on the server side. Recall that LTP is the place where same layer switching is happening, while TTP is the place where the client adaptation on the server trail is happening.

Please, note that none of the TE link attributes with a questionable exception of TE metric makes any sense for transitional link on the client side. Only the bandwidth attribute makes sense on the transitional link server side; however, this is not the bandwidth we model for our “regular” TE link – unreserved bandwidth available on the link on per priority level. This is the adaptation bandwidth shared among all transitional links pointing to the same server layer TTP, where priority does not seem to apply. The TE metric is of a questionable value: why would you have a separate TE metric for each transitional link? It is not like they are different in fiber length, delay or anything. It would be sufficient for the inter-layer path computer to have a simple policy saying something like this: every time you go from client layer X to server layer Y apply cost penalty Z.

The bottom line: if transitional TE link cannot re-use any attributes of  “regular” TE link, what do we actually gain by modeling the former as TE link? It would be better and cleaner to model the inter-layer relationship as somewhat totally different from TE link.

3.      Transitional TE link breaks the assumption of nodeID/linkID combination uniqueness.

On the picture server layer TTP1s can adopt client L1c and L2c. Hence Ns/TTP1s combination is not unique. On the other hand, client L1c can be adopted on either TTP1s or TTP2s, hence Nc/L1c is not unique either. This is a serious deviation from current modeling concepts.

So, to summarize the effect of introduction of transitional TE link into the model:

1)      Huge overhead and scalability concerns;

2)      Breaking of current modeling principles;

3)      No advantage in “bending” it to look like a “regular” TE link.
Fortunately, there is a simple alterative to model the inter-layer relationships outlined as follows:

-         We introduce “many-to-many”  construct, let’s call it “inter-layer lock” IL-Lock;

-         An instance of IL-Lock is identified by IL-Lock ID, which is unique across all TE topologies provided by the same provider.

-         Each TE link will have 0 or more IL-Lock IDs identifying the link’s adaptation options in one or more server layers within the combined or separately provided TE topologies;

-         Each TTP will have one or more IL Lock IDs it supports along with the unused adaptation bandwidth;

-         A multi-layer path computer will be able to lock client TE links with server TTPs based on matching IP-lock IDs.
     The advantages of the inter-layer lock method compared to the transitional link method:

1.      Succinct, concise, efficient, simple, minimal overhead;

2.      Sufficient for multi-layer computations,  yet easily ignored by single-layer path computations;

3.        IL-Locks can lock layers inside a single multi-layer TE node, between TE nodes in the same TE topology and between TE nodes from different TE topologies.  The latter is especially important because different layers could be described by separate TE topologies with possibly independent name spaces, which still need to be locked for multi-layer path computations.
Having said that, please, note that the two alternatives are not necessarily mutually exclusive – if necessary, we can support both methods. Even transitional link aficionados will admit that one can never assume that all layers from MPLS-TP to OCh layers are in the same combined TE topology, hence there will be always a need to interlock layers described by separate TE topologies.

So, what do you think?
Cheers,
Igor

From: Teas [mailto:[email-masked]] On Behalf Of Dieter Beller
Sent: Thursday, March 03, 2016 9:31 AM
To: EXT Gert Grammel; Zhangxian (Xian); TEAS WG
Subject: Re: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

Hi Gert, Xiang, all,

during the TE Topology YANG Model Design Meetings, we discussed how the TE topology of a multi-layer network should be modeled.

This is different from the GMPLS MRN extensions defined in RFC6001! RFC6001 defines the IACD sub-TLV fro OSPF-TE as an extension
for the network element extenal LSAs to describe network element internal capabilities. It shall be noted that OSPF-TE is only advertising
TE information only for the links interconnecting the network element with its neighbors ("normal" links). Based on the MRN information
disseminated via OSPF into the network, each network element has to determine whether layer transitions are possible inside all the other
network elements in the domain and has to create a topology graph (TED) including transitional links.

Now, we are defining a TE topology YANG model for that topology including the transitional links. Therefore, it does not make sense to
add the IACD information to the normal links. Instead, the TE topology model should explicitly include the transitional links already as
they belong to the multi-layer topology. IMO, it does not make sense to still use the IACD approach.

I hope that this clarifies why we are proposing to model transitional links in the TE topology.

Thanks,
Dieter

P.S.: I am preparing a figure showing the decomposition of a multi-layer node into external links, sub-nodes, and transitional links.
On 03.03.2016 11:57, EXT Gert Grammel wrote:
Hi Zhangxian,

You got my point

Gert

Hi, Gert, Paul, Dieter,

Regards,
Xian

Paul,

- Gert

Paul,

Gert

best,
pd

Sent from my Apple ][

Hi Gert (and Dieter),

if I may interject here:

best,
pd

Hi Dieter,

See below ...

Hi Gert,

thanks for your comment!

Thanks,
Dieter

Thoughts?

Gert

Hi TEAS WG,

Comments are welcome.

Thanks,
Dieter

---

From: Gert Grammel <[email-masked]>
Date: Thu, 3 Mar 2016 16:49:50 +0000

I think this is a good start to discuss the problem first and then see if/what definitions are needed to address it.

Gert

Sent from my Apple ][

On 03 Mar 2016, at 17:15, Igor Bryskin <[email-masked]<mailto:[email-masked]>> wrote:

Hi guys,

So, what do you think?
Cheers,
Igor

Hi Gert, Xiang, all,

Thanks,
Dieter

You got my point

Gert

Hi, Gert, Paul, Dieter,

Regards,
Xian

Paul,

- Gert

Paul,

Gert

best,
pd

Sent from my Apple ][

Hi Gert (and Dieter),

if I may interject here:

best,
pd

Hi Dieter,

See below ...

Hi Gert,

thanks for your comment!

Thanks,
Dieter

seems that the term "transitional link^2 is the same construct as
^3internal
Link^2 in RFC6001:

Thoughts?

Gert

Hi TEAS WG,

Comments are welcome.

Thanks,
Dieter

---

From: Dieter Beller <[email-masked]>
Date: Fri, 4 Mar 2016 18:45:57 +0100

Hi Igor, all,

please find my comments inline below.

Thanks and have a nice WE,

Dieter

On 03.03.2016 17:15, EXT Igor Bryskin
wrote:

Hi guys,

First, I welcome new folks – Gert, Paul and
the WG to the discussion.

I do agree with Dieter that having IACD
associated with “regular” TE links is very ambiguous, does not
help much for multi-layer  TE and, therefore, totally
unnecessary.

But I do have some concerns WRT
transitional link method, which I summarized below. I am also
suggesting an alternative solution based on the concept of
“inter-layer locks”.

Today, our “regular” TE link looks like
this:

It interconnects two distinct TE nodes with
the topology unique IDs, N1 and N2. The link is connected to
both nodes via link termination points (LTPs) identified by
topology (numbered) or respective node scope unique IDs, L1
and L2, so that node ID/link ID combination is always topology
unique. Rare exceptions aside, the TE link is symmetrical,
i.e. except for mirrored local/remote node/link IDs, both
nodes normally advertise the same set of attributes.

The introduction of transitional TE link
has IMO the following issues:

1.
Multi-layer nodes have to be
split into as many TE nodes (each with the topology unique ID)
as the number of layers they are part of: TE link ends cannot
belong to the same TE node or  to TE nodes with identical Node
IDs. Furthermore, because multiple client links can be adopted
on the same server tunnel termination point (TTP), and the
same client link can be adopted on several server TTPs (see
more below), this many-to-many inter-layer cardinality will
likely to take significant amount of p2p transitional links to
model. For example, WDM ROADM may have 80 transponders capable
of terminating 80 OCh trails. This means 80 Och layer TTPs and
at least 80 transitional links to terminate. In fact the
number could be much greater because each TTP can adopt
multiple clients, each connected via separate transitional
link. The point is that a TE topology with transitional TE
links can potentially explode size-wise (or, at least, become
significantly larger) as compared to the TE topology without
transitional links.

[DB>] The conclusion is correct that a physical node has to be
subdivided into logical sub-nodes - this is shown on the following
figure:

[DB>] Your concern that the introduction of transitional links
has a scalability issue is not true because we have OTN switches
today.

[DB>] that have a high capacity and can handle huge numbers of
TPs and there's no difference with this approach. Moreover, you

[DB>] do not equip your nodes with optical transponders that are
not used because of the associated cost!

2.
Transitional TE link is heavily
asymmetrical:

Not only it goes across the layer
boundary and interconnects termination points in different
layers (which we allow today for legacy reasons, although
discourage), transitional link interconnects TPs of completely
different types – link termination point – LTP - on the client
side and tunnel termination point  - TTP - on the server
side. Recall that LTP is the place where same layer switching
is happening, while TTP is the place where the client
adaptation on the server trail is happening.

[DB>] Switching doe not occur on a transitional link - TPs of the
same layer are connected via a switching fabric (the blue or orange

[DB>] switch in the figure above.

Please, note that none of the TE
link attributes with a questionable exception of TE metric
makes any sense for transitional link on the client side.

[DB>] Link metric does make perfectly sense to control whether
existing resources shall be preferred if available before a new
server

[DB>] layer trail is established.

Only the bandwidth attribute makes
sense on the transitional link server side; however, this is
not the bandwidth we model for our “regular” TE link –
unreserved bandwidth available on the link on per priority
level. This is the adaptation bandwidth shared among all
transitional links pointing to the same server layer TTP,
where priority does not seem to apply. The TE metric is of a
questionable value: why would you have a separate TE metric
for each transitional link? It is not like they are different
in fiber length, delay or anything. It would be sufficient for
the inter-layer path computer to have a simple policy saying
something like this: every time you go from client layer X to
server layer Y apply cost penalty Z.

[DB>] Isn't that what the link metric is all about?

The bottom line: if transitional TE
link cannot re-use any attributes of  “regular” TE link, what
do we actually gain by modeling the former as TE link? It
would be better and cleaner to model the inter-layer
relationship as somewhat totally different from TE link.

[DB>] Up to now, I have not seen a killing argument that prevents
us from using transitional links in the TE topology.

3.
Transitional TE link breaks the
assumption of nodeID/linkID combination uniqueness.

On the picture server layer TTP1s
can adopt client L1c and L2c. Hence Ns/TTP1s combination is
not unique. On the other hand, client L1c can be adopted on
either TTP1s or TTP2s, hence Nc/L1c is not unique either. This
is a serious deviation from current modeling concepts.

[DB>] This issue, I don't understand. A incoming client layer
connection can of course use any of the transitional links. When a

[DB>] path is calculated, one transitional link is selected in
case several transitional links are possible leading to equal cost
paths.

So, to summarize the effect of
introduction of transitional TE link into the model:

1)
Huge overhead and scalability
concerns;

2)
Breaking of current modeling
principles;

3)
No advantage in “bending” it to
look like a “regular” TE link.

Fortunately, there is a simple alterative
to model the inter-layer relationships outlined as follows:

-
We introduce “many-to-many”
construct, let’s call it “inter-layer lock” IL-Lock;

-
An instance of IL-Lock is
identified by IL-Lock ID, which is unique across all TE
topologies provided by the same provider.

-
Each TE link will have 0 or more
IL-Lock IDs identifying the link’s adaptation options in one
or more server layers within the combined or separately
provided TE topologies;

-
Each TTP will have one or more
IL Lock IDs it supports along with the unused adaptation
bandwidth;

-
A multi-layer path computer will
be able to lock client TE links with server TTPs based on
matching IP-lock IDs.

The advantages of the inter-layer lock
method compared to the transitional link method:

1.
Succinct, concise, efficient,
simple, minimal overhead;

2.
Sufficient for multi-layer
computations,  yet easily ignored by single-layer path
computations;

3.
IL-Locks can lock layers
inside a single multi-layer TE node, between TE nodes in the
same TE topology and between TE nodes from different TE
topologies.  The latter is especially important because
different layers could be described by separate TE topologies
with possibly independent name spaces, which still need to be
locked for multi-layer path computations.

Having said that, please, note that the two
alternatives are not necessarily mutually exclusive – if
necessary, we can support both methods. Even transitional link
aficionados will admit that one can never assume that all
layers from MPLS-TP to OCh layers are in the same combined TE
topology, hence there will be always a need to interlock
layers described by separate TE topologies.

So, what do you think?

[DB>] I think that I need to understand better the concept you
call "inter-layer lock". Maybe you can prepare some slides for the

[DB>] cal next Mon.

Cheers,

Igor

From:
Teas [mailto:[email-masked]]
On Behalf Of Dieter Beller

Subject: Re: [Teas] Use cases discussed during
the IETF TE Topology YANG Model Design Meeting

Hi Gert,
Xiang, all,

during the TE Topology YANG Model Design Meetings, we
discussed how the TE topology of a multi-layer network should
be modeled.

This is different from the GMPLS MRN extensions defined in
RFC6001! RFC6001 defines the IACD sub-TLV fro OSPF-TE as an
extension

for the network element extenal LSAs to describe network
element internal capabilities. It shall be noted that OSPF-TE
is only advertising

disseminated via OSPF into the network, each network element
has to determine whether layer transitions are possible inside
all the other

network elements in the domain and has to create a topology
graph (TED) including transitional links.

Now, we are defining a TE topology YANG model for that
topology including the transitional links. Therefore, it does
not make sense to

add the IACD information to the normal links. Instead, the TE
topology model should explicitly include the transitional
links already as

they belong to the multi-layer topology. IMO, it does not make
sense to still use the IACD approach.

Thanks,

Dieter

P.S.: I am preparing a figure showing the decomposition of a
multi-layer node into external links, sub-nodes, and
transitional links.

Hi Zhangxian,

You got my point

Gert

From:
Teas
<[email-masked]>

Subject: Re: [Teas] Use cases discussed during
the IETF TE Topology YANG Model Design Meeting

Hi,
Gert, Paul, Dieter,

I wonder if we are only debating whether there is need
of new terminology,  or whether TE TOPOLOGY YANG model
have already captured the attributes needed for such
an entity (be it transitional link or internal link)?

|  |        +--ro priority     uint8

Regards,

Xian

From:
Teas [mailto:[email-masked]]
On Behalf Of Gert Grammel

Sent: 2016年3月2日
18:03

Paul,

New
terms & definitions are welcome if they are
necessary. In the case under discussion, we have a
few slides that apparently describe the model used
by RFC5212 - albeit with different terms.  In the
following thread it was clarified that the author
knew about RFC5212 and intentionally decided to use
alternative terms, which is his choice.

So
apparently there are now two distinct concepts of an
internal/transitional link. Without a definition of
“transitional link”, it is premature to conclude
that there is a consensus for one of those
incarnations. I am wary about the fact that the term
“transitional link” comes already with a baggage of
connotation that may spoil the technical discussion
about what problem we need to address: a YANG data
model.

In
that sense, I’d like to come back to your statement:

<snip>
So to answer your question, a new term facilitates
the definition of YANG model (for topology) if the
existing terminology  is inadequate to describe
something necessary, or at least 'useful' ,to  allow
that model to describe the reality it is intended to
describe. <snip>

If
you feel that existing terminology would be
inadequate to describe something necessary, some due
diligence should be spent to define “something” and
then have a look if existing terms can be extended
or new terms need to be coined.

-
Gert

From:
Paul
Doolan <[email-masked]>

On
Mar 1, 2016, at 4:08 PM, Gert Grammel wrote:

Paul,

Gert

Well
Gert , at the start of this thread Dieter
observed that :-

According
to my perception, there was rough consensus
that transition links are useful  and should
be included in the TE topology YANG models.

Nothing
that you have cited so far provides an
accurate definition of transition links as
explained by Dieter. In fact I think they
point to deficiencies in the definition(s),
such as they are, of something different,
namely 'internal links'.

Why
does this matter in the context of YANG model

So
to answer your question, a new term
facilitates the definition of YANG model (for
topology) if the existing terminology  is
inadequate to describe something necessary, or
at least 'useful' ,to  allow that model to
describe the reality it is intended to
describe.

I
see no reason that a draft describing a model
cannot define terms specific to the domain it
is attempting to model.

best,

pd

Sent from my Apple ][

On
01 Mar 2016, at 20:34, Doolan, Paul (Coriant -
US/Irving) <[email-masked]>
wrote:

Hi
Gert (and Dieter),

if
I may interject here:

Isn’t
that what RFC5212 defined as “internal
link”?

I
don't think that, if you look carefully, you
will find that RFC5212 defines 'internal
link'.  It uses it, and you may be tempted
to infer a definition from that usage, but
it doesn't IMO define it.

In
any case you earlier quote RFC6001 thus:

The
logical composition of a hybrid node
contains at least two distinct switching
elements that are interconnected by
"internal links" to provide adjustment
between the supported  switching
capabilities.

Again
as a definition this text leaves something
to be desired; I don't think it's good
practice that reader is supposed to infer
from the quotation marks that this is a
(complete) definition. In addition there is
no requirement imposed by this text that the
switching capabilities on each end of the
internal link be different.

Using

best,

pd

On
Mar 1, 2016, at 12:45 PM, Gert Grammel
wrote:

Hi
Dieter,

See
below ...

On

Hi
Gert,

thanks
for your comment!

If
I understand your comment correctly, you
are basically in agreement

with
the concept of modelling layer
transitions between

adjacent

Since
RFC5212 defined that relation (among
others) it appears to me the

natural
way to do so in a multi-layer context.

When
we introduced the term "transitional
link, we were well aware of

RFC5212

The
term "internal link" may make sense in
the context of a network

element

however,

of
nodes and links and in this context the
qualifier

"internal"
seems not very useful.

When
looking at your slides e.g. P.5  it seems
the transitional link is

internal
to N2 and N5. Looks pretty much like an
internal link.

Therefore,

"transitional"

"transitional

"transitional

The
major differences are that it has TPs of
a different type on the

link
ends (for normal links, they are the
same) and the

YANG
model shall unambiguously describe the
adaptation and termination

functions

Isn’t
that what RFC5212 defined as “internal
link”?

This
can probably be inferred from the
properties of the "transitional

link"
and does not need to be describes
explicitly.

I
hope that this clarifies why we are
preferring a different term.

In

the
draft, when the term "transitional link"
is defined we can

mention
that the term "internal link" is used in
RFC5212.

If
so, why bothering with "yet another term”,
instead of referencing

RFC5212
an move on?

Thanks,

Dieter

On
01.03.2016 16:32, EXT Gert Grammel
wrote:

Hi
Dieter,

Thanks
for sharing the slides. When it comes
to Multilayer use cases,

RFC5212
appears to be a good starting point.
So looking at the slides,

it

seems
that the term "transitional link² is
the same construct as

³internal

Link²
in RFC6001:

<snip>
The logical composition of a hybrid
node contains at least two

distinct
switching elements that are
interconnected by "internal links"

to

provide
adjustment between the supported

switching
capabilities.  These internal links
have finite capacities

that
MUST be taken into account when
computing the path of a multi-

region

TE-LSP.
<snip>

While
I see value in modelling those
constructs in YANG, it might not

require
new terminology.

Thoughts?

Gert

On
2016-01-03 14:45, "Teas on behalf of
Dieter Beller"

<[email-masked]
on behalf of
[email-masked]>
wrote:

Hi
TEAS WG,

as

single

layer

the
IETF TE Topology YANG Model Design
Meeting yesterday.

The

the

not
blocking free.

The

a
server layer trail is established in
order to carry client layer

connections.

transitional

multi-layer

topology

based
on the capability of a node to
encapsulate a client layer signal

into
a server layer signal. Exampleas
are: IP in MPLS, OTN ODUk

into
an OCh signal. While the
transitional link concept is
explained in

the

networks.

According

links

YANG
models.

Comments
are welcome.

Thanks,

Dieter

Teas
mailing list

[email-masked]

---

From: Igor Bryskin <[email-masked]>
Date: Fri, 4 Mar 2016 20:15:28 +0000

Hi Dieter,

Please, see in line,

Igor

From: Dieter Beller [mailto:[email-masked]]
Sent: Friday, March 04, 2016 12:46 PM
To: Igor Bryskin; EXT Gert Grammel; Zhangxian (Xian); TEAS WG
Subject: Re: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

Hi Igor, all,

On 03.03.2016 17:15, EXT Igor Bryskin wrote:
Hi guys,

1.      Multi-layer nodes have to be split into as many TE nodes (each with the topology unique ID) as the number of layers they are part of: TE link ends cannot belong to the same TE node or  to TE nodes with identical Node IDs. Furthermore, because multiple client links can be adopted on the same server tunnel termination point (TTP), and the same client link can be adopted on several server TTPs (see more below), this many-to-many inter-layer cardinality will likely to take significant amount of p2p transitional links to model. For example, WDM ROADM may have 80 transponders capable of terminating 80 OCh trails. This means 80 Och layer TTPs and at least 80 transitional links to terminate. In fact the number could be much greater because each TTP can adopt multiple clients, each connected via separate transitional link. The point is that a TE topology with transitional TE links can potentially explode size-wise (or, at least, become significantly larger) as compared to the TE topology without transitional links.
[DB>] The conclusion is correct that a physical node has to be subdivided into logical sub-nodes - this is shown on the following figure:

[DB>] Your concern that the introduction of transitional links has a scalability issue is not true because we have OTN switches today.
[DB>] that have a high capacity and can handle huge numbers of TPs and there's no difference with this approach.

IB>> But we are not modeling OTN switches, do we? I think you are confusing the TEDB implementation (where you can put as many transitional links as you want)  with the data store structure as it is seen from outside. No one assumes that you run your path computation directly on data received via RESTCONF/METCONF session. Rather, it is assumed that you use the latter information to incorporate it into an internal TEDB, which will be used for path computations. By doing so you have freedom to modify the received data in any way you want. For example, you can use the inter-layer lock information to locally produce transitional links if you want to, provided, of course, you have all information you need.

Again, we are modeling the relationship between two (client, provider) SDN controllers. It is one thing to respond to the RESTCONF “get” with 100 links, and, totally different thing to respond with thousands links, especially when there is also a need to send updates on all link modifications.

Moreover, you
[DB>] do not equip your nodes with optical transponders that are not used because of the associated cost!

IB>> Well, in ADVA, for one,  we had such ROADMs with 80 transponders, all of them in use.
These transponders are in use for a reason: they carry client payload.
Also transponders can stand by as redundancy for recovery purposes

Not only it goes across the layer boundary and interconnects termination points in different layers (which we allow today for legacy reasons, although discourage), transitional link interconnects TPs of completely different types – link termination point – LTP - on the client side and tunnel termination point  - TTP - on the server side. Recall that LTP is the place where same layer switching is happening, while TTP is the place where the client adaptation on the server trail is happening.
[DB>] Switching doe not occur on a transitional link - TPs of the same layer are connected via a switching fabric (the blue or orange
[DB>] switch in the figure above.

IB>> Adaptation is happenning on server TP (one side of transitional link), but not on the client TP (the other side)

Please, note that none of the TE link attributes with a questionable exception of TE metric makes any sense for transitional link on the client side.
[DB>] Link metric does make perfectly sense to control whether existing resources shall be preferred if available before a new server
[DB>] layer trail is established.

IB>> Correct, but do you really need to specify this preference for each individual transitional link?

Only the bandwidth attribute makes sense on the transitional link server side; however, this is not the bandwidth we model for our “regular” TE link – unreserved bandwidth available on the link on per priority level. This is the adaptation bandwidth shared among all transitional links pointing to the same server layer TTP, where priority does not seem to apply. The TE metric is of a questionable value: why would you have a separate TE metric for each transitional link? It is not like they are different in fiber length, delay or anything. It would be sufficient for the inter-layer path computer to have a simple policy saying something like this: every time you go from client layer X to server layer Y apply cost penalty Z.
[DB>] Isn't that what the link metric is all about?

IB>> It is one thing to say once as a policy when you enter layer X from layer Y, apply  penalty Z, than to say the same thing 1000 time (per every transitional link). You will need inter-layer policies anyway, otherwise you will end up engaging several 100Gb trails to accommodate a single 10Mb MPLS-TP layer LSP.
Also, except for TE metric what other TE link attributes you plan to re-use?

The bottom line: if transitional TE link cannot re-use any attributes of  “regular” TE link, what do we actually gain by modeling the former as TE link? It would be better and cleaner to model the inter-layer relationship as somewhat totally different from TE link.
[DB>] Up to now, I have not seen a killing argument that prevents us from using transitional links in the TE topology.

On the picture server layer TTP1s can adopt client L1c and L2c. Hence Ns/TTP1s combination is not unique. On the other hand, client L1c can be adopted on either TTP1s or TTP2s, hence Nc/L1c is not unique either. This is a serious deviation from current modeling concepts.
[DB>] This issue, I don't understand. A incoming client layer connection can of course use any of the transitional links. When a
[DB>] path is calculated, one transitional link is selected in case several transitional links are possible leading to equal cost paths.

IB>>Those are logistics issues One of the issues: when pce returns resulting path, today it only specifies one (e.g. outbound) link end per each path element. Because, nodeId/linked combination is not unique for transitional links, the path now will have to include both ends of each link. Other issue: today TE link key is local linked/ local nodeID, now we will have to change it to be local link ID/ local node ID/remote link ID/ remote node ID.

So, what do you think?
[DB>] I think that I need to understand better the concept you call "inter-layer lock". Maybe you can prepare some slides for the
[DB>] cal next Mon.

IB>> I thought I was clear in explaining this very simple concept, but will be happy to explain on Monday.

Cheers,
Igor

Cheers,
Igor

Hi Gert, Xiang, all,

Thanks,
Dieter

You got my point

Gert

Hi, Gert, Paul, Dieter,

Regards,
Xian

Paul,

- Gert

Paul,

Gert

best,
pd

Sent from my Apple ][

Hi Gert (and Dieter),

if I may interject here:

best,
pd

Hi Dieter,

See below ...

Hi Gert,

thanks for your comment!

Thanks,
Dieter

Thoughts?

Gert

Hi TEAS WG,

Comments are welcome.

Thanks,
Dieter

Teas mailing list

---

From: "Xufeng Liu" <[email-masked]>
Date: Fri, 4 Mar 2016 15:24:30 -0500

Hi Dieter and All,

A few comments below.

Thanks,

- Xufeng

From: Teas [mailto:[email-masked]] On Behalf Of Dieter Beller
Sent: Friday, March 4, 2016 12:46 PM
To: EXT Igor Bryskin <[email-masked]>; EXT Gert Grammel <[email-masked]>; Zhangxian (Xian) <[email-masked]>; TEAS WG <[email-masked]>
Subject: Re: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

Hi Igor, all,

Hi guys,

 

[Xufeng] Splitting N2 into N2_L1 and N2_L0 like this will lose necessary constraints and generate unnecessary complexities. How do we know N2_L1 and N2_L0 were bound together before the splitting? How do we prevent one end of the “transitional link” from being connected to an end on an unrelated node, for example N3_L0 or N4_L1? A topology link, in our model, can connect any link end (link TP) on one node to another link TP on a different node, within a particular topology. 

[DB>] Your concern that the introduction of transitional links has a scalability issue is not true because we have OTN switches today.
[DB>] that have a high capacity and can handle huge numbers of TPs and there's no difference with this approach. Moreover, you
[DB>] do not equip your nodes with optical transponders that are not used because of the associated cost!

 

[Xufeng] If the characteristics of  a “transitional link” are too different from a normal TE link, it would better not to model it as a TE link. A TE link currently covers attributes like switch-capability, encoding-type, srlgs, protection capabilities, and under-lay information. Not many of them are applicable to the “transitional link”.

 

 

So, what do you think?

Cheers,

Igor

 

Hi Gert, Xiang, all,

Thanks,
Dieter

Hi Zhangxian,

You got my point

Gert

From: Teas <[email-masked] <mailto:[email-masked]> > on behalf of Zhangxian <[email-masked] <mailto:[email-masked]> >
Date: Thursday 3 March 2016 08:56
To: Gert Grammel <[email-masked] <mailto:[email-masked]> >, Paul Doolan <[email-masked] <mailto:[email-masked]> >, Dieter Beller <[email-masked] <mailto:[email-masked]> >
Cc: TEAS WG <[email-masked] <mailto:[email-masked]> >
Subject: Re: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

Hi, Gert, Paul, Dieter, 

            |  |        +--ro priority     uint8

 

Regards,

Xian     

Paul,

- Gert

From: Paul Doolan <[email-masked] <mailto:[email-masked]> >
Date: Wednesday 2 March 2016 04:01
To: Gert Grammel <[email-masked] <mailto:[email-masked]> >
Cc: Dieter Beller <[email-masked] <mailto:[email-masked]> >, TEAS WG <[email-masked] <mailto:[email-masked]> >
Subject: Re: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

Paul,

Gert

best,

pd

Sent from my Apple ][

On 01 Mar 2016, at 20:34, Doolan, Paul (Coriant - US/Irving) <[email-masked] <mailto:[email-masked]> > wrote:

Hi Gert (and Dieter), 

if I may interject here:

 

best,

pd

Hi Dieter,

See below ...

On 2016-01-03 18:14, "Dieter Beller" <[email-masked] <mailto:[email-masked]> > wrote:

Hi Gert,

thanks for your comment!

 

In 

RFC5212 an move on?

Thanks,

Dieter

Hi Dieter,

it

³internal

Link² in RFC6001:

to

region

TE-LSP. <snip>

require new terminology.

Thoughts?

Gert

 

<[email-masked] <mailto:[email-masked]>  on behalf of [email-masked] <mailto:[email-masked]> > wrote:

Hi TEAS WG,

single

not blocking free.

networks.

YANG models.

Comments are welcome.

Thanks,

Dieter

Teas mailing list

[email-masked] <mailto:[email-masked]> 

 

_______________________________________________
Teas mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/teas

---

From: Fatai Zhang <[email-masked]>
Date: Tue, 15 Mar 2016 08:30:42 +0000

Hi Gert,

I would second you. 

If there is nothing missing, why it needs a new terminology？

Best Regards

Fatai

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Gert Grammel
Sent: Wednesday, March 02, 2016 6:05 AM
To: Belotti, Sergio (Nokia - IT)
Cc: Beller, Dieter (Nokia - DE); TEAS WG
Subject: Re: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

Sergio,

Gert

Sent from my Apple ][

---

From: Fatai Zhang <[email-masked]>
Date: Tue, 15 Mar 2016 08:38:23 +0000

Hi Dieter,

Thanks for your slides, very clear.

Which layer (either client or server) does the transitional link belong to?

I think it is valuable to have ‘transitional link’ symbol when drawing a picture for a multi-layer network topology, but Yang Model is a kind of data model, so how ‘transitional link’ can help if there  is no this kind of attribute in the reality (i.e, the relevant protocols)?

Best Regards

Fatai

From: Teas [mailto:[email-masked]] On Behalf Of Dieter Beller
Sent: Thursday, March 03, 2016 10:31 PM
To: EXT Gert Grammel; Zhangxian (Xian); TEAS WG
Subject: Re: [Teas] Use cases discussed during the IETF TE Topology YANG Model Design Meeting

Hi Gert, Xiang, all,

Thanks,
Dieter

You got my point

Gert

Hi, Gert, Paul, Dieter,

Regards,
Xian

Paul,

- Gert

Paul,

Gert

best,
pd

Sent from my Apple ][

Hi Gert (and Dieter),

if I may interject here:

best,
pd

Hi Dieter,

See below ...

Hi Gert,

thanks for your comment!

Thanks,
Dieter

Thoughts?

Gert

Hi TEAS WG,

Comments are welcome.

Thanks,
Dieter

---

From: Dieter Beller <[email-masked]>
Date: Tue, 15 Mar 2016 17:00:28 +0100

Hi Fatai, all

On 15.03.2016 09:38, EXT Fatai Zhang
wrote:

Hi Dieter,

Which layer (either client or server) does
the transitional link belong to?

the answer is: to both and here is the explanation: a transitional
link has different types of TPs on the two end of a transitional
link.

On the client layer side it typically has a set of TPs that can be
used for carrying traffic as soon as the server layer trail is
established.

Example: a transitional link representing a 100G optical transponder
may have the following client layer TPs of the type ODUk:

{1 x ODU4, 2 x ODU3, 10 x ODU2, 40 x ODU1, 80 x ODU0} and on the
server layer side it will have a single server layer TP of the

type OCh.

I think it is valuable to have ‘transitional
link’ symbol when drawing a picture for a multi-layer
network topology, but Yang Model is a kind of data model,
so how ‘transitional link’ can help if there  is no this
kind of attribute in the reality (i.e, the relevant
protocols)?

The idea is to model transitional links using the model of regular
links. During the call yesterday, we agreed that it is probably very
useful

to define a new TE link type attribute that explicitly indicates
whether the link is a regular (horizontal) link or a transitional
(vertical) link.

Otherwise, this property has to be inferred from the TPs associated
with the link ends. Please note that there is nothing special in
addition

to what I just described above. The purpose of the transitional link
is to link a client layer topology with a server layer topology in
order to

support multi-layer path computation in a multi-layer network. The
concept is not specific to the OTN and is applicable to any layer

transition between a client layer network and its adjacent server
layer network (e.g. Ethernet over ODUk or IP over MPLS).

Thanks,

Dieter

Best Regards

Fatai

Hi Gert, Xiang, all,

during the TE Topology YANG Model Design Meetings, we
discussed how the TE topology of a multi-layer network
should be modeled.

for the network element extenal LSAs to describe network
element internal capabilities. It shall be noted that
OSPF-TE is only advertising

TE information only for the links interconnecting the
network element with its neighbors ("normal" links). Based
on the MRN information

disseminated via OSPF into the network, each network element
has to determine whether layer transitions are possible
inside all the other

Now, we are defining a TE topology YANG model for that
topology including the transitional links. Therefore, it
does not make sense to

add the IACD information to the normal links. Instead, the
TE topology model should explicitly include the transitional
links already as

they belong to the multi-layer topology. IMO, it does not
make sense to still use the IACD approach.

Thanks,

Dieter

On 03.03.2016 11:57,
EXT Gert Grammel wrote:

Hi Zhangxian,

You got my point

Gert

From:
Teas <[email-masked]>
on behalf of Zhangxian <[email-masked]>

Hi, Gert, Paul, Dieter,

I wonder if we are only debating
whether there is need of new terminology,  or whether
TE TOPOLOGY YANG model have already captured the
attributes needed for such an entity (be it
transitional link or internal link)?

None of this two terms are listed in
this YANG model and what we have now is only the IACD
and it has  the following information/attributes under
the TE link:

|  |        +--ro priority     uint8

Regards,

Xian

Sent: 2016年3月2日 18:03

Paul,

<snip>  So to answer your

- Gert

From:

On Mar 1, 2016, at 4:08 PM, Gert
Grammel wrote:

Paul,

Gert

Well Gert , at the start of this
thread Dieter observed that :-

Nothing that you have cited so
far provides an accurate definition of
transition links as explained by Dieter. In
fact I think they point to deficiencies in the
definition(s), such as they are, of something
different, namely 'internal links'.

Why does this matter in the
context of YANG model definition? It matters
only insofar as a model is useful if, and only
if, there is no ambiguity as to the meaning of
the terms that it, the model, employs. A
consequence of this is that if one finds while
developing a model  that the existing
vocabulary is inadequate to unambiguously
describe the situation being modeled then new
terms need to be defined. In an ideal world
one would go back to the relevant Information
Model  and fix the problem - if it exists -
there or use an applicable definition from
that model.

So to answer your question, a new
term facilitates the definition of YANG model
(for topology) if the existing terminology  is
inadequate to describe something necessary, or
at least 'useful' ,to  allow that model to
describe the reality it is intended to
describe.

I see no reason that a draft
describing a model cannot define terms
specific to the domain it is attempting to
model.

best,

pd

Sent from my Apple ][

On 01 Mar 2016, at 20:34, Doolan,
Paul (Coriant - US/Irving) <[email-masked]>
wrote:

Hi Gert (and Dieter),

if I may interject here:

Isn’t that what RFC5212
defined as “internal link”?

I don't think that, if you look
carefully, you will find that RFC5212
defines 'internal link'.  It uses it, and
you may be tempted to infer a definition
from that usage, but it doesn't IMO define
it.

In any case you earlier quote
RFC6001 thus:

The logical composition of a
hybrid node contains at least two distinct
switching elements that are interconnected
by "internal links" to provide adjustment
between the supported  switching
capabilities.

Again as a definition this text
leaves something to be desired; I don't
think it's good practice that reader is
supposed to infer from the quotation marks
that this is a (complete) definition. In
addition there is no requirement imposed by
this text that the switching capabilities on
each end of the internal link be different.

Using transitional link allows
us to provide a definition that improves on
these shortcomings. A definition of
transitional link should explicitly state
whether the TPs at the link ends MUST be
different or if they MAY be the same.

best,

pd

On Mar 1, 2016, at 12:45 PM,
Gert Grammel wrote:

Hi Dieter,

See below ...

On 2016-01-03 18:14,
"Dieter Beller" <[email-masked]>
wrote:

Hi Gert,

thanks for your comment!

If I understand your
comment correctly, you are basically in
agreement

with the concept of
modelling layer transitions between

adjacent layers in a
multi-layer network.

Since RFC5212 defined that
relation (among others) it appears to me
the

natural way to do so in a
multi-layer context.

When we introduced the term
"transitional link, we were well aware
of

RFC5212 which is also
addressing multi-layer aspects.

The term "internal link"
may make sense in the context of a
network

element (--> Figure 1).
The TE topology YANG model,

however, shall model the TE
topology graph of a network that is
composed

of nodes and links and in
this context the qualifier

"internal" seems not very
useful.

When looking at your slides
e.g. P.5  it seems the transitional link
is

internal to N2 and N5. Looks
pretty much like an internal link.

Therefore, we introduced
the qualifier

"transitional" to indicate
the difference between a

"transitional link" and a
"normal" link. We do belive that a

"transitional link" can be
modeled very similar to a "normal" link.

The major differences are
that it has TPs of a different type on
the

link ends (for normal
links, they are the same) and the

YANG model shall
unambiguously describe the adaptation
and termination

functions which a re
logically located on the link.

Isn’t that what RFC5212
defined as “internal link”?

This can probably be
inferred from the properties of the
"transitional

link" and does not need to
be describes explicitly.

I hope that this clarifies
why we are preferring a different term.

In

the draft, when the term
"transitional link" is defined we can

mention that the term
"internal link" is used in RFC5212.

If so, why bothering with
"yet another term”, instead of referencing

RFC5212 an move on?

Thanks,

Dieter

On 01.03.2016 16:32, EXT
Gert Grammel wrote:

Hi Dieter,

Thanks for sharing the

RFC5212 appears to be a

it

seems that the term

³internal

Link² in RFC6001:

<snip> The logical

distinct switching

to

provide adjustment
between the supported

switching capabilities.

that MUST be taken into

region

TE-LSP. <snip>

While I see value in

require new terminology.

Thoughts?

Gert

On 2016-01-03 14:45,

<[email-masked]
on behalf of
[email-masked]>
wrote:

Hi TEAS WG,

as suggested by Lou, I
am sharing with you some slides
describing

single

layer and multi layer
use cases, which were discussed
during

the IETF TE Topology
YANG Model Design Meeting yesterday.

The first 2 slides
address (sub-)network abstraction
and propose to use

the connectivity matrix
in case the resulting abstract node
is

not blocking free.

The remaining slides
are describing multi-layer network
scenarios where

a server layer trail is
established in order to carry client
layer

connections. In order
to support multi-layer path
computation,

transitional links are
proposed, which allow the
construction of a

multi-layer network
topology graph. Transitional links
connect the

topology graphs of two
adjacent network layers. They are
created

based on the capability
of a node to encapsulate a client
layer signal

into a server layer
signal. Exampleas are: IP in MPLS,
OTN ODUk

into an OCh signal.
While the transitional link concept
is explained in

the context of the OTN,
it is generally applicable to all
mult-layer

networks.

According to my
perception, there was rough
consensus that transitional

links are useful  and
should be included in the TE
topology

YANG models.

Comments are welcome.

Thanks,

Dieter

Teas mailing list

[email-masked]