Subject: [Teas] Review of draft-ietf-teas-actn-framework-01

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 25 Nov 2016 19:03:48 -0000

Hi list and authors,

I took an action to review the ACTN documents for terminology and consistency
with RFC 7926.

The first on my list was the framework draft.

The terminology was not too bad. The main issue was that the document was using
"abstraction" in two different ways:
1. presentation of real resources as a virtualised set of resources
2. separation of processes used by an overlay from the actual processes used by
the underlay.
These are both correct uses of the word although the first definition is what is
usually used in the industry (ONF, IETF). Orchestration may be an adequate term
for the second meaning.

I found the definitions of "node" and "link" and suggested replacement text.

Also some need to be careful with the term "aggregation".

Along the way I found quite a number of typos, format issues, and changes for
clarity. I collected these in a Word file with change markers. I sent that to
Young, and I won't bore the list with a non-standard format file.

In summary...
- Lots of format issues caused by export from Word
- Need to put Abstract on front page
- s/draft/document/
- sort out references
- expand abbreviations on first use
- clarify the difference between "resource slicing" and "resource sharing"
- clarify the terms "client" and "customer"
- some of the statements about VPNs seem to be over-constrained
- delete figures 2 and 3 as basically empty
- tidy up figures
- note "editor note" needs fixing
- try to resolve difference between an end point and a network function
   located in a DC
- security section is absent
- sort out authors and contributors

As an aside, I am not sure that there is a necessity to have APs (and VNAPs) in
the architecture. I don't object to them, just I don't see the point.

Cheers,
Adrian

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 28 Nov 2016 14:14:47 +0000

Hi Adrian,

Thanks a lot for the thorough review. 

I agree with the usage of abstraction in the two scenarios, the suggested change makes sense to me. 

We'll go through the doc and fix the comments. Regarding the APs I don't understand if you're suggesting to define the APs in a different document since they don't fit into the architecture or you don't see any value in them at all and you're suggesting to drop them?

Thanks a lot
Daniele   

> -----Original Message-----
> From: Teas [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: venerdì 25 novembre 2016 20:04
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Teas] Review of draft-ietf-teas-actn-framework-01
> 
> Hi list and authors,
> 
> I took an action to review the ACTN documents for terminology and
> consistency with RFC 7926.
> 
> The terminology was not too bad. The main issue was that the document was
> using "abstraction" in two different ways:
> 1. presentation of real resources as a virtualised set of resources 2. separation
> of processes used by an overlay from the actual processes used by the
> underlay.
> usually used in the industry (ONF, IETF). Orchestration may be an adequate
> term for the second meaning.
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: Leeyoung <[email-masked]>
Date: Mon, 28 Nov 2016 15:06:35 +0000

Hi Adrian,

I also thank you for your careful and useful review of the framework document. 
As Daniele committed for the revision, we will promptly make the changes and have the list know what changes has been made.

In regard to your comments on the APs/VNAPs, I have the same question as Daniele's. Please clarify it. Thanks.

Best regards,
Young

-----Original Message-----
From: Daniele Ceccarelli [mailto:[email-masked]] 
Sent: Monday, November 28, 2016 8:15 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [Teas] Review of draft-ietf-teas-actn-framework-01

Hi Adrian,

Thanks a lot
Daniele   

> The terminology was not too bad. The main issue was that the document 
> was using "abstraction" in two different ways:
> 1. presentation of real resources as a virtualised set of resources 2. 
> separation of processes used by an overlay from the actual processes 
> used by the underlay.
> These are both correct uses of the word although the first definition 
> is what is usually used in the industry (ONF, IETF). Orchestration may 
> be an adequate term for the second meaning.
> 
> Along the way I found quite a number of typos, format issues, and 
> changes for clarity. I collected these in a Word file with change 
> markers. I sent that to Young, and I won't bore the list with a non-standard format file.
> 
> In summary...
> As an aside, I am not sure that there is a necessity to have APs (and 
> VNAPs) in the architecture. I don't object to them, just I don't see the point.
> 
> Cheers,
> Adrian
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 28 Nov 2016 18:04:14 -0000

> As Daniele committed for the revision, we will promptly make the changes and
> have the list know what changes has been made.

Great. I have the Requirements draft open in my editor for a similar review.

> Daniele's. Please clarify it. Thanks.

Correct document. I just fail to grasp the value of APs within the architecture.
They seem to sit on the boundary between a CE and PE and there is a 1:1
relationship between a CE-PE pair and an AP. 

But anyway, I don't think they harm anything.

Adrian
--
Support an author and your imagination.
Tales from the Wood - Eighteen new fairy tales.
More Tales from the Wood - Eighteen MORE new fairy tales.
https://www.feedaread.com/profiles/8604/
http://www.amazon.co.uk/Tales-Wood-Adrian-Farrel/dp/1786100924
Or buy from me direct.

---

From: Leeyoung <[email-masked]>
Date: Mon, 28 Nov 2016 19:16:49 +0000

Hi Adrian,

Thanks. This helps understand your comments better. 

Best regards,
Young

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Monday, November 28, 2016 12:04 PM
To: Leeyoung; 'Daniele Ceccarelli'; [email-masked]
Cc: [email-masked]
Subject: RE: [Teas] Review of draft-ietf-teas-actn-framework-01

> As Daniele committed for the revision, we will promptly make the 
> changes and have the list know what changes has been made.

Correct document. I just fail to grasp the value of APs within the architecture.
They seem to sit on the boundary between a CE and PE and there is a 1:1 relationship between a CE-PE pair and an AP. 

Adrian