Subject: [Teas] impact of I2RS models only being applicable to I2RS&Ephemeral state

From: Lou Berger <[email-masked]>
Date: Wed, 25 Jan 2017 09:19:00 -0500

WG,

The TE topology and some other individual drafts rely on the I2RS
topology drafts.  As part of a long IESG discussion* it seems that the
applicability of the I2RS drafts may be (re)scoped to just the future
I2RS protocol(s) and ephemeral state. 

I'd like to hear from the WG/authors/implementers on what they think the
impact of such a change will be on our WG drafts.  What do you think?

>From my standpoint, it seems like it means we would have to remove any
dependencies on this I2RS drafts, but I'm hoping I'm mistaken.

Thanks,
Lou

(*) if you feel like reading the background on this, a good starting
point is:
https://www.ietf.org/mail-archive/web/i2rs/current/msg04274.html

---

From: Igor Bryskin <[email-masked]>
Date: Wed, 25 Jan 2017 14:44:58 +0000

Hi Lou,

As a co-author of TE topology model I really welcome and am looking forward to such a change. We heard from many implementers that such I2RS dependency causes quite a bit of confusion and pain with giving virtually nothing in return. If you remember said dependency was more of a logistic than anything else - to find a home in the YANG family. I think the TE topology model today is well recognized and stable and will do just fine on its own.

Cheers,
Igor

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, January 25, 2017 9:19 AM
To: TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: [Teas] impact of I2RS models only being applicable to I2RS&Ephemeral state

WG,

Thanks,
Lou

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Lou Berger <[email-masked]>
Date: Wed, 25 Jan 2017 09:56:45 -0500

Thanks Igor for being flexible.  Well we'll have to see how this plays out 
in I2RS and the iesg  as well as see what others in the wg say to decide...

Lou

On January 25, 2017 9:45:52 AM Igor Bryskin <[email-masked]> wrote:

> Hi Lou,
>
> As a co-author of TE topology model I really welcome and am looking forward 
> to such a change. We heard from many implementers that such I2RS dependency 
> causes quite a bit of confusion and pain with giving virtually nothing in 
> return. If you remember said dependency was more of a logistic than 
> anything else - to find a home in the YANG family. I think the TE topology 
> model today is well recognized and stable and will do just fine on its own.
>
> Cheers,
> Igor
>

---

From: Alia Atlas <[email-masked]>
Date: Wed, 25 Jan 2017 10:09:48 -0500

Igor,

Is the TE topology model only reading from the operational state - or is
there any expectation that any expectation of the ability to write parts of
the
topology as well?

Could you describe how that will behave at a reboot time in detail with the
dependencies?

Regards,
Alia

On Wed, Jan 25, 2017 at 9:56 AM, Lou Berger <[email-masked]> wrote:

>> As a co-author of TE topology model I really welcome and am looking
>> forward to such a change. We heard from many implementers that such I2RS
>> dependency causes quite a bit of confusion and pain with giving virtually
>> nothing in return. If you remember said dependency was more of a logistic
>> than anything else - to find a home in the YANG family. I think the TE
>> topology model today is well recognized and stable and will do just fine on
>> its own.
>>
>> Cheers,
>> Igor
>>

---

From: "Aihuaguo (Aihua Guo, CRC)" <[email-masked]>
Date: Wed, 25 Jan 2017 15:54:22 +0000

As an implementer I fully support Igor's view. We are implementing the TE topology model in open source project in ONOS, and found that it is really an issue to have to use the I2RS keys externally whereas internally our TE logic is all built using the keys defined in the TE topology. 

I look forward to such a change to make the TE models more implementable and usable.

Thanks,
Aihua

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: Wednesday, January 25, 2017 9:45 AM
To: Lou Berger; TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: Re: [Teas] impact of I2RS models only being applicable to I2RS&Ephemeral state

Hi Lou,

Cheers,
Igor

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, January 25, 2017 9:19 AM
To: TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: [Teas] impact of I2RS models only being applicable to I2RS&Ephemeral state

WG,

The TE topology and some other individual drafts rely on the I2RS topology drafts.  As part of a long IESG discussion* it seems that the applicability of the I2RS drafts may be (re)scoped to just the future I2RS protocol(s) and ephemeral state. 

I'd like to hear from the WG/authors/implementers on what they think the impact of such a change will be on our WG drafts.  What do you think?

Thanks,
Lou

(*) if you feel like reading the background on this, a good starting point is:
https://www.ietf.org/mail-archive/web/i2rs/current/msg04274.html

---

From: Giles Heron <[email-masked]>
Date: Wed, 25 Jan 2017 16:38:09 +0000

Hi Aihua,

as an author of models based on the I2RS topology model i disagree (no surprise I’m sure).

when you implement client code that consumes a network topology it’s nice not to have to know the topology type (or at least to be able to isolate that knowledge to specific per-protocol areas within your code).   So for example with the TEAS model as currently defined, if OpenDaylight migrated BGP-LS data to an instance of the TEAS model we would only have to make minimal changes to existing client-side code that interfaces with linkstate topology.

so scoping the I2RS models to the I2RS use case is a bad idea IMO.

and I’m not sure what you mean by “use the I2RS keys externally”.  The keys in the I2RS model are the node-id, link-id, tp-id etc.   Those generally contain data that you’ve mapped in from the relevant protocol.   Or is your issue that the keys are URIs (hence opaque values rather than of a type specific to your model?)

Giles

> On 25 Jan 2017, at 15:54, Aihuaguo (Aihua Guo, CRC) <[email-masked]> wrote:
>

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 25 Jan 2017 12:31:51 -0500

Lou:

As a member of TEAS and an I2RS co-Chair, I object to the conclusion in this
email.  I believe that you do not have your facts straight on the I2RS
protocol or the ephemeral drafts.  Perhaps we should talk via phone.  Please
let's take this discussion across multiple lists down a notch. 

Sue 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: Wednesday, January 25, 2017 9:45 AM
To: Lou Berger; TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Hi Lou,

As a co-author of TE topology model I really welcome and am looking forward
to such a change. We heard from many implementers that such I2RS dependency
causes quite a bit of confusion and pain with giving virtually nothing in
return. If you remember said dependency was more of a logistic than anything
else - to find a home in the YANG family. I think the TE topology model
today is well recognized and stable and will do just fine on its own.

Cheers,
Igor

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, January 25, 2017 9:19 AM
To: TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

WG,

The TE topology and some other individual drafts rely on the I2RS topology
drafts.  As part of a long IESG discussion* it seems that the applicability
of the I2RS drafts may be (re)scoped to just the future I2RS protocol(s) and
ephemeral state. 

Thanks,
Lou

(*) if you feel like reading the background on this, a good starting point
is:
https://www.ietf.org/mail-archive/web/i2rs/current/msg04274.html

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 25 Jan 2017 12:39:35 -0500

Igor: 

I believe Lou does not have his facts correct.   I object to TEAS taking
this action base on Lou's misstatement of the facts.   

Sue 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: Wednesday, January 25, 2017 9:45 AM
To: Lou Berger; TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Hi Lou,

Cheers,
Igor

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, January 25, 2017 9:19 AM
To: TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

WG,

Thanks,
Lou

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 25 Jan 2017 12:40:36 -0500

Lou: 

You are mistaken in your understanding.  I object to you derailing the work
from I2RS individuals based on your misunderstanding.  I encourage you to
get the facts straight. 

Sue Hares 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, January 25, 2017 9:19 AM
To: TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

WG,

Thanks,
Lou

---

From: Lou Berger <[email-masked]>
Date: Wed, 25 Jan 2017 12:47:12 -0500

Sue,

    I believe Igor is just stating his personal opinion.  I believe it
should be clear from my follow up message [1] that the discussion on use
will continue beyond this one statement, and any action within the WG
will be gated by how the I2RS/IESG discussion plays out.

Lou

PS I'll contact you off line for a 1-on-1 sync up.  Thanks for the offer!

[1] https://www.ietf.org/mail-archive/web/teas/current/msg01956.html

---

From: Lou Berger <[email-masked]>
Date: Wed, 25 Jan 2017 12:54:50 -0500

Sue,

    I certainly didn't mean to misrepresent anything -- My understanding
is that there is a discussion going on in I2RS with the IESG that may
lead to a result that has significant impact on one of our WG documents.
I thought it would be good to get *this* WG's feedback on that
possibility.  Of course there is a huge amount of mail on this topic
over in I2RS so I completely accept I may have misunderstood this
*possible* outcome.

Is my statement that "the applicability of the I2RS drafts may be
(re)scoped to just the future I2RS protocol(s) and ephemeral state. "
incorrect?  If so, in what way? -- please note I said *may* as the
discussion in  I2RS is ongoing. 

Thank you,
Lou

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 25 Jan 2017 13:03:12 -0500

Lou: 

If one does not understand all the facts, perhaps a wise course is silence
(aka no messages).  I really believe that TEAS, NETMOD, NETCONF, and I2RS
are all the same wave-length and plan regarding topology models.   We've
been doing good work together.  Sowing FUD (fear, uncertainty, doubt) wastes
time.  

NETMOD is the WG setting up the solution for ephemeral state which I2RS yang
models sit in.  An NETMOD based security considerations for ephemeral state
data stores would mean that I2RS YANG models would not have to state it.
This ephemeral state model could be examined by TEAS to see if works for
them.  I2RS could also review it.  

Sue 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, January 25, 2017 12:55 PM
To: Susan Hares; 'TEAS WG'
Cc: 'Benoit Claise'; 'Alia Atlas'
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Sue,

    I certainly didn't mean to misrepresent anything -- My understanding is
that there is a discussion going on in I2RS with the IESG that may lead to a
result that has significant impact on one of our WG documents.
I thought it would be good to get *this* WG's feedback on that possibility.
Of course there is a huge amount of mail on this topic over in I2RS so I
completely accept I may have misunderstood this
*possible* outcome.

Is my statement that "the applicability of the I2RS drafts may be (re)scoped
to just the future I2RS protocol(s) and ephemeral state. "
incorrect?  If so, in what way? -- please note I said *may* as the
discussion in  I2RS is ongoing. 

Thank you,
Lou

On 1/25/2017 12:40 PM, Susan Hares wrote:
> Lou: 
>
> You are mistaken in your understanding.  I object to you derailing the 
> work from I2RS individuals based on your misunderstanding.  I 
> encourage you to get the facts straight.
>
> Sue Hares
>
> I'd like to hear from the WG/authors/implementers on what they think 
> the impact of such a change will be on our WG drafts.  What do you think?
>
> point

---

From: Igor Bryskin <[email-masked]>
Date: Wed, 25 Jan 2017 18:19:31 +0000

Hi Sue,

We (co-authors) discussed today the implications of this new BREXIT - becoming independent from I2RS topology model. The conclusion is that there are pros and cons to that, with one of the latter being existing implementations, for example. Obviously, we can live with staying dependent (otherwise, we would fight for the independence :=). What I was saying is that there are also advantages to become independent. In short we can live with either decision. 

We also do not have all facts, not even a clue as to why is this dramatic change after all the hard work we put to "marry" I2RS and TE topology models.

Cheers,
Igor 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Wednesday, January 25, 2017 12:40 PM
To: Igor Bryskin; 'Lou Berger'; 'TEAS WG'
Cc: 'Benoit Claise'; 'Alia Atlas'
Subject: Re: [Teas] impact of I2RS models only being applicable to I2RS&Ephemeral state

Igor: 

Sue 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: Wednesday, January 25, 2017 9:45 AM
To: Lou Berger; TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Hi Lou,

Cheers,
Igor

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, January 25, 2017 9:19 AM
To: TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

WG,

Thanks,
Lou

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 25 Jan 2017 13:16:50 -0500

Lou: 

The I2RS discussion thread needs to be reformed to do something actionable.
IMO, the problem is the NETMOD definition of ephemeral state is not firm
enough to have a reasonable discussion.  So FUD reigns.   Let's talk as
chairs on how to break the issues into questions we can discuss about
topology models, ephemeral state, and I2RS ephemeral state.   We should
collect issues/questions from WG.  Igor might have some Question or
comments. 

I'll contact you offline. 

Sue 

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Wednesday, January 25, 2017 12:55 PM
To: Susan Hares; 'TEAS WG'
Cc: 'Benoit Claise'; 'Alia Atlas'
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Sue,

Thank you,
Lou

---

From: Lou Berger <[email-masked]>
Date: Wed, 25 Jan 2017 13:25:52 -0500

Sue,

    I'm fine with taking the discussion offline and then coming back and
reporting next steps to our respective WGs.

Lou

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 25 Jan 2017 13:43:47 -0500

Igor: 

I do not think there is a change in work or the attitudes in I2RS. I2RS's
ephemeral design has topology models at heart and TEAS concept in mind.  

The whole discussion came regarding the expanding the yang security section
for the models, and not the model content.  Security area experts gave I2RS
good ideas on how to secure topology information which the I2RS WG placed in
our requirements for protocol security and ephemeral state.   We had hoped
that NETMOD would create definition of ephemeral state, review the I2RS
security requirements, and make a recommendations for deployment of YANG
topology models (in or outside of ephemeral state). 

Thanks for listening, 

Sue Hares 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: Wednesday, January 25, 2017 1:20 PM
To: Susan Hares; 'Lou Berger'; 'TEAS WG'
Cc: 'Benoit Claise'; 'Alia Atlas'
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Hi Sue,

We (co-authors) discussed today the implications of this new BREXIT -
becoming independent from I2RS topology model. The conclusion is that there
are pros and cons to that, with one of the latter being existing
implementations, for example. Obviously, we can live with staying dependent
(otherwise, we would fight for the independence :=). What I was saying is
that there are also advantages to become independent. In short we can live
with either decision. 

We also do not have all facts, not even a clue as to why is this dramatic
change after all the hard work we put to "marry" I2RS and TE topology
models.

Cheers,
Igor 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Wednesday, January 25, 2017 12:40 PM
To: Igor Bryskin; 'Lou Berger'; 'TEAS WG'
Cc: 'Benoit Claise'; 'Alia Atlas'
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Igor: 

Sue 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: Wednesday, January 25, 2017 9:45 AM
To: Lou Berger; TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Hi Lou,

Cheers,
Igor

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, January 25, 2017 9:19 AM
To: TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

WG,

Thanks,
Lou

---

From: Igor Bryskin <[email-masked]>
Date: Wed, 25 Jan 2017 19:02:51 +0000

Hi Alia,

One of the things the model allows for the client is to configure with the provider (e.g. T-SDN network controller) desired abstract topologies (virtual TE networksl) it wants the provider  to calculate, configure and expose back to the client. The client basically can say: “I don’t care about your native/real topology, just present your network to me as this set of (e.g. border) nodes interconnected by this set of links”, with the expectation of provider presenting the requested topology in the data state. Said configuration is modeled as CONFIG=TRUE nodes/ sub-trees. and as such must survive the provider’s reboots.

Cheers,
Igor

From: Alia Atlas [mailto:[email-masked]]
Sent: Wednesday, January 25, 2017 10:10 AM
To: Lou Berger
Cc: Igor Bryskin; TEAS WG; Benoit Claise
Subject: Re: [Teas] impact of I2RS models only being applicable to I2RS&Ephemeral state

Igor,

Is the TE topology model only reading from the operational state - or is
there any expectation that any expectation of the ability to write parts of the
topology as well?

Regards,
Alia

On Wed, Jan 25, 2017 at 9:56 AM, Lou Berger <[email-masked]<mailto:[email-masked]>> wrote:
Thanks Igor for being flexible.  Well we'll have to see how this plays out in I2RS and the iesg  as well as see what others in the wg say to decide...

Lou

On January 25, 2017 9:45:52 AM Igor Bryskin <[email-masked]<mailto:[email-masked]>> wrote:
Hi Lou,

Cheers,
Igor

-----Original Message-----
From: Teas [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Lou Berger
Sent: Wednesday, January 25, 2017 9:19 AM
To: TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: [Teas] impact of I2RS models only being applicable to I2RS&Ephemeral state

WG,

Thanks,
Lou

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Wed, 25 Jan 2017 19:12:01 +0000

Transport SDN controllers typically run in high availability mode (typically even with geo-redundancy). If the controller “reboots” despite HA, there network may have other problems. The same applies to software upgrade.

Michael

From: Teas [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: Wednesday, January 25, 2017 8:03 PM
To: Alia Atlas; Lou Berger
Cc: Benoit Claise; TEAS WG
Subject: Re: [Teas] impact of I2RS models only being applicable to I2RS&Ephemeral state

Hi Alia,

Cheers,
Igor

Igor,

Regards,
Alia

Lou

Cheers,
Igor

-----Original Message-----
From: Teas [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Lou Berger
Sent: Wednesday, January 25, 2017 9:19 AM
To: TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: [Teas] impact of I2RS models only being applicable to I2RS&Ephemeral state

WG,

Thanks,
Lou

---

From: Igor Bryskin <[email-masked]>
Date: Wed, 25 Jan 2017 19:22:15 +0000

Hi Sue,

I understand. Please, don't get me wrong. I never said that I2RS model is somewhat deficient, rather, that there are certain deviations the TE topology model has WRT the I2RS topology model, making the resulting augmentation somewhat difficult/painful to implement and use. One significant such difference is, as I responded to Alia, that in contrast to the I2RS model, the TE model does allow for the client to configure topologies (in addition to just consuming them). This might warrant for different security concerns/restrictions, and this is where Lou and Alia are getting at, I think. 

Cheers,
Igor

-----Original Message-----
From: Susan Hares [mailto:[email-masked]] 
Sent: Wednesday, January 25, 2017 1:44 PM
To: Igor Bryskin; 'Lou Berger'; 'TEAS WG'
Cc: 'Benoit Claise'; 'Alia Atlas'
Subject: RE: [Teas] impact of I2RS models only being applicable to I2RS&Ephemeral state

Igor: 

Thanks for listening, 

Sue Hares 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: Wednesday, January 25, 2017 1:20 PM
To: Susan Hares; 'Lou Berger'; 'TEAS WG'
Cc: 'Benoit Claise'; 'Alia Atlas'
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Hi Sue,

Cheers,
Igor 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Wednesday, January 25, 2017 12:40 PM
To: Igor Bryskin; 'Lou Berger'; 'TEAS WG'
Cc: 'Benoit Claise'; 'Alia Atlas'
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Igor: 

Sue 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: Wednesday, January 25, 2017 9:45 AM
To: Lou Berger; TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Hi Lou,

Cheers,
Igor

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, January 25, 2017 9:19 AM
To: TEAS WG
Cc: Benoit Claise; Alia Atlas
Subject: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

WG,

Thanks,
Lou

---

From: Lou Berger <[email-masked]>
Date: Thu, 26 Jan 2017 10:40:10 -0500

WG,

    I talked off-line with Sue about this.  As I understand it, the
intent remains for the topology models to remain reusable by non-I2RS
applications and reuse.  So no change is warranted at this time. 
Obviously, things may still change and we'll need to keep an eye on the
documents as they progress through the publication process.  It's good
to know that if something does change, we can rapidly adjust our
documents accordingly.

Lou

---

From: Benoit Claise <[email-masked]>
Date: Thu, 26 Jan 2017 16:48:08 +0100

> data stores would mean that I2RS YANG models would not have to state it.
That would work, I think, as it would imply: if I want to use any YANG 
model, not only the topo-related ones, with the I2RS protocol (and as a 
consequence, with the ephemeral state data store), then I need to apply 
these generic security considerations for ephemeral state data stores.
And they would not have to be repeated in the YANG model documents. This 
solves the issue that we don't have to make the distinction between I2RS 
YANG models and generic YANG models.

Regards, Benoit
> .

---

From: Igor Bryskin <[email-masked]>
Date: Thu, 26 Jan 2017 17:13:14 +0000

Hi Benoit,

One thing to keep in mind is that T-SDN controllers (the most popular TE topology  clients and servers) work almost always in HA (high availability) environments. For such entities the ephemeral configuration is no different from normal configuration because as far as the outside world is concerned they never crash, reboot, etc., hence IMHO everything to do with ephemeral state and it's subtleties is unnecessary and unwelcome complication.

Cheers,
Igor  

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Thursday, January 26, 2017 10:48 AM
To: Susan Hares; 'Lou Berger'; 'TEAS WG'
Cc: 'Alia Atlas'
Subject: Re: [Teas] impact of I2RS models only being applicable to I2RS&Ephemeral state

Regards, Benoit

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 26 Jan 2017 14:20:30 -0500

Igor:

Good point on HA.   You may find that in that environment, the ephemeral
data store has less constraints than the configuration data store.  With the
appropriate information about configuration or ephemeral data store, you can
choose what fits your environment best.   You can decide if models started
in one data store can be moved to another.   

Sue 

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: Thursday, January 26, 2017 12:13 PM
To: Benoit Claise; Susan Hares; 'Lou Berger'; 'TEAS WG'
Cc: 'Alia Atlas'
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

Hi Benoit,

One thing to keep in mind is that T-SDN controllers (the most popular TE
topology  clients and servers) work almost always in HA (high availability)
environments. For such entities the ephemeral configuration is no different
from normal configuration because as far as the outside world is concerned
they never crash, reboot, etc., hence IMHO everything to do with ephemeral
state and it's subtleties is unnecessary and unwelcome complication.

Cheers,
Igor  

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Thursday, January 26, 2017 10:48 AM
To: Susan Hares; 'Lou Berger'; 'TEAS WG'
Cc: 'Alia Atlas'
Subject: Re: [Teas] impact of I2RS models only being applicable to
I2RS&Ephemeral state

On 1/25/2017 7:03 PM, Susan Hares wrote:
> Lou:
>
> If one does not understand all the facts, perhaps a wise course is 
> silence (aka no messages).  I really believe that TEAS, NETMOD, NETCONF,
and I2RS
> been doing good work together.  Sowing FUD (fear, uncertainty, doubt) 
> wastes time.
>
> NETMOD is the WG setting up the solution for ephemeral state which 
> I2RS yang models sit in.  An NETMOD based security considerations for 
> ephemeral state data stores would mean that I2RS YANG models would not
have to state it.

Regards, Benoit
> This ephemeral state model could be examined by TEAS to see if works 
> for them.  I2RS could also review it.
>
> Sue
>
>      I certainly didn't mean to misrepresent anything -- My 
> understanding is that there is a discussion going on in I2RS with the 
> IESG that may lead to a result that has significant impact on one of our
WG documents.
> I thought it would be good to get *this* WG's feedback on that
possibility.
> Of course there is a huge amount of mail on this topic over in I2RS so 
> I completely accept I may have misunderstood this
> *possible* outcome.
>
>> You are mistaken in your understanding.  I object to you derailing 
>> the work from I2RS individuals based on your misunderstanding.  I 
>> topology drafts.  As part of a long IESG discussion* it seems that 
>> the applicability of the I2RS drafts may be (re)scoped to just the 
>> future I2RS protocol(s) and ephemeral state.
>>