Subject: [Teas] Relationship between TE Tutorial and TNBI Applicability Statement

From: Italo Busi <[email-masked]>
Date: Thu, 19 Apr 2018 10:20:01 +0000

During IETF 101 we have received a comment/question regarding the relationship between the TE Tutorial (draft-ietf-teas-te-topo-and-tunnel-modeling) and the TNBI Applicability Statement (draft-ietf-ccamp-transport-nbi-app-statement) documents.

This mail summarizes the output of the discussion with Igor and CCAMP TNBI DT members. Further feedbacks/suggestions are very welcome.

It seems that the two documents have common objectives (clarify how the IETF YANG model can be used) but different scopes.

The scope of the TE Tutorial is to clarify the terminology, definitions, semantics description and modelling considerations. Its focus is only on the TE Topology and TE Tunnel models: use cases are developed on-demand to clarify also advanced topics like detailed connectivity matrix, constraint-based path computation, ...

The scope of the TNBI Applicability Statement is to analyses the applicability of the YANG models to multi-domain OTN network scenario, and in particular what needs to be done to coordinate control of multiple domains. Its focus is on TE Topology, TE Tunnel, OTN augmentation and client mapping models: advanced topics (e.g., constraints based path computation) outside the scope.

Some overlapping of the content between the two documents (in particular when developing JSON code examples) seems unavoidable and, considering that they are Informative document, harmless as long as they are not inconsistent.

In order to minimize the overlapping, the TNBI Applicability Statement will be updated to reference as much as possible the TE Tutorial: if needed, some exiting text can be moved from the TNBI Applicability Statement to the TE Tutorial.

The authors of the two draft will continue to work together to avoid inconsistencies between the two documents.

Italo

Italo Busi
Principal Optical Transport Network Research Engineer
____________________________________________________________________________
Huawei Technologies Italia S.r.l.
Address：Centro Direzionale Milano 2, Palazzo Verrocchio, 3° Floor, 20090 Segrate (MI), Italy
Tel：+39 02 399948 32    Fax：   Mobile：+39 345 4721946
_____________________________________________________________________________
Huawei Technologies Italia S.r.l. is a company registered in Italy at the Company Registration Office of Milan, with registered number 04501190963 and equity capital €3,000,000 fully paid up, whose registered office is in Milan, Via Lorenteggio 257, Tower B, 20152 Milan. Huawei Technologies Italia S.r.l. is 100% owned by Huawei Technologies Cooperatief U.A
_____________________________________________________________________________
This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
PRIVACY NOTICE: Pursuant to Art. 13 of Legislative Decree 196/03, so called "Data Protection Code", Huawei Technologies Italia Srl. informs you that the personal data provided by you will be treated for the acquisition of information preliminary to the conclusion of contracts, for the definition and formalization of contractual relationship with you as well as for their management and for the fulfillment of legal requirements related to civil, tax and accounting law. Data are processed both through computer or paper in a lawful and correct manner and in compliance with the Decree. Personal data and its processing are necessary for business negotiation and will not be subject to disclosure and spread out the circumstances permitted by law, on the same you can exercise your rights under art. 7 of the above mentioned decree. The Data Controller is Huawei Technologies Italia Srl, which has appointed Data Processors, the list of which is available at [email-masked]<mailto:[email-masked]>.

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 19 Apr 2018 19:20:54 +0000

Thanks a lot for the analysis Italo and team.

Daniele

From: Teas [mailto:[email-masked]] On Behalf Of Italo Busi
Sent: giovedì 19 aprile 2018 12:20
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [Teas] Relationship between TE Tutorial and TNBI Applicability Statement

Italo

Italo Busi