Subject: Re: [Teas] [netmod] Key collision between configured and ephemeral list entries

From: Qin Wu <[email-masked]>
Date: Wed, 19 Jun 2019 06:23:47 +0000

Sorry to chime in.
If my understanding is correct, I think in most cases the DS should be shared by multiple clients. In the first case, the <lock> operation should be used to prevent two clients from writing the content into the same datastore at the same time.

-Qin
-----邮件原件-----
发件人: Teas [mailto:[email-masked]] 代表 Italo Busi
发送时间: 2019年6月19日 1:24
收件人: Juergen Schoenwaelder <[email-masked]>
抄送: [email-masked]; Tarek Saad <[email-masked]>; Andy Bierman <[email-masked]>; [email-masked]
主题: Re: [Teas] [netmod] Key collision between configured and ephemeral list entries

Hi Juergen,

What is the DS architecture you have in mind with multiple client creating entries?

Are the two clients creating entries in the same <running> DS or in two different <running> DS?

In the latter case, the two clients could also rely on different <operational> DS and therefore can assign the same name to different entries (since they will be instantiated in different DS). There is no need for them to avoid name clash

In the former case, a name clash would cause one client to override the configuration of another client

Are the two clients aware of each other?

I take the opportunity to clarify one point (not sure I have been clear about it). I do not think we need to define any rule which is enforced by the server to avoid name clashes since the server cannot understand whether the name clash is intentional or not. I think we just need to define some known/common/standard rules that allow the client(s) to avoid creating unintended name clashes.

Thanks, Italo

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]]
Sent: martedì 11 giugno 2019 20:37
To: Italo Busi <[email-masked]>
Cc: Andy Bierman <[email-masked]>; [email-masked]; Tarek Saad <[email-masked]>; [email-masked]
Subject: Re: [netmod] [Teas] Key collision between configured and ephemeral list entries

On Tue, Jun 11, 2019 at 05:43:27PM +0000, Italo Busi wrote:

> [Italo Busi] If the client knows the prefix used by the server, it can 
> pick up a different prefix and use it to tag its own entries. I think 
> this rule is not really complex and it seems much simpler than 
> managing unintended name clashes

A prefix only helps a little. Once you have multiple clients creating entries, you will have to handle collisions again. Sometimes solving the more general case leads to solutions that also work nicely in simpler special cases.
	
/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Italo Busi <[email-masked]>
Date: Wed, 19 Jun 2019 11:50:45 +0000

Hi Qin,

Thanks for your feedback

The <lock> operation would allow the two clients not to create any unintentional name clash. Therefore, I think, the issue of avoiding unintentional name clash applies only between <running> and <operational> DS

Italo

-----Original Message-----
From: Qin Wu 
Sent: mercoledì 19 giugno 2019 08:24
To: Italo Busi <[email-masked]>; Juergen Schoenwaelder <[email-masked]>
Cc: [email-masked]; Tarek Saad <[email-masked]>; Andy Bierman <[email-masked]>; [email-masked]
Subject: RE: [Teas] [netmod] Key collision between configured and ephemeral list entries

Sorry to chime in.

-Qin
-----邮件原件-----
发件人: Teas [mailto:[email-masked]] 代表 Italo Busi
发送时间: 2019年6月19日 1:24
收件人: Juergen Schoenwaelder <[email-masked]>
抄送: [email-masked]; Tarek Saad <[email-masked]>; Andy Bierman <[email-masked]>; [email-masked]
主题: Re: [Teas] [netmod] Key collision between configured and ephemeral list entries

Hi Juergen,

Thanks, Italo

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]]
Sent: martedì 11 giugno 2019 20:37
To: Italo Busi <[email-masked]>
Cc: Andy Bierman <[email-masked]>; [email-masked]; Tarek Saad <[email-masked]>; [email-masked]
Subject: Re: [netmod] [Teas] Key collision between configured and ephemeral list entries

	
/js