Subject: [Teas] Comment on draft-ietf-teas-actn-yang-03

From: Italo Busi <[email-masked]>
Date: Wed, 31 Jul 2019 16:02:31 +0000

During the review of draft-ietf-ccamp-transport-nbi-app-statement-05, the CCAMP WG Transport NBI DT has noted that the ietf-eth-te-topology YANG model (providing Client Topology Abstraction), defined in draft-zheng-ccamp-client-topo-yang-06, is not listed as applicable to the ACTN MPI in draft-ietf-teas-actn-yang-03.

We would propose to update section 4.3 of draft-ietf-teas-actn-yang-03, as follow:

OLD

       Function                 Yang Model
      --------------------------------------------------------
       Configuration Scheduling      [Schedule]
       Path computation           [PATH_COMPUTATION-API]
       Tunnel/LSP Provisioning        [TE-tunnel]
       Topology Abstraction         [TE-topology]
       Client Signal Description        [Client-signal]
       Service Provisioning         [Client-signal]&[TE-tunnel]*

       OTN Topology Abstraction      [OTN-topo]
         WSON Topology Abstraction      [WSON-topo]
       Flexi-grid Topology Abstraction  [Flexi-topo]
       Microwave Topology Abstraction   [MW-topo]
         OTN Tunnel Model           [OTN-Tunnel]
         WSON TE Tunnel Model         [WSON-Tunnel]
         Flexi-grid Tunnel Model       [Flexigrid-Tunnel]

NEW

       Function                         Yang Model
      ---------------------------------------------------------------
       Configuration Scheduling         [Schedule]
       Path computation                 [PATH_COMPUTATION-API]
       Tunnel/LSP Provisioning          [TE-tunnel]
       Topology Abstraction             [TE-topology]
       Service Provisioning             [Client-signal]&[TE-tunnel]*

       Client Topology Abstraction      [Client-topo]
       OTN Topology Abstraction         [OTN-topo]
       WSON Topology Abstraction        [WSON-topo]
       Flexi-grid Topology Abstraction  [Flexi-topo]
       Microwave Topology Abstraction   [MW-topo]
       Client Signal Description        [Client-signal]
       OTN Tunnel Model                 [OTN-Tunnel]
       WSON TE Tunnel Model             [WSON-Tunnel]
       Flexi-grid Tunnel Model          [Flexigrid-Tunnel]

We would also propose to add the following reference:

   [Client-topo] H. Zheng, et al, "A YANG Data Model for Ethernet TE
             Topology", draft-zheng-ccamp-client-topo-yang, work in
             progress.

Thanks, Italo (on behalf of the Transport NBI DT)

Italo Busi
Principal Optical Transport Network Research Engineer
Huawei Technologies Co., Ltd.
Tel : +39 345 4721946
Email : [email-masked]

This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

---

From: Zhenghaomian <[email-masked]>
Date: Thu, 1 Aug 2019 00:50:00 +0000

Thank you Italo, the client topology would be a necessary part for MPI; we are going to add it into the next update.

Best wishes,
Haomian (on behalf of authors & contributors)

发件人: [email-masked] [mailto:[email-masked]] 代表 Italo Busi
发送时间: 2019年8月1日 0:03
收件人: [email-masked]
抄送: [email-masked]; [email-masked]
主题: Comment on draft-ietf-teas-actn-yang-03

OLD

       Function                 Yang Model

NEW

       Function                         Yang Model

Italo Busi
Principal Optical Transport Network Research Engineer
Huawei Technologies Co., Ltd.
Tel : +39 345 4721946
Email : [email-masked]<mailto:[email-masked]>

--
You received this message because you are subscribed to the Google Groups "transport-nbi-dt" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked]<mailto:[email-masked]>.
To view this discussion on the web, visit https://groups.google.com/d/msgid/transport-nbi-dt/91E3A1BD737FDF4FA14118387FF6766B277AB9CA%40lhreml504-mbs<https://groups.google.com/d/msgid/transport-nbi-dt/91E3A1BD737FDF4FA14118387FF6766B277AB9CA%40lhreml504-mbs?utm_medium=email&utm_source=footer>.