Subject: [Teas] I-D Action: draft-ietf-teas-yang-path-computation-06.txt

From: [email-masked]
Date: Mon, 08 Jul 2019 07:52:19 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Traffic Engineering Architecture and Signaling WG of the IETF.

        Title           : Yang model for requesting Path Computation
        Authors         : Italo Busi
                          Sergio Belotti
	Filename        : draft-ietf-teas-yang-path-computation-06.txt
	Pages           : 73
	Date            : 2019-07-08

Abstract:
   There are scenarios, typically in a hierarchical SDN context, where
   the topology information provided by a TE network provider may not
   be sufficient for its client to perform end-to-end path computation.
   In these cases the client would need to request the provider to
   calculate some (partial) feasible paths.

   This document defines a YANG data model for a stateless RPC to
   request path computation. This model complements the stateful
   solution defined in [TE-TUNNEL].

   Moreover this document describes some use cases where a path
   computation request, via YANG-based protocols (e.g., NETCONF or
   RESTCONF), can be needed.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-teas-yang-path-computation/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-teas-yang-path-computation-06
https://datatracker.ietf.org/doc/html/draft-ietf-teas-yang-path-computation-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-yang-path-computation-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Italo Busi <[email-masked]>
Date: Thu, 11 Jul 2019 10:10:36 +0000

This version of the draft addresses the comments from Olivier about using the Path Computation YANG model in a flat/distributed network (open issue #61 in github).

Text in section 2 has been updated to clarify that the use of the Path Computation YANG model is not restricted to these use cases but can be used in any other use case when deemed useful.
Sections 2.4 and 2.5 have been added to described two additional use cases (thanks to Julien and Olivier).
No changes are required to the current YANG model.

The editors and Olivier are satisfy with these text changes.

Please review and send your comments to the list.

Sergio and Italo (on behalf of co-authors)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: lunedì 8 luglio 2019 16:52
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Teas] I-D Action: draft-ietf-teas-yang-path-computation-06.txt
> 
>