Subject: [Teas] Te-topology and te data models questions

From: Anton Snitser <[email-masked]>
Date: Tue, 22 Oct 2019 10:54:53 +0000

Hello everyone,

Name is Anton, am a systems engineer from Sedona systems.

I have been reviewing the ietf-te.yang and ietf-te-topology.yang data models as well as their various augmentations and I had a few questions regarding how they are meant to be used when representing native network state and managed objects. Not sure if this Is the correct email group. Saw it in the drafts, decided to try.

  1.  What is the usage scope of transitional links? – it is meant to represent an inter-layer transition between different layers, but as per the diagrams In the drafts I have only seen it being used in the same node. Can transitional links be used inter layer to describe a cross-layer-link in a technology disaggregated environment? E.g., a router port <-> OTN client-port and subsequently the OTN to WDM cross-layer-links. consider each layer node as a separate physical node e.g., physical router, OTN switch and WDM node

Consider the following.
Is it possible to describe a link where a source node:tp from the IP topology and a destination node:tp from the OTN/WDM topology create a transitional link

  1.  Are there strict guidelines on how a TTP should be modeled? In the drafts it is mentioned a TTP can be an OCH transponder in the WDM topology. What about OTN and IP? What are the rules used to designate a physical/logical entity as a TTP or non-TTP entity?
     *   Can an IP loopback on routers be considered a TTP? If not then what is a TTP in the IP layer?
     *   What is a TTP in the OTN layer? Is it the framing module in the switch?

  1.  The figures are missing from the tutorial draft<https://tools.ietf.org/html/draft-ietf-teas-te-topo-and-tunnel-modeling-04>. Is there a reference implementation document somewhere?

  1.  I have more questions, but I wanted to start slow.. to see there I get an ACK response.

Thank you very much to whoever answers!
Brgrds

[id:[email-masked]]
Anton Snizar | Systems Engineer 
m: +972-504042744
e: [email-masked]<mailto:[email-masked]>
w: sedonasys.com<https://sedonasys.com/>
l: Linkedin<http://linkedin.com/in/anton-snizar-4aa57646/>

---

From: Igor Bryskin <[email-masked]>
Date: Tue, 22 Oct 2019 14:05:30 +0000 (UTC)

Hi Anton,

Thank you for the interest, review and questions Please, find in line.

Cheers,
Igor

    On Tuesday, October 22, 2019, 6:55:07 AM EDT, Anton Snitser <[email-masked]> wrote:  

Hello everyone,

 

   - What is the usage scope of transitional links? – it is meant to represent an inter-layer transition between different layers, but as peC the diagrams In the drafts I have only seen it being used in the same    

   -    

   -  IB>>Correct. Transitional link is a special link modeling an inter-layer relationship. Specifically, it connects a client layer LTP with a server layer TTP and may articulate a cost of adding additional links in the server layer to satisfy  path computation request in the client layer. Transitional link is only useful  in multi-layer computations. Alternative to transitional link is inter-layer lock.
   -    

   - Can transitional links be used inter layer to describe a cross-layer-link in a technology disaggregated environment? E.g., a router port <-> OTN client-port and subsequently the OTN to WDM cross-layer-links. consider each layer node as a separate physical node e.g., physical router, OTN switch and WDM node    

   -    

   - IB>> No, in your case the link from the router is a regular TE link and belongs to OTN, while transitional link is inside WDM device (where OTN to WDM adaptation actually occurs)   

Consider the following.

 Is it possible to describe a link where a source node:tp from the IP topology and a destination node:tp from the OTN/WDM topology create a transitional link. IB>> No, see above

   - Are there strict guidelines on how a TTP should be modeled? In the drafts it is mentioned a TTP can be an OCH transponder in the WDM topology. What about OTN and IP? What are the rules used to designate a physical/logical entity as a TTP or non-TTP entity?
   
   - Can an IP loopback on routers be considered a TTP? If not then what is a TTP in the IP layer?
   - What is a TTP in the OTN layer? Is it the framing module in the switch?
   
   - IB>> TTP, generally speaking,  represents a device inside a TE node where a particular client-server layer adaptation (different in some way from other client-layer adaptations in the same node) occurs.  Normally, IP layer TE nodes do not have/requite TTPs, unless it is an abstract node, in which case the TTP may indicate, for example,  the physical router where TE tunnel (described on abstract IP topology) terminates.    

    
   - The figures are missing from thetutorial draft. Is there a reference implementation document somewhere?    

    
   - I have more questions, but I wanted to start slow.. to see there I get an ACK response.

 
Brgrds

 
m: +972-504042744
 
e: [email-masked]
 
w: sedonasys.com
 
l: Linkedin

 _______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Anton Snitser <[email-masked]>
Date: Wed, 23 Oct 2019 13:19:11 +0000

Hi Igor,

Thank you for the prompt reply. Will sum up your responses here to reference.
Thank you for taking the time to respond!

General question – is this distribution ok with this much chatter? Or should we limit?

  1.  IB >> Correct. Transitional link is a special link modeling an inter-layer relationship. Specifically, it connects a client layer LTP with a server layer TTP and may articulate a cost of adding additional links in the server layer to satisfy  path computation request in the client layer. Transitional link is only useful  in multi-layer computations. Alternative to transitional link is inter-layer lock.

[AS] to avoid confusion on my part, in the draft it states it connects client layer LTP to server layer LTP. Is that correct? Or your “it connects a client layer LTP with a server layer TTP” is the correct interpretation?

  1.  IB >> No, in your case the link from the router is a regular TE link and belongs to OTN, while transitional link is inside WDM device (where OTN to WDM adaptation actually occurs)
[AS] is there no adaptation done in the OTN device as well? Taking the IP Ethernet frame adapting to ODU? Or a transitional-link can only occur in the WDM device?

  1.  IB >> TTP, generally speaking,  represents a device inside a TE node where a particular client-server layer adaptation (different in some way from other client-layer adaptations in the same node) occurs.  Normally, IP layer TE nodes do not have/requite TTPs, unless it is an abstract node, in which case the TTP may indicate, for example,  the physical router where TE tunnel (described on abstract IP topology) terminates.

[AS] ok understood, but in any case if supposedly one needs to portray a native topology of IP routers how does one describe the TTP? Asking because in one supporting data model ietf-te for management and maintenance of TE-Tunnels (where tunnels can be IP/MPLS LSPs, ODU Tunnels, OCH/OTSi Tunnels) TTPs are used as src and dst. in an IP topology what would those TTPs be? The devices/routers themselves?

  1.  [AS] I have some assumptions based on the existing data modules produced from both TEAS and I2RS, wondering if you can confirm on them and shed some light. Apologies in advance if questions refer to data models produced in other WG, maybe you can answer to the best you know.

  1.  Te-topo and augmentations of te-topo are not necessarily used for pure topology depiction for generic purposes. Its main goal is to allow a client to have an abstracted understanding of the network to complete path computation and path setup if necessary. Correct?
  2.  Referring back to a. when I mean pure topology discovery, I mean sometimes a client will need to have a complete view of topology down to port to port connectivity through all the layers to understand traffic patterns and complete physical path routes. This is not part of the mandate of te-topo right?
  3.  The way I2RS data models are portraying multi-layer topology relation is by using supporting-network/node/link/ltp attributes whereas in TEAS data models these same attributes are used more in order to show relation between nodes in case abstraction is used to show node within node. is this the same to your knowledge?
  4.  If all of the above are somewhat true and the mandate for the TEAS WG is to provide “just enough” topology data (native or otherwise) across layers IP/OTN/WDM to be able to compute paths and set them up then there should be another set of augmentations (one for each technology layer including OTN and WDM) to provide native topology data model – similar to the tech specific l2 and l3 unicast topology augmentation which came from I2RS. Correct?

Best regards!

From: Igor Bryskin <[email-masked]>
Date: Tuesday, 22 October 2019 at 17:05
To: "[email-masked]" <[email-masked]>, Anton Snitser <[email-masked]>
Subject: Re: [Teas] Te-topology and te data models questions

Hi Anton,

Cheers,
Igor

Hello everyone,

  1.  What is the usage scope of transitional links? – it is meant to represent an inter-layer transition between different layers, but as peC the diagrams In the drafts I have only seen it being used in the same
  2.
  3.   IB>>Correct. Transitional link is a special link modeling an inter-layer relationship. Specifically, it connects a client layer LTP with a server layer TTP and may articulate a cost of adding additional links in the server layer to satisfy  path computation request in the client layer. Transitional link is only useful  in multi-layer computations. Alternative to transitional link is inter-layer lock.
  4.
  5.  Can transitional links be used inter layer to describe a cross-layer-link in a technology disaggregated environment? E.g., a router port <-> OTN client-port and subsequently the OTN to WDM cross-layer-links. consider each layer node as a separate physical node e.g., physical router, OTN switch and WDM node
  6.
  7.  IB>> No, in your case the link from the router is a regular TE link and belongs to OTN, while transitional link is inside WDM device (where OTN to WDM adaptation actually occurs)

Consider the following.

  1.  IB>> TTP, generally speaking,  represents a device inside a TE node where a particular client-server layer adaptation (different in some way from other client-layer adaptations in the same node) occurs.  Normally, IP layer TE nodes do not have/requite TTPs, unless it is an abstract node, in which case the TTP may indicate, for example,  the physical router where TE tunnel (described on abstract IP topology) terminates.

Brgrds

m: +972-504042744

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: Igor Bryskin <[email-masked]>
Date: Wed, 23 Oct 2019 13:57:44 +0000 (UTC)

Hi Anton,

Please, see my further responses in line.
Igor

    On Wednesday, October 23, 2019, 9:19:28 AM EDT, Anton Snitser <[email-masked]> wrote:  

Hi Igor,

 

    
   - IB >> Correct. Transitional link is a special link modeling an inter-layer relationship. Specifically, it connects a client layer LTP with a server layer TTP and may articulate a cost of adding additional links in the server layer to satisfy  path computation request in the client layer. Transitional link is only useful  in multi-layer computations. Alternative to transitional link is inter-layer lock.
 [AS] to avoid confusion on my part, in the draft it states it connects client layer LTP to server layer LTP. Is that correct? Or your“it connects a client layer LTP with a server layer TTP”is the correct interpretation?
   IB>> The latter, c-ltp<=>s-ttp

   - IB >> No, in your case the link from the router is a regular TE link and belongs to OTN, while transitional link is inside WDM device (where OTN to WDM adaptation actually occurs)
 [AS] is there no adaptation done in the OTN device as well?
IB>> Yes, but in a different layer, i.e. IP-Ethernet LTP <=>OTN TTP ( this is totally different client-server relationship that could be described by a separate transitional link located inside IP/OTN device

 Taking the IP Ethernet frame adapting to ODU? Or a transitional-link can only occur in the WDM device?

IB>> No, TL can describe any client-server adaptation

   - IB >> TTP, generally speaking,  represents a device inside a TE node where a particular client-server layer adaptation (different in some way from other client-layer adaptations in the same node) occurs.  Normally, IP layer TE nodes do not have/requite TTPs, unless it is an abstract node, in which case the TTP may indicate, for example,  the physical router where TE tunnel (described on abstract IP topology) terminates.
 [AS] ok understood, but in any case if supposedly one needs to portray a native topology of IP routers how does one describe the TTP? Asking because in one supporting data model ietf-te for management and maintenance of TE-Tunnels (where tunnels can be IP/MPLS LSPs, ODU Tunnels, OCH/OTSi Tunnels) TTPs are used as src and dst. in an IP topology what would those TTPs be? The devices/routers themselves?

IB>> In the te-tunnel model src /dst TTPs are optional and could be omitted, as usually the case in IP-TE layer. In other words, IP te-tunnels are simply terminated on src/dst IP te-nodes

   - [AS] I have some assumptions based on the existing data modules produced from both TEAS and I2RS, wondering if you can confirm on them and shed some light. Apologies in advance if questions refer to data models produced in other WG, maybe you can answer to the best you know.
    
   - Te-topo and augmentations of te-topo are not necessarily used for pure topology depiction for generic purposes. Its main goal is to allow a client to have an abstracted understanding of the network to complete path computation and path setup if necessary. Correct? IB>> Correct, the main purpose is to enable TE path computations

   - Referring back to a. when I mean pure topology discovery, I mean sometimes a client will need to have a complete view of topology down to port to port connectivity through all the layers to understand traffic patterns and complete physical path routes. This is not part of the mandate of te-topo right?
IB>> Disagree. te-topo model allows for hierarchical representation of a multi-layer network, including the inter-layer relationships. This allows for single- and multi-layer path computations

   - The way I2RS data models are portraying multi-layer topology relation is by using supporting-network/node/link/ltp attributes whereas in TEAS data models these same attributes are used more in order to show relation between nodes in case abstraction is used to show node within node. is this the same to your knowledge?
IB>> Disagree. te-topo model augments the i2rs model, but goes far further in describing the inter-layer relationships, such as client-server adaptations.

   - If all of the above are somewhat true and the mandate for the TEAS WG is to provide “just enough” topology data (nativeor otherwise) across layers IP/OTN/WDM to be able to compute paths and set them up then there should be another set of augmentations (one for each technology layer including OTN and WDM) to provide native topology data model – similar to the tech specific l2 and l3 unicast topology augmentation which came from I2RS. Correct? 
IB>> i2rs model does not allow you to doTE path computations. For example, it does not allow to describe various node and link properties and limitations, hence do not allow for constraint based computations. I would not recommend using i2rs model directly. If you want TE path computations (especially multi-layer) you should use te-topo model family. If you need single layer reachability  computations you should  use models like l3-topology.

Best regards!

 
Hi Anton,

 
Cheers,
Igor

 

Hello everyone,

 

 

Consider the following.

    

    
   - The figures are missing from the tutorial draft. Is there a reference implementation document somewhere? 

 

Brgrds

Anton Snizar| Systems Engineer 
 
m: +972-504042744
 
e:[email-masked]
 
w:sedonasys.com
 
l:Linkedin