Subject: Re: [Teas] Éric Vyncke's Abstain on draft-ietf-teas-native-ip-scenarios-09: (with COMMENT)

From: Aijun Wang <[email-masked]>
Date: Tue, 1 Oct 2019 23:26:14 +0800

Hi, Éric Vyncke:
Thanks for you review.
As I explained in previous mails for Alvaro and TSV reviewer, this draft describes mainly the TE scenarios that needed in operators’ network and the simulation optimization results from the global view.

Such kind of efforts are inadequate in current IETF community considering the networks are controlled mainly by distributed protocol.

With the emerge of critical applications in 5G era, the E2E QoS assurance requirements will be pervasive and it almost impossible to accomplish the expected results without the info of global view and the help of central control.

This draft, together with other two drafts:

https://datatracker.ietf.org/doc/draft-ietf-teas-pce-native-ip/ (Solutions)

https://datatracker.ietf.org/doc/draft-ietf-pce-pcep-extension-native-ip/(PCEP extension)

just want to solve such problems in one feasible way.
Wish the above info can convince you for the future vote of this draft.

The followings are responses for your comments:
1. OSPF or ISIS will not influence the simulation results, as they are all based on Dijkstra algorithm.
2. The topology is generated in random manner under the rule described in https://tools.ietf.org/html/draft-ietf-teas-native-ip-scenarios-09#section-4.2. That is, the core nodes are connected in full mesh and the edge connects the core in random links. We have tried several different topology and the results are similar.
3. We will try to use the new XML2RFC format for the SVG graph in next version if necessary. Anyway, the reader can get the impressive concept by comparison the results described in section 4.4 and 4.5

Thanks in advance.

Aijun Wang
China Telecom

> On Oct 1, 2019, at 17:22, Éric Vyncke via Datatracker <[email-masked]> wrote:
> 
> Éric Vyncke has entered the following ballot position for
> draft-ietf-teas-native-ip-scenarios-09: Abstain
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> 
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-teas-native-ip-scenarios/
> 
> 
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> I share Alvaro's and TSV reviewer feeling about this is not a usual RFC but
> rather a scientific paper (even if the results are not really a surprise). So,
> I am abstaining.
> 
> Some comments though:
> - why using OSPF and not IS-IS for the comparison ? Not that it would change a
> lot IMHO - when using generated topologies, little is written on how it is
> generated (as it could introduce some bias changing the results of section 4.4)
> - using the new format for XML2RFC could have included SVG for graphics
> 
> Interesting read anyway
> 
> -éric
> 
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 2 Oct 2019 06:10:51 +0000

Aijun Wang

Thank you for the added pieces of information.

  1.  Indeed this was my guess, but, worth explaining the obvious in the document
  2.  The ‘random’ link from edge to core is that part that bothers me. Perhaps worth stating that you run the simulation multiple times on several topologies with similar results? And perhaps display the confidence interval
  3.  Up to you :-)

Regards

-éric