Subject: Re: [Teas] Network Slicing design team definitions- transport slice

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 1 Sep 2020 17:57:28 +0000

All,

Thanks Kiran. As the co-author of the draft, I agree with Kiran’s response.

In summary, the main reason was to differentiate between “Network Slice” and its components which depends on the use case might be “RAN Slice”, “Core Slice” or “Transport Slice”.
As pointed out in email below, we on purpose removed “Network” from the name to make sure “Network Slice” and “Transport Slice” are clearly differentiated.

Please note that the 5G is one example of  network slicing. So, in the context of “ 5G Network Slice” we will have all of the three (i.e RAN, Core and Transport Slices).
If for example the use case is DCI, there is no RAN and Core slices and the “DCI Network Slice” will contain only “Transport  slices”.

Since the concept of “Transport slice” discuss at IETF is general and not just for 5G, the authors of the draft tried to generalize the idea and as a result the name “Transport Slice” was used.

Cheers,

Reza

From: Teas <[email-masked]> on behalf of Kiran Makhijani <[email-masked]>
Date: Tuesday, September 1, 2020 at 11:35 AM
To: "BRUNGARD, DEBORAH A" <[email-masked]>, TEAS WG <[email-masked]>
Subject: Re: [Teas] Network Slicing design team definitions- transport slice

Hi Deborah,
It was a deliberate effort to avoid using term network slice – which is a broader concept of “End-to-end network slice” and everything is not IETF specific. By use of term transport, we are able to  (quite precisely) scope our work in the context of IP/MPLS technologies – things IETF concern with. Another advantage is clarity from the network slice concept in 3GPP which has already been defined and described in a particular way. I will find it confusing if we had to always explain that 3gpp-network slices are different than ietf-network slices. Because they are going to be different in functionality.

Transport slices capture only the connectivity specific details for things we refer to as transport networks. So far it has aligned will with ACTN, enhance VPN and other TE related work. We will not know how to specify, mange or onboard a RAN, Wireless or a vertical-centric functionality, so there is no point in making assumptions about them in our design and terminology.

-Kiran

From: Teas <[email-masked]> On Behalf Of BRUNGARD, DEBORAH A
Sent: Tuesday, September 1, 2020 7:31 AM
To: TEAS WG <[email-masked]>
Subject: [Teas] Network Slicing design team definitions- transport slice

Hi,
(speaking as an individual)

Picking up on Jari’s comment “sometimes people want to use labels that are a bit more imprecise, but I think we should strive to avoid such labels as much as we can”, can you give more background on the choice of the term “transport slice”?

I noted while you have text on the use of “transport” by 3GPP as specifying a very specific sub-network in the radio network (which excludes the handoff to the rest of the network), you referenced RFC5921 (MPLS-TP) for the term “transport”.

There was a long thread of mail on ACTN, RFC8453, to move away from the term “transport” to “TE networks” which was agreed to be more specific/appropriate for TEAS. Considering IETF is already using the term “network slicing” (including TEAS RFC8453) and 3GPP use of the term, I don’t understand the use of “transport” in this document.

Considering IETF already uses the term “network slice” and 3GPP uses the term (and all the industry SDOs), I am concerned we will be confusing the industry, especially as “transport” is an imprecise term for TEAS work. Is this work a subset and scoped only to the 3GPP “transport” cloud (and implied use of MPLS-TP)? Or is it planned to be generic (for all TE networks)?

Deborah
(speaking as individual)

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 1 Sep 2020 23:14:26 -0700

+1

To add to Reza’ points - the term has been thoroughly  discussed and agreed upon by the design team.

Regards,
Jeff

> On Sep 1, 2020, at 10:57, Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]> wrote:
> 
> 
> All,
>  
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: John E Drake <[email-masked]>
Date: Wed, 2 Sep 2020 12:29:44 +0000

Hi,

Jeff’s note, below, seems to imply that the members of the design team implicitly support adoption of this draft.  This is not the case - I don’t support its adoption.

Yours Irrespectively,

John

Juniper Business Use Only
From: Teas <[email-masked]> On Behalf Of Jeff Tantsura
Sent: Wednesday, September 2, 2020 2:14 AM
To: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Cc: Kiran Makhijani <[email-masked]>; TEAS WG <[email-masked]>; BRUNGARD, DEBORAH A <[email-masked]>
Subject: Re: [Teas] Network Slicing design team definitions- transport slice

[External Email. Be cautious of content]

+1

On Sep 1, 2020, at 10:57, Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>> wrote:

All,

Cheers,

Reza

From: Teas <[email-masked]<mailto:[email-masked]>> on behalf of Kiran Makhijani <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, September 1, 2020 at 11:35 AM
To: "BRUNGARD, DEBORAH A" <[email-masked]<mailto:[email-masked]>>, TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] Network Slicing design team definitions- transport slice

Hi Deborah,

-Kiran

From: Teas <[email-masked]<mailto:[email-masked]>> On Behalf Of BRUNGARD, DEBORAH A
Sent: Tuesday, September 1, 2020 7:31 AM
To: TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: [Teas] Network Slicing design team definitions- transport slice

Hi,

Deborah
(speaking as individual)
_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 2 Sep 2020 11:27:10 -0700

John,

I’m not implying anything, just stating the facts.
As for the WG adoption - every member of the wg is entailed to their position.

Cheers,
Jeff