Subject: [Teas] I-D Action: draft-ietf-teas-yang-te-26.txt

From: [email-masked]
Date: Mon, 22 Feb 2021 10:31:01 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Traffic Engineering Architecture and Signaling WG of the IETF.

        Title           : A YANG Data Model for Traffic Engineering Tunnels, Label Switched Paths and Interfaces
        Authors         : Tarek Saad
                          Rakesh Gandhi
                          Xufeng Liu
                          Vishnu Pavan Beeram
                          Igor Bryskin
                          Oscar Gonzalez de Dios
	Filename        : draft-ietf-teas-yang-te-26.txt
	Pages           : 120
	Date            : 2021-02-22

Abstract:
   This document defines a YANG data model for the configuration and
   management of Traffic Engineering (TE) tunnels, Label Switched Paths
   (LSPs). and interfaces.  The model is divided into YANG modules that
   classify data into generic, device-specific, technology agnostic, and
   technology-specific elements.

   This model covers data for configuration, operational state, remote
   procedural calls, and event notifications.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-teas-yang-te/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-teas-yang-te-26
https://datatracker.ietf.org/doc/html/draft-ietf-teas-yang-te-26

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-yang-te-26

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: tom petch <[email-masked]>
Date: Tue, 23 Feb 2021 12:27:00 +0000

________________________________________
From: Teas <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: 22 February 2021 18:31

<tp>
Any of the authors care to comment on this reissue, whether or not any of the 200pp have changed and if so why.

Tom Petch

Abstract:

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Tarek Saad <[email-masked]>
Date: Wed, 24 Feb 2021 15:47:47 +0000

Hi Tom and WG,

The latest version contains the following changes:
- editorial nits
- new identity for metric "path-metric-loss"
- rearranging headend LSP attributes
- addressing issue in reference groupings from external modules (using absolute leafref path, and prefix'ing module prefix in XPath)
- added 'controller' container to indicate the controller-id and 'protocol-origin' for externally created tunnels
- added JSON example of the instance tree when using the YANG model to create and query state for a TE tunnel
- new co-author joined

Regards,
Tarek (for the co-authors)

On 2/23/21, 7:27 AM, "Teas on behalf of tom petch" <[email-masked] on behalf of [email-masked]> wrote:

    <tp>

    Tom Petch

    Abstract:

Juniper Business Use Only

---

From: tom petch <[email-masked]>
Date: Thu, 25 Feb 2021 16:29:01 +0000

From: Tarek Saad <[email-masked]>
Sent: 24 February 2021 15:47

Hi Tom and WG,

Tarek

Thank you for the clarification.  As you may have guessed, I had a second look at the YANG paths to see if they fixed the issue that Martin encountered and they did, but had not got any further than that.

Tom Petch

Regards,

    <tp>

    Tom Petch

    Abstract: