Subject: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

From: <[email-masked]>
Date: Wed, 3 Mar 2021 13:56:52 +0000

Re-,

Thanks Adrian for raising this point.

My take is that we can’t discard it by design. Take the example of stitched slices where packets are marked by the CE + that marking is trusted by the PE to graft them to the appropriate network slice. Likewise, a hierarchical design where an aggregate slice trusts the marking of the upper slice to identify how to map between the levels. Such trust may be justified under specific deployment contexts.

Cheers,
Med

De : Teas [mailto:[email-masked]] De la part de Adrian Farrel
Envoyé : jeudi 25 février 2021 11:52
À : 'Young Lee' <[email-masked]>; 'Luis M. Contreras' <[email-masked]>
Cc : 'Joel M. Halpern' <[email-masked]>; [email-masked]; 'Eric Gray' <[email-masked]>; 'John E Drake' <jdrake=[email-masked]>; 'Rokui, Reza (Nokia - CA/Ottawa)' <[email-masked]>; BOUCADAIR Mohamed TGI/OLN <[email-masked]>
Objet : Re: [Teas] network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

[...]
... but we have to ask ourselves carefully whether we *really* want the CE-based approach in our network slicing:
-          What are the considerations for how much knowledge of the underlay network has to be shared to the CE?
-          What are the considerations for how an underlay distinguishes CE-originated slicing traffic?
These are pretty much the same questions that CE-based VPNs have to answer. Of course, the concept of a “provider-managed CE” muddies these waters somewhat.

Conversely, the port-based PE-based VPN has none of these problems, but does have to agree on the “Access Connection” encoding, and that is either payload-sensitive (like in PWE3) or technology-aware (like in L3VPN).

[...]

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Shunsuke Homma <[email-masked]>
Date: Thu, 4 Mar 2021 09:25:28 +0900

Hi Med,

I think it's an important discussion. I'd like to clarify the range which
should be managed as an IETF network slice. In my understanding, CE will be
a slice consumer's end-host or an endpoint of an opposite network slice,
and it will be generally out of control of IETF network slice. As you
described, there may be cases where CE makes marking on traffic and PE
allocate it to appropriate slice based on the mark, but I think the
arrangement between CE and PE will be done by controller/orchestrator
higher than IETF Network Slice Controller. In other words, a necessary
policy is set to PE from higher controller/orchestrator, and IETF network
slice can work independently of whether the CE is slice-aware or not.

So my question is which is appropriate as the range of IETF network slice.

1. it is always between CE and CE,
2. it is always between PE and PE,
3. it is basically from PE to PE, and sometimes between CE and CE (e.g., in
case that CE is slice-aware,)

# From a network operator or slice provider aspect, I'd like to know
whether SLA/SLO between CE and PE must  be assured.

Regards,

Shunsuke

2021年3月3日(水) 22:57 <[email-masked]>:

> My take is that we can’t discard it by design. Take the example of
> stitched slices where packets are marked by the CE + that marking is
> trusted by the PE to graft them to the appropriate network slice. Likewise,
> a hierarchical design where an aggregate slice trusts the marking of the
> upper slice to identify how to map between the levels. Such trust may be
> justified under specific deployment contexts.
>
>
>
> Cheers,
>
> Med
>
>
>
> *De :* Teas [mailto:[email-masked]] *De la part de* Adrian Farrel
> *Envoyé :* jeudi 25 février 2021 11:52
> *À :* 'Young Lee' <[email-masked]>; 'Luis M. Contreras' <
> [email-masked]>
> *Cc :* 'Joel M. Halpern' <[email-masked]>; [email-masked]; 'Eric
> Gray' <[email-masked]>; 'John E Drake' <jdrake=
> [email-masked]>; 'Rokui, Reza (Nokia - CA/Ottawa)' <
> [email-masked]>; BOUCADAIR Mohamed TGI/OLN <
> [email-masked]>
> *Objet :* Re: [Teas] network Slice Endpoint in
> draft-ietf-teas-ietf-network-slice-definition-00
>
>
>
>
>
> [...]
>
> ... but we have to ask ourselves carefully whether we **really** want the
> CE-based approach in our network slicing:
>
> -          What are the considerations for how much knowledge of the
> underlay network has to be shared to the CE?
>
> These are pretty much the same questions that CE-based VPNs have to
> answer. Of course, the concept of a “provider-managed CE” muddies these
> waters somewhat.
>
>
>
> Conversely, the port-based PE-based VPN has none of these problems, but
> does have to agree on the “Access Connection” encoding, and that is either
> payload-sensitive (like in PWE3) or technology-aware (like in L3VPN).
>
>
>
> [...]
>
>
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 3 Mar 2021 19:42:20 -0500

I can't speak for Med, but in my opinion, the right scope for the IETF 
Network Slice is PE to PE.  Information about the access circuit will 
need to be provided, but it is not, as I understand it,under the control 
of the IETF Network Slice Controller.

Yours,
Joel

On 3/3/2021 7:25 PM, Shunsuke Homma wrote:
> Hi Med,
> 
> I think it's an important discussion. I'd like to clarify the range 
> which should be managed as an IETF network slice. In my understanding, 
> CE will be a slice consumer's end-host or an endpoint of an opposite 
> network slice, and it will be generally out of control of IETF network 
> slice. As you described, there may be cases where CE makes marking on 
> traffic and PE allocate it to appropriate slice based on the mark, but I 
> think the arrangement between CE and PE will be done by 
> controller/orchestrator higher than IETF Network Slice Controller. In 
> other words, a necessary policy is set to PE from higher 
> controller/orchestrator, and IETF network slice can work independently 
> of whether the CE is slice-aware or not.
> 
> 3. it is basically from PE to PE, and sometimes between CE and CE (e.g., 
> in case that CE is slice-aware,)
> 
> 2021年3月3日(水) 22:57 <[email-masked] 
> <mailto:[email-masked]>>:
> 
>     Re-,____
> 
>     __ __
> 
>     Thanks Adrian for raising this point.____
> 
>     __ __
> 
>     trusted by the PE to graft them to the appropriate network slice.
>     Likewise, a hierarchical design where an aggregate slice trusts the
>     marking of the upper slice to identify how to map between the
>     levels. Such trust may be justified under specific deployment
>     contexts. ____
> 
>     __ __
> 
>     Cheers,____
> 
>     Med____
> 
>     __ __
> 
>     *De :* Teas [mailto:[email-masked]
>     <mailto:[email-masked]>] *De la part de* Adrian Farrel
>     *À :* 'Young Lee' <[email-masked]
>     <mailto:[email-masked]>>; 'Luis M. Contreras'
>     <[email-masked] <mailto:[email-masked]>>
>     *Cc :* 'Joel M. Halpern' <[email-masked]
>     <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>;
>     'Eric Gray' <[email-masked] <mailto:[email-masked]>>; 'John
>     E Drake' <jdrake=[email-masked]
>     <mailto:[email-masked]>>; 'Rokui, Reza (Nokia -
>     CA/Ottawa)' <[email-masked] <mailto:[email-masked]>>;
>     BOUCADAIR Mohamed TGI/OLN <[email-masked]
>     <mailto:[email-masked]>>
>     draft-ietf-teas-ietf-network-slice-definition-00____
> 
>     __ __
> 
>     __ __
> 
>     [...] ____
> 
>     ...but we have to ask ourselves carefully whether we **really** want
>     the CE-based approach in our network slicing:____
> 
>     __-__What are the considerations for how much knowledge of the
>     underlay network has to be shared to the CE?____
> 
>     __-__What are the considerations for how an underlay distinguishes
>     CE-originated slicing traffic?____
> 
>     answer. Of course, the concept of a “provider-managed CE” muddies
>     these waters somewhat.____
> 
>     __ __
> 
>     Conversely, the port-based PE-based VPN has none of these problems,
>     but does have to agree on the “Access Connection” encoding, and that
>     is either payload-sensitive (like in PWE3) or technology-aware (like
>     in L3VPN).____
> 
>     __ __
> 
>     [...] ____
> 
>     __ __
> 
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/teas>
> 
>

---

From: <[email-masked]>
Date: Thu, 4 Mar 2021 10:54:50 +0000

Hi Sunshuke,

Please see inline.

Cheers,
Med

De : Shunsuke Homma [mailto:[email-masked]]
Envoyé : jeudi 4 mars 2021 01:25
À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>
Cc : [email-masked]; [email-masked]
Objet : Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

Hi Med,

I think it's an important discussion. I'd like to clarify the range which should be managed as an IETF network slice. In my understanding, CE will be a slice consumer's end-host or an endpoint of an opposite network slice,

[Med] I’m not sure about this one. For the cases I have in mind, the endpoint is separate from the CE.

and it will be generally out of control of IETF network slice.

[Med] Agree with your comment about the control of the endpoint, but there is the “managed CE” case. For such a case, the operator can have some control on the CE.

As you described, there may be cases where CE makes marking on traffic and PE allocate it to appropriate slice based on the mark, but I think the arrangement between CE and PE will be done by controller/orchestrator higher than IETF Network Slice Controller. In other words, a necessary policy is set to PE from higher controller/orchestrator, and IETF network slice can work independently of whether the CE is slice-aware or not.

1. it is always between CE and CE,
[Med] This visibility is needed at the service level independently whether the CE is slice-aware or not.

3. it is basically from PE to PE, and sometimes between CE and CE (e.g., in case that CE is slice-aware,)

# From a network operator or slice provider aspect, I'd like to know whether SLA/SLO between CE and PE must  be assured.

Regards,

Shunsuke

2021年3月3日(水) 22:57 <[email-masked]<mailto:[email-masked]>>:
Re-,

Cheers,
Med

De : Teas [mailto:[email-masked]<mailto:[email-masked]>] De la part de Adrian Farrel
Envoyé : jeudi 25 février 2021 11:52
À : 'Young Lee' <[email-masked]<mailto:[email-masked]>>; 'Luis M. Contreras' <[email-masked]<mailto:[email-masked]>>
Cc : 'Joel M. Halpern' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; 'Eric Gray' <[email-masked]<mailto:[email-masked]>>; 'John E Drake' <jdrake=[email-masked]<mailto:[email-masked]>>; 'Rokui, Reza (Nokia - CA/Ottawa)' <[email-masked]<mailto:[email-masked]>>; BOUCADAIR Mohamed TGI/OLN <[email-masked]<mailto:[email-masked]>>
Objet : Re: [Teas] network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

[...]

[...]

Thank you.
_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: <[email-masked]>
Date: Thu, 4 Mar 2021 11:05:31 +0000

Re-, 

I think here where we need to invoke the new term proposed by John/Eric: IETF Network Slice Service. 

The IETF Network Slice Service is always between CEs.

Other than the managed CE case, the scope of the IETF Network Slice is what Joel said with an emphasis on the adequate configuration of the access circuit. 

Cheers,
Med

> -----Message d'origine-----
> De : Joel M. Halpern [mailto:[email-masked]]
> Envoyé : jeudi 4 mars 2021 01:42
> À : Shunsuke Homma <[email-masked]>; BOUCADAIR Mohamed TGI/OLN
> <[email-masked]>
> Cc : [email-masked]
> Objet : Re: [Teas] CE-based Network Slice RE: network Slice Endpoint
> in draft-ietf-teas-ietf-network-slice-definition-00
> 
> I can't speak for Med, but in my opinion, the right scope for the
> IETF Network Slice is PE to PE.  Information about the access circuit
> will need to be provided, but it is not, as I understand it,under the
> control of the IETF Network Slice Controller.
> 
> Yours,
> Joel
> 
> > traffic and PE allocate it to appropriate slice based on the mark,
> but
> > I think the arrangement between CE and PE will be done by
> _____________________________________________________________________
> _
> > ___________________________________________________
> >
> >     Ce message et ses pieces jointes peuvent contenir des
> informations confidentielles ou privilegiees et ne doivent donc
> >     pas etre diffuses, exploites ou copies sans autorisation. Si
> vous avez recu ce message par erreur, veuillez le signaler
> >     a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration,
> >     This message and its attachments may contain confidential or
> privileged information that may be protected by law;
> >     If you have received this email in error, please notify the
> sender and delete this message and its attachments.
> >     As emails may be altered, Orange is not liable for messages
> that have been modified, changed or falsified.
> >     Thank you.
> >

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 4 Mar 2021 12:01:25 -0000

I think Med captures the point.

What do we slice? We slice the underlay, and that runs from PE to PE.

What does the consumer see? They see a service, and that runs from CE to CE.

And yes, the connection between CE and PE (the access circuit) is a factor.

Adrian

-----Original Message-----
From: Teas <[email-masked]> On Behalf Of [email-masked]
Sent: 04 March 2021 11:06
To: Joel M. Halpern <[email-masked]>; Shunsuke Homma <[email-masked]>
Cc: [email-masked]
Subject: Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

Re-, 

Cheers,
Med

---

From: Joel Halpern Direct <[email-masked]>
Date: Thu, 4 Mar 2021 08:02:36 -0500

That works for me.
Thanks Med.
Joel

---

From: Shunsuke Homma <[email-masked]>
Date: Fri, 5 Mar 2021 02:13:29 +0900

Thanks Med and Joel.

I agree that CE can be an endpoint of IETF Network Slice in managed CE
case, and in other cases, IETF Network Slice is PE to PE.

And this is a reason why I'm hesitating to use the term CE/PE as the
endpoint of IETF Network Slice. If endpoints may vary depending on underlay
implementation (e.g., whether CE is managed or not), a logical identifier
independent of underlay would be needed to simplify network slice model.
(In my understanding, it was NSE.)

Also, I understand the concept of "IETF Network Slice Service",  but I have
some questions. In case that CE is not managed, can we call the connection
between CEs which includes uncontrollable section IETF Network Slice
Service?

One more, in the wholesale model, a slice broker may create an E2E network
slice by combining slices provided from several network providers. In such
a case, from a broker, where are endpoints in each network provider's
domain? For simplifying it, I think IETF Network Slice Service and IETF
Network Slice should be the same. For instance, IETF Network Slice Service
between PE and PE (excluding a case that CEs are managed).

Regards,

Shunsuke

2021年3月4日(木) 22:02 Joel Halpern Direct <[email-masked]>:

> > Other than the managed CE case, the scope of the IETF Network Slice is
> what Joel said with an emphasis on the adequate configuration of the access
> circuit.
> >
> > Cheers,
> > Med
> >
> > Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> > pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> > a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> > This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 4 Mar 2021 18:33:59 +0000

Hi all,

I concur on Shunsuke’s questions. I think as well we need a logical identifier independent of the underlay. Think also that in the same slice request we could have a mix of situations. For instance we could be providing a slice where in one of the ends we have a physical network function connected to a router (then classical CE-PE approach) while another end of the slice being a virtualized network function with the handover of traffic to the slice being resolved in the internals of the data center (I mean, the slice being terminated in some of the leaf/spine routers there, where I don’t see an easy mapping of CE-PE).

Having a single approach would be desirable for all the cases and situations, including the mixed ones.

Best regards

Luis

De: Teas <[email-masked]> En nombre de Shunsuke Homma
Enviado el: jueves, 4 de marzo de 2021 18:13
Para: Joel Halpern Direct <[email-masked]>
CC: [email-masked]; [email-masked]
Asunto: Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

Thanks Med and Joel.

I agree that CE can be an endpoint of IETF Network Slice in managed CE case, and in other cases, IETF Network Slice is PE to PE.

And this is a reason why I'm hesitating to use the term CE/PE as the endpoint of IETF Network Slice. If endpoints may vary depending on underlay implementation (e.g., whether CE is managed or not), a logical identifier independent of underlay would be needed to simplify network slice model. (In my understanding, it was NSE.)

Also, I understand the concept of "IETF Network Slice Service",  but I have some questions. In case that CE is not managed, can we call the connection between CEs which includes uncontrollable section IETF Network Slice Service?

One more, in the wholesale model, a slice broker may create an E2E network slice by combining slices provided from several network providers. In such a case, from a broker, where are endpoints in each network provider's domain? For simplifying it, I think IETF Network Slice Service and IETF Network Slice should be the same. For instance, IETF Network Slice Service between PE and PE (excluding a case that CEs are managed).

Regards,

Shunsuke

2021年3月4日(木) 22:02 Joel Halpern Direct <[email-masked]<mailto:[email-masked]>>:
That works for me.
Thanks Med.
Joel

On 3/4/2021 6:05 AM, [email-masked]<mailto:[email-masked]> wrote:
>> De : Joel M. Halpern [mailto:[email-masked]<mailto:[email-masked]>]
>> À : Shunsuke Homma <[email-masked]<mailto:[email-masked]>>; BOUCADAIR Mohamed TGI/OLN
>> <[email-masked]<mailto:[email-masked]>>
>> Cc : [email-masked]<mailto:[email-masked]>
>>> 2021年3月3日(水) 22:57 <[email-masked]<mailto:[email-masked]>
>>> <mailto:[email-masked]<mailto:[email-masked]>>>:
>>>
>>>      Re-,____
>>>
>>>      __ __
>>>
>>>      *De :* Teas [mailto:[email-masked]<mailto:[email-masked]>
>>>      <mailto:[email-masked]<mailto:[email-masked]>>] *De la part de* Adrian Farrel
>>>      *À :* 'Young Lee' <[email-masked]<mailto:[email-masked]>
>>>      <mailto:[email-masked]<mailto:[email-masked]>>>; 'Luis M. Contreras'
>>>      <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>>>      *Cc :* 'Joel M. Halpern' <[email-masked]<mailto:[email-masked]>
>>>      <mailto:[email-masked]<mailto:[email-masked]>>>; [email-masked]<mailto:[email-masked]>
>> <mailto:[email-masked]<mailto:[email-masked]>>;
>>>      'Eric Gray' <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>;
>> 'John
>>>      E Drake' <jdrake=[email-masked]<mailto:[email-masked]>
>>>      <mailto:[email-masked]<mailto:[email-masked]>>>; 'Rokui, Reza (Nokia -
>>>      CA/Ottawa)' <[email-masked]<mailto:[email-masked]>
>> <mailto:[email-masked]<mailto:[email-masked]>>>;
>>>      BOUCADAIR Mohamed TGI/OLN <[email-masked]<mailto:[email-masked]>
>>>      <mailto:[email-masked]<mailto:[email-masked]>>>
>>>      [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: John E Drake <[email-masked]>
Date: Thu, 4 Mar 2021 20:09:27 +0000

I think it was Eric that pointed out that ‘CE’, ‘PE’, and ‘attachment circuit’ describe entities that may either physical or virtual and which are completely technology agnostic.  Further, the reference I provided,  https://tools.ietf.org/html/rfc4364#section-9, describes the case where a CE is actually a PE in another provider’s network.

Yours Irrespectively,

John

Juniper Business Use Only
From: Teas <[email-masked]> On Behalf Of LUIS MIGUEL CONTRERAS MURILLO
Sent: Thursday, March 4, 2021 1:34 PM
To: Shunsuke Homma <[email-masked]>; Joel Halpern Direct <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

[External Email. Be cautious of content]

Hi all,

Best regards

Luis

De: Teas <[email-masked]<mailto:[email-masked]>> En nombre de Shunsuke Homma
Enviado el: jueves, 4 de marzo de 2021 18:13
Para: Joel Halpern Direct <[email-masked]<mailto:[email-masked]>>
CC: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Asunto: Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

Thanks Med and Joel.

Regards,

Shunsuke

On 3/4/2021 6:05 AM, [email-masked]<mailto:[email-masked]> wrote:
>>>      https://www.ietf.org/mailman/listinfo/teas<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/teas__;!!NEt6yMaO-gk!WMD3Xr96AB23B9GgI2OrrZPUaiS33HPddkzMIcHwyEZDJg6U10f3IUCfqzlNPKU$>
>>>      <https://www.ietf.org/mailman/listinfo/teas<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/teas__;!!NEt6yMaO-gk!WMD3Xr96AB23B9GgI2OrrZPUaiS33HPddkzMIcHwyEZDJg6U10f3IUCfqzlNPKU$>>
>>>
>>>
>>> https://www.ietf.org/mailman/listinfo/teas<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/teas__;!!NEt6yMaO-gk!WMD3Xr96AB23B9GgI2OrrZPUaiS33HPddkzMIcHwyEZDJg6U10f3IUCfqzlNPKU$>
>>>
>
> https://www.ietf.org/mailman/listinfo/teas<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/teas__;!!NEt6yMaO-gk!WMD3Xr96AB23B9GgI2OrrZPUaiS33HPddkzMIcHwyEZDJg6U10f3IUCfqzlNPKU$>
>

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/teas__;!!NEt6yMaO-gk!WMD3Xr96AB23B9GgI2OrrZPUaiS33HPddkzMIcHwyEZDJg6U10f3IUCfqzlNPKU$>

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 4 Mar 2021 23:44:59 +0000

Hi All,

In my opinion, even where an IETF network slice is composed of multiple layer/segment slices by multiple providers, the SLA/SLO must be assured between PE and PE by the end-to-end slice service provider if this includes multiple CE(PE)-PE connections(access circuits) inside. 

As for access circuit itself, it depends on who prepares the access circuit. When we say IX service, the consumer prepares and assures this in our service. Say VPN service, the provider prepares and assures. This means the access circuit belongs to CE for the former case and belongs to PE for the latter case.
#I know IX is an inappropriate example for slice.

> As you described, there may be cases where CE makes marking on traffic 
> and PE allocate it to appropriate slice based on the mark, but I think 
> the arrangement between CE and PE will be done by 

We are now asking ACTN to support this with actn-vn-yang and te-service-mapping for TE enabled underlying network.

Thanks,
Kenichi

-----Original Message-----
From: Teas <[email-masked]> On Behalf Of Joel M. Halpern
Sent: Thursday, March 4, 2021 9:42 AM
To: Shunsuke Homma <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

I can't speak for Med, but in my opinion, the right scope for the IETF Network Slice is PE to PE.  Information about the access circuit will need to be provided, but it is not, as I understand it,under the control of the IETF Network Slice Controller.

Yours,
Joel

On 3/3/2021 7:25 PM, Shunsuke Homma wrote:
> traffic and PE allocate it to appropriate slice based on the mark, but 
> ______________________________________________________________________

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Fri, 5 Mar 2021 02:10:20 +0000

Hi All,

My mailer couldn't catch up the latest discussion...

As for the term for the boundary between CE and PE, if we have to define this, we prefer the reuse of an existing term, AP, consistent with the existing definition as possible. As the framework document says, ACTN is one of base frameworks in case of TE enabled underlying network.

>If endpoints may vary depending on underlay implementation (e.g., whether CE is managed or not), a logical identifier independent of underlay would be needed to simplify network slice model.

We can understand your concern, but are also concerned about the complexity to map the logical identifier/simplify network slice model to an underlying technology, and difficulty to implement in practical. In my understanding, the provider managed CE is a kind of option in L3VPN technology. From NBI perspective, for example, L3SM just defines this as an option of a basic/customer-managed CE - PE model.

Thanks,
Kenichi

-----Original Message-----
From: Teas <[email-masked]> On Behalf Of Ogaki, Kenichi
Sent: Friday, March 5, 2021 8:45 AM
To: Joel M. Halpern <[email-masked]>; Shunsuke Homma <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

Hi All,

Thanks,
Kenichi

-----Original Message-----
From: Teas <[email-masked]> On Behalf Of Joel M. Halpern
Sent: Thursday, March 4, 2021 9:42 AM
To: Shunsuke Homma <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

Yours,
Joel

---

From: <[email-masked]>
Date: Fri, 5 Mar 2021 10:07:35 +0000

Hi Shunsuke,

Please see inline.

Cheers,
Med

De : Shunsuke Homma [mailto:[email-masked]]
Envoyé : jeudi 4 mars 2021 18:13
À : Joel Halpern Direct <[email-masked]>
Cc : BOUCADAIR Mohamed TGI/OLN <[email-masked]>; [email-masked]
Objet : Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

Thanks Med and Joel.

[Med] CE/PE terms are independent of the underlay. They simply delimit the scope of what is visible to a slice customer vs. the internal view of the slice provider.

[Med] It is still a service because it is where the service is delivered. For unmanaged CEs, the ** Guarantee Scope ** does not include the CE itself but may include the maintenance of attachment circuit if a physical link, for example, is also provided and maintained by the slice provider. It may also include the activation of specific protocols over that circuit by the slice provider. These considerations (activation means, service assurance) should be covered in the slice agreement.

One more, in the wholesale model, a slice broker may create an E2E network slice by combining slices provided from several network providers. In such a case, from a broker, where are endpoints in each network provider's domain?

[Med] The slice service will be delimited by the peer PEs (that will behave as CEs in the proposed model), while the slice itself is delimited by local PEs.

Regards,

Shunsuke

---

From: Shunsuke Homma <[email-masked]>
Date: Sat, 6 Mar 2021 01:26:14 +0900

Thank you for the clarifications. I can understand them and I won't say
that PE/CE/AC can't be applied to IETF Network Slice usages.

I assume that this mismatch is brought by different perceptions about what
network slice. Many people seem to think that network slice is a type of
VPN service, and hope to use the traditional terms. I see network slice as
an aggregate of resources and technologies. Also, I expect that network
slices will be used by vertical industries in B2B2X models, and thus I need
a more abstracted model.

In addition, regarding the term "IETF Network Slice Service", I think
elaboration of the definition would be needed. For example, is this service
 from whose point of view? In B2B2X models, I think what a middle B wants
to see will be the range where a network slice is actually realized. Also,
end customers will never recognize an IETF network slice exists there as
well as other network services. So, I'm not sure if the service endpoint
which is different from the network slice endpoint should be defined.

Regards,

Shunsuke

2021年3月5日(金) 19:07 <[email-masked]>:

> Hi Shunsuke,
>
>
>
> Please see inline.
>
>
>
> Cheers,
>
> Med
>
>
>
> *De :* Shunsuke Homma [mailto:[email-masked]]
> *Envoyé :* jeudi 4 mars 2021 18:13
> *À :* Joel Halpern Direct <[email-masked]>
> *Cc :* BOUCADAIR Mohamed TGI/OLN <[email-masked]>;
> [email-masked]
> *Objet :* Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in
> [Med] CE/PE terms are independent of the underlay. They simply delimit the
> scope of what is visible to a slice customer vs. the internal view of the
> slice provider.
>
> Also, I understand the concept of "IETF Network Slice Service",  but I
> have some questions. In case that CE is not managed, can we call the
> connection between CEs which includes uncontrollable section IETF Network
> Slice Service?
>
>
>
> slice by combining slices provided from several network providers. In
> such a case, from a broker, where are endpoints in each network provider's
> domain?
>
>
>
> [Med] The slice service will be delimited by the peer PEs (that will
> behave as CEs in the proposed model), while the slice itself is delimited
> by local PEs.
>
>
>
> Regards,
>
>
>
> Shunsuke
>
>
>

---

From: Kiran Makhijani <[email-masked]>
Date: Fri, 5 Mar 2021 17:07:30 +0000

These are very good clarifications.
Fwiw, I also see network slices as an abstract concept. Shunsuke did a much better job of bringing forth the right set of scenarios. Especially the last part on wholesale example is quite important and I wonder if this abstract slice is a service, is it sufficient to resolve the naming convention from  NSEs as CEs?

Cheers,
Kiran

From: Teas <[email-masked]> on behalf of Shunsuke Homma <[email-masked]>
Date: Friday, March 5, 2021 at 08:26
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00
Thank you for the clarifications. I can understand them and I won't say that PE/CE/AC can't be applied to IETF Network Slice usages.

I assume that this mismatch is brought by different perceptions about what network slice. Many people seem to think that network slice is a type of VPN service, and hope to use the traditional terms. I see network slice as an aggregate of resources and technologies. Also, I expect that network slices will be used by vertical industries in B2B2X models, and thus I need a more abstracted model.

In addition, regarding the term "IETF Network Slice Service", I think elaboration of the definition would be needed. For example, is this service  from whose point of view? In B2B2X models, I think what a middle B wants to see will be the range where a network slice is actually realized. Also, end customers will never recognize an IETF network slice exists there as well as other network services. So, I'm not sure if the service endpoint which is different from the network slice endpoint should be defined.

Regards,

Shunsuke

2021年3月5日(金) 19:07 <[email-masked]<mailto:[email-masked]>>:
Hi Shunsuke,

Please see inline.

Cheers,
Med

De : Shunsuke Homma [mailto:[email-masked]<mailto:[email-masked]>]
Envoyé : jeudi 4 mars 2021 18:13
À : Joel Halpern Direct <[email-masked]<mailto:[email-masked]>>
Cc : BOUCADAIR Mohamed TGI/OLN <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Objet : Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

Thanks Med and Joel.

Regards,

Shunsuke

Thank you.

---

From: <[email-masked]>
Date: Fri, 5 Mar 2021 17:43:04 +0000

Re-,

I’m not sure I agree with your point on “traditional terms” and the “perception that a slice is a type of VPN”. Please see, for example, https://mailarchive.ietf.org/arch/msg/teas/XKgkDJBvkISZw0VHDDH8_tL8SRA/ asking for text in the documents to explain that slice!=VPN.

I agree with you that the elaboration of the definition of "IETF Network Slice Service" is needed. Actually, we don’t even have one in the documents :-)

From a service perspective, I don’t think that slicing comes with unique aspects that would revolutionize how services (including brokering, transit, wholesale, etc.) are modeled.

Cheers,
Med

De : Shunsuke Homma [mailto:[email-masked]]
Envoyé : vendredi 5 mars 2021 17:26
À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>
Cc : [email-masked]
Objet : Re: [Teas] CE-based Network Slice RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

Regards,

Shunsuke

Please see inline.

Cheers,
Med

Thanks Med and Joel.

Regards,

Shunsuke

Thank you.

---

From: Shunsuke Homma <[email-masked]>
Date: Sun, 7 Mar 2021 01:15:17 +0900

Hi Med,

Please see inline.

2021年3月6日(土) 2:43 <[email-masked]>:

> Re-,
>
>
>
> I’m not sure I agree with your point on “traditional terms” and the
> “perception that a slice is a type of VPN”. Please see, for example,
> https://mailarchive.ietf.org/arch/msg/teas/XKgkDJBvkISZw0VHDDH8_tL8SRA/
> asking for text in the documents to explain that slice!=VPN.
>
>
>
[SH] Sorry, it was just my impression. I personally agree with your
thoughts described in the mail archive.

> I agree with you that the elaboration of the definition of "IETF Network
> Slice Service" is needed. Actually, we don’t even have one in the documents
> :-)
>
>
>
[SH] Fine.

> From a service perspective, I don’t think that slicing comes with unique
> aspects that would revolutionize how services (including brokering,
> transit, wholesale, etc.) are modeled.
>
>
>
[SH] Perhaps, slicing is not something new from service perspectives. But
I'm not sure if existing models are sufficient for IETF network slice. It
will be clarified in the progress of elaborating the definition of "IETF
Network Slice Service".

> *Envoyé :* vendredi 5 mars 2021 17:26
> *À :* BOUCADAIR Mohamed TGI/OLN <[email-masked]>
> *Cc :* [email-masked]