Subject: [Teas] Status update on draft-ietf-teas-yang-l3-te-topo

From: Xufeng Liu <[email-masked]>
Date: Wed, 3 Mar 2021 18:56:21 -0500

Current Status:

  *  Received further valuable comments from Tom Petch.
  *  Posted updated version -10, to address the comments from Tom.

Open Issues:

  *  Authors are continuously working on addressing received comments.

Next Steps:

  *  Follow-up with Tom and resolve comments.
  *  Welcome further reviews and suggestions.
  *  Keep coordinating with ietf-eth-te-topology and ietf-te-mpls-tp-topo
to ensure aligned model relations.
  *  Working Group Last Call after completing the above.

Thanks,
- Xufeng

---

From: tom petch <[email-masked]>
Date: Wed, 24 Mar 2021 12:32:56 +0000

From: Xufeng Liu <[email-masked]>
Sent: 24 February 2021 16:54

Hi Tom,

Thanks for the additional thoughts. We have posted an updated version https://tools.ietf.org/html/draft-ietf-teas-yang-l3-te-topo-10, which hopefully addresses these comments.

<tp>

I like the division of the YANG tree into sections, so much easier to see what is what.  Others should do likewise!

You still have out-of-date references to two I-D that are now RFC, te-types and te-topo; I see seven references but might have missed some.

Part of the packet statistics I cannot get my mind around but need to sleep on it and try again.

Tom Petch
 
Best,
- Xufeng

On Wed, Nov 25, 2020 at 7:37 AM tom petch <[email-masked]<mailto:[email-masked]>> wrote:
From: Xufeng Liu <[email-masked]<mailto:[email-masked]>>
Sent: 20 November 2020 23:02

Hi Tom,
Thank you much for your further comments. We have posted https://datatracker.ietf.org/doc/html/draft-ietf-teas-yang-l3-te-topo-09, hoping to address some of your comments below.

<tp>
I have had a second go at -09 and have some more thoughts.

Figure 3 I like, especially as you have achieved it in ASCII.

s.2.2.3
Can a termination point be reference with tp-id or do you have to use node+link as here?

[Xufeng]: tp-id is unique within a node, a node-ref is unique within a network (i.e. topology), so we have to use the tuple {tip-id, node-ref, network-id} to uniquely identify a tp-id.

s.2 talks of two YANG modules when there are four; ok two are PSC but I think that that might be spelt out here in this section.

[Xufeng]: Added a paragraph.

congruent is 'with' something not 'to' something, I believe

[Xufeng]: Changed.

between the one modeling element in the layer 3 unicast topology /to/and/

[Xufeng]: Fixed.

This YANG data model /allows/supports/ both cases.

[Xufeng]: Fixed.

associated /to/with/ the objects in one /corresponding/corresponding
[corresponding is what adulterers do!]

[Xufeng]: Fixed.

Tom Petch

Thanks,
- Xufeng

On Tue, Jul 14, 2020 at 7:34 AM tom petch <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>> wrote:
From: Xufeng Liu <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>
Sent: 13 July 2020 15:29

Hi Tom,

Thanks for further reviewing. We have posted an updated version https://datatracker.ietf.org/doc/html/draft-ietf-teas-yang-l3-te-topo-08. Some rewording has been made, with the hope of making the document more comprehensible. Please let us know for anything that is still confusing (for such an unconventional modeling approach).

<tp>
I still find some of the terminology in this a challenge.

2.1   o  The multiplicity of such an association is: 0..1 to 0..1.
the following sentence suggests it is '1 to 0..1'

[Xufeng]: The next sentence describes the relation on an object, but such a description is relevant only if such an object exists. When such an object has not been created in the ietf-l3-te-topology, the corresponding layer 3 TE topology may already contain an object that can be potentially associated with the to-be-created object. In this case, 0 in ietf-l3-te-topology, and 1 in ietf-te-topology. Therefore, I’d say that multiplicity is still 0..1 to 0..1.

'associated to the objects in a coresponding TE topology'
'a' suggests there can be more than one which the YANG does not seem to
and 2.2.1 has 'the' not 'a'

[Xufeng]: Changed ‘a’ to ‘one’, hoping that “associated to the objects in one corresponding TE topology" would avoid the possibility of “more than one”.

in passing 'associated with' and 'corresponding'

'   Since ietf-te-topology augments ietf-network-topology defined in
[RFC8345] [I-D.ietf-teas-yang-te-topo], the referenced leaf
   /nw:networks/network/network-id identifies an instance of TE topology
   by inheritance. '
No and no!  ietf-network-topology is in one document so there should be
only one reference or else the module name is wrong or ....
And the referenced leaf does not identify an instance of TE Topology -
it identifies a network of any type.  As the next sentence makes clear,
this module has to ensure it is of the correct type and does so.

[Xufeng]: Reworded the section, trying to clarify the leafref relationship. Please let us know if it is better.

'   If the TE topology is congruent to the layer 3 unicast topology, the
   above reference can still be used to specified TE parameters defined
   in the TE topology model.
I do not understand.  What parameters? I do not see any and if they were
to be defined in TE Topology then they should not be specified here or
anywhere else.

[Xufeng]: One example of the TE parameters is te-delay-metric. Such parameters are defined in the TE Topology model. They are not specified in l3-te-topology, but they can be configured in the corresponding te-topology instance.

s.2.2.2
'a node in the layer 3 TE topology may have a reference to the
corresponding TE node.'
perhaps clearer as
'a node in the layer  3 TE topology may have a reference to the
corresponding node in the TE Topology.'

[Xufeng]: Yes. Reworded as suggested.

s.2.2.3 s.2.2.4 ditto mutatis mutandi

[Xufeng]: Fixed too.

More technically this I-D seems confused about prefix and inconsistent
elsewhere
.
module
     namespace "urn:ietf:params:xml:ns:yang:ietf-l3-te-topology";
     prefix "l3tet";
IANA
   name:         ietf-l3-te-topology
   namespace:    urn:ietf:params:xml:ns:yang:ietf-l3-te-topology
   prefix:       l3te

[Xufeng]: Fixed the IANA section.

YANG
       container l3-te {
         presence "Indicates L3 TE Topology";

   augment /nw:networks/nw:network/nw:network-types
             /l3t:l3-unicast-topology:
     +--rw l3-te!

[Xufeng]: Is there anything wrong here? l3-te is the name of a container and is not the prefix.

In passing, 'congruent with' in many places (at least in English
English)

[Xufeng]: Is it not correct? Or “congruent to” is preferred? Did a brief search, it seems that “congruent with” is more popular.

s.3
The YANG data  model defined in this document ...
This document specifies two YANG modules ..
actually three!

[Xufeng]: Is the above paragraph in Sec 2: “Modeling Considerations for L3 TE Topologies”? If so, the the description is intended to be scoped to Sec 2. We have two modules for L3 TE Topologies, and the other two modules are for Packet Switching Technology Extensions.

Tom Petch

Best regards,
- Xufeng

On Fri, May 8, 2020 at 6:06 AM tom petch <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>><mailto:[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>> wrote:
From: Xufeng Liu <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>><mailto:[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>>
Sent: 07 May 2020 00:22

Hi Tom,

Thanks for reviewing and sorry about the errors. We have posted an updated version https://tools.ietf.org/html/draft-ietf-teas-yang-l3-te-topo-07, to fix the errors about the augmentation description and to rephrase a couple of sections to explain the relations between the related models and their objects. Please let us know for anything that is not clear enough.

<tp>
Thanks for the update.  I now find s.2 s.2.1 clear but still struggle thereafter.  When you use layer 3 topology I find it ambiguous.  Is it layer 3 unicast topology or layer 3 te topology?  Thus in s.2.2.1
"When TE is enabled on a layer 3 topology .. " implies unicast
"congruent to the layer 3 topology .."
implies unicast
" the layer 3 topology will have a reference.."
 ah, no, must be layer 3 te topology
and this is the case throughout the rest of s.2.  I would like to see those references to layer 3 topology clarified, unicast or te.  You may want to say that layer 3 topology means ... while layer 3 ... topology will be spelt out in full or some such, I am easy, but do think that you need to use two distinct terms.
[Xufeng]: Reworded. Please let us know if anything is confusing.

As you may infer, I like to work top down, start with Abstract, then Introduction, then s.2 s.3 making sense of them before seeing if the module does what these sections say, so when I get stuck in s.2, I do not make it to details of the YANG module.
[Xufeng]: Thank you much for looking at it. We are striving to get your review unstuck.

Tom Petch

Thanks,
- Xufeng

On Fri, May 1, 2020 at 6:56 AM tom petch <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>><mailto:[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>><mailto:[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>><mailto:[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>>> wrote:
From: Teas <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>><mailto:[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>><mailto:[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>><mailto:[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>>> on behalf of Xufeng Liu <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>><mailto:[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>><mailto:[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>><mailto:[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>>>
Sent: 21 April 2020 21:09

Status update on draft-ietf-teas-yang-l3-te-topo

Current Status:

  *  The updated revision -06 was posted on March 8, 2020:
     - Editorial changes.
  *  Corordinated with ietf-eth-te-topology and ietf-te-mpls-tp-topo
     for the augmentation of ietf-te-topology
     - ietf-te-topology does not need to be changed.
  *  Answered YANG doctor's review comments.

Open Issues:

  *   None.

<tp>

I started  to review this and have given up,  I cannot make sense of section 2, which I see as fundamental to understanding the I-D.
 Thus
The YANG modulues  ietf-l3-te-topology ...
These two modules augment ietf-l3-te topology
No they don't!  This augments
ietf-l3-unicast-topology
which is quite different and I find this confusion elsewhere in section two. Thus
Relationship  between Layer 3 Topology and TE Topology
Is that Layer 3 TE Topology or ietf-network-topology?  I think that many if not most  references to TE Topology are ambiguous and need clarifying - is the reference to Layer 3 TE Topology to  ietf-network-topology?

Some of the words are quirky and this website is determined not to let me put them into an e-mail but here goes.

modulues
topoology
moducment
Local ink

Tom Petch
Next Steps:

  *  Update the model to sync with the referenced models like draft-ietf-teas-yang-te-types if there are any changes.
  *  Welcome further reviews and suggestions.
  *  Working Group Last Call after completing the above.

Thanks,
- Xufeng