Subject: Re: [Teas] WG adoption poll: draft-bestbar-teas-ns-packet-08

From: "Wubo (lana)" <[email-masked]>
Date: Wed, 23 Feb 2022 12:39:38 +0000

Hi all,

I have read the draft and have some questions with the text and terms.

1. This document seems only define SFA (slice-flow aggregation) based mapping solution, that is, slice services mapping to SFAs, and SFAs to NRP(Network Resource Partition)s. 
If this draft is supposed to be a generic slicing realization document, I think, it should allow more options. For example, the slice services could be mapped to VPNs, and 
VPNs mapped to underlying resources with method described in draft-ietf-teas-te-service-mapping-yang.

2. This draft refers to draft-bestbar-teas-yang-slice-policy, but the following definition are not consistent:
1) SFA is not defined in draft-bestbar-teas-yang-slice-policy, but is seems relevant from the definition. And I can't find NRP Policy selection Criteria in the model definition.
Slice-Flow Aggregate: a collection of packets that match an NRP Policy selection criteria and are given the same forwarding treatment ; 

2) draft-bestbar-teas-yang-slice-policy defines Slice Selector, but apart from Slice Selector, this draft also defines FAS and FASL. It is recommended that the terms be consistent.
FAS: Flow Aggregate Selector; FASL: Flow Aggregate Selector Label.

Thanks,
Bo
> -----邮件原件-----
> 发件人: Teas [mailto:[email-masked]] 代表 Lou Berger
> 发送时间: 2022年2月18日 21:28
> 收件人: TEAS WG <[email-masked]>
> 抄送: TEAS WG Chairs <[email-masked]>;
> [email-masked]
> 主题: [Teas] WG adoption poll: draft-bestbar-teas-ns-packet-08
> 
> Hello,
> 
> This email begins a 2-week adoption poll for:
> https://datatracker.ietf.org/doc/draft-bestbar-teas-ns-packet/
> 
> Please note that IPR has been disclosed on this document:
> https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-bestbar-teas-n
> s-packet
> 
> Please voice your support or objections to adoption on the list by the end of the
> day (any time zone) March 4.
> 
> Thank you,
> Lou (as Co-chair)
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: <[email-masked]>
Date: Wed, 23 Feb 2022 13:36:49 +0000

Hi Bo, all,

I fully support your point (1). 

I think that approach is also the spirit of draft-barguil-teas-network-slices-instantation cited in a previous message in this thread. 

Cheers,
Med

> -----Message d'origine-----
> De : Teas <[email-masked]> De la part de Wubo (lana)
> Envoyé : mercredi 23 février 2022 13:40
> À : Lou Berger <[email-masked]>; TEAS WG <[email-masked]>
> Cc : TEAS WG Chairs <[email-masked]>; draft-bestbar-teas-ns-
> [email-masked]
> Objet : Re: [Teas] WG adoption poll: draft-bestbar-teas-ns-packet-08
> 
> Hi all,
> 
> 1. This document seems only define SFA (slice-flow aggregation) based
> mapping solution, that is, slice services mapping to SFAs, and SFAs to
> NRP(Network Resource Partition)s.
> If this draft is supposed to be a generic slicing realization document,
> I think, it should allow more options. For example, the slice services
> could be mapped to VPNs, and VPNs mapped to underlying resources with
> method described in draft-ietf-teas-te-service-mapping-yang.
> 
> 1) SFA is not defined in draft-bestbar-teas-yang-slice-policy, but is
> seems relevant from the definition. And I can't find NRP Policy
> selection Criteria in the model definition.
> Slice-Flow Aggregate: a collection of packets that match an NRP Policy
> selection criteria and are given the same forwarding treatment ;
> 
> 2) draft-bestbar-teas-yang-slice-policy defines Slice Selector, but
> apart from Slice Selector, this draft also defines FAS and FASL. It is
> recommended that the terms be consistent.
> > Please voice your support or objections to adoption on the list by the
> > end of the day (any time zone) March 4.
> >
> > Thank you,
> > Lou (as Co-chair)
> >

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Wed, 23 Feb 2022 08:29:01 -0600

Bo,

Please see inline for responses (prefixed VPB)..

Regards,

-Pavan (on behalf of the authors)

On Wed, Feb 23, 2022 at 6:39 AM Wubo (lana) <lana.wubo=
[email-masked]> wrote:

> If this draft is supposed to be a generic slicing realization document, I
> think, it should allow more options. For example, the slice services could
> be mapped to VPNs, and

[VPB] Please refer to section 5.3 (
https://datatracker.ietf.org/doc/html/draft-bestbar-teas-ns-packet-08#section-5.3
<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-bestbar-teas-ns-packet-08*section-5.3__;Iw!!NEt6yMaO-gk!RKgzM9K5I6Crs9-9OkxWcIvs0atMYM1O1zZWrRa009HkrnmqRqcVdrJg4EU6Aib-$>).
It does note that the usual techniques for steering service traffic onto
paths are applicable -- the example that you cite is certainly allowed. We
can add a reference to draft-ietf-teas-te-service-mapping-yang in this
section and make it explicit.

> seems relevant from the definition. And I can't find NRP Policy selection
> Criteria in the model definition.
> 2) draft-bestbar-teas-yang-slice-policy defines Slice Selector, but apart
> from Slice Selector, this draft also defines FAS and FASL. It is

[VPB] The last two comments above are for the NRP policy data model draft
(Thanks for bringing it up!). We agree that the NRP policy data model draft
needs to be updated to be in sync with the current terminology used in
draft-bestbar-teas-ns-packet. This should get done in the next few days.
But please note that the NRP policy data model draft is not the one that is
currently being polled for adoption.