Subject: [Teas] AQM in draft-ietf-teas-rfc3272bis

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 25 Feb 2022 09:06:00 -0000

Dave Taht (cc here) recently mentioned in a social media comment that
draft-ietf-teas-rfc3272bis fails to mention the work of the AQM working
group.

I've invited him to suggest a couple of short paragraphs and also recommend
where they might fit into the document.

Everyone is welcome to discuss whether AQM constitutes Traffic Engineering,
and (of course) suggest their own text.

Thanks,
Adrian

---

From: <[email-masked]>
Date: Fri, 25 Feb 2022 09:20:14 +0000

Hi Adrian, all, 

I would simply add a pointer to BCP 197 at the end of the third sub-bullet under the first bullet of Section 2.4.1. 

Cheers,
Med

> -----Message d'origine-----
> De : Teas <[email-masked]> De la part de Adrian Farrel
> Envoyé : vendredi 25 février 2022 10:06
> À : [email-masked]
> Cc : 'Dave Taht' <[email-masked]>
> Objet : [Teas] AQM in draft-ietf-teas-rfc3272bis
> 
> I've invited him to suggest a couple of short paragraphs and also
> recommend where they might fit into the document.
> 
> Everyone is welcome to discuss whether AQM constitutes Traffic
> Engineering, and (of course) suggest their own text.
> 
> Thanks,
> Adrian
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Dave Taht <[email-masked]>
Date: Fri, 25 Feb 2022 07:10:06 -0500

I certainly think that some form of aqm,fq,or fq+aqm, awareness of
correct buffer sizing for certain traffic types, notably voip, are
essential components of quality traffic engineering.

very useful e2e techniques such as packet pacing are also now widely deployed.

In lieu of actually contributing text to teas at this particular moment in time:

rfc7567 is worth citing at least.

this is a good read about short vs big buffered switches:
https://blog.cloudflare.com/asics-at-the-edge/

Over here is some recent work with graphs (if you login) on the
mikrotik deployment:

https://forum.mikrotik.com/viewtopic.php?t=179307

https://forum.mikrotik.com/viewtopic.php?t=181289

A fallout of those threads above for me is trying to discover the
actual use and deployment of wred today, particularly with or without
rfc3168 style ecn or l4s/sce style early marking.

docsis 3.1 has pie: deployment report here:
https://blog.apnic.net/2021/12/02/working-latency-the-next-qoe-frontier/
-

cisco's AFD is useful (but not an ietf standard)

fq_codel is the default in linux, ios, osx, used as a core component
in "smart queue management"
(https://www.bufferbloat.net/projects/cerowrt/wiki/Smart_Queue_Management/
) in a ton of linux based routers, and in wifi.

Middleboxes such as preseem, and libreqos are also essentially doing
what I would consider to be TE.

After dumping all that stuff at y'all, the recent bitag report might
be of some interest

https://www.bitag.org/documents/BITAG_latency_explained.pdf

and for laughs:

https://blog.apnic.net/2020/01/22/bufferbloat-may-be-solved-but-its-not-over-yet/

-- 
I tried to build a better future, a few times:
https://wayforward.archive.org/?site=https%3A%2F%2Fwww.icei.org

Dave Täht CEO, TekLibre, LLC